<!doctype html > <!--[if IE 8]><html class="ie8" lang="en"> <![endif]--> <!--[if IE 9]><html class="ie9" lang="en"> <![endif]--> <!--[if gt IE 8]><!--><html lang="en-GB"> <!--<![endif]--><head><script data-cfasync="false" id="ao_optimized_gfonts_config">WebFontConfig={google:{families:["Open Sans:400,600,700","Roboto:400,500,700"] },classes:false, events:false, timeout:1500};</script><link media="all" href="https://www.caymancompass.com/wp-content/cache/autoptimize/css/autoptimize_cc325678fcf9ad49118988ea703d96fa.css" rel="stylesheet" /><link media="only screen and (max-width: 768px)" href="https://www.caymancompass.com/wp-content/cache/autoptimize/css/autoptimize_2e61cf55767583ee8f53abbd2039ead1.css" rel="stylesheet" /><link media=" print" href="https://www.caymancompass.com/wp-content/cache/autoptimize/css/autoptimize_af3f06c364b63b8f7839aa5d50777c54.css" rel="stylesheet" /><title>Iggy Pop joins cast of &#039;Blue Iguana&#039; comedy - Cayman Compass</title><meta charset="UTF-8" /><meta name="viewport" content="width=device-width, initial-scale=1.0"><link rel="pingback" href="https://www.caymancompass.com/xmlrpc.php" /> <script type='text/javascript' src='https://servedbyadbutler.com/hb_app.js' async></script><link rel="icon" type="image/png" href="https://www.caymancompass.com/wp-content/uploads/2021/01/Compass-Favicon-round-32x.png"><link rel="apple-touch-icon-precomposed" sizes="76x76" href="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassSqareiOSBookmarklet-76x.png"/><link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassSqareiOSBookmarklet-114x.png"/><link rel="apple-touch-icon-precomposed" sizes="152x152" href="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassSqareiOSBookmarklet-152x.png"/><link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassSqareiOSBookmarklet-114x.png"/><link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassSqareiOSBookmarklet-144x.png"/><meta name="description" content="Punk-rock icon Iggy Pop has joined the cast of the dark comedy &#039;Blue Iguana&#039;, currently filming in the Cayman Islands." /><meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://www.caymancompass.com/2021/04/01/iggy-pop-joins-cast-of-blue-iguana-comedy/" /><meta property="og:locale" content="en_GB" /><meta property="og:type" content="article" /><meta property="og:title" content="Iggy Pop joins cast of &#039;Blue Iguana&#039; comedy - Cayman Compass" /><meta property="og:description" content="Punk-rock icon Iggy Pop has joined the cast of the dark comedy &#039;Blue Iguana&#039;, currently filming in the Cayman Islands." /><meta property="og:url" content="https://www.caymancompass.com/2021/04/01/iggy-pop-joins-cast-of-blue-iguana-comedy/" /><meta property="og:site_name" content="Cayman Compass" /><meta property="article:publisher" content="https://www.facebook.com/caycompass" /><meta property="article:published_time" content="2021-04-01T15:55:01+00:00" /><meta property="article:modified_time" content="2021-04-01T17:46:27+00:00" /><meta property="og:image" content="https://www.caymancompass.com/wp-content/uploads/2021/04/0185_Iggy-Pop-19.07.30_Rob-Baker-Ashton_v1-copy.jpg" /><meta property="og:image:width" content="1744" /><meta property="og:image:height" content="2048" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@cayCompass" /><meta name="twitter:site" content="@cayCompass" /><meta name="twitter:label1" content="Written by"><meta name="twitter:data1" content="Staff"><meta name="twitter:label2" content="Est. reading time"><meta name="twitter:data2" content="1 minute"> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.caymancompass.com/#organization","name":"Cayman Compass","url":"https://www.caymancompass.com/","sameAs":["https://www.facebook.com/caycompass","https://instagram.com/cayman_compass","https://www.youtube.com/caymancompas","https://twitter.com/cayCompass"],"logo":{"@type":"ImageObject","@id":"https://www.caymancompass.com/#logo","inLanguage":"en-GB","url":"https://www.caymancompass.com/wp-content/uploads/2019/10/CompassLogo-white-bgd.gif","width":400,"height":275,"caption":"Cayman Compass"},"image":{"@id":"https://www.caymancompass.com/#logo"}},{"@type":"WebSite","@id":"https://www.caymancompass.com/#website","url":"https://www.caymancompass.com/","name":"Cayman Compass","description":"The Cayman Islands&#039; Most Trusted News Source","publisher":{"@id":"https://www.caymancompass.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://www.caymancompass.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-GB"},{"@type":"ImageObject","@id":"https://www.caymancompass.com/2021/04/01/iggy-pop-joins-cast-of-blue-iguana-comedy/#primaryimage","inLanguage":"en-GB","url":"https://www.caymancompass.com/wp-content/uploads/2021/04/0185_Iggy-Pop-19.07.30_Rob-Baker-Ashton_v1-copy.jpg","width":1744,"height":2048,"caption":"Iggy Pop. - Photo: Rob Baker Ashton"},{"@type":"WebPage","@id":"https://www.caymancompass.com/2021/04/01/iggy-pop-joins-cast-of-blue-iguana-comedy/#webpage","url":"https://www.caymancompass.com/2021/04/01/iggy-pop-joins-cast-of-blue-iguana-comedy/","name":"Iggy Pop joins cast of 'Blue Iguana' comedy - Cayman Compass","isPartOf":{"@id":"https://www.caymancompass.com/#website"},"primaryImageOfPage":{"@id":"https://www.caymancompass.com/2021/04/01/iggy-pop-joins-cast-of-blue-iguana-comedy/#primaryimage"},"datePublished":"2021-04-01T15:55:01+00:00","dateModified":"2021-04-01T17:46:27+00:00","description":"Punk-rock icon Iggy Pop has joined the cast of the dark comedy 'Blue Iguana', currently filming in the Cayman Islands.","inLanguage":"en-GB","potentialAction":[{"@type":"ReadAction","target":["https://www.caymancompass.com/2021/04/01/iggy-pop-joins-cast-of-blue-iguana-comedy/"]}]},{"@type":"Article","@id":"https://www.caymancompass.com/2021/04/01/iggy-pop-joins-cast-of-blue-iguana-comedy/#article","isPartOf":{"@id":"https://www.caymancompass.com/2021/04/01/iggy-pop-joins-cast-of-blue-iguana-comedy/#webpage"},"author":{"@id":"https://www.caymancompass.com/#/schema/person/d5917ed25a6a3765c0f2d4a80220c34e"},"headline":"Iggy Pop joins cast of &#8216;Blue Iguana&#8217; comedy","datePublished":"2021-04-01T15:55:01+00:00","dateModified":"2021-04-01T17:46:27+00:00","mainEntityOfPage":{"@id":"https://www.caymancompass.com/2021/04/01/iggy-pop-joins-cast-of-blue-iguana-comedy/#webpage"},"commentCount":0,"publisher":{"@id":"https://www.caymancompass.com/#organization"},"image":{"@id":"https://www.caymancompass.com/2021/04/01/iggy-pop-joins-cast-of-blue-iguana-comedy/#primaryimage"},"keywords":"Darius Films,Iggy Pop,Productivity Media","articleSection":"Entertainment,Life","inLanguage":"en-GB","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://www.caymancompass.com/2021/04/01/iggy-pop-joins-cast-of-blue-iguana-comedy/#respond"]}]},{"@type":"Person","@id":"https://www.caymancompass.com/#/schema/person/d5917ed25a6a3765c0f2d4a80220c34e","name":"Staff"}]}</script> <link rel='dns-prefetch' href='//ajax.googleapis.com' /><link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' /><link rel='dns-prefetch' href='//s.w.org' /><link href='https://fonts.gstatic.com' crossorigin='anonymous' rel='preconnect' /><link href='https://ajax.googleapis.com' rel='preconnect' /><link href='https://fonts.googleapis.com' rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="Cayman Compass &raquo; Feed" href="https://www.caymancompass.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Cayman Compass &raquo; Comments Feed" href="https://www.caymancompass.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Cayman Compass &raquo; Iggy Pop joins cast of &#8216;Blue Iguana&#8217; comedy Comments Feed" href="https://www.caymancompass.com/2021/04/01/iggy-pop-joins-cast-of-blue-iguana-comedy/feed/" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.caymancompass.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=01c406beee79eb478b26e999eb5427ea"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);</script> <style type="text/css">img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}</style><link rel='stylesheet' id='jqueryuicss-css'  href='https://ajax.googleapis.com/ajax/libs/jqueryui/1.11.4/themes/smoothness/jquery-ui.css?ver=01c406beee79eb478b26e999eb5427ea' type='text/css' media='all' /><style id='woocommerce-inline-inline-css' type='text/css'>.woocommerce form .form-row .required { visibility: visible; }</style><link rel='stylesheet' id='sb-font-awesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=01c406beee79eb478b26e999eb5427ea' type='text/css' media='all' /><style id='td-theme-inline-css' type='text/css'>@media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }</style> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/pinnacle-newsletter/pinnacle_javascript.js?ver=01c406beee79eb478b26e999eb5427ea' id='script1-js'></script> <script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jqueryui/1.11.4/jquery-ui.min.js?ver=01c406beee79eb478b26e999eb5427ea' id='jqueryui-js'></script> <script type='text/javascript' id='compass_piano-js-before'>var tp = window.tp || [];
            var subscriptionsTemplateId = 'OTYU83ND4XJZ';
            var subscriptionsOfferId = 'OFSX9O2BRA8Y';
            tp.push(['setUseTinypassAccounts', false]);
            tp.push(['setUsePianoIdUserProvider', false]);
            tp.push(['setUsePianoIdLiteUserProvider', true]);

            
            tp.push(['setTags', ['Darius Films', 'Iggy Pop', 'Productivity Media', 'Entertainment', 'Life']]);
            tp.push(['setContentCreated', '2021-04-01T10:55:01-05:00']);
            tp.push(['setContentAuthor', 'Staff']);

            document.cookie = '__adblocker=; expires=Thu, 01 Jan 1970 00:00:00 GMT; path=/';
            var setNptTechAdblockerCookie = function(adblocker) {
                var d = new Date();
                d.setTime(d.getTime() + 60 * 5 * 1000);
                document.cookie = '__adblocker=' + (adblocker ? 'true' : 'false') + '; expires=' + d.toUTCString() + '; path=/';
            };
            var script = document.createElement('script');
            script.setAttribute('async', true);
            script.setAttribute('src', '//www.npttech.com/advertising.js');
            script.setAttribute('onerror', 'setNptTechAdblockerCookie(true);');
            document.getElementsByTagName('head')[0].appendChild(script);

            (function(src) {
                var a = document.createElement('script');
                a.type = 'text/javascript';
                a.async = true;
                a.src = src;
                var b = document.getElementsByTagName('script')[0];
                b.parentNode.insertBefore(a, b)
            })('//api.tinypass.com/xbuilder/experience/load?aid=wmD32Scjpu');</script> <script type='text/javascript' id='likebtn_frontend-js-extra'>var likebtn_eh_data = {"ajaxurl":"https:\/\/www.caymancompass.com\/wp-admin\/admin-ajax.php","security":"31ac668465"};</script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/likebtn-like-button/public/js/frontend.js?ver=01c406beee79eb478b26e999eb5427ea' id='likebtn_frontend-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script> <script type='text/javascript' id='enr-frontend-js-extra'>var enr_frontend_params = {"ajax_url":"https:\/\/www.caymancompass.com\/wp-admin\/admin-ajax.php","subscribe_now_nonce":"e100df0494","single_add_to_cart_text":"Add to cart","subscribe_now_button_text":"Subscribe Now","hide_variable_limited_notice":""};</script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/enhancer-for-woocommerce-subscriptions/assets/js/frontend.js?ver=2.0' id='enr-frontend-js'></script> <link rel="https://api.w.org/" href="https://www.caymancompass.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.caymancompass.com/wp-json/wp/v2/posts/520572" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.caymancompass.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.caymancompass.com/wp-includes/wlwmanifest.xml" /><link rel='shortlink' href='https://www.caymancompass.com/?p=520572' /><link rel="alternate" type="application/json+oembed" href="https://www.caymancompass.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.caymancompass.com%2F2021%2F04%2F01%2Figgy-pop-joins-cast-of-blue-iguana-comedy%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.caymancompass.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.caymancompass.com%2F2021%2F04%2F01%2Figgy-pop-joins-cast-of-blue-iguana-comedy%2F&#038;format=xml" />  <script type="text/javascript">var cffsiteurl = "https://www.caymancompass.com/wp-content/plugins";
var cffajaxurl = "https://www.caymancompass.com/wp-admin/admin-ajax.php";


var cfflinkhashtags = "false";</script> <style id="ctcc-css" type="text/css" media="screen">#catapult-cookie-bar {
					box-sizing: border-box;
					max-height: 0;
					opacity: 0;
					z-index: 99999;
					overflow: hidden;
					color: #ffffff;
					position: fixed;
					left: 0;
					bottom: 0;
					width: 100%;
					background-color: #0e1523;
				}
				#catapult-cookie-bar a {
					color: #c6e9ff;
				}
				#catapult-cookie-bar .x_close span {
					background-color: #ffffff;
				}
				button#catapultCookie {
					background:#00aeef;
					color: #ffffff;
					border: 0; padding: 6px 9px; border-radius: 3px;
				}
				#catapult-cookie-bar h3 {
					color: #ffffff;
				}
				.has-cookie-bar #catapult-cookie-bar {
					opacity: 1;
					max-height: 999px;
					min-height: 30px;
				}</style><script type="text/javascript">var ajax_url = "https://www.caymancompass.com/wp-admin/admin-ajax.php";</script><!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]--> <script>window.tdb_globals = {"wpRestNonce":"f07d0a1831","wpRestUrl":"https:\/\/www.caymancompass.com\/wp-json\/","permalinkStructure":"\/%year%\/%monthnum%\/%day%\/%postname%\/","isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":50,"postAutoloadStatus":"off","origPostEditUrl":null};</script> <script>window.tdwGlobal = {"adminUrl":"https:\/\/www.caymancompass.com\/wp-admin\/","wpRestNonce":"f07d0a1831","wpRestUrl":"https:\/\/www.caymancompass.com\/wp-json\/","permalinkStructure":"\/%year%\/%monthnum%\/%day%\/%postname%\/"};</script> <noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript>  <script>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</script> <style>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</style> <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-PBNB99T');</script>    <script type="text/javascript" id="hs-script-loader" async defer src="//js.hs-scripts.com/5627643.js"></script>    <script id="mcjs">!function(c,h,i,m,p){m=c.createElement(h),p=c.getElementsByTagName(h)[0],m.async=1,m.src=i,p.parentNode.insertBefore(m,p)}(document,"script","https://chimpstatic.com/mcjs-connected/js/users/b144ccc8214e0a3588b280790/225c3aaa4ffba0c893d5e5913.js");</script>  <script type="application/ld+json">{
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://www.caymancompass.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.caymancompass.com/category/life/",
                    "name": "Life"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.caymancompass.com/category/life/entertainment/",
                    "name": "Entertainment"                                
                }
            }
            ,{
                "@type": "ListItem",
                "position": 4,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.caymancompass.com/2021/04/01/iggy-pop-joins-cast-of-blue-iguana-comedy/",
                    "name": "Iggy Pop joins cast of &#8216;Blue Iguana&#8217; comedy"                                
                }
            }    
        ]
    }</script> <style>.tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,
                .tds-button2 .tdm-btn-text,
                .tds-button2 i,
                .tds-button5:hover .tdm-btn-text,
                .tds-button5:hover i,
                .tds-button6 .tdm-btn-text,
                .tds-button6 i,
                .tdm_block_list .tdm-list-item i,
                .tdm_block_pricing .tdm-pricing-feature i,
                .tdm-social-item i {
                    color: #a0213f;
                }
                .tds-button1,
                .tds-button6:after,
                .tds-title2 .tdm-title-line:after,
                .tds-title3 .tdm-title-line:after,
                .tdm_block_pricing.tdm-pricing-featured:before,
                .tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,
                .tds-progress-bar1 .tdm-progress-bar:after,
                .tds-progress-bar2 .tdm-progress-bar:after,
                .tds-social3 .tdm-social-item {
                    background-color: #a0213f;
                }
                .tds-button2:before,
                .tds-button6:before,
                .tds-progress-bar3 .tdm-progress-bar:after {
                  border-color: #a0213f;
                }
                .tdm-btn-style1 {
					background-color: #a0213f;
				}
				.tdm-btn-style2:before {
				    border-color: #a0213f;
				}
				.tdm-btn-style2 {
				    color: #a0213f;
				}
				.tdm-btn-style3 {
				    -webkit-box-shadow: 0 2px 16px #a0213f;
                    -moz-box-shadow: 0 2px 16px #a0213f;
                    box-shadow: 0 2px 16px #a0213f;
				}
				.tdm-btn-style3:hover {
				    -webkit-box-shadow: 0 4px 26px #a0213f;
                    -moz-box-shadow: 0 4px 26px #a0213f;
                    box-shadow: 0 4px 26px #a0213f;
				}</style><style id="tdw-css-placeholder">body .tds-button1 .tdm-btn-text {
  color: #fff !important;
}
.finance-hp-highlight .td-post-date {
  color: #777 !important;
}
.finance-hp-highlight .td_module_mx1 .td-post-date {
  color: #fff !important;
}
body .td-trending-now-wrapper .td-trending-now-title {
  font-family: "Open Sans", arial, sans-serif;
  font-weight: bold !important;
}
.td-big-grid-wrapper .td-module-meta-info .td-post-author-name a {
  color: #fff !important;
}
.home-pg-news-block-with-ad {
  max-height: 620px;
  overflow: hidden;
}
.home-pg-top-features h4 {
  margin-bottom: 5px !important;
}
.home-pg-top-features img {
  float: left !important;
  margin-right: 12px !important;
}
.home-pg-top-features {
  min-height: 90px;
}
/* election menu button */
.election-nav-btn > a {
  color: #fff !important;
  background-color: #a0213f !important;
  background-image: url('https://www.caymancompass.com/wp-content/uploads/2016/12/CaymanFlag-background-blurred-696x343.jpg');
  background-size: cover;
}
/* REMOVE BOTTOM SHADOW FROM MODAL POPUP IMAGES */
.mfp-figure::before {
  display: none !important;
}
.mfp-counter,
.mfp-title {
  background: #0007 !important;
  line-height: 30px !important;
  padding-left: 10px;
  font-size: 15px;
}</style><script data-cfasync="false" id="ao_optimized_gfonts_webfontloader">(function() {var wf = document.createElement('script');wf.src='https://ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';wf.type='text/javascript';wf.async='true';var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(wf, s);})();</script><script async src='/cdn-cgi/bm/cv/669835187/api.js'></script></head><body class="post-template-default single single-post postid-520572 single-format-standard theme-Newspaper td-standard-pack woocommerce-no-js woocommerce-multicurrency-KYD iggy-pop-joins-cast-of-blue-iguana-comedy global-block-template-16 cc single_template white-menu td-animation-stack-type0 td-boxed-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage"><div class="td-scroll-up"><i class="td-icon-menu-up"></i></div><div class="td-menu-background"></div><div id="td-mobile-nav"><div class="td-mobile-container"><div class="td-menu-socials-wrap"><div class="td-menu-socials"> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.facebook.com/caycompass/" title="Facebook"> <i class="td-icon-font td-icon-facebook"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.instagram.com/cayman_compass/" title="Instagram"> <i class="td-icon-font td-icon-instagram"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://twitter.com/cayCompass" title="Twitter"> <i class="td-icon-font td-icon-twitter"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.youtube.com/user/caymancompas" title="Youtube"> <i class="td-icon-font td-icon-youtube"></i> </a> </span></div><div class="td-mobile-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div></div><div class="td-mobile-content"><div class="menu-main-menu-container"><ul id="menu-main-menu" class="td-mobile-main-menu"><li id="menu-item-489485" class="hide-for-desktop menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-first menu-item-489485"><a href="/account/profile">Members<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-489489" class="s-trigger-login s-logged-out menu-item menu-item-type-custom menu-item-object-custom menu-item-489489"><a href="#login">Login/Register</a></li><li id="menu-item-490096" class="s-logged-in menu-item menu-item-type-custom menu-item-object-custom menu-item-490096"><a href="https://www.caymancompass.com/wp-login.php?action=logout&#038;redirect_to=%2F">Logout</a></li><li id="menu-item-489486" class="s-logged-in menu-item menu-item-type-custom menu-item-object-custom menu-item-489486"><a href="/account/profile">Profile</a></li><li id="menu-item-489487" class="s-logged-in menu-item menu-item-type-custom menu-item-object-custom menu-item-489487"><a href="/account/subscription">Subscription</a></li><li id="menu-item-489488" class="s-logged-in menu-item menu-item-type-custom menu-item-object-custom menu-item-489488"><a href="/account/update-password">Update password</a></li><li id="menu-item-499355" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-499355"><a href="https://www.caymancompass.com/faq/">Help &#038; FAQ</a></li></ul></li><li id="menu-item-187847" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-187847"><a href="https://www.caymancompass.com/cayman-news/">News<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-187848" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-187848"><a href="https://www.caymancompass.com/cayman-news/">Cayman News</a></li><li id="menu-item-464189" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-464189"><a href="https://www.caymancompass.com/issues/">Issues<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-514433" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-514433"><a href="https://www.caymancompass.com/issues/cost-of-living-cayman/">Cost of Living</a></li><li id="menu-item-486325" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-486325"><a href="https://www.caymancompass.com/issues/cayman2-0/">Cayman 2.0</a></li><li id="menu-item-470131" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-470131"><a href="https://www.caymancompass.com/issues/climate-change/">Climate Change</a></li><li id="menu-item-466938" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-466938"><a href="https://www.caymancompass.com/issues/traffic/">Traffic</a></li><li id="menu-item-464188" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-464188"><a href="https://www.caymancompass.com/issues/founded-upon-the-seas/">Founded Upon the Seas</a></li><li id="menu-item-458002" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-458002"><a href="https://www.caymancompass.com/issues/port-vote-2019/">Port Vote 2019</a></li><li id="menu-item-458001" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-458001"><a href="https://www.caymancompass.com/issues/friday-features/">Friday Features</a></li><li id="menu-item-456066" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-456066"><a href="https://www.caymancompass.com/issues/sargassum/">Sargassum</a></li><li id="menu-item-471740" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-471740"><a href="https://www.caymancompass.com/issues/">All Issues Stories</a></li></ul></li><li id="menu-item-470185" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-470185"><a href="https://www.caymancompass.com/coronavirus-cayman/">Coronavirus (COVID-19)</a></li><li id="menu-item-188240" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188240"><a href="https://www.caymancompass.com/crime-and-courts/">Crime and Courts</a></li><li id="menu-item-461693" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-461693"><a href="https://www.caymancompass.com/living/">Living</a></li><li id="menu-item-512411" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-512411"><a href="https://www.caymancompass.com/politics/">Politics</a></li><li id="menu-item-465716" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-465716"><a href="https://www.caymancompass.com/opinion/">Opinion<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-465705" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-465705"><a href="https://www.caymancompass.com/opinion/editoral/">Editorial</a></li><li id="menu-item-465695" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-465695"><a href="https://www.caymancompass.com/opinion/letters-to-the-editor/">Letters</a></li><li id="menu-item-465696" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-465696"><a href="https://www.caymancompass.com/opinion/columns/">Columns</a></li><li id="menu-item-461688" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-461688"><a href="https://www.caymancompass.com/cartoons/">Cartoons</a></li><li id="menu-item-188304" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188304"><a href="https://www.caymancompass.com/submit-letter-to-the-editor/">Write a Letter to the Editor</a></li></ul></li><li id="menu-item-461689" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-461689"><a href="https://www.caymancompass.com/sports/">Sports</a></li><li id="menu-item-485925" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-485925"><a href="https://www.caymancompass.com/tourism/">Travel and Tourism</a></li><li id="menu-item-489131" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-489131"><a href="https://www.caymancompass.com/world/">World</a></li><li id="menu-item-461692" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-461692"><a href="https://www.caymancompass.com/weather/">Weather</a></li><li id="menu-item-484447" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-484447"><a href="https://www.caymancompass.com/storm-centre/">Cayman Storm Centre</a></li></ul></li><li id="menu-item-513521" class="election-nav-btn menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-513521"><a href="https://www.caymancompass.com/vote-cayman/">Election<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-513522" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-513522"><a href="https://www.caymancompass.com/vote-cayman/">2021 Election Hub</a></li><li id="menu-item-515287" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-515287"><a href="https://www.caymancompass.com/vote-cayman/">Districts<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-515288" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515288"><a href="https://www.caymancompass.com/vote-cayman/bodden-town-east/">Bodden Town East</a></li><li id="menu-item-515289" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515289"><a href="https://www.caymancompass.com/vote-cayman/bodden-town-west/">Bodden Town West</a></li><li id="menu-item-515290" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515290"><a href="https://www.caymancompass.com/vote-cayman/cayman-brac-east/">Cayman Brac East</a></li><li id="menu-item-515286" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515286"><a href="https://www.caymancompass.com/vote-cayman/cayman-brac-west-and-little-cayman/">Cayman Brac West and Little Cayman</a></li><li id="menu-item-516473" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-516473"><a href="https://www.caymancompass.com/vote-cayman/east-end/">East End</a></li><li id="menu-item-515285" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515285"><a href="https://www.caymancompass.com/vote-cayman/george-town-central/">George Town Central</a></li><li id="menu-item-515284" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515284"><a href="https://www.caymancompass.com/vote-cayman/george-town-east/">George Town East</a></li><li id="menu-item-515283" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515283"><a href="https://www.caymancompass.com/vote-cayman/george-town-north/">George Town North</a></li><li id="menu-item-515282" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515282"><a href="https://www.caymancompass.com/vote-cayman/george-town-south/">George Town South</a></li><li id="menu-item-515281" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515281"><a href="https://www.caymancompass.com/vote-cayman/george-town-west/">George Town West</a></li><li id="menu-item-515280" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515280"><a href="https://www.caymancompass.com/vote-cayman/newlands/">Newlands</a></li><li id="menu-item-515279" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515279"><a href="https://www.caymancompass.com/vote-cayman/north-side/">North Side</a></li><li id="menu-item-515278" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515278"><a href="https://www.caymancompass.com/vote-cayman/prospect/">Prospect</a></li><li id="menu-item-515277" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515277"><a href="https://www.caymancompass.com/vote-cayman/red-bay/">Red Bay</a></li><li id="menu-item-515276" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515276"><a href="https://www.caymancompass.com/vote-cayman/savannah/">Savannah</a></li><li id="menu-item-515275" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515275"><a href="https://www.caymancompass.com/vote-cayman/west-bay-central/">West Bay Central</a></li><li id="menu-item-515274" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515274"><a href="https://www.caymancompass.com/vote-cayman/west-bay-north/">West Bay North</a></li><li id="menu-item-515273" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515273"><a href="https://www.caymancompass.com/vote-cayman/west-bay-south/">West Bay South</a></li><li id="menu-item-515272" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515272"><a href="https://www.caymancompass.com/vote-cayman/west-bay-west/">West Bay West</a></li></ul></li><li id="menu-item-514647" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-514647"><a href="https://www.caymancompass.com/vote-cayman/candidates/">Candidates</a></li><li id="menu-item-516966" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-516966"><a href="https://www.caymancompass.com/vote-cayman/debate-schedule/">Vote Cayman Debate Schedule</a></li><li id="menu-item-517581" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-517581"><a href="https://www.caymancompass.com/makeyourvoiceheard/">Make your voice heard</a></li><li id="menu-item-515784" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515784"><a href="https://www.caymancompass.com/vote-cayman/resources/">Resources</a></li><li id="menu-item-517834" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-517834"><a href="https://www.caymancompass.com/candidate-video-shoot-schedule/">Candidates &#8211; book your video shoot</a></li></ul></li><li id="menu-item-463399" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-463399"><a href="https://www.caymancompass.com/business/">Business<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-512427" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-512427"><a href="https://www.caymancompass.com/business/">Cayman Business</a></li><li id="menu-item-512428" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-512428"><a href="https://www.caymancompass.com/business/compass-finance/">Compass  Finance</a></li><li id="menu-item-512426" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-512426"><a href="https://www.caymancompass.com/women-in-business/">Women In Business</a></li></ul></li><li id="menu-item-512410" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-512410"><a href="https://www.caymancompass.com/jobs/">Jobs<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-512433" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-512433"><a href="https://www.caymancompass.com/jobs/">Employment News</a></li><li id="menu-item-512432" class="s-trigger-login s-logged-out menu-item menu-item-type-post_type menu-item-object-page menu-item-512432"><a href="https://www.caymancompass.com/e-versions/">E-versions &#038; Classifieds</a></li></ul></li><li id="menu-item-512421" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-512421"><a href="https://www.caymancompass.com/health-and-wellness/">Health<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-512478" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-512478"><a href="https://www.caymancompass.com/coronavirus-cayman/">Coronavirus (COVID-19) Cayman</a></li><li id="menu-item-512424" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-512424"><a href="https://www.caymancompass.com/health-and-wellness/">Health &#038; Wellness</a></li><li id="menu-item-512423" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-512423"><a href="https://www.caymancompass.com/healthcare-in-a-pandemic/">Healthcare in a Pandemic</a></li><li id="menu-item-512422" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-512422"><a target="_blank" href="https://www.caymanhealth.com/">Cayman Health Directory</a></li></ul></li><li id="menu-item-512412" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-512412"><a href="https://www.caymancompass.com/community/">Community<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-188277" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-188277"><a href="/events/">Calendar<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-314306" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-314306"><a href="/events/">Event Listings</a></li><li id="menu-item-315091" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-315091"><a href="https://www.caymancompass.com/submit-event/">Submit an Event</a></li></ul></li><li id="menu-item-457157" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-457157"><a href="https://www.caymancompass.com/notices/">Notices</a></li><li id="menu-item-515426" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515426"><a href="https://www.caymancompass.com/press-releases/">Press Releases</a></li><li id="menu-item-512415" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-512415"><a href="https://www.caymancompass.com/opinion/letters-to-the-editor/">Letters</a></li><li id="menu-item-188303" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188303"><a href="https://www.caymancompass.com/submit-a-story-idea/">Submit a Story Idea</a></li><li id="menu-item-512413" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-512413"><a href="https://www.caymancompass.com/submit-letter-to-the-editor/">Submit Letter to the Editor</a></li><li id="menu-item-508585" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-508585"><a href="https://www.caymancompass.com/cayman-islands-public-holidays-2021/">Cayman Islands Public Holidays 2021</a></li><li id="menu-item-500450" class="menu-item menu-item-type-post_type menu-item-object-product menu-item-500450"><a href="https://www.caymancompass.com/store/cayman-islands-2021-calendar/">Cayman Islands 2021 Printed Calendar</a></li><li id="menu-item-188275" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188275"><a href="https://www.caymancompass.com/contests/">Contests</a></li></ul></li><li id="menu-item-512430" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-512430"><a href="#">Watch/Listen<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-461691" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-461691"><a href="https://www.caymancompass.com/video/">Video</a></li><li id="menu-item-467157" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-467157"><a href="https://www.caymancompass.com/podcasts/">Podcasts</a></li><li id="menu-item-464405" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-464405"><a href="https://www.caymancompass.com/interactive/">Interactive</a></li></ul></li><li id="menu-item-188276" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-188276"><a href="#">More<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-461690" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-461690"><a href="https://www.caymancompass.com/subscribe/">Subscribe</a></li><li id="menu-item-482735" class="menu-item menu-item-type-post_type menu-item-object-product menu-item-482735"><a href="https://www.caymancompass.com/store/donate/">Donate &#8211; Support Local Journalism</a></li><li id="menu-item-489945" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-489945"><a href="https://www.caymancompass.com/e-versions/">E-versions</a></li><li id="menu-item-359853" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-359853"><a href="https://www.caymancompass.com/editorial-staff/">Editorial Staff</a></li><li id="menu-item-499356" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-499356"><a href="https://www.caymancompass.com/faq/">Help &#038; FAQ</a></li><li id="menu-item-465825" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-465825"><a href="https://www.caymancompass.com/contact/">Contact</a></li><li id="menu-item-188280" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188280"><a href="https://www.caymancompass.com/advertise-with-us/">Advertise With Us</a></li><li id="menu-item-371483" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-371483"><a target="_blank" href="https://www.caymancompass.com/wp-content/uploads/2021/01/CompassMediaKit_JUL_2020-Print.pdf">Print Media Kit</a></li><li id="menu-item-389921" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-389921"><a href="https://www.caymancompass.com/wp-content/uploads/2020/09/CompassDigitalMediaKit2020-July-v2.pdf">Online Media Kit</a></li><li id="menu-item-511478" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-511478"><a href="https://www.caymancompass.com/wp-content/uploads/2021/01/Compass-Classifieds-Rate-Sheet-Jan2021.pdf">Classifieds Rate Sheet</a></li><li id="menu-item-482734" class="menu-item menu-item-type-post_type menu-item-object-product menu-item-482734"><a href="https://www.caymancompass.com/store/pay-bill/">Pay Bill</a></li><li id="menu-item-492594" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-492594"><a href="https://www.caymancompass.com/legal/">Legal</a></li></ul></li><li id="menu-item-490102" class="s-logged-in hide-for-desktop menu-item menu-item-type-custom menu-item-object-custom menu-item-490102"><a href="https://www.caymancompass.com/wp-login.php?action=logout&#038;redirect_to=%2F">Logout</a></li></ul></div></div></div><div id="login-form-mobile" class="td-register-section"><div id="td-login-mob" class="td-login-animation td-login-hide-mob"><div class="td-login-close"> <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a><div class="td-login-title">Sign in</div><div class="td-mobile-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div></div><div class="td-login-form-wrap"><div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div><div class="td_display_err"></div><div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div><div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div> <input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN"><div class="td-login-info-text"> <a href="#" id="forgot-pass-link-mob">Forgot your password?</a></div><div class="td-login-register-link"> <a id="signin-register-link-mob">Create an account</a></div><div class="td-login-info-text"><a class="privacy-policy-link" href="https://www.caymancompass.com/privacy-policy/">Privacy Policy</a></div></div></div><div id="td-register-mob" class="td-login-animation td-login-hide-mob"><div class="td-register-close"> <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a><div class="td-login-title">Sign up</div><div class="td-mobile-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div></div><div class="td-login-panel-title"><span>Welcome!</span>Register for an account</div><div class="td-login-form-wrap"><div class="td_display_err"></div><div class="td-login-inputs"><input class="td-login-input" type="text" name="register_email" id="register_email-mob" value="" required><label>your email</label></div><div class="td-login-inputs"><input class="td-login-input" type="text" name="register_user" id="register_user-mob" value="" required><label>your username</label></div> <input type="button" name="register_button" id="register_button-mob" class="td-login-button" value="REGISTER"><div class="td-login-info-text">A password will be e-mailed to you.</div><div class="td-login-info-text"><a class="privacy-policy-link" href="https://www.caymancompass.com/privacy-policy/">Privacy Policy</a></div></div></div><div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob"><div class="td-forgot-pass-close"> <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a><div class="td-login-title">Password recovery</div></div><div class="td-login-form-wrap"><div class="td-login-panel-title">Recover your password</div><div class="td_display_err"></div><div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div> <input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass"></div></div></div></div><div class="td-search-background"></div><div class="td-search-wrap-mob"><div class="td-drop-down-search"><form method="get" class="td-search-form" action="https://www.caymancompass.com/"><div class="td-search-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div><div role="search" class="td-search-input"> <span>Search</span> <input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" /></div></form><div id="td-aj-search-mob" class="td-ajax-search-flex"></div></div></div><div id="td-outer-wrap" class="td-theme-wrap"><div class="tdc-header-wrap "><div class="td-header-wrap td-header-style-1 "><div class="td-header-top-menu-full td-container-wrap td_stretch_container"><div class="td-container td-header-row td-header-top-menu"><div class="top-bar-style-1"><div class="td-header-sp-top-menu"><div class="menu-top-container"><ul id="menu-top-menu" class="top-header-menu"><li id="menu-item-461694" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-461694"><a href="https://www.caymancompass.com/subscribe/">Subscribe</a></li><li id="menu-item-489480" class="top-menu-red-button menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-489480"><a href="/account/profile">Members</a><ul class="sub-menu"><li id="menu-item-489484" class="s-logged-out s-trigger-login menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-489484"><a href="#login">Login/Register</a></li><li id="menu-item-490099" class="s-logged-in menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-490099"><a href="https://www.caymancompass.com/wp-login.php?action=logout&#038;redirect_to=%2F">Logout</a></li><li id="menu-item-489481" class="s-logged-in menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-489481"><a href="/account/profile">Profile</a></li><li id="menu-item-489482" class="s-logged-in menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-489482"><a href="/account/subscription">Subscription</a></li><li id="menu-item-489483" class="s-logged-in menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-489483"><a href="/account/update-password">Update password</a></li></ul></li><li id="menu-item-428186" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-428186"><a href="https://www.caymancompass.com/advertise-with-us/">Advertise</a></li><li id="menu-item-316348" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-316348"><a href="https://www.caymancompass.com/faq/">Help</a></li></ul></div></div><div class="td-header-sp-top-widget"> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.facebook.com/caycompass/" title="Facebook"> <i class="td-icon-font td-icon-facebook"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.instagram.com/cayman_compass/" title="Instagram"> <i class="td-icon-font td-icon-instagram"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://twitter.com/cayCompass" title="Twitter"> <i class="td-icon-font td-icon-twitter"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.youtube.com/user/caymancompas" title="Youtube"> <i class="td-icon-font td-icon-youtube"></i> </a> </span></div></div><div  id="login-form" class="white-popup-block mfp-hide mfp-with-anim"><div class="td-login-wrap"> <a href="#" class="td-back-button"><i class="td-icon-modal-back"></i></a><div id="td-login-div" class="td-login-form-div td-display-block"><div class="td-login-panel-title">Sign in</div><div class="td-login-panel-descr">Welcome! Log into your account</div><div class="td_display_err"></div><div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email" value="" required><label>your username</label></div><div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" required><label>your password</label></div> <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login"><div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div> <a id="register-link">Create an account</a><div class="td-login-info-text"><a class="privacy-policy-link" href="https://www.caymancompass.com/privacy-policy/">Privacy Policy</a></div></div><div id="td-register-div" class="td-login-form-div td-display-none"><div class="td-login-panel-title">Create an account</div><div class="td-login-panel-descr">Welcome! Register for an account</div><div class="td_display_err"></div><div class="td-login-inputs"><input class="td-login-input" type="text" name="register_email" id="register_email" value="" required><label>your email</label></div><div class="td-login-inputs"><input class="td-login-input" type="text" name="register_user" id="register_user" value="" required><label>your username</label></div> <input type="button" name="register_button" id="register_button" class="wpb_button btn td-login-button" value="Register"><div class="td-login-info-text">A password will be e-mailed to you.</div><div class="td-login-info-text"><a class="privacy-policy-link" href="https://www.caymancompass.com/privacy-policy/">Privacy Policy</a></div></div><div id="td-forgot-pass-div" class="td-login-form-div td-display-none"><div class="td-login-panel-title">Password recovery</div><div class="td-login-panel-descr">Recover your password</div><div class="td_display_err"></div><div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label>your email</label></div> <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password"><div class="td-login-info-text">A password will be e-mailed to you.</div></div></div></div></div></div><div class="td-banner-wrap-full td-logo-wrap-full td-container-wrap td_stretch_container"><div class="td-container td-header-row td-header-header"><div class="td-header-sp-logo"> <a class="td-main-logo" href="https://www.caymancompass.com/"> <img class="td-retina-data" data-retina="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassLogoNew544x180.png" src="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassLogoNew-272x90.png" alt="Cayman Compass" title="The most trusted news source in the Cayman Islands"/> <span class="td-visual-hidden">Cayman Compass</span> </a></div><div class="td-header-sp-recs"><div class="td-header-rec-wrap"><div class="td-a-rec td-a-rec-id-header  tdi_1_7b6 td_block_template_16"><style>/* custom css */
.tdi_1_7b6.td-a-rec{
					text-align: center;
				}.tdi_1_7b6 .td-element-style{
					z-index: -1;
				}.tdi_1_7b6.td-a-rec-img{
				    text-align: left;
				}.tdi_1_7b6.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_1_7b6.td-a-rec-img {
				        text-align: center;
				    }
                }</style> <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PBNB99T"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><div class="ad-delay-fix-for-mobile" style="min-height:50px;height:auto;"><div class="td-visible-all-devices" id="placement_197225_container">  <script type="text/javascript">if (!window.AdButler){(function(){var s = document.createElement("script"); s.async = true; s.type = "text/javascript";s.src = 'https://servedbyadbutler.com/app.js';var n = document.getElementsByTagName("script")[0]; n.parentNode.insertBefore(s, n);}());}</script> <script type="text/javascript">if (typeof _la === 'undefined' || !Array.isArray(_la)) _la = []; _la.push(function() {
    console.log('Loading header ad');
    var abkw = window.abkw || '';
    var plc197225 = window.plc197225 || 0;
    var dom = document.querySelector('#placement_197225_container');

    dom.innerHTML = '<div id="placement_197225_'+plc197225+'"></div>';
    window.AdButler.ads.push({
        handler: function(opt){
            window.AdButler.register(165413, 197225, [728,90], 'placement_197225_' + opt.place, opt);
        }, opt: {
            place: plc197225++,
            keywords: abkw,
            domain: 'servedbyadbutler.com',
            click:'CLICK_MACRO_PLACEHOLDER'
        }
    });
});</script> </div></div></div></div></div></div></div><div class="td-header-menu-wrap-full td-container-wrap td_stretch_container"><div class="td-header-menu-wrap td-header-gradient "><div class="td-container td-header-row td-header-main-menu"><div id="td-header-menu" role="navigation"><div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div><div class="td-main-menu-logo td-logo-in-header"> <a class="td-mobile-logo td-sticky-header" href="https://www.caymancompass.com/"> <img class="td-retina-data" data-retina="https://www.caymancompass.com/wp-content/uploads/2019/10/CaymanCompassLogoWhiteNew280x96.png" src="https://www.caymancompass.com/wp-content/uploads/2019/10/CaymanCompassLogoWhiteNew140x48.png" alt="Cayman Compass" title="The most trusted news source in the Cayman Islands"/> </a> <a class="td-header-logo td-sticky-header" href="https://www.caymancompass.com/"> <img class="td-retina-data" data-retina="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassLogoNew544x180.png" src="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassLogoNew-272x90.png" alt="Cayman Compass" title="The most trusted news source in the Cayman Islands"/> </a></div><div class="menu-main-menu-container"><ul id="menu-main-menu-1" class="sf-menu"><li class="hide-for-desktop menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-first td-menu-item td-normal-menu menu-item-489485"><a href="/account/profile">Members</a><ul class="sub-menu"><li class="s-trigger-login s-logged-out menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-489489"><a href="#login">Login/Register</a></li><li class="s-logged-in menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-490096"><a href="https://www.caymancompass.com/wp-login.php?action=logout&#038;redirect_to=%2F">Logout</a></li><li class="s-logged-in menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-489486"><a href="/account/profile">Profile</a></li><li class="s-logged-in menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-489487"><a href="/account/subscription">Subscription</a></li><li class="s-logged-in menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-489488"><a href="/account/update-password">Update password</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-499355"><a href="https://www.caymancompass.com/faq/">Help &#038; FAQ</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-187847"><a href="https://www.caymancompass.com/cayman-news/">News</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-187848"><a href="https://www.caymancompass.com/cayman-news/">Cayman News</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-464189"><a href="https://www.caymancompass.com/issues/">Issues</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-514433"><a href="https://www.caymancompass.com/issues/cost-of-living-cayman/">Cost of Living</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-486325"><a href="https://www.caymancompass.com/issues/cayman2-0/">Cayman 2.0</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-470131"><a href="https://www.caymancompass.com/issues/climate-change/">Climate Change</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-466938"><a href="https://www.caymancompass.com/issues/traffic/">Traffic</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-464188"><a href="https://www.caymancompass.com/issues/founded-upon-the-seas/">Founded Upon the Seas</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-458002"><a href="https://www.caymancompass.com/issues/port-vote-2019/">Port Vote 2019</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-458001"><a href="https://www.caymancompass.com/issues/friday-features/">Friday Features</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-456066"><a href="https://www.caymancompass.com/issues/sargassum/">Sargassum</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-471740"><a href="https://www.caymancompass.com/issues/">All Issues Stories</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-470185"><a href="https://www.caymancompass.com/coronavirus-cayman/">Coronavirus (COVID-19)</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188240"><a href="https://www.caymancompass.com/crime-and-courts/">Crime and Courts</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-461693"><a href="https://www.caymancompass.com/living/">Living</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-512411"><a href="https://www.caymancompass.com/politics/">Politics</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-465716"><a href="https://www.caymancompass.com/opinion/">Opinion</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-465705"><a href="https://www.caymancompass.com/opinion/editoral/">Editorial</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-465695"><a href="https://www.caymancompass.com/opinion/letters-to-the-editor/">Letters</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-465696"><a href="https://www.caymancompass.com/opinion/columns/">Columns</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-461688"><a href="https://www.caymancompass.com/cartoons/">Cartoons</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188304"><a href="https://www.caymancompass.com/submit-letter-to-the-editor/">Write a Letter to the Editor</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-461689"><a href="https://www.caymancompass.com/sports/">Sports</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-485925"><a href="https://www.caymancompass.com/tourism/">Travel and Tourism</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-489131"><a href="https://www.caymancompass.com/world/">World</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-461692"><a href="https://www.caymancompass.com/weather/">Weather</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-484447"><a href="https://www.caymancompass.com/storm-centre/">Cayman Storm Centre</a></li></ul></li><li class="election-nav-btn menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-513521"><a href="https://www.caymancompass.com/vote-cayman/">Election</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-513522"><a href="https://www.caymancompass.com/vote-cayman/">2021 Election Hub</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-515287"><a href="https://www.caymancompass.com/vote-cayman/">Districts</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-515288"><a href="https://www.caymancompass.com/vote-cayman/bodden-town-east/">Bodden Town East</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-515289"><a href="https://www.caymancompass.com/vote-cayman/bodden-town-west/">Bodden Town West</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-515290"><a href="https://www.caymancompass.com/vote-cayman/cayman-brac-east/">Cayman Brac East</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-515286"><a href="https://www.caymancompass.com/vote-cayman/cayman-brac-west-and-little-cayman/">Cayman Brac West and Little Cayman</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-516473"><a href="https://www.caymancompass.com/vote-cayman/east-end/">East End</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-515285"><a href="https://www.caymancompass.com/vote-cayman/george-town-central/">George Town Central</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-515284"><a href="https://www.caymancompass.com/vote-cayman/george-town-east/">George Town East</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-515283"><a href="https://www.caymancompass.com/vote-cayman/george-town-north/">George Town North</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-515282"><a href="https://www.caymancompass.com/vote-cayman/george-town-south/">George Town South</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-515281"><a href="https://www.caymancompass.com/vote-cayman/george-town-west/">George Town West</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-515280"><a href="https://www.caymancompass.com/vote-cayman/newlands/">Newlands</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-515279"><a href="https://www.caymancompass.com/vote-cayman/north-side/">North Side</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-515278"><a href="https://www.caymancompass.com/vote-cayman/prospect/">Prospect</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-515277"><a href="https://www.caymancompass.com/vote-cayman/red-bay/">Red Bay</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-515276"><a href="https://www.caymancompass.com/vote-cayman/savannah/">Savannah</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-515275"><a href="https://www.caymancompass.com/vote-cayman/west-bay-central/">West Bay Central</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-515274"><a href="https://www.caymancompass.com/vote-cayman/west-bay-north/">West Bay North</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-515273"><a href="https://www.caymancompass.com/vote-cayman/west-bay-south/">West Bay South</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-515272"><a href="https://www.caymancompass.com/vote-cayman/west-bay-west/">West Bay West</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-514647"><a href="https://www.caymancompass.com/vote-cayman/candidates/">Candidates</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-516966"><a href="https://www.caymancompass.com/vote-cayman/debate-schedule/">Vote Cayman Debate Schedule</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-517581"><a href="https://www.caymancompass.com/makeyourvoiceheard/">Make your voice heard</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-515784"><a href="https://www.caymancompass.com/vote-cayman/resources/">Resources</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-517834"><a href="https://www.caymancompass.com/candidate-video-shoot-schedule/">Candidates &#8211; book your video shoot</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-463399"><a href="https://www.caymancompass.com/business/">Business</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-512427"><a href="https://www.caymancompass.com/business/">Cayman Business</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-512428"><a href="https://www.caymancompass.com/business/compass-finance/">Compass  Finance</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-512426"><a href="https://www.caymancompass.com/women-in-business/">Women In Business</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-512410"><a href="https://www.caymancompass.com/jobs/">Jobs</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-512433"><a href="https://www.caymancompass.com/jobs/">Employment News</a></li><li class="s-trigger-login s-logged-out menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-512432"><a href="https://www.caymancompass.com/e-versions/">E-versions &#038; Classifieds</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-512421"><a href="https://www.caymancompass.com/health-and-wellness/">Health</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-512478"><a href="https://www.caymancompass.com/coronavirus-cayman/">Coronavirus (COVID-19) Cayman</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-512424"><a href="https://www.caymancompass.com/health-and-wellness/">Health &#038; Wellness</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-512423"><a href="https://www.caymancompass.com/healthcare-in-a-pandemic/">Healthcare in a Pandemic</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-512422"><a target="_blank" href="https://www.caymanhealth.com/">Cayman Health Directory</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-512412"><a href="https://www.caymancompass.com/community/">Community</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-188277"><a href="/events/">Calendar</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-314306"><a href="/events/">Event Listings</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-315091"><a href="https://www.caymancompass.com/submit-event/">Submit an Event</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-457157"><a href="https://www.caymancompass.com/notices/">Notices</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-515426"><a href="https://www.caymancompass.com/press-releases/">Press Releases</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-512415"><a href="https://www.caymancompass.com/opinion/letters-to-the-editor/">Letters</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188303"><a href="https://www.caymancompass.com/submit-a-story-idea/">Submit a Story Idea</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-512413"><a href="https://www.caymancompass.com/submit-letter-to-the-editor/">Submit Letter to the Editor</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-508585"><a href="https://www.caymancompass.com/cayman-islands-public-holidays-2021/">Cayman Islands Public Holidays 2021</a></li><li class="menu-item menu-item-type-post_type menu-item-object-product td-menu-item td-normal-menu menu-item-500450"><a href="https://www.caymancompass.com/store/cayman-islands-2021-calendar/">Cayman Islands 2021 Printed Calendar</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188275"><a href="https://www.caymancompass.com/contests/">Contests</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-512430"><a href="#">Watch/Listen</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-461691"><a href="https://www.caymancompass.com/video/">Video</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-467157"><a href="https://www.caymancompass.com/podcasts/">Podcasts</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-464405"><a href="https://www.caymancompass.com/interactive/">Interactive</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-188276"><a href="#">More</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-461690"><a href="https://www.caymancompass.com/subscribe/">Subscribe</a></li><li class="menu-item menu-item-type-post_type menu-item-object-product td-menu-item td-normal-menu menu-item-482735"><a href="https://www.caymancompass.com/store/donate/">Donate &#8211; Support Local Journalism</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-489945"><a href="https://www.caymancompass.com/e-versions/">E-versions</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-359853"><a href="https://www.caymancompass.com/editorial-staff/">Editorial Staff</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-499356"><a href="https://www.caymancompass.com/faq/">Help &#038; FAQ</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-465825"><a href="https://www.caymancompass.com/contact/">Contact</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188280"><a href="https://www.caymancompass.com/advertise-with-us/">Advertise With Us</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-371483"><a target="_blank" href="https://www.caymancompass.com/wp-content/uploads/2021/01/CompassMediaKit_JUL_2020-Print.pdf">Print Media Kit</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-389921"><a href="https://www.caymancompass.com/wp-content/uploads/2020/09/CompassDigitalMediaKit2020-July-v2.pdf">Online Media Kit</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-511478"><a href="https://www.caymancompass.com/wp-content/uploads/2021/01/Compass-Classifieds-Rate-Sheet-Jan2021.pdf">Classifieds Rate Sheet</a></li><li class="menu-item menu-item-type-post_type menu-item-object-product td-menu-item td-normal-menu menu-item-482734"><a href="https://www.caymancompass.com/store/pay-bill/">Pay Bill</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-492594"><a href="https://www.caymancompass.com/legal/">Legal</a></li></ul></li><li class="s-logged-in hide-for-desktop menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-490102"><a href="https://www.caymancompass.com/wp-login.php?action=logout&#038;redirect_to=%2F">Logout</a></li></ul></div></div><div class="header-search-wrap"><div class="td-search-btns-wrap"> <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a> <a id="td-header-search-button-mob" href="#" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a></div><div class="td-drop-down-search" aria-labelledby="td-header-search-button"><form method="get" class="td-search-form" action="https://www.caymancompass.com/"><div role="search" class="td-head-form-search-wrap"> <input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" /></div></form><div id="td-aj-search"></div></div></div></div></div></div></div></div><div class="td-main-content-wrap td-container-wrap"><div class="td-container td-post-template-default "><div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://www.caymancompass.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Life" class="entry-crumb" href="https://www.caymancompass.com/category/life/">Life</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Entertainment" class="entry-crumb" href="https://www.caymancompass.com/category/life/entertainment/">Entertainment</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Iggy Pop joins cast of &#8216;Blue Iguana&#8217; comedy</span></div></div><div class="td-pb-row"><div class="td-pb-span8 td-main-content" role="main"><div class="td-ss-main-content"><article id="post-520572" class="post-520572 post type-post status-publish format-standard has-post-thumbnail category-entertainment category-life tag-darius-films tag-iggy-pop tag-productivity-media" itemscope itemtype="https://schema.org/Article"47><div class="td-post-header"><ul class="td-category"><li class="entry-category"><a  href="https://www.caymancompass.com/category/life/">Life</a></li><li class="entry-category"><a  href="https://www.caymancompass.com/category/life/entertainment/">Entertainment</a></li></ul><header class="td-post-title"><h1 class="entry-title">Iggy Pop joins cast of &#8216;Blue Iguana&#8217; comedy</h1><p class="td-post-sub-title">Producers 'ecstatic' to have punk icon on board</p><div class="td-module-meta-info"><div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://www.caymancompass.com/author/staff/">Staff</a><div class="td-author-line"> -</div></div> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-04-01T10:55:01-05:00" >April 1, 2021</time></span></div></header></div><div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-bg td-ps-notext td-ps-rounded td-post-sharing-style3 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.caymancompass.com%2F2021%2F04%2F01%2Figgy-pop-joins-cast-of-blue-iguana-comedy%2F"><div class="td-social-but-icon"><i class="td-icon-facebook"></i></div><div class="td-social-but-text">Facebook</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Iggy+Pop+joins+cast+of+%E2%80%98Blue+Iguana%E2%80%99+comedy&url=https%3A%2F%2Fwww.caymancompass.com%2F2021%2F04%2F01%2Figgy-pop-joins-cast-of-blue-iguana-comedy%2F&via=cayCompass"><div class="td-social-but-icon"><i class="td-icon-twitter"></i></div><div class="td-social-but-text">Twitter</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="https://api.whatsapp.com/send?text=Iggy+Pop+joins+cast+of+%E2%80%98Blue+Iguana%E2%80%99+comedy %0A%0A https://www.caymancompass.com/2021/04/01/iggy-pop-joins-cast-of-blue-iguana-comedy/"><div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div><div class="td-social-but-text">WhatsApp</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="/cdn-cgi/l/email-protection#ecd39f998e86898f98d1a58b8b95ccbc839ccc868385829fcc8f8d9f98cc838acccacfd4dedddad7ae809989cca58b998d828dcacfd4dedddbd7cc8f8381898895ca8e838895d18498989c9fd6c3c39b9b9bc28f8d95818d828f83819c8d9f9fc28f8381c3dedcdeddc3dcd8c3dcddc3858b8b95c19c839cc1868385829fc18f8d9f98c1838ac18e809989c1858b998d828dc18f8381898895c3"><div class="td-social-but-icon"><i class="td-icon-mail"></i></div><div class="td-social-but-text">Email</div> </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top"><div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div> </a></div></div></div><div class="td-post-content tagdiv-type"><div class="td-post-featured-image"><figure><a href="https://www.caymancompass.com/wp-content/uploads/2021/04/0185_Iggy-Pop-19.07.30_Rob-Baker-Ashton_v1-copy.jpg" data-caption="Iggy Pop. - Photo: Rob Baker Ashton"><img width="696" height="817" class="entry-thumb td-modal-image" src="https://www.caymancompass.com/wp-content/uploads/2021/04/0185_Iggy-Pop-19.07.30_Rob-Baker-Ashton_v1-copy-696x817.jpg" srcset="https://www.caymancompass.com/wp-content/uploads/2021/04/0185_Iggy-Pop-19.07.30_Rob-Baker-Ashton_v1-copy-696x817.jpg 696w, https://www.caymancompass.com/wp-content/uploads/2021/04/0185_Iggy-Pop-19.07.30_Rob-Baker-Ashton_v1-copy-255x300.jpg 255w, https://www.caymancompass.com/wp-content/uploads/2021/04/0185_Iggy-Pop-19.07.30_Rob-Baker-Ashton_v1-copy-1226x1440.jpg 1226w, https://www.caymancompass.com/wp-content/uploads/2021/04/0185_Iggy-Pop-19.07.30_Rob-Baker-Ashton_v1-copy-1308x1536.jpg 1308w, https://www.caymancompass.com/wp-content/uploads/2021/04/0185_Iggy-Pop-19.07.30_Rob-Baker-Ashton_v1-copy-1068x1254.jpg 1068w, https://www.caymancompass.com/wp-content/uploads/2021/04/0185_Iggy-Pop-19.07.30_Rob-Baker-Ashton_v1-copy-358x420.jpg 358w, https://www.caymancompass.com/wp-content/uploads/2021/04/0185_Iggy-Pop-19.07.30_Rob-Baker-Ashton_v1-copy-600x705.jpg 600w, https://www.caymancompass.com/wp-content/uploads/2021/04/0185_Iggy-Pop-19.07.30_Rob-Baker-Ashton_v1-copy.jpg 1744w" sizes="(max-width: 696px) 100vw, 696px" alt="" title="0185_Iggy Pop 19.07.30_Rob Baker Ashton_v1 copy"/></a><figcaption class="wp-caption-text">Iggy Pop. - Photo: Rob Baker Ashton</figcaption></figure></div><div class="td-a-rec td-a-rec-id-content_top  tdi_3_006 td_block_template_16"><style>/* custom css */
.tdi_3_006.td-a-rec{
					text-align: center;
				}.tdi_3_006 .td-element-style{
					z-index: -1;
				}.tdi_3_006.td-a-rec-img{
				    text-align: left;
				}.tdi_3_006.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_3_006.td-a-rec-img {
				        text-align: center;
				    }
                }</style><div id="isb_phone_advert" class="td-visible-phone">  <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">if (typeof _la === 'undefined' || !Array.isArray(_la)) _la = [];

        _la.push(function() {
            var elem = document.getElementById("isb_phone_advert");
            var theCSSprop = window.getComputedStyle(elem,null).getPropertyValue("display");

            if (theCSSprop != "none") {
                window.loadAdZone(420687, 'isb_phone_advert');
            }
        });</script> </div></div><p>Producers William G. Santor, CEO of Productivity Media, and Nicholas Tabarrok, President of Darius Films, announced today that punk-rock icon Iggy Pop has joined the cast of the dark comedy &#8216;Blue Iguana&#8217;, currently filming in the Cayman Islands.</p><p>&#8216;Blue Iguana&#8217; is directed by Canadian filmmaker Jeremy LaLonde from a script by Matthew Dressel and stars Joel David Moore, Bob Saget, Jason Jones, Carly Chaikin<i>,</i> and Mary Lynn Rajskub.</p><p>Iggy Pop plays the role of Edward, the wealthy patriarch whose death kicks off a chain of unfortunate events after Daniel Powell&#8217;s plan to reconnect with his siblings hits a snag when he discovers they all want to kill him for his inheritance. As the brothers and sisters are forced to spend the weekend together at the family beach house on the Cayman Islands, one thing becomes painfully clear: Daniel’s going to find out what family means, even if it kills him.</p><p>Producers Santor and Tabarrok said, “We are beyond ecstatic to have the legendary Iggy Pop join the cast of &#8216;Blue Iguana&#8217;. While purely coincidental to his casting, his name is derived from the word iguana so it couldn’t be more fitting that Iggy joins our already stellar cast. We can’t wait to work with him in the beautiful Cayman Islands.”</p><p>Read our previous story on the multi-picture deal between the film companies and the Cayman Islands Government <a href="https://www.caymancompass.com/2021/03/05/productivity-media-and-darius-films-to-shoot-three-features-in-cayman/" target="_blank" rel="noopener">here</a>.</p><div class="td-a-rec td-a-rec-id-content_inline  tdi_2_7fb td_block_template_16"><style>/* custom css */
.tdi_2_7fb.td-a-rec{
					text-align: center;
				}.tdi_2_7fb .td-element-style{
					z-index: -1;
				}.tdi_2_7fb.td-a-rec-img{
				    text-align: left;
				}.tdi_2_7fb.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_2_7fb.td-a-rec-img {
				        text-align: center;
				    }
                }</style><div id="in_article_ad" class="td-all-devices in-article-lb-ad">  <script type="text/javascript">if (typeof _la === 'undefined' || !Array.isArray(_la)) _la = [];

        _la.push(function() {
            window.loadAdZone(420688, 'in_article_ad');
        });</script> </div></div><div class="likebtn_container" style="clear:both;"><span class="likebtn-wrapper"  data-identifier="post_520572"  data-site_id="5a6f97366fd08b0f18563396"  data-theme="custom"  data-icon_l="thmb4-u"  data-icon_d="thmb4-d"  data-icon_size="24"  data-icon_l_c_v="#00aeef"  data-icon_d_c_v="#00aeef"  data-counter_l_c="#222222"  data-counter_d_c="#222222"  data-bg_c="rgba(250,250,250,0)"  data-bg_c_v="rgba(250,250,250,0)"  data-brdr_c="rgba(255,255,255,0)"  data-f_size="14"  data-f_family="Georgia"  data-counter_fs="b"  data-show_like_label="false"  data-share_enabled="false"  data-voting_cancelable="false"  data-tooltip_enabled="false"  data-white_label="true"  data-popup_disabled="true"  data-style=""  data-unlike_allowed=""  data-show_copyright=""  data-item_url="https://www.caymancompass.com/2021/04/01/iggy-pop-joins-cast-of-blue-iguana-comedy/"  data-item_title="Iggy Pop joins cast of 'Blue Iguana' comedy"  data-item_image="https://www.caymancompass.com/wp-content/uploads/2021/04/0185_Iggy-Pop-19.07.30_Rob-Baker-Ashton_v1-copy-1226x1440.jpg"  data-item_date="2021-04-01T10:55:01-05:00"  data-engine="WordPress"  data-plugin_v="2.6.36"  data-prx="https://www.caymancompass.com/wp-admin/admin-ajax.php?action=likebtn_prx"  data-event_handler="likebtn_eh" ></span></div><div class="td-a-rec td-a-rec-id-content_bottom  tdi_4_0e0 td_block_template_16"><style>/* custom css */
.tdi_4_0e0.td-a-rec{
					text-align: center;
				}.tdi_4_0e0 .td-element-style{
					z-index: -1;
				}.tdi_4_0e0.td-a-rec-img{
				    text-align: left;
				}.tdi_4_0e0.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_4_0e0.td-a-rec-img {
				        text-align: center;
				    }
                }</style><div id="bottom_article_ad" class="td-all-devices">  <script type="text/javascript">if (typeof _la === 'undefined' || !Array.isArray(_la)) _la = [];

        _la.push(function() {
            window.loadAdZone(421033, 'bottom_article_ad');
        });</script> </div><div class="s-logged-out" style="margin-top:50px; border: 1px solid #ddd; background-color: #fff; padding: 30px 30px 10px 30px;"><p style="text-align:center;">Support local journalism. Subscribe to the all-access pass for the Cayman Compass.</p><p style="text-align:center;"><span class="td_btn td_btn_lg td_default_btn s-trigger-subscriptions"><a><span style="color: #ffffff;">Subscribe now</span></a></span></p></div></div></div><footer><div class="td-post-source-tags"><ul class="td-tags td-post-small-box clearfix"><li><span>Topics</span></li><li><a href="https://www.caymancompass.com/tag/darius-films/">Darius Films</a></li><li><a href="https://www.caymancompass.com/tag/iggy-pop/">Iggy Pop</a></li><li><a href="https://www.caymancompass.com/tag/productivity-media/">Productivity Media</a></li></ul></div><div class="td-post-sharing-bottom"><div class="td-post-sharing-classic"><iframe frameBorder="0" src="https://www.facebook.com/plugins/like.php?href=https://www.caymancompass.com/2021/04/01/iggy-pop-joins-cast-of-blue-iguana-comedy/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:auto; height:21px; background-color:transparent;"></iframe></div><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-ps-rounded td-post-sharing-style3 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.caymancompass.com%2F2021%2F04%2F01%2Figgy-pop-joins-cast-of-blue-iguana-comedy%2F"><div class="td-social-but-icon"><i class="td-icon-facebook"></i></div><div class="td-social-but-text">Facebook</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Iggy+Pop+joins+cast+of+%E2%80%98Blue+Iguana%E2%80%99+comedy&url=https%3A%2F%2Fwww.caymancompass.com%2F2021%2F04%2F01%2Figgy-pop-joins-cast-of-blue-iguana-comedy%2F&via=cayCompass"><div class="td-social-but-icon"><i class="td-icon-twitter"></i></div><div class="td-social-but-text">Twitter</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="https://api.whatsapp.com/send?text=Iggy+Pop+joins+cast+of+%E2%80%98Blue+Iguana%E2%80%99+comedy %0A%0A https://www.caymancompass.com/2021/04/01/iggy-pop-joins-cast-of-blue-iguana-comedy/"><div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div><div class="td-social-but-text">WhatsApp</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="/cdn-cgi/l/email-protection#af90dcdacdc5caccdb92e6c8c8d68fffc0df8fc5c0c6c1dc8fcccedcdb8fc0c98f898c979d9e9994edc3daca8fe6c8dacec1ce898c979d9e98948fccc0c2cacbd689cdc0cbd692c7dbdbdfdc958080d8d8d881ccced6c2cec1ccc0c2dfcedcdc81ccc0c2809d9f9d9e809f9b809f9e80c6c8c8d682dfc0df82c5c0c6c1dc82cccedcdb82c0c982cdc3daca82c6c8dacec1ce82ccc0c2cacbd680"><div class="td-social-but-icon"><i class="td-icon-mail"></i></div><div class="td-social-but-text">Email</div> </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom"><div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div> </a></div></div></div><div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://www.caymancompass.com/2021/04/01/crosstalk-debate-prospect-candidates-face-off/">Crosstalk debate: Prospect candidates face off</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="https://www.caymancompass.com/2021/04/01/central-planning-authority-denies-dart-helipad-application/">Central Planning Authority denies Dart helipad application</a></div></div></div><div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="https://www.caymancompass.com/author/staff/">Staff</a></span></div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Staff"></span><meta itemprop="datePublished" content="2021-04-01T10:55:01-05:00"><meta itemprop="dateModified" content="2021-04-01T12:46:27-05:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.caymancompass.com/2021/04/01/iggy-pop-joins-cast-of-blue-iguana-comedy/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassLogoNew-272x90.png"></span><meta itemprop="name" content="Cayman Compass"></span><meta itemprop="headline " content="Iggy Pop joins cast of &#039;Blue Iguana&#039; comedy"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.caymancompass.com/wp-content/uploads/2021/04/0185_Iggy-Pop-19.07.30_Rob-Baker-Ashton_v1-copy.jpg"><meta itemprop="width" content="1744"><meta itemprop="height" content="2048"></span></footer></article><div class="td_block_wrap td_block_related_posts tdi_5_7f3 td_with_ajax_pagination td-pb-border-top td_block_template_16"  data-td-block-uid="tdi_5_7f3" ><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>var block_tdi_5_7f3 = new tdBlock();
block_tdi_5_7f3.id = "tdi_5_7f3";
block_tdi_5_7f3.atts = '{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_tags","td_ajax_filter_type":"td_custom_related","class":"tdi_5_7f3","td_column_number":3,"block_type":"td_block_related_posts","live_filter_cur_post_id":520572,"live_filter_cur_post_author":"50","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"tdi_5_7f3","tdc_css_class_style":"tdi_5_7f3_rand_style"}';
block_tdi_5_7f3.td_column_number = "3";
block_tdi_5_7f3.block_type = "td_block_related_posts";
block_tdi_5_7f3.post_count = "3";
block_tdi_5_7f3.found_posts = "4";
block_tdi_5_7f3.header_color = "";
block_tdi_5_7f3.ajax_pagination_infinite_stop = "";
block_tdi_5_7f3.max_num_pages = "2";
tdBlocksArray.push(block_tdi_5_7f3);</script><h4 class="td-related-title td-block-title"><a id="tdi_6_f33" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="tdi_5_7f3" href="#">Related articles</a><a id="tdi_7_063" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="tdi_5_7f3" href="#">More from author</a></h4><div id=tdi_5_7f3 class="td_block_inner"><div class="td-related-row"><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.caymancompass.com/2021/03/05/productivity-media-and-darius-films-to-shoot-three-features-in-cayman/" rel="bookmark" class="td-image-wrap " title="Deal inked to shoot three films in Cayman" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Deal inked to shoot three films in Cayman" data-type="image_tag" data-img-url="https://www.caymancompass.com/wp-content/uploads/2021/03/Bob-Saget-Color-21-1-e1614984323273-218x150.jpg"  width="218" height="150" /></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.caymancompass.com/2021/03/05/productivity-media-and-darius-films-to-shoot-three-features-in-cayman/" rel="bookmark" title="Deal inked to shoot three films in Cayman">Deal inked to shoot three films in Cayman</a></h3></div></div></div><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.caymancompass.com/2021/02/26/godfather-of-punk/" rel="bookmark" class="td-image-wrap " title="Godfather of Punk!" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Godfather of Punk!" data-type="image_tag" data-img-url="https://www.caymancompass.com/wp-content/uploads/2021/02/MAIN-COLOUR-218x150.jpg"  width="218" height="150" /></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.caymancompass.com/2021/02/26/godfather-of-punk/" rel="bookmark" title="Godfather of Punk!">Godfather of Punk!</a></h3></div></div></div><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.caymancompass.com/2021/02/14/godfather-of-punk-raises-the-roof-at-harquail/" rel="bookmark" class="td-image-wrap " title="&#8216;Godfather of Punk&#8217; raises the roof at Harquail" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="&#8216;Godfather of Punk&#8217; raises the roof at Harquail" data-type="image_tag" data-img-url="https://www.caymancompass.com/wp-content/uploads/2021/02/Iggy-Pop-live-at-harquail-theatre-13-crop-218x150.jpg"  width="218" height="150" /><span class="td-video-play-ico"><i class="td-icon-video-thumb-play"></i></span></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.caymancompass.com/2021/02/14/godfather-of-punk-raises-the-roof-at-harquail/" rel="bookmark" title="&#8216;Godfather of Punk&#8217; raises the roof at Harquail">&#8216;Godfather of Punk&#8217; raises the roof at Harquail</a></h3></div></div></div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_5_7f3" data-td_block_id="tdi_5_7f3"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-tdi_5_7f3" data-td_block_id="tdi_5_7f3"><i class="td-icon-font td-icon-menu-right"></i></a></div></div><div class="comments" id="comments"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">LEAVE A REPLY <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2021/04/01/iggy-pop-joins-cast-of-blue-iguana-comedy/#respond" style="display:none;">Cancel reply</a></small></h3><p class="must-log-in td-login-comment"><a class="s-trigger-login" data-effect="mpf-td-login-effect" href="#">Log in to leave a comment </a></p></div></div></div></div><div class="td-pb-span4 td-main-sidebar" role="complementary"><div class="td-ss-main-sidebar"><div class="td-a-rec td-a-rec-id-sidebar  tdi_8_f65 td_block_template_16"><style>/* custom css */
.tdi_8_f65.td-a-rec{
					text-align: center;
				}.tdi_8_f65 .td-element-style{
					z-index: -1;
				}.tdi_8_f65.td-a-rec-img{
				    text-align: left;
				}.tdi_8_f65.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_8_f65.td-a-rec-img {
				        text-align: center;
				    }
                }</style><div id="isb_desktop_advert" class="td-visible-desktop sidebar-ad-compass-fix">  <script type="text/javascript">if (typeof _la === 'undefined' || !Array.isArray(_la)) _la = [];

        _la.push(function() {
            var elem = document.getElementById("isb_desktop_advert");
            var theCSSprop = window.getComputedStyle(elem,null).getPropertyValue("display");

            if (theCSSprop != "none") {
                window.loadAdZone(420687, 'isb_desktop_advert');
            }
        });</script> </div><div id="isb_tablet_portrait_advert" class="td-visible-tablet-portrait sidebar-ad-compass-fix">  <script type="text/javascript">if (typeof _la === 'undefined' || !Array.isArray(_la)) _la = [];

        _la.push(function() {
            var elem = document.getElementById("isb_tablet_portrait_advert");
            var theCSSprop = window.getComputedStyle(elem,null).getPropertyValue("display");

            if (theCSSprop != "none") {
                window.loadAdZone(420687, 'isb_tablet_portrait_advert');
            }
        });</script> </div><div id="isb_tablet_landscape_advert" class="td-visible-tablet-landscape sidebar-ad-compass-fix">  <script type="text/javascript">if (typeof _la === 'undefined' || !Array.isArray(_la)) _la = [];

        _la.push(function() {
            var elem = document.getElementById("isb_tablet_landscape_advert");
            var theCSSprop = window.getComputedStyle(elem,null).getPropertyValue("display");

            if (theCSSprop != "none") {
                window.loadAdZone(420687, 'isb_tablet_landscape_advert');
            }
        });</script> </div></div><aside id="custom_html-4" class="widget_text td_block_template_16 widget custom_html-4 widget_custom_html"><h4 class="td-block-title"><span>Daily newsletter</span></h4><div class="textwidget custom-html-widget"><div id="hs_embed_signup" style="margin-top: -10px;"> <!--[if lte IE 8]> <script charset="utf-8" type="text/javascript" src="//js.hsforms.net/forms/v2-legacy.js"></script> <![endif]--> <script charset="utf-8" type="text/javascript" src="//js.hsforms.net/forms/v2.js"></script> <script>hbspt.forms.create({
	portalId: "5627643",
	formId: "1cc15e7f-bbe8-4430-aa57-9225745cb133"
});</script> </div></div></aside><div class="td_block_wrap td_block_7 td_block_widget tdi_9_683 td_with_ajax_pagination td-pb-border-top td_block_template_16 td-column-1 td_block_padding"  data-td-block-uid="tdi_9_683" ><style>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</style><script>var block_tdi_9_683 = new tdBlock();
block_tdi_9_683.id = "tdi_9_683";
block_tdi_9_683.atts = '{"custom_title":"This week","custom_url":"","block_template_id":"","header_text_color":"#","border_color":"#","accent_text_color":"#","m6_tl":"","limit":"3","offset":"","el_class":"","post_ids":"","category_id":"","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","sort":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"next_prev","ajax_pagination_infinite_stop":"","class":"td_block_widget tdi_9_683","block_type":"td_block_7","separator":"","show_modified_date":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m6f_title_font_header":"","m6f_title_font_title":"Article title","m6f_title_font_settings":"","m6f_title_font_family":"","m6f_title_font_size":"","m6f_title_font_line_height":"","m6f_title_font_style":"","m6f_title_font_weight":"","m6f_title_font_transform":"","m6f_title_font_spacing":"","m6f_title_":"","m6f_cat_font_title":"Article category tag","m6f_cat_font_settings":"","m6f_cat_font_family":"","m6f_cat_font_size":"","m6f_cat_font_line_height":"","m6f_cat_font_style":"","m6f_cat_font_weight":"","m6f_cat_font_transform":"","m6f_cat_font_spacing":"","m6f_cat_":"","m6f_meta_font_title":"Article meta info","m6f_meta_font_settings":"","m6f_meta_font_family":"","m6f_meta_font_size":"","m6f_meta_font_line_height":"","m6f_meta_font_style":"","m6f_meta_font_weight":"","m6f_meta_font_transform":"","m6f_meta_font_spacing":"","m6f_meta_":"","css":"","tdc_css":"","td_column_number":1,"header_color":"","color_preset":"","border_top":"","tdc_css_class":"tdi_9_683","tdc_css_class_style":"tdi_9_683_rand_style"}';
block_tdi_9_683.td_column_number = "1";
block_tdi_9_683.block_type = "td_block_7";
block_tdi_9_683.post_count = "3";
block_tdi_9_683.found_posts = "91874";
block_tdi_9_683.header_color = "";
block_tdi_9_683.ajax_pagination_infinite_stop = "";
block_tdi_9_683.max_num_pages = "30625";
tdBlocksArray.push(block_tdi_9_683);</script><div class="td-block-title-wrap"><h4 class="td-block-title"><span class="td-pulldown-size">This week</span></h4></div><div id=tdi_9_683 class="td_block_inner"><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.caymancompass.com/2021/04/01/hurricane-ivan-era-governor-passes-away/" rel="bookmark" class="td-image-wrap " title="Hurricane Ivan-era governor passes away" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" alt="Bruce Dinwiddy" title="Hurricane Ivan-era governor passes away" data-type="image_tag" data-img-url="https://www.caymancompass.com/wp-content/uploads/2021/04/Bruce-Dinwiddy_highrez-e1617307677935-100x70.jpg"  width="100" height="70" /></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.caymancompass.com/2021/04/01/hurricane-ivan-era-governor-passes-away/" rel="bookmark" title="Hurricane Ivan-era governor passes away">Hurricane Ivan-era governor passes away</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-04-01T15:06:08-05:00" >April 1, 2021</time></span></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.caymancompass.com/2021/04/01/central-planning-authority-denies-dart-helipad-application/" rel="bookmark" class="td-image-wrap " title="Central Planning Authority denies Dart helipad application" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" alt="DoE CPA sumbmission" title="Central Planning Authority denies Dart helipad application" data-type="image_tag" data-img-url="https://www.caymancompass.com/wp-content/uploads/2021/04/DoE-CPA-sumbmission-e1617302751135-100x70.jpg"  width="100" height="70" /></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.caymancompass.com/2021/04/01/central-planning-authority-denies-dart-helipad-application/" rel="bookmark" title="Central Planning Authority denies Dart helipad application">Central Planning Authority denies Dart helipad application</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-04-01T14:26:02-05:00" >April 1, 2021</time></span></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.caymancompass.com/2021/04/01/iggy-pop-joins-cast-of-blue-iguana-comedy/" rel="bookmark" class="td-image-wrap " title="Iggy Pop joins cast of &#8216;Blue Iguana&#8217; comedy" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" alt="" title="Iggy Pop joins cast of &#8216;Blue Iguana&#8217; comedy" data-type="image_tag" data-img-url="https://www.caymancompass.com/wp-content/uploads/2021/04/0185_Iggy-Pop-19.07.30_Rob-Baker-Ashton_v1-copy-100x70.jpg"  width="100" height="70" /></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.caymancompass.com/2021/04/01/iggy-pop-joins-cast-of-blue-iguana-comedy/" rel="bookmark" title="Iggy Pop joins cast of &#8216;Blue Iguana&#8217; comedy">Iggy Pop joins cast of &#8216;Blue Iguana&#8217; comedy</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-04-01T10:55:01-05:00" >April 1, 2021</time></span></div></div></div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_9_683" data-td_block_id="tdi_9_683"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-tdi_9_683" data-td_block_id="tdi_9_683"><i class="td-icon-font td-icon-menu-right"></i></a></div></div></div></div></div></div></div><div id="s-login-modal"></div><div id="s-checkout-modal"></div><div class="tdc-footer-wrap "><div class="td-footer-wrapper td-footer-container td-container-wrap td_stretch_container"><div class="td-container"><div class="td-pb-row"><div class="td-pb-span12"></div></div><div class="td-pb-row"><div class="td-pb-span4"><aside class="td_block_template_16 widget widget_nav_menu"><h4 class="td-block-title"><span>Useful Links</span></h4><div class="menu-footer-links-container"><ul id="menu-footer-links" class="menu"><li id="menu-item-511412" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-511412"><a href="https://www.caymancompass.com/advertise-with-us/">Advertise With Us</a></li><li id="menu-item-510665" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-510665"><a href="https://www.caymancompass.com/faq/">Help &#038; FAQ</a></li><li id="menu-item-510654" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-510654"><a href="https://www.caymancompass.com/issues/cayman2-0/">Cayman 2.0</a></li><li id="menu-item-510667" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-510667"><a href="https://www.caymancompass.com/video/">Video and Live Streams</a></li><li id="menu-item-510659" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-510659"><a href="https://www.caymancompass.com/interactive/">Interactive</a></li><li id="menu-item-510653" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-510653"><a href="https://www.caymancompass.com/cayman-real-estate/">Cayman Real Estate</a></li><li id="menu-item-510655" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-510655"><a href="https://www.caymancompass.com/tourism/">Cayman Islands Travel and Tourism News</a></li><li id="menu-item-510657" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-510657"><a href="https://www.caymancompass.com/e-versions/">E-versions</a></li><li id="menu-item-510663" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-510663"><a href="https://www.caymancompass.com/opinion/letters-to-the-editor/">Letters to the Editor</a></li><li id="menu-item-510682" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-510682"><a href="https://www.caymancompass.com/opinion/">Opinion</a></li><li id="menu-item-510652" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-510652"><a href="https://www.caymancompass.com/traffic-map-cayman/">Grand Cayman Traffic Map</a></li></ul></div></aside></div><div class="td-pb-span4"><aside class="td_block_template_16 widget widget_nav_menu"><h4 class="td-block-title"><span>Compass Media</span></h4><div class="menu-footer-brand-links-container"><ul id="menu-footer-brand-links" class="menu"><li id="menu-item-510670" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-first td-menu-item td-normal-menu menu-item-510670"><a target="_blank" rel="noopener" href="https://www.compassmedia.ky">About Compass Media</a></li><li id="menu-item-519808" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-519808"><a href="https://www.compassmedia.ky/our-brands/">Our Brands</a></li><li id="menu-item-519812" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-519812"><a href="https://www.compassmedia.ky/what-we-do/#our_platforms">Our Platforms</a></li><li id="menu-item-519813" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-519813"><a href="https://www.compassmedia.ky/what-we-do/#our_platforms">Radio</a></li><li id="menu-item-519805" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-519805"><a href="https://www.compassmedia.ky/print-shop/">Print Shop</a></li><li id="menu-item-510684" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-510684"><a target="_blank" rel="noopener" href="https://www.compassmedia.ky/compass-content/">Content Creation</a></li><li id="menu-item-519817" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-519817"><a href="https://www.compassmedia.ky/advertise/">Advertising</a></li><li id="menu-item-510675" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-510675"><a target="_blank" rel="noopener" href="https://www.caymanhealth.com">Cayman Health Directory</a></li><li id="menu-item-510674" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-510674"><a href="https://www.caymancompass.com/cayman-real-estate/">Cayman Real Estate &#038; InsideOut Magazine</a></li><li id="menu-item-510678" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-510678"><a href="https://www.caymancompass.com/special-features-and-publications/">Special Features and Publications</a></li><li id="menu-item-510673" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-510673"><a href="https://www.caymancompass.com/emergency-guide/">Emergency Guide</a></li></ul></div></aside></div><div class="td-pb-span4"><aside class="td_block_template_16 widget widget_nav_menu"><h4 class="td-block-title"><span>Subscribe</span></h4><div class="menu-footer-subscribe-links-container"><ul id="menu-footer-subscribe-links" class="menu"><li id="menu-item-510636" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-510636"><a href="https://www.caymancompass.com/subscribe/">Subscribe to the Compass All-Access Pass</a></li><li id="menu-item-510641" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-510641"><a href="https://www.caymancompass.com/subscribe/daily-newsletter/">Subscribe to the Daily Newsletter</a></li><li id="menu-item-510638" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-510638"><a href="https://www.caymancompass.com/subscribe/employment-newsletter/">Subscribe to the Employment Newsletter</a></li><li id="menu-item-510637" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-510637"><a href="https://www.caymancompass.com/subscribe/cayman-real-estate-newsletter/">Subscribe to the Cayman Real Estate Newsletter</a></li><li id="menu-item-510639" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-510639"><a href="https://www.caymancompass.com/subscribe/financial-newsletter/">Subscribe to the Financial Newsletter</a></li></ul></div></aside><aside class="widget_text td_block_template_16 widget widget_custom_html"><div class="textwidget custom-html-widget"><div style="display: table;"><div class="footer-payment-logos" style="position:relative; display: inline;"><img class="alignnone size-full wp-image-482000" src="https://www.caymancompass.com/wp-content/uploads/2020/06/american_express.png" alt="" style="margin-top:10px;" width="46" height="24"> <img class="alignnone size-full wp-image-480084" src="https://www.caymancompass.com/wp-content/uploads/2020/06/visa.png" alt="" style="margin-top:10px;" width="46" height="24"> <img class="size-full wp-image-480085" src="https://www.caymancompass.com/wp-content/uploads/2020/06/mastercard.png" alt="" width="46" height="24"></div><div class="footer-payment-links-text" style="position:relative; display: inline;"> <span style="font-size: 14px; line-height:14px; font-family: Gliko-Modern-S-Regular !important; position: relative;"><br />Pay securely with your Credit Card. <a href="https://www.caymancompass.com/refund-policy/"><br />Click here to view our Refund Policy</a>.</span></div></div></div></aside></div></div></div><div class="td-footer-bottom-full"><div class="td-container"><div class="td-pb-row"><div class="td-pb-span3"><aside class="footer-logo-wrap"><a href="https://www.caymancompass.com/"><img class="td-retina-data" src="https://www.caymancompass.com/wp-content/uploads/2019/10/CaymanCompassLogoWhiteNew140x48.png" data-retina="https://www.caymancompass.com/wp-content/uploads/2019/10/CaymanCompassLogoWhiteNew280x96.png" alt="Cayman Compass" title="The most trusted news source in the Cayman Islands" width="140" /></a></aside></div><div class="td-pb-span5"><aside class="footer-text-wrap"><div class="block-title"><span>ABOUT US</span></div>Cayman Compass is Cayman Islands' most trusted news source.</aside></div><div class="td-pb-span4"><aside class="footer-social-wrap td-social-style-2"><div class="block-title"><span>FOLLOW US</span></div> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.facebook.com/caycompass/" title="Facebook"> <i class="td-icon-font td-icon-facebook"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.instagram.com/cayman_compass/" title="Instagram"> <i class="td-icon-font td-icon-instagram"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://twitter.com/cayCompass" title="Twitter"> <i class="td-icon-font td-icon-twitter"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.youtube.com/user/caymancompas" title="Youtube"> <i class="td-icon-font td-icon-youtube"></i> </a> </span></aside></div></div></div></div></div><div class="td-sub-footer-container td-container-wrap td_stretch_container"><div class="td-container"><div class="td-pb-row"><div class="td-pb-span td-sub-footer-menu"><div class="menu-sub-footer-menu-container"><ul id="menu-sub-footer-menu" class="td-subfooter-menu"><li id="menu-item-492593" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-492593"><a href="https://www.caymancompass.com/legal/">Legal</a></li><li id="menu-item-316352" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-316352"><a href="https://www.caymancompass.com/faq/">Help &#038; FAQ</a></li><li id="menu-item-480188" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-480188"><a href="https://www.caymancompass.com/contact/">Contact</a></li></ul></div></div><div class="td-pb-span td-sub-footer-copy"> &copy; Copyright Cayman Compass Ltd.</div></div></div></div></div></div>  <script type="text/javascript">var likebtn_wl = 1; (function(d, e, s) {a = d.createElement(e);m = d.getElementsByTagName(e)[0];a.async = 1;a.src = s;m.parentNode.insertBefore(a, m)})(document, 'script', '//w.likebtn.com/js/w/widget.js'); if (typeof(LikeBtn) != "undefined") { LikeBtn.init(); }</script>  
<style type="text/css" media="screen">/* custom css theme panel */
/* FOOTER LINKS FONT OVERRIDE */

.td-footer-wrapper .widget_nav_menu li {
    font-size: 14px;
    font-family: Gliko-Modern-S-Regular !important;
    line-height: 20px;
}

/* WOOCOMMERCE LIGHTBOX BEHIND HEADER */

.pswp {
z-index: 9999;
}
.woocommerce .product .woocommerce-tabs .panel {
    margin-top: 2em !important;
}

/* TOP MENU SUBSCRIBE BUTTON */

.top-header-menu li {
    display: inline-block;
    position: relative;
    margin-left: 0 !important;
    padding: 4px 14px;
}
.top-header-menu li.menu-item-first  {
    background-color: #a0213f !important;
}

.top-header-menu li a {
    margin-right: 0 !important;
}

.td-header-top-menu .menu-item-first {
    color: #fff;
    font-size: 13px;
    text-align: center;
    font-weight: bold;
    text-transform: uppercase;
}

.td-header-top-menu .menu-item-first, 
.td-header-top-menu .menu-item-first a, 
.td-header-wrap .td-header-top-menu-full .td-header-top-menu .menu-item-first, 
.td-header-wrap .td-header-top-menu-full .menu-item-first a,
.td-header-style-8 .td-header-top-menu .menu-item-first, 
.td-header-style-8 .td-header-top-menu .menu-item-first a, 
.td-header-top-menu .td-drop-down-search .entry-title .menu-item-first a {
    color: #fff;
}

.top-header-menu .menu-item-first.current-menu-item > a, 
/* .top-header-menu .menu-item-first .current-menu-ancestor > a, 
.top-header-menu .menu-item-first .current-category-ancestor > a, 
.td-header-sp-top-widget .menu-item-first .td-icon-search:hover*/
.top-header-menu li.menu-item-first a:hover {
    color: #eabfbf;
}

/*  PULL QUOTE OVERRIDE  */
.post .td_pull_quote p, .page .td_pull_quote p, .post .wp-block-pullquote blockquote p, .page .wp-block-pullquote blockquote p {
    font-family: Gliko-Modern-S-Bold-Italic;
    font-size: 21px !important;
    line-height: 30px !important;
}</style> <script type="text/javascript">(function () {
			var c = document.body.className;
			c = c.replace(/woocommerce-no-js/, 'woocommerce-js');
			document.body.className = c;
		})()</script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/themes/newspaper-child/assets/js/dist/bundle.js?ver=ee343576727bbb75118955d926a694bed1747443' id='compass_front_js-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/adbutler/includes/../js/adbutler_hb_init.js?ver=1.28' id='adbutler_hb_init-js'></script> <script type='text/javascript' id='adbutler_hb_init-js-after'>AdButlerHB.timeout = 700;</script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/adbutler/includes/../js/adbutler_hb_final.js?ver=1.28' id='adbutler_hb_final-js'></script> <script type='text/javascript' id='cookie-consent-js-extra'>var ctcc_vars = {"expiry":"90","method":"","version":"1"};</script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/uk-cookie-consent/assets/js/uk-cookie-consent-js.js?ver=2.3.0' id='cookie-consent-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/woocommerce/assets/js/jquery-blockui/jquery.blockUI.min.js?ver=2.70' id='jquery-blockui-js'></script> <script type='text/javascript' id='wc-add-to-cart-js-extra'>var wc_add_to_cart_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","i18n_view_cart":"View cart","cart_url":"https:\/\/www.caymancompass.com\/cart\/","is_cart":"","cart_redirect_after_add":"no"};</script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/woocommerce/assets/js/frontend/add-to-cart.min.js?ver=4.9.2' id='wc-add-to-cart-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/woocommerce/assets/js/js-cookie/js.cookie.min.js?ver=2.1.4' id='js-cookie-js'></script> <script type='text/javascript' id='woocommerce-js-extra'>var woocommerce_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%"};</script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/woocommerce/assets/js/frontend/woocommerce.min.js?ver=4.9.2' id='woocommerce-js'></script> <script type='text/javascript' id='wc-cart-fragments-js-extra'>var wc_cart_fragments_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","cart_hash_key":"wc_cart_hash_4437ba34d6b5d70623e49270760f1a5e","fragment_name":"wc_fragments_4437ba34d6b5d70623e49270760f1a5e","request_timeout":"5000"};</script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/woocommerce/assets/js/frontend/cart-fragments.min.js?ver=4.9.2' id='wc-cart-fragments-js'></script> <script type='text/javascript' id='cffscripts-js-extra'>var cffOptions = {"placeholder":"https:\/\/www.caymancompass.com\/wp-content\/plugins\/custom-facebook-feed-pro\/assets\/img\/placeholder.png","resized_url":"https:\/\/www.caymancompass.com\/wp-content\/uploads\/sb-facebook-feed-images\/"};</script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/custom-facebook-feed-pro/assets/js/cff-scripts.js?ver=3.19.3' id='cffscripts-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-includes/js/underscore.min.js?ver=1.8.3' id='underscore-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/td-cloud-library/assets/js/js_posts_autoload.min.js?ver=a50385a2d79d6600973a7e697f735a0b' id='tdb_js_posts_autoload-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js?ver=10.3.9.1' id='td-site-min-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-includes/js/comment-reply.min.js?ver=01c406beee79eb478b26e999eb5427ea' id='comment-reply-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=a50385a2d79d6600973a7e697f735a0b' id='tdb_js_files_for_front-js'></script> <script type='text/javascript' id='woomc-frontend-js-extra'>var woomc = {"currentURL":"https:\/\/www.caymancompass.com\/2021\/04\/01\/iggy-pop-joins-cast-of-blue-iguana-comedy\/","currency":"KYD","cookieSettings":{"name":"woocommerce_multicurrency_forced_currency","expires":31536000},"console_log":"N","settings":{"woocommerce_default_customer_address":"***"}};</script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/woocommerce-multicurrency/src/WOOMC/Frontend/dist/frontend.js?ver=2.9.3' id='woomc-frontend-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-includes/js/wp-embed.min.js?ver=01c406beee79eb478b26e999eb5427ea' id='wp-embed-js'></script>  <script></script> <script type="text/javascript">jQuery(document).ready(function($){
												if(!catapultReadCookie("catAccCookies")){ // If the cookie has not been set then show the bar
							$("html").addClass("has-cookie-bar");
							$("html").addClass("cookie-bar-bottom-bar");
							$("html").addClass("cookie-bar-bar");
													}
													$(window).scroll(function(){
								var scroll = $(window).scrollTop();
								if ( scroll > 700 ) {
									ctccCloseNotification();
								}
							});	
																	});</script> <div id="catapult-cookie-bar" class=""><div class="ctcc-inner "><span class="ctcc-left-side">This site uses cookies. By using this site, you agree to our policies. <a class="ctcc-more-info-link" tabindex=0 target="_blank" href="https://www.caymancompass.com/privacy-policy/">Find out more.</a></span><span class="ctcc-right-side"><button id="catapultCookie" tabindex=0 onclick="catapultAcceptCookies();">CLOSE</button></span></div></div><script type="text/javascript">(function(){window['__CF$cv$params']={r:'639520e4787615b7',m:'01ce0b542ff32ad98b8847396cdb3ecfe40a0771-1617314827-1800-AfLPGKTIMtgkiM4ROJvUtiPAVYIG6sXlLBvSfcKYsxQV/nqAQSmBgDfRxjmle5GARbPnsvXzLEV9Xs99ysS0VnZDKsTpnYFlERqtiMB56EPhXVtN5TL3aObr968GkxMzhdIrRrTm7tmimB2T+5ez7PHf6cD+JqHxRroPcLTstEEl3pyWa1QyTJRl4z/6m13XCA==',s:[0x50aeadc4d7,0xc10a4e763d],}})();</script></body></html>
<!-- Dynamic page generated in 0.774 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2021-04-01 16:14:39 -->

<!-- Compression = gzip -->