<!doctype html > <!--[if IE 8]><html class="ie8" lang="en"> <![endif]--> <!--[if IE 9]><html class="ie9" lang="en"> <![endif]--> <!--[if gt IE 8]><!--><html lang="en-US"> <!--<![endif]--><head><script data-cfasync="false" id="ao_optimized_gfonts_config">WebFontConfig={google:{families:["Open Sans:400,600,700","Roboto:400,500,700"] },classes:false, events:false, timeout:1500};</script><link media="all" href="https://www.caymancompass.com/core/wp-content/cache/autoptimize/css/autoptimize_8521c113f76f403ed1b17e070a4ba282.css" rel="stylesheet" /><link media="only screen and (max-width: 768px)" href="https://www.caymancompass.com/core/wp-content/cache/autoptimize/css/autoptimize_dcb2de333eec7ab4ae31385ed8d6a393.css" rel="stylesheet" /><title>NAU applications on the rise - Cayman Compass</title><meta charset="UTF-8" /><meta name="viewport" content="width=device-width, initial-scale=1.0"><link rel="pingback" href="https://www.caymancompass.com/core/xmlrpc.php" /><link rel="icon" type="image/png" href="https://www.caymancompass.com/core/wp-content/uploads/2019/10/favicon.png"><link rel="apple-touch-icon-precomposed" sizes="76x76" href="https://www.caymancompass.com/core/wp-content/uploads/2019/10/CompassSqareiOSBookmarklet-76x.png" /><link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://www.caymancompass.com/core/wp-content/uploads/2019/10/CompassSqareiOSBookmarklet-120x.png" /><link rel="apple-touch-icon-precomposed" sizes="152x152" href="https://www.caymancompass.com/core/wp-content/uploads/2019/10/CompassSqareiOSBookmarklet-152x.png" /><link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://www.caymancompass.com/core/wp-content/uploads/2019/10/CompassSqareiOSBookmarklet-114x.png" /><link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://www.caymancompass.com/core/wp-content/uploads/2019/10/CompassSqareiOSBookmarklet-144x.png" /><meta name="description" content="The demand for Needs Assessment Unit assistance by vulnerable Caymanians is increasing, with 136 new applications set to be processed this week, officials said." /><meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://www.caymancompass.com/2020/04/06/nau-applications-on-the-rise/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="NAU applications on the rise - Cayman Compass" /><meta property="og:description" content="The demand for Needs Assessment Unit assistance by vulnerable Caymanians is increasing, with 136 new applications set to be processed this week, officials said." /><meta property="og:url" content="https://www.caymancompass.com/2020/04/06/nau-applications-on-the-rise/" /><meta property="og:site_name" content="Cayman Compass" /><meta property="article:publisher" content="https://www.facebook.com/caycompass" /><meta property="article:tag" content="coronavirus" /><meta property="article:tag" content="COVID-19" /><meta property="article:tag" content="NAU" /><meta property="article:tag" content="Premier Alden McLaughlin" /><meta property="article:section" content="Featured" /><meta property="article:published_time" content="2020-04-07T01:40:37+00:00" /><meta property="article:modified_time" content="2020-04-07T23:28:12+00:00" /><meta property="og:updated_time" content="2020-04-07T23:28:12+00:00" /><meta property="og:image" content="https://www.caymancompass.com/core/wp-content/uploads/2020/04/WhatsApp-Image-2020-04-06-at-5.23.20-PM-e1586302075292.jpeg" /><meta property="og:image:secure_url" content="https://www.caymancompass.com/core/wp-content/uploads/2020/04/WhatsApp-Image-2020-04-06-at-5.23.20-PM-e1586302075292.jpeg" /><meta property="og:image:width" content="1196" /><meta property="og:image:height" content="1380" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="The demand for Needs Assessment Unit assistance by vulnerable Caymanians is increasing, with 136 new applications set to be processed this week, officials said." /><meta name="twitter:title" content="NAU applications on the rise - Cayman Compass" /><meta name="twitter:site" content="@cayCompass" /><meta name="twitter:image" content="https://www.caymancompass.com/core/wp-content/uploads/2020/04/WhatsApp-Image-2020-04-06-at-5.23.20-PM-e1586302075292.jpeg" /><meta name="twitter:creator" content="@cayCompass" /> <script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.caymancompass.com/#organization","name":"Cayman Compass","url":"https://www.caymancompass.com/","sameAs":["https://www.facebook.com/caycompass","https://instagram.com/cayman_compass","https://www.youtube.com/caymancompas","https://twitter.com/cayCompass"],"logo":{"@type":"ImageObject","@id":"https://www.caymancompass.com/#logo","inLanguage":"en-US","url":"https://www.caymancompass.com/core/wp-content/uploads/2019/10/CompassLogo-white-bgd.gif","width":400,"height":275,"caption":"Cayman Compass"},"image":{"@id":"https://www.caymancompass.com/#logo"}},{"@type":"WebSite","@id":"https://www.caymancompass.com/#website","url":"https://www.caymancompass.com/","name":"Cayman Compass","inLanguage":"en-US","description":"The Cayman Islands&#039; Most Trusted News Source","publisher":{"@id":"https://www.caymancompass.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://www.caymancompass.com/?s={search_term_string}","query-input":"required name=search_term_string"}]},{"@type":"ImageObject","@id":"https://www.caymancompass.com/2020/04/06/nau-applications-on-the-rise/#primaryimage","inLanguage":"en-US","url":"https://www.caymancompass.com/core/wp-content/uploads/2020/04/WhatsApp-Image-2020-04-06-at-5.23.20-PM-e1586302075292.jpeg","width":1196,"height":1380,"caption":"Premier Alden McLaughlin"},{"@type":"WebPage","@id":"https://www.caymancompass.com/2020/04/06/nau-applications-on-the-rise/#webpage","url":"https://www.caymancompass.com/2020/04/06/nau-applications-on-the-rise/","name":"NAU applications on the rise - Cayman Compass","isPartOf":{"@id":"https://www.caymancompass.com/#website"},"inLanguage":"en-US","primaryImageOfPage":{"@id":"https://www.caymancompass.com/2020/04/06/nau-applications-on-the-rise/#primaryimage"},"datePublished":"2020-04-07T01:40:37+00:00","dateModified":"2020-04-07T23:28:12+00:00","description":"The demand for Needs Assessment Unit assistance by vulnerable Caymanians is increasing, with 136 new applications set to be processed this week, officials said.","potentialAction":[{"@type":"ReadAction","target":["https://www.caymancompass.com/2020/04/06/nau-applications-on-the-rise/"]}]},{"@type":"Article","@id":"https://www.caymancompass.com/2020/04/06/nau-applications-on-the-rise/#article","isPartOf":{"@id":"https://www.caymancompass.com/2020/04/06/nau-applications-on-the-rise/#webpage"},"author":{"@id":"https://www.caymancompass.com/#/schema/person/c7da4fb9ffebdb339a13ad2ff875aa0e"},"headline":"NAU applications on the rise","datePublished":"2020-04-07T01:40:37+00:00","dateModified":"2020-04-07T23:28:12+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://www.caymancompass.com/2020/04/06/nau-applications-on-the-rise/#webpage"},"publisher":{"@id":"https://www.caymancompass.com/#organization"},"image":{"@id":"https://www.caymancompass.com/2020/04/06/nau-applications-on-the-rise/#primaryimage"},"keywords":"coronavirus,COVID-19,NAU,Premier Alden McLaughlin","articleSection":"Featured,Local","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://www.caymancompass.com/2020/04/06/nau-applications-on-the-rise/#respond"]}]},{"@type":["Person"],"@id":"https://www.caymancompass.com/#/schema/person/c7da4fb9ffebdb339a13ad2ff875aa0e","name":"Reshma Ragoonath","image":{"@type":"ImageObject","@id":"https://www.caymancompass.com/#authorlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/c49b9c7df61cde549ce8b73dd2b810df?s=96&d=blank&r=g","caption":"Reshma Ragoonath"},"sameAs":[]}]}</script> <link rel='dns-prefetch' href='//ajax.googleapis.com' /><link rel='dns-prefetch' href='//js.hs-scripts.com' /><link rel='dns-prefetch' href='//s.w.org' /><link href='https://fonts.gstatic.com' crossorigin='anonymous' rel='preconnect' /><link href='https://ajax.googleapis.com' rel='preconnect' /><link href='https://fonts.googleapis.com' rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="Cayman Compass &raquo; Feed" href="https://www.caymancompass.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Cayman Compass &raquo; Comments Feed" href="https://www.caymancompass.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Cayman Compass &raquo; NAU applications on the rise Comments Feed" href="https://www.caymancompass.com/2020/04/06/nau-applications-on-the-rise/feed/" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.caymancompass.com\/core\/wp-includes\/js\/wp-emoji-release.min.js?ver=7046c1370d646b344933e44fa737dfea"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);</script> <style type="text/css">img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}</style><link rel='stylesheet' id='jqueryuicss-css' href='https://ajax.googleapis.com/ajax/libs/jqueryui/1.11.4/themes/smoothness/jquery-ui.css?ver=7046c1370d646b344933e44fa737dfea' type='text/css' media='all' /><style id='woocommerce-inline-inline-css' type='text/css'>.woocommerce form .form-row .required { visibility: visible; }</style><style id='td-theme-inline-css' type='text/css'>@media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }</style><link rel='stylesheet' id='Gliko-Modern-S-Italic-css' href='https://www.caymancompass.com/core/wp-content/uploads/2019/10/Gliko-Modern-S-Italic.woff?ver=7046c1370d646b344933e44fa737dfea' type='text/css' media='all' /><link rel='stylesheet' id='Gliko-Modern-S-Bold-Italic-css' href='https://www.caymancompass.com/core/wp-content/uploads/2019/10/Gliko-Modern-S-Bold-Italic.woff?ver=7046c1370d646b344933e44fa737dfea' type='text/css' media='all' /> <script type='text/javascript' src='https://www.caymancompass.com/core/wp-content/plugins/pinnacle-newsletter/pinnacle_javascript.js?ver=7046c1370d646b344933e44fa737dfea'></script> <script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jqueryui/1.11.4/jquery-ui.min.js?ver=7046c1370d646b344933e44fa737dfea'></script> <script type='text/javascript' src='https://www.caymancompass.com/core/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script> <script type='text/javascript' src='https://www.caymancompass.com/core/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script> <script type='text/javascript'>var likebtn_eh_data = {"ajaxurl":"https:\/\/www.caymancompass.com\/core\/wp-admin\/admin-ajax.php","security":"a55249ac7c"};</script> <script type='text/javascript' src='https://www.caymancompass.com/core/wp-content/plugins/likebtn-like-button/public/js/frontend.js?ver=7046c1370d646b344933e44fa737dfea'></script> <script type='text/javascript' src='https://www.caymancompass.com/core/wp-content/plugins/ultimate-member/assets/js/um-gdpr.min.js?ver=2.1.4'></script> <link rel='https://api.w.org/' href='https://www.caymancompass.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.caymancompass.com/core/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.caymancompass.com/core/wp-includes/wlwmanifest.xml" /><link rel='shortlink' href='https://www.caymancompass.com/?p=474431' /><link rel="alternate" type="application/json+oembed" href="https://www.caymancompass.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.caymancompass.com%2F2020%2F04%2F06%2Fnau-applications-on-the-rise%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.caymancompass.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.caymancompass.com%2F2020%2F04%2F06%2Fnau-applications-on-the-rise%2F&#038;format=xml" /> <script type="text/javascript">var _hsq = _hsq || [];
				_hsq.push(["setContentType", "blog-post"]);</script> <style id="ctcc-css" type="text/css" media="screen">#catapult-cookie-bar {
					box-sizing: border-box;
					max-height: 0;
					opacity: 0;
					z-index: 99999;
					overflow: hidden;
					color: #ffffff;
					position: fixed;
					left: 0;
					bottom: 0;
					width: 100%;
					background-color: #0e1523;
				}
				#catapult-cookie-bar a {
					color: #c6e9ff;
				}
				#catapult-cookie-bar .x_close span {
					background-color: #ffffff;
				}
				button#catapultCookie {
					background:#00aeef;
					color: #ffffff;
					border: 0; padding: 6px 9px; border-radius: 3px;
				}
				#catapult-cookie-bar h3 {
					color: #ffffff;
				}
				.has-cookie-bar #catapult-cookie-bar {
					opacity: 1;
					max-height: 999px;
					min-height: 30px;
				}</style><style type="text/css">.request_name {
				display: none !important;
			}</style><!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]--> <script>window.tdb_globals = {"wpRestNonce":"f2485b84ed","wpRestUrl":"https:\/\/www.caymancompass.com\/wp-json\/","permalinkStructure":"\/%year%\/%monthnum%\/%day%\/%postname%\/","isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":50,"postAutoloadStatus":"off","origPostEditUrl":null};</script> <script>window.tdwGlobal = {"adminUrl":"https:\/\/www.caymancompass.com\/core\/wp-admin\/","wpRestNonce":"f2485b84ed","wpRestUrl":"https:\/\/www.caymancompass.com\/wp-json\/","permalinkStructure":"\/%year%\/%monthnum%\/%day%\/%postname%\/"};</script> <noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript> <script>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</script> <style>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</style> <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-PBNB99T');</script> <script type="text/javascript" id="hs-script-loader" async defer src="//js.hs-scripts.com/5627643.js"></script> <script type="text/javascript" src="https://app.adsalesgenius.com/marketing/website/main.js"></script> <script type="text/javascript">new VisitorLog(1272);</script> <script type="application/ld+json">{
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://www.caymancompass.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.caymancompass.com/category/localnews/",
                    "name": "Local"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.caymancompass.com/2020/04/06/nau-applications-on-the-rise/",
                    "name": "NAU applications on the rise"                                
                }
            }    
        ]
    }</script> <style>.tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,
                .tds-button2 .tdm-btn-text,
                .tds-button2 i,
                .tds-button5:hover .tdm-btn-text,
                .tds-button5:hover i,
                .tds-button6 .tdm-btn-text,
                .tds-button6 i,
                .tdm_block_list .tdm-list-item i,
                .tdm_block_pricing .tdm-pricing-feature i,
                .tdm-social-item i {
                    color: #00b3e5;
                }
                .tds-button1,
                .tds-button6:after,
                .tds-title2 .tdm-title-line:after,
                .tds-title3 .tdm-title-line:after,
                .tdm_block_pricing.tdm-pricing-featured:before,
                .tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,
                .tds-progress-bar1 .tdm-progress-bar:after,
                .tds-progress-bar2 .tdm-progress-bar:after,
                .tds-social3 .tdm-social-item {
                    background-color: #00b3e5;
                }
                .tds-button2:before,
                .tds-button6:before,
                .tds-progress-bar3 .tdm-progress-bar:after {
                  border-color: #00b3e5;
                }
                .tdm-btn-style1 {
					background-color: #00b3e5;
				}
				.tdm-btn-style2:before {
				    border-color: #00b3e5;
				}
				.tdm-btn-style2 {
				    color: #00b3e5;
				}
				.tdm-btn-style3 {
				    -webkit-box-shadow: 0 2px 16px #00b3e5;
                    -moz-box-shadow: 0 2px 16px #00b3e5;
                    box-shadow: 0 2px 16px #00b3e5;
				}
				.tdm-btn-style3:hover {
				    -webkit-box-shadow: 0 4px 26px #00b3e5;
                    -moz-box-shadow: 0 4px 26px #00b3e5;
                    box-shadow: 0 4px 26px #00b3e5;
				}</style><style id="tdw-css-placeholder"></style><script data-cfasync="false" id="ao_optimized_gfonts_webfontloader">(function() {var wf = document.createElement('script');wf.src='https://ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';wf.type='text/javascript';wf.async='true';var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(wf, s);})();</script></head><body class="post-template-default single single-post postid-474431 single-format-standard theme-Newspaper td-standard-pack woocommerce-no-js nau-applications-on-the-rise global-block-template-16 single_template_1 td-animation-stack-type0 td-boxed-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage"><div class="td-scroll-up"><i class="td-icon-menu-up"></i></div><div class="td-menu-background"></div><div id="td-mobile-nav"><div class="td-mobile-container"><div class="td-menu-socials-wrap"><div class="td-menu-socials"> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.facebook.com/caycompass" title="Facebook"> <i class="td-icon-font td-icon-facebook"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.instagram.com/cayman_compass/" title="Instagram"> <i class="td-icon-font td-icon-instagram"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://twitter.com/cayCompass" title="Twitter"> <i class="td-icon-font td-icon-twitter"></i> </a> </span></div><div class="td-mobile-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div></div><div class="td-menu-login-section"><div class="td-guest-wrap"><div class="td-menu-login"><a id="login-link-mob">Sign in</a><span></span><a id="register-link-mob" href="https://www.caymancompass.com/register/">Join</a></div></div></div><div class="td-mobile-content"><div class="menu-main-menu-container"><ul id="menu-main-menu" class="td-mobile-main-menu"><li id="menu-item-187846" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first menu-item-187846"><a href="https://www.caymancompass.com/">Home</a></li><li id="menu-item-187847" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-187847"><a href="https://www.caymancompass.com/cayman-news/">News<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-471912" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-471912"><a href="https://www.caymancompass.com/issues/coronavirus-cayman/">Coronavirus Cayman</a></li><li id="menu-item-187848" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-187848"><a href="https://www.caymancompass.com/cayman-news/">Cayman News</a></li><li id="menu-item-463399" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-463399"><a href="https://www.caymancompass.com/business/">Business</a></li><li id="menu-item-188240" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188240"><a href="https://www.caymancompass.com/crime-and-courts/">Crime and Courts</a></li><li id="menu-item-461693" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-461693"><a href="https://www.caymancompass.com/lifestyle/">Lifestyle</a></li><li id="menu-item-461689" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-461689"><a href="https://www.caymancompass.com/sports/">Sports</a></li><li id="menu-item-461691" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-461691"><a href="https://www.caymancompass.com/video/">Video</a></li><li id="menu-item-461692" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-461692"><a href="https://www.caymancompass.com/weather/">Weather</a></li><li id="menu-item-463093" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-463093"><a href="https://www.caymancompass.com/spotlight/">Spotlight and Features</a></li><li id="menu-item-467157" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-467157"><a href="https://www.caymancompass.com/podcasts/">Podcasts</a></li><li id="menu-item-464405" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-464405"><a href="https://www.caymancompass.com/interactive/">Interactive</a></li></ul></li><li id="menu-item-464189" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-464189"><a href="https://www.caymancompass.com/issues/">Issues<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-470185" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-470185"><a href="https://www.caymancompass.com/issues/coronavirus-cayman/">Coronavirus Cayman</a></li><li id="menu-item-470131" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-470131"><a href="https://www.caymancompass.com/issues/climate-change/">Climate Change</a></li><li id="menu-item-466938" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-466938"><a href="https://www.caymancompass.com/issues/traffic/">Traffic</a></li><li id="menu-item-464188" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-464188"><a href="https://www.caymancompass.com/issues/founded-upon-the-seas/">Founded Upon the Seas</a></li><li id="menu-item-458002" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-458002"><a href="https://www.caymancompass.com/issues/port-vote-2019/">Port Vote 2019</a></li><li id="menu-item-458001" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-458001"><a href="https://www.caymancompass.com/issues/friday-features/">Friday Features</a></li><li id="menu-item-456066" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-456066"><a href="https://www.caymancompass.com/issues/sargassum/">Sargassum</a></li><li id="menu-item-471740" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-471740"><a href="https://www.caymancompass.com/issues/">All Issues Stories</a></li></ul></li><li id="menu-item-465716" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-465716"><a href="https://www.caymancompass.com/opinion/">Opinion<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-465705" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-465705"><a href="https://www.caymancompass.com/opinion/editoral/">Editorial</a></li><li id="menu-item-465695" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-465695"><a href="https://www.caymancompass.com/opinion/letters-to-the-editor/">Letters</a></li><li id="menu-item-465696" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-465696"><a href="https://www.caymancompass.com/opinion/columns/">Columns</a></li><li id="menu-item-461688" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-461688"><a href="https://www.caymancompass.com/cartoons/">Cartoons</a></li><li id="menu-item-188304" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188304"><a href="https://www.caymancompass.com/submit-letter-to-the-editor/">Write a Letter to the Editor</a></li></ul></li><li id="menu-item-188277" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-188277"><a href="/events/">Calendar<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-314306" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-314306"><a href="/events/">Event Listings</a></li><li id="menu-item-457157" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-457157"><a href="https://www.caymancompass.com/notices/">Notices</a></li><li id="menu-item-315091" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-315091"><a href="https://www.caymancompass.com/submit-event/">Submit an Event</a></li><li id="menu-item-463065" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-463065"><a href="https://www.caymancompass.com/cayman-islands-public-holidays-2020/">Cayman Islands Public Holidays 2020</a></li></ul></li><li id="menu-item-373520" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-373520"><a href="#">Our Brands<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-399126" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-399126"><a href="https://www.compassmedia.ky">All Publications</a></li><li id="menu-item-470176" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-470176"><a href="http://caymaniancompass.cay.newsmemory.com/?special=Careers">Careers Guide</a></li><li id="menu-item-466685" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-466685"><a href="https://www.caymancompass.com/wellness-feature/">Wellness Feature</a></li><li id="menu-item-460236" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-460236"><a href="https://www.caymancompass.com/women-in-business/">Women In Business</a></li><li id="menu-item-373529" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-373529"><a href="http://caymanhealth.com/">Cayman Health</a></li><li id="menu-item-373523" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-373523"><a href="http://www.flava.ky">Flava</a></li><li id="menu-item-450244" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-450244"><a href="http://caymaniancompass.cay.newsmemory.com/?special=Hurricane+Guide">Hurricane Guide 2019</a></li><li id="menu-item-373527" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-373527"><a href="http://www.insideoutcayman.com">Inside Out</a></li><li id="menu-item-188285" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188285"><a href="https://www.caymancompass.com/special-features-and-publications/">Special Features and Publications</a></li></ul></li><li id="menu-item-188276" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-188276"><a href="#">More<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-461690" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-461690"><a href="https://www.caymancompass.com/subscribe/">Subscribe to Newsletter</a></li><li id="menu-item-465825" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-465825"><a href="https://www.caymancompass.com/contact/">Contact</a></li><li id="menu-item-188275" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188275"><a href="https://www.caymancompass.com/contests/">Contests</a></li><li id="menu-item-465826" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-465826"><a href="https://www.caymancompass.com/view-eversion/">View e-version and classifieds</a></li><li id="menu-item-188280" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188280"><a href="https://www.caymancompass.com/advertise-with-us/">Advertise With Us</a></li><li id="menu-item-371483" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-371483"><a target="_blank" href="https://www.caymancompass.com/core/wp-content/uploads/2019/12/Compass-Print-Media-Kit.pdf">Print Media Kit</a></li><li id="menu-item-389921" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-389921"><a href="https://www.caymancompass.com/core/wp-content/uploads/2020/03/CompassDigitalMediaKit-UpdatedInventory-2020.pdf">Online Media Kit</a></li><li id="menu-item-359853" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-359853"><a href="https://www.caymancompass.com/editorial-staff/">Editorial Staff</a></li><li id="menu-item-188303" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188303"><a href="https://www.caymancompass.com/submit-a-story-idea/">Submit a Story Idea</a></li><li id="menu-item-374166" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-374166"><a href="https://www.caymancompass.com/online-subscriptions/">Online Subscriptions</a></li><li id="menu-item-471913" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-471913"><a href="https://www.caymancompass.com/newspaper-home-delivery-coronavirus-cayman/">Newspaper Home Delivery</a></li><li id="menu-item-188284" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188284"><a href="https://www.caymancompass.com/privacy-policy/">Privacy Policy</a></li><li id="menu-item-188282" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188282"><a href="https://www.caymancompass.com/copyright-policy-2/">Copyright Policy</a></li><li id="menu-item-314305" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-314305"><a href="https://www.caymancompass.com/terms-of-use/">Terms and Conditions of Use</a></li><li id="menu-item-380233" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-380233"><a href="https://www.caymancompass.com/rss-feeds-information/">RSS Feed Information</a></li></ul></li></ul></div></div></div><div id="login-form-mobile" class="td-register-section"><div id="td-login-mob" class="td-login-animation td-login-hide-mob"><div class="td-login-close"> <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a><div class="td-login-title">Sign in</div><div class="td-mobile-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div></div><div class="td-login-form-wrap"><div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div><div class="td_display_err"></div><div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div><div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div> <input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN"><div class="td-login-info-text"> <a href="#" id="forgot-pass-link-mob">Forgot your password?</a></div><div class="td-login-register-link"> <a id="signin-register-link-mob" href="https://www.caymancompass.com/register/">Join</a></div></div></div><div id="td-register-mob" class="td-login-animation td-login-hide-mob"><div class="td-register-close"> <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a><div class="td-login-title">Sign up</div><div class="td-mobile-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div></div><div class="td-login-panel-title"><span>Redirecting...</div></div><div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob"><div class="td-forgot-pass-close"> <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a><div class="td-login-title">Password recovery</div></div><div class="td-login-form-wrap"><div class="td-login-panel-title">Recover your password</div><div class="td_display_err"></div><div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div> <input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass"></div></div></div></div><div class="td-search-background"></div><div class="td-search-wrap-mob"><div class="td-drop-down-search"><form method="get" class="td-search-form" action="https://www.caymancompass.com/"><div class="td-search-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div><div role="search" class="td-search-input"> <span>Search</span> <input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" /></div></form><div id="td-aj-search-mob" class="td-ajax-search-flex"></div></div></div><div id="td-outer-wrap" class="td-theme-wrap"><div class="tdc-header-wrap "><div class="td-header-wrap td-header-style-1 "><div class="td-header-top-menu-full td-container-wrap td_stretch_content"><div class="td-container td-header-row td-header-top-menu"><div class="top-bar-style-1"><div class="td-header-sp-top-menu"><div class="td-weather-top-widget" id="td_top_weather_uid"> <i class="td-icons clear-sky-d"></i><div class="td-weather-now" data-block-uid="td_top_weather_uid"> <span class="td-big-degrees">83</span> <span class="td-weather-unit">F</span></div><div class="td-weather-header"><div class="td-weather-city">Cayman Islands</div></div></div><div class="td_data_time"><div> Tuesday, April 7, 2020</div></div><ul class="top-header-menu td_ul_login"><li class="menu-item"><a class="td-login-modal-js menu-item" href="#login-form" data-effect="mpf-td-login-effect">Sign in / Join</a><span class="td-sp-ico-login td_sp_login_ico_style"></span></li></ul></div><div class="td-header-sp-top-widget"> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.facebook.com/caycompass" title="Facebook"> <i class="td-icon-font td-icon-facebook"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.instagram.com/cayman_compass/" title="Instagram"> <i class="td-icon-font td-icon-instagram"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://twitter.com/cayCompass" title="Twitter"> <i class="td-icon-font td-icon-twitter"></i> </a> </span></div></div><div id="login-form" class="white-popup-block mfp-hide mfp-with-anim"><div class="td-login-wrap"> <a href="#" class="td-back-button"><i class="td-icon-modal-back"></i></a><div id="td-login-div" class="td-login-form-div td-display-block"><div class="td-login-panel-title">Sign in</div><div class="td-login-panel-descr">Welcome. Log into your account</div><div class="td_display_err"></div><div class="mobile-facebook-login" style="margin-bottom: 10px;"><div class="um um-shortcode-social" id="um-shortcode-social-381831" style="padding:;margin:!important;"><div class="um-field"><div class="um-col-alt"><div class="um-left um-half"> <a href="?oauthWindow=true&#038;provider=facebook&#038;um_sso=381831" title="Connect with Facebook" class="um-button um-alt um-button-social um-button-facebook" data-redirect-url="https://www.caymancompass.com/2020/04/06/nau-applications-on-the-rise" onclick="um_social_login_oauth_window( this.href,'authWindow', 'width=600,height=600,scrollbars=yes' );return false;"> <i class="um-faicon-facebook-square" style="margin-right: 8px;"></i> <span>Connect with Facebook</span> </a></div><div class="um-clear"></div></div></div><style type="text/css">div#um-shortcode-social-381831 div.um-field {padding: 0}

		div#um-shortcode-social-381831 a.um-button.um-button-social {
			font-size: 15px;
			padding: 16px 20px !important;
		}

		div#um-shortcode-social-381831 a.um-button.um-button-social i {
			font-size: 18px;
			width: 18px;
			top: auto;
			vertical-align: baseline !important;
			margin-right: 0;
		}

		
			div#um-shortcode-social-381831 div.um-field {margin:0 auto; max-width: 696px}

		
			div#um-shortcode-social-381831 a.um-button.um-button-facebook {background-color: #4267B2!important}
			div#um-shortcode-social-381831 a.um-button.um-button-facebook:hover {background-color: #365899!important}
			div#um-shortcode-social-381831 a.um-button.um-button-facebook {color: #fff!important}</style></div></div><div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email" value="" required><label>your username</label></div><div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" required><label>your password</label></div> <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login"><div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div> <a id="register-link" href="https://www.caymancompass.com/register/">Create an account</a></div><div id="td-register-div" class="td-login-form-div td-display-none"><div class="td-login-panel-title">Redirecting...</div></div><div id="td-forgot-pass-div" class="td-login-form-div td-display-none"><div class="td-login-panel-title">Password recovery</div><div class="td-login-panel-descr">Recover your password</div><div class="td_display_err"></div><div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label>your email</label></div> <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password"><div class="td-login-info-text">A password will be e-mailed to you.</div></div></div></div></div></div><div class="td-banner-wrap-full td-logo-wrap-full td-container-wrap td_stretch_container"><div class="td-container td-header-row td-header-header"><div class="td-header-sp-logo"> <a class="td-main-logo" href="https://www.caymancompass.com/"> <img class="td-retina-data" data-retina="https://www.caymancompass.com/core/wp-content/uploads/2019/10/CompassLogoNew544x180.png" src="https://www.caymancompass.com/core/wp-content/uploads/2019/10/CompassLogoNew-272x90.png" alt="Cayman Compass" title="Cayman Compass" /> <span class="td-visual-hidden">Cayman Compass</span> </a></div><div class="td-header-sp-recs"><div class="td-header-rec-wrap"><div class="td-a-rec td-a-rec-id-header  tdi_1_4c6 td_block_template_16"><style>/* custom css */
.tdi_1_4c6.td-a-rec-img,
				.tdi_1_4c6 .td-adspot-title{
				    text-align: left;
				}.tdi_1_4c6.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }.tdi_1_4c6 .td-element-style{
					z-index: -1;
				}</style><div class="td-all-devices"> <script type="text/javascript">if (!window.AdButler){(function(){var s = document.createElement("script"); s.async = true; s.type = "text/javascript";s.src = 'https://servedbyadbutler.com/app.js';var n = document.getElementsByTagName("script")[0]; n.parentNode.insertBefore(s, n);}());}</script> <script type="text/javascript">var AdButler = AdButler || {}; AdButler.ads = AdButler.ads || [];
var abkw = window.abkw || '';
var plc197225 = window.plc197225 || 0;
document.write('<'+'div id="placement_197225_'+plc197225+'"></'+'div>');
AdButler.ads.push({handler: function(opt){ AdButler.register(165413, 197225, [728,90], 'placement_197225_'+opt.place, opt); }, opt: { place: plc197225++, keywords: abkw, domain: 'servedbyadbutler.com', click:'CLICK_MACRO_PLACEHOLDER' }});</script> </div></div></div></div></div></div><div class="td-header-menu-wrap-full td-container-wrap td_stretch_container"><div class="td-header-menu-wrap td-header-gradient "><div class="td-container td-header-row td-header-main-menu"><div id="td-header-menu" role="navigation"><div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div><div class="td-main-menu-logo td-logo-in-header"> <a class="td-mobile-logo td-sticky-header" href="https://www.caymancompass.com/"> <img class="td-retina-data" data-retina="https://www.caymancompass.com/core/wp-content/uploads/2019/10/CaymanCompassLogoWhiteNew280x96.png" src="https://www.caymancompass.com/core/wp-content/uploads/2019/10/CaymanCompassLogoWhiteNew140x48.png" alt="Cayman Compass" title="Cayman Compass" /> </a> <a class="td-header-logo td-sticky-header" href="https://www.caymancompass.com/"> <img class="td-retina-data" data-retina="https://www.caymancompass.com/core/wp-content/uploads/2019/10/CompassLogoNew544x180.png" src="https://www.caymancompass.com/core/wp-content/uploads/2019/10/CompassLogoNew-272x90.png" alt="Cayman Compass" title="Cayman Compass" /> </a></div><div class="menu-main-menu-container"><ul id="menu-main-menu-1" class="sf-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-187846"><a href="https://www.caymancompass.com/">Home</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-187847"><a href="https://www.caymancompass.com/cayman-news/">News</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-471912"><a href="https://www.caymancompass.com/issues/coronavirus-cayman/">Coronavirus Cayman</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-187848"><a href="https://www.caymancompass.com/cayman-news/">Cayman News</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-463399"><a href="https://www.caymancompass.com/business/">Business</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188240"><a href="https://www.caymancompass.com/crime-and-courts/">Crime and Courts</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-461693"><a href="https://www.caymancompass.com/lifestyle/">Lifestyle</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-461689"><a href="https://www.caymancompass.com/sports/">Sports</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-461691"><a href="https://www.caymancompass.com/video/">Video</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-461692"><a href="https://www.caymancompass.com/weather/">Weather</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-463093"><a href="https://www.caymancompass.com/spotlight/">Spotlight and Features</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-467157"><a href="https://www.caymancompass.com/podcasts/">Podcasts</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-464405"><a href="https://www.caymancompass.com/interactive/">Interactive</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-464189"><a href="https://www.caymancompass.com/issues/">Issues</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-470185"><a href="https://www.caymancompass.com/issues/coronavirus-cayman/">Coronavirus Cayman</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-470131"><a href="https://www.caymancompass.com/issues/climate-change/">Climate Change</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-466938"><a href="https://www.caymancompass.com/issues/traffic/">Traffic</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-464188"><a href="https://www.caymancompass.com/issues/founded-upon-the-seas/">Founded Upon the Seas</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-458002"><a href="https://www.caymancompass.com/issues/port-vote-2019/">Port Vote 2019</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-458001"><a href="https://www.caymancompass.com/issues/friday-features/">Friday Features</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-456066"><a href="https://www.caymancompass.com/issues/sargassum/">Sargassum</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-471740"><a href="https://www.caymancompass.com/issues/">All Issues Stories</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-465716"><a href="https://www.caymancompass.com/opinion/">Opinion</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-465705"><a href="https://www.caymancompass.com/opinion/editoral/">Editorial</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-465695"><a href="https://www.caymancompass.com/opinion/letters-to-the-editor/">Letters</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-465696"><a href="https://www.caymancompass.com/opinion/columns/">Columns</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-461688"><a href="https://www.caymancompass.com/cartoons/">Cartoons</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188304"><a href="https://www.caymancompass.com/submit-letter-to-the-editor/">Write a Letter to the Editor</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-188277"><a href="/events/">Calendar</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-314306"><a href="/events/">Event Listings</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-457157"><a href="https://www.caymancompass.com/notices/">Notices</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-315091"><a href="https://www.caymancompass.com/submit-event/">Submit an Event</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-463065"><a href="https://www.caymancompass.com/cayman-islands-public-holidays-2020/">Cayman Islands Public Holidays 2020</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-373520"><a href="#">Our Brands</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-399126"><a href="https://www.compassmedia.ky">All Publications</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-470176"><a href="http://caymaniancompass.cay.newsmemory.com/?special=Careers">Careers Guide</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-466685"><a href="https://www.caymancompass.com/wellness-feature/">Wellness Feature</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-460236"><a href="https://www.caymancompass.com/women-in-business/">Women In Business</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-373529"><a href="http://caymanhealth.com/">Cayman Health</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-373523"><a href="http://www.flava.ky">Flava</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-450244"><a href="http://caymaniancompass.cay.newsmemory.com/?special=Hurricane+Guide">Hurricane Guide 2019</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-373527"><a href="http://www.insideoutcayman.com">Inside Out</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188285"><a href="https://www.caymancompass.com/special-features-and-publications/">Special Features and Publications</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-188276"><a href="#">More</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-461690"><a href="https://www.caymancompass.com/subscribe/">Subscribe to Newsletter</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-465825"><a href="https://www.caymancompass.com/contact/">Contact</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188275"><a href="https://www.caymancompass.com/contests/">Contests</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-465826"><a href="https://www.caymancompass.com/view-eversion/">View e-version and classifieds</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188280"><a href="https://www.caymancompass.com/advertise-with-us/">Advertise With Us</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-371483"><a target="_blank" href="https://www.caymancompass.com/core/wp-content/uploads/2019/12/Compass-Print-Media-Kit.pdf">Print Media Kit</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-389921"><a href="https://www.caymancompass.com/core/wp-content/uploads/2020/03/CompassDigitalMediaKit-UpdatedInventory-2020.pdf">Online Media Kit</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-359853"><a href="https://www.caymancompass.com/editorial-staff/">Editorial Staff</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188303"><a href="https://www.caymancompass.com/submit-a-story-idea/">Submit a Story Idea</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-374166"><a href="https://www.caymancompass.com/online-subscriptions/">Online Subscriptions</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-471913"><a href="https://www.caymancompass.com/newspaper-home-delivery-coronavirus-cayman/">Newspaper Home Delivery</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188284"><a href="https://www.caymancompass.com/privacy-policy/">Privacy Policy</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188282"><a href="https://www.caymancompass.com/copyright-policy-2/">Copyright Policy</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-314305"><a href="https://www.caymancompass.com/terms-of-use/">Terms and Conditions of Use</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-380233"><a href="https://www.caymancompass.com/rss-feeds-information/">RSS Feed Information</a></li></ul></li></ul></div></div><div class="header-search-wrap"><div class="td-search-btns-wrap"> <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a> <a id="td-header-search-button-mob" href="#" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a></div><div class="td-drop-down-search" aria-labelledby="td-header-search-button"><form method="get" class="td-search-form" action="https://www.caymancompass.com/"><div role="search" class="td-head-form-search-wrap"> <input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" /></div></form><div id="td-aj-search"></div></div></div></div></div></div></div></div><div class="td-main-content-wrap td-container-wrap"><div class="td-container td-post-template-1 "><div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://www.caymancompass.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Local" class="entry-crumb" href="https://www.caymancompass.com/category/localnews/">Local</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">NAU applications on the rise</span></div></div><div class="td-pb-row"><div class="td-pb-span8 td-main-content" role="main"><div class="td-ss-main-content"><article id="post-474431" class="post-474431 post type-post status-publish format-standard has-post-thumbnail category-featured category-localnews tag-coronavirus tag-covid-19 tag-nau tag-premier-alden-mclaughlin" itemscope itemtype="https://schema.org/Article"><div class="td-post-header"><ul class="td-category"><li class="entry-category"><a href="https://www.caymancompass.com/category/localnews/">Local</a></li></ul><header class="td-post-title"><h1 class="entry-title">NAU applications on the rise</h1><p class="td-post-sub-title">Distribution of non-Caymanian support begins</p><div class="td-module-meta-info"><div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://www.caymancompass.com/author/rragoonath/">Reshma Ragoonath</a><div class="td-author-line"> -</div></div> <span class="td-post-date"><time class="entry-date updated td-module-date">April 6, 2020</time></span></div></header></div><div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-bg td-ps-notext td-ps-rounded td-post-sharing-style3 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.caymancompass.com%2F2020%2F04%2F06%2Fnau-applications-on-the-rise%2F"><div class="td-social-but-icon"><i class="td-icon-facebook"></i></div><div class="td-social-but-text">Facebook</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=NAU+applications+on+the+rise&url=https%3A%2F%2Fwww.caymancompass.com%2F2020%2F04%2F06%2Fnau-applications-on-the-rise%2F&via=cayCompass"><div class="td-social-but-icon"><i class="td-icon-twitter"></i></div><div class="td-social-but-text">Twitter</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=NAU+applications+on+the+rise %0A%0A https://www.caymancompass.com/2020/04/06/nau-applications-on-the-rise/"><div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div><div class="td-social-but-text">WhatsApp</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-linkedin" href="https://www.linkedin.com/shareArticle?mini=true&url=https://www.caymancompass.com/2020/04/06/nau-applications-on-the-rise/&title=NAU+applications+on+the+rise"><div class="td-social-but-icon"><i class="td-icon-linkedin"></i></div><div class="td-social-but-text">Linkedin</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="/cdn-cgi/l/email-protection#9aa5e9eff8f0fff9eea7d4dbcfbafbeaeaf6f3f9fbeef3f5f4e9baf5f4baeef2ffbae8f3e9ffbcf8f5fee3a7f2eeeeeae9a0b5b5edededb4f9fbe3f7fbf4f9f5f7eafbe9e9b4f9f5f7b5a8aaa8aab5aaaeb5aaacb5f4fbefb7fbeaeaf6f3f9fbeef3f5f4e9b7f5f4b7eef2ffb7e8f3e9ffb5"><div class="td-social-but-icon"><i class="td-icon-mail"></i></div><div class="td-social-but-text">Email</div> </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top"><div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div> </a></div></div></div><div class="td-post-content tagdiv-type"><div class="td-featured-image-rec"><div class="td-post-featured-image"><figure><a href="https://www.caymancompass.com/core/wp-content/uploads/2020/04/WhatsApp-Image-2020-04-06-at-5.23.20-PM-e1586302075292.jpeg" data-caption="Premier Alden McLaughlin says 136 applications have been received for immediate food assistance. - Photo: GIS"><img width="696" height="803" class="entry-thumb td-modal-image" src="https://www.caymancompass.com/core/wp-content/uploads/2020/04/WhatsApp-Image-2020-04-06-at-5.23.20-PM-e1586302075292-696x803.jpeg" srcset="https://www.caymancompass.com/core/wp-content/uploads/2020/04/WhatsApp-Image-2020-04-06-at-5.23.20-PM-e1586302075292-696x803.jpeg 696w, https://www.caymancompass.com/core/wp-content/uploads/2020/04/WhatsApp-Image-2020-04-06-at-5.23.20-PM-e1586302075292-260x300.jpeg 260w, https://www.caymancompass.com/core/wp-content/uploads/2020/04/WhatsApp-Image-2020-04-06-at-5.23.20-PM-e1586302075292-1068x1232.jpeg 1068w, https://www.caymancompass.com/core/wp-content/uploads/2020/04/WhatsApp-Image-2020-04-06-at-5.23.20-PM-e1586302075292-364x420.jpeg 364w, https://www.caymancompass.com/core/wp-content/uploads/2020/04/WhatsApp-Image-2020-04-06-at-5.23.20-PM-e1586302075292-600x692.jpeg 600w, https://www.caymancompass.com/core/wp-content/uploads/2020/04/WhatsApp-Image-2020-04-06-at-5.23.20-PM-e1586302075292.jpeg 1196w" sizes="(max-width: 696px) 100vw, 696px" alt="Premier Alden McLaughlin" title="Premier Alden McLaughlin" /></a><figcaption class="wp-caption-text">Premier Alden McLaughlin says 136 applications have been received for immediate food assistance. - Photo: GIS</figcaption></figure></div></div><p>The demand for Needs Assessment Unit assistance for vulnerable Caymanians is increasing, with 136 new applications set to be processed this week, officials said.</p><p>Premier Alden McLaughlin shared the figure Monday as he addressed the daily COVID-19 briefing.</p><p>McLaughlin, who is also community affairs minister, said the 136 applications are for immediate food vouchers.</p><p>“Ongoing requests continue to be processed for NAU services. With the immediate focus being placed on food vouchers, 1,681 existing families are now approved for services. Persons who have already submitted an application may call 244-2426 for confirmation of approval of services,” the premier said.</p><p>He said government has received 76 applications from work-permit holders for vetting for assistance, three of which came from the Sister Islands.</p><div class="td-a-rec td-a-rec-id-content_inline  tdi_3_686 td_block_template_16"><style>/* custom css */
.tdi_3_686.td-a-rec-img,
				.tdi_3_686 .td-adspot-title{
				    text-align: left;
				}.tdi_3_686.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }.tdi_3_686 .td-element-style{
					z-index: -1;
				}</style><div class="td-all-devices in-article-lb-ad"> <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">var rnd = window.rnd || Math.floor(Math.random()*10e6);
var pid420688 = window.pid420688 || rnd;
var plc420688 = window.plc420688 || 0;
var abkw = window.abkw || '';
var absrc = 'https://servedbyadbutler.com/adserve/;ID=165413;size=0x0;setID=420688;type=js;sw='+screen.width+';sh='+screen.height+';spr='+window.devicePixelRatio+';kw='+abkw+';pid='+pid420688+';place='+(plc420688++)+';rnd='+rnd+';click=CLICK_MACRO_PLACEHOLDER';
document.write('<scr'+'ipt src="'+absrc+'" type="text/javascript"></scr'+'ipt>');</script> </div></div><p>“Distribution of one-off food vouchers will take place [Tuesday] and Thursday of this week,” he said.</p><p>To assist with the increase in demand, McLaughlin said, the Department of Community Rehabilitation has been enlisted to help with processing calls and services.</p><p>“We&#8217;ve added five persons to this call centre,&#8221; the premier said.</p><p>He added that the NAU on Grand Cayman can be contacted on 294-6002, and on Cayman Brac on 948-8758. The unit can also be emailed at <a href="/cdn-cgi/l/email-protection#9fd1decaf6f1f9f0dff8f0e9b1f4e6"><span class="__cf_email__" data-cfemail="eba5aabe82858d84ab8c849dc58092">[email&#160;protected]</span></a>.</p><p>Despite the boost in staffing, McLaughlin is urging non-Caymanians seeking support not to call the NAU or Department of Children and Family Services.</p><p>“I need to emphasise that these persons should not contact NAU or DCFS. They should email <a href="/cdn-cgi/l/email-protection#caa9a3ada9a5bca3aeb9bfbabaa5b8be8aada5bce4a1b3"><span class="__cf_email__" data-cfemail="ccafa5abafa3baa5a8bfb9bcbca3beb88caba3bae2a7b5">[email&#160;protected]</span></a> or call 244-8000 Monday through Friday, 10am to 4pm,” he said.</p><p>A hotline, +1 800-534-2222, has been created for Cayman’s ageing population to reach out for information and advice.</p><p>The premier, in his report from DCFS, said since 23 March there have been 22 child-protection referrals that have been investigated.</p><p>“The MASH (Multi-Agency Safeguarding Hub) team continues to be in operation to ensure the safety of our children and can be contacted at +1 800-534-2273 or emailed at <a href="/cdn-cgi/l/email-protection#8ee3effde6cee9e1f8a0e5f7"><span class="__cf_email__" data-cfemail="5934382a31193e362f773220">[email&#160;protected]</span></a>,” he said.</p><p>He also reminded the public that Cayman’s emergency number remains 911, and other general inquiries for non-emergency-related issues should be made by calling 916-2837 or 926-6853 between 8:30am and 5pm or by emailing <a href="/cdn-cgi/l/email-protection#3f7b7c796c7f585049115446"><span class="__cf_email__" data-cfemail="e6a2a5a0b5a6818990c88d9f">[email&#160;protected]</span></a>.</p><p><strong>NAU numbers</strong></p><ul><li>136 applications for immediate food vouchers</li><li>1,681 families approved for services</li><li>76 voucher applications from work-permit holders</li></ul><div class="likebtn_container" style="clear:both;"><span class="likebtn-wrapper" data-identifier="post_474431" data-site_id="5a6f97366fd08b0f18563396" data-theme="custom" data-icon_l="thmb4-u" data-icon_d="thmb4-d" data-icon_size="24" data-icon_l_c_v="#00aeef" data-icon_d_c_v="#00aeef" data-counter_l_c="#222222" data-counter_d_c="#222222" data-bg_c="rgba(250,250,250,0)" data-bg_c_v="rgba(250,250,250,0)" data-brdr_c="rgba(255,255,255,0)" data-f_size="14" data-f_family="Georgia" data-counter_fs="b" data-show_like_label="false" data-share_enabled="false" data-voting_cancelable="false" data-tooltip_enabled="false" data-white_label="true" data-popup_disabled="true" data-style="" data-unlike_allowed="" data-show_copyright="" data-item_url="https://www.caymancompass.com/2020/04/06/nau-applications-on-the-rise/" data-item_title="NAU applications on the rise" data-item_image="https://www.caymancompass.com/core/wp-content/uploads/2020/04/WhatsApp-Image-2020-04-06-at-5.23.20-PM-1076x1440.jpeg" data-item_date="2020-04-06T20:40:37-05:00" data-engine="WordPress" data-plugin_v="2.6.25" data-prx="https://www.caymancompass.com/core/wp-admin/admin-ajax.php?action=likebtn_prx" data-event_handler="likebtn_eh"></span></div><div class="td-a-rec td-a-rec-id-content_bottom  tdi_4_e46 td_block_template_16"><style>/* custom css */
.tdi_4_e46.td-a-rec-img,
				.tdi_4_e46 .td-adspot-title{
				    text-align: left;
				}.tdi_4_e46.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }.tdi_4_e46 .td-element-style{
					z-index: -1;
				}</style><div class="td-all-devices"> <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">var rnd = window.rnd || Math.floor(Math.random()*10e6);
var pid421033 = window.pid421033 || rnd;
var plc421033 = window.plc421033 || 0;
var abkw = window.abkw || '';
var absrc = 'https://servedbyadbutler.com/adserve/;ID=165413;size=0x0;setID=421033;type=js;sw='+screen.width+';sh='+screen.height+';spr='+window.devicePixelRatio+';kw='+abkw+';pid='+pid421033+';place='+(plc421033++)+';rnd='+rnd+';click=CLICK_MACRO_PLACEHOLDER';
document.write('<scr'+'ipt src="'+absrc+'" type="text/javascript"></scr'+'ipt>');</script> </div><div style="background-color: #fffcbb; padding: 20px 20px 10px 20px; margin-top:30px; border: 1px solid #999; border-radius: 3px;"><p style="margin-bottom: 10px;">If you value our service, if you have turned to us in the past few days or weeks for verified, factual updates, if you have watched our live streaming of press conferences or sent an article to a friend... please consider a donation. Quality local journalism was at risk before the coronavirus crisis. It is now deeply threatened. Even a small amount can go a long way to sustaining our mission of informing the public. We need our readers’ financial support now more than ever.</p><h4 style="text-align: center; margin-top: 0 !important;"><a href="https://www.caymancompass.com/donate/"><span class="td_btn td_btn_md td_outlined_btn" style="border-color: #e00606; color: #e00606;">Donate</span></a></h4></div></div></div><footer><div class="td-post-source-tags"><ul class="td-tags td-post-small-box clearfix"><li><span>TOPICS</span></li><li><a href="https://www.caymancompass.com/tag/coronavirus/">coronavirus</a></li><li><a href="https://www.caymancompass.com/tag/covid-19/">COVID-19</a></li><li><a href="https://www.caymancompass.com/tag/nau/">NAU</a></li><li><a href="https://www.caymancompass.com/tag/premier-alden-mclaughlin/">Premier Alden McLaughlin</a></li></ul></div><div class="td-post-sharing-bottom"><div class="td-post-sharing-classic"><iframe frameBorder="0" src="https://www.facebook.com/plugins/like.php?href=https://www.caymancompass.com/2020/04/06/nau-applications-on-the-rise/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:auto; height:21px; background-color:transparent;"></iframe></div><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-ps-rounded td-post-sharing-style3 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.caymancompass.com%2F2020%2F04%2F06%2Fnau-applications-on-the-rise%2F"><div class="td-social-but-icon"><i class="td-icon-facebook"></i></div><div class="td-social-but-text">Facebook</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=NAU+applications+on+the+rise&url=https%3A%2F%2Fwww.caymancompass.com%2F2020%2F04%2F06%2Fnau-applications-on-the-rise%2F&via=cayCompass"><div class="td-social-but-icon"><i class="td-icon-twitter"></i></div><div class="td-social-but-text">Twitter</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=NAU+applications+on+the+rise %0A%0A https://www.caymancompass.com/2020/04/06/nau-applications-on-the-rise/"><div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div><div class="td-social-but-text">WhatsApp</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-linkedin" href="https://www.linkedin.com/shareArticle?mini=true&url=https://www.caymancompass.com/2020/04/06/nau-applications-on-the-rise/&title=NAU+applications+on+the+rise"><div class="td-social-but-icon"><i class="td-icon-linkedin"></i></div><div class="td-social-but-text">Linkedin</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="/cdn-cgi/l/email-protection#340b4741565e515740097a756114554444585d5755405d5b5a47145b5a14405c5114465d475112565b504d095c404044470e1b1b4343431a57554d59555a575b59445547471a575b591b060406041b04001b04021b5a554119554444585d5755405d5b5a47195b5a19405c5119465d47511b"><div class="td-social-but-icon"><i class="td-icon-mail"></i></div><div class="td-social-but-text">Email</div> </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom"><div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div> </a></div></div></div><div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://www.caymancompass.com/2020/04/06/new-cayman-spirits-gin-is-drink-of-the-gods/">New Cayman Spirits gin is ‘drink of the gods’</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="https://www.caymancompass.com/2020/04/06/emergency-ba-flight-arrives-in-cayman/">Emergency BA flight arrives in Cayman</a></div></div></div><div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="https://www.caymancompass.com/author/rragoonath/">Reshma Ragoonath</a></span></div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Reshma Ragoonath"></span><meta itemprop="datePublished" content="2020-04-06T20:40:37-05:00"><meta itemprop="dateModified" content="2020-04-07T18:28:12-05:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.caymancompass.com/2020/04/06/nau-applications-on-the-rise/" /><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.caymancompass.com/core/wp-content/uploads/2019/10/CompassLogoNew-272x90.png"></span><meta itemprop="name" content="Cayman Compass"></span><meta itemprop="headline " content="NAU applications on the rise"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.caymancompass.com/core/wp-content/uploads/2020/04/WhatsApp-Image-2020-04-06-at-5.23.20-PM-e1586302075292.jpeg"><meta itemprop="width" content="1196"><meta itemprop="height" content="1380"></span></footer></article><div class="td_block_wrap td_block_related_posts tdi_5_ddd td_with_ajax_pagination td-pb-border-top td_block_template_16" data-td-block-uid="tdi_5_ddd"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>var block_tdi_5_ddd = new tdBlock();
block_tdi_5_ddd.id = "tdi_5_ddd";
block_tdi_5_ddd.atts = '{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_tags","td_ajax_filter_type":"td_custom_related","class":"tdi_5_ddd","td_column_number":3,"live_filter_cur_post_id":474431,"live_filter_cur_post_author":"9892","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"tdi_5_ddd","tdc_css_class_style":"tdi_5_ddd_rand_style"}';
block_tdi_5_ddd.td_column_number = "3";
block_tdi_5_ddd.block_type = "td_block_related_posts";
block_tdi_5_ddd.post_count = "3";
block_tdi_5_ddd.found_posts = "347";
block_tdi_5_ddd.header_color = "";
block_tdi_5_ddd.ajax_pagination_infinite_stop = "";
block_tdi_5_ddd.max_num_pages = "116";
tdBlocksArray.push(block_tdi_5_ddd);</script><h4 class="td-related-title td-block-title"><a id="tdi_6_5c5" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="tdi_5_ddd" href="#">Related articles</a><a id="tdi_7_0e6" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="tdi_5_ddd" href="#">More from this author</a></h4><div id=tdi_5_ddd class="td_block_inner"><div class="td-related-row"><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.caymancompass.com/2020/04/07/airports-likely-to-remain-closed-until-at-least-30-may/" rel="bookmark" class="td-image-wrap " title="Airports likely to remain closed until at least 30 May"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Airports likely to remain closed until at least 30 May" data-type="image_tag" data-img-url="https://www.caymancompass.com/core/wp-content/uploads/2020/04/BA-flight-outgoing-218x150.jpg" width="218" height="150" /></a></div> <a href="https://www.caymancompass.com/category/localnews/" class="td-post-category">Local</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.caymancompass.com/2020/04/07/airports-likely-to-remain-closed-until-at-least-30-may/" rel="bookmark" title="Airports likely to remain closed until at least 30 May">Airports likely to remain closed until at least 30 May</a></h3></div></div></div><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.caymancompass.com/2020/04/07/6-new-virus-cases-reported-including-4-students/" rel="bookmark" class="td-image-wrap " title="4 students among 6 new virus cases"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="4 students among 6 new virus cases" data-type="image_tag" data-img-url="https://www.caymancompass.com/core/wp-content/uploads/2020/04/Dr.-John-Lee-e1586284509853-218x150.jpg" width="218" height="150" /></a></div> <a href="https://www.caymancompass.com/category/breakingnews/" class="td-post-category">Breaking News</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.caymancompass.com/2020/04/07/6-new-virus-cases-reported-including-4-students/" rel="bookmark" title="4 students among 6 new virus cases">4 students among 6 new virus cases</a></h3></div></div></div><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.caymancompass.com/2020/04/07/first-covid-deaths-in-turks-bermuda/" rel="bookmark" class="td-image-wrap " title="First COVID deaths in Turks, Bermuda"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="First COVID deaths in Turks, Bermuda" data-type="image_tag" data-img-url="https://www.caymancompass.com/core/wp-content/uploads/2013/09/Tax-Havens-Bermuda-France-Blacklists-218x150.jpg" width="218" height="150" /></a></div> <a href="https://www.caymancompass.com/category/localnews/" class="td-post-category">Local</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.caymancompass.com/2020/04/07/first-covid-deaths-in-turks-bermuda/" rel="bookmark" title="First COVID deaths in Turks, Bermuda">First COVID deaths in Turks, Bermuda</a></h3></div></div></div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_5_ddd" data-td_block_id="tdi_5_ddd"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-tdi_5_ddd" data-td_block_id="tdi_5_ddd"><i class="td-icon-font td-icon-menu-right"></i></a></div></div><div class="comments" id="comments"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">LEAVE A REPLY <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/04/06/nau-applications-on-the-rise/#respond" style="display:none;">Cancel reply</a></small></h3><p class="must-log-in td-login-comment"><a class="td-login-modal-js" data-effect="mpf-td-login-effect" href="#login-form">Log in to leave a comment </a></p></div></div></div></div><div class="td-pb-span4 td-main-sidebar" role="complementary"><div class="td-ss-main-sidebar"><div class="td-a-rec td-a-rec-id-sidebar  tdi_8_060 td_block_template_16"><style>/* custom css */
.tdi_8_060.td-a-rec-img,
				.tdi_8_060 .td-adspot-title{
				    text-align: left;
				}.tdi_8_060.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }.tdi_8_060 .td-element-style{
					z-index: -1;
				}</style><div id="isb_desktop_advert" class="td-visible-desktop sidebar-ad-compass-fix"> <script type="text/javascript">var elem = document.getElementById("isb_desktop_advert");
var theCSSprop = window.getComputedStyle(elem,null).getPropertyValue("display");

if (theCSSprop!="none"){


var rnd = window.rnd || Math.floor(Math.random()*10e6);
var pid420687 = window.pid420687 || rnd;
var plc420687 = window.plc420687 || 0;
var abkw = window.abkw || '';
var absrc = 'https://servedbyadbutler.com/adserve/;ID=165413;size=0x0;setID=420687;type=js;sw='+screen.width+';sh='+screen.height+';spr='+window.devicePixelRatio+';kw='+abkw+';pid='+pid420687+';place='+(plc420687++)+';rnd='+rnd+';click=CLICK_MACRO_PLACEHOLDER';
document.write('<scr'+'ipt src="'+absrc+'" type="text/javascript"></scr'+'ipt>');

}else{
}</script> </div><div id="isb_tablet_portrait_advert" class="td-visible-tablet-portrait sidebar-ad-compass-fix"> <script type="text/javascript">var elem = document.getElementById("isb_tablet_portrait_advert");
var theCSSprop = window.getComputedStyle(elem,null).getPropertyValue("display");
if (theCSSprop!="none"){


var rnd = window.rnd || Math.floor(Math.random()*10e6);
var pid420687 = window.pid420687 || rnd;
var plc420687 = window.plc420687 || 0;
var abkw = window.abkw || '';
var absrc = 'https://servedbyadbutler.com/adserve/;ID=165413;size=0x0;setID=420687;type=js;sw='+screen.width+';sh='+screen.height+';spr='+window.devicePixelRatio+';kw='+abkw+';pid='+pid420687+';place='+(plc420687++)+';rnd='+rnd+';click=CLICK_MACRO_PLACEHOLDER';
document.write('<scr'+'ipt src="'+absrc+'" type="text/javascript"></scr'+'ipt>');


}else{

}</script> </div><div id="isb_tablet_landscape_advert" class="td-visible-tablet-landscape sidebar-ad-compass-fix"> <script type="text/javascript">var elem = document.getElementById("isb_tablet_landscape_advert");
var theCSSprop = window.getComputedStyle(elem,null).getPropertyValue("display");
if (theCSSprop!="none"){


var rnd = window.rnd || Math.floor(Math.random()*10e6);
var pid420687 = window.pid420687 || rnd;
var plc420687 = window.plc420687 || 0;
var abkw = window.abkw || '';
var absrc = 'https://servedbyadbutler.com/adserve/;ID=165413;size=0x0;setID=420687;type=js;sw='+screen.width+';sh='+screen.height+';spr='+window.devicePixelRatio+';kw='+abkw+';pid='+pid420687+';place='+(plc420687++)+';rnd='+rnd+';click=CLICK_MACRO_PLACEHOLDER';
document.write('<scr'+'ipt src="'+absrc+'" type="text/javascript"></scr'+'ipt>');

}else{
}</script> </div></div><aside id="text-6" class="td_block_template_16 widget text-6 widget_text"><div class="textwidget"><div class="td_block_social_counter newsletter-addon newsletter-sidebar"><div class="td_social_type td-pb-margin-side td-social-newsletter"><div class="td-social-box"><div class="td-sp td-sp-newsletter"><i class="td-icon-mail"></i></div><span class="td_social_button"><a href="https://www.caymancompass.com/subscribe/" target="_blank" rel="noopener noreferrer">SUBSCRIBE TO<span class="sublongtext"> THE COMPASS</span> NEWSLETTER</a></span></div></div></div></div></aside><div class="td_block_wrap td_block_7 td_block_widget tdi_9_5cd td_with_ajax_pagination td-pb-border-top td_block_template_16 td-column-1 td_block_padding" data-td-block-uid="tdi_9_5cd"><script>var block_tdi_9_5cd = new tdBlock();
block_tdi_9_5cd.id = "tdi_9_5cd";
block_tdi_9_5cd.atts = '{"custom_title":"This week","custom_url":"","block_template_id":"","header_text_color":"#","border_color":"#","accent_text_color":"#","m6_tl":"","limit":"3","offset":"","el_class":"","post_ids":"","category_id":"","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","sort":"random_7_day","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"next_prev","ajax_pagination_infinite_stop":"","class":"td_block_widget tdi_9_5cd","separator":"","show_modified_date":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m6f_title_font_header":"","m6f_title_font_title":"Article title","m6f_title_font_settings":"","m6f_title_font_family":"","m6f_title_font_size":"","m6f_title_font_line_height":"","m6f_title_font_style":"","m6f_title_font_weight":"","m6f_title_font_transform":"","m6f_title_font_spacing":"","m6f_title_":"","m6f_cat_font_title":"Article category tag","m6f_cat_font_settings":"","m6f_cat_font_family":"","m6f_cat_font_size":"","m6f_cat_font_line_height":"","m6f_cat_font_style":"","m6f_cat_font_weight":"","m6f_cat_font_transform":"","m6f_cat_font_spacing":"","m6f_cat_":"","m6f_meta_font_title":"Article meta info","m6f_meta_font_settings":"","m6f_meta_font_family":"","m6f_meta_font_size":"","m6f_meta_font_line_height":"","m6f_meta_font_style":"","m6f_meta_font_weight":"","m6f_meta_font_transform":"","m6f_meta_font_spacing":"","m6f_meta_":"","css":"","tdc_css":"","td_column_number":1,"header_color":"","color_preset":"","border_top":"","tdc_css_class":"tdi_9_5cd","tdc_css_class_style":"tdi_9_5cd_rand_style"}';
block_tdi_9_5cd.td_column_number = "1";
block_tdi_9_5cd.block_type = "td_block_7";
block_tdi_9_5cd.post_count = "3";
block_tdi_9_5cd.found_posts = "78";
block_tdi_9_5cd.header_color = "";
block_tdi_9_5cd.ajax_pagination_infinite_stop = "";
block_tdi_9_5cd.max_num_pages = "26";
tdBlocksArray.push(block_tdi_9_5cd);</script><div class="td-block-title-wrap"><h4 class="td-block-title"><span class="td-pulldown-size">This week</span></h4></div><div id=tdi_9_5cd class="td_block_inner"><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.caymancompass.com/2020/03/31/hundreds-use-covid-19-online-assessment/" rel="bookmark" class="td-image-wrap " title="Hundreds use COVID-19 online assessment"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" alt="" title="Hundreds use COVID-19 online assessment" data-type="image_tag" data-img-url="https://www.caymancompass.com/core/wp-content/uploads/2020/04/self-assessment-100x70.jpg" width="100" height="70" /></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.caymancompass.com/2020/03/31/hundreds-use-covid-19-online-assessment/" rel="bookmark" title="Hundreds use COVID-19 online assessment">Hundreds use COVID-19 online assessment</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-31T16:00:04+00:00">March 31, 2020</time></span></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.caymancompass.com/2020/04/03/foster-a-furry-friend/" rel="bookmark" class="td-image-wrap " title="Foster a furry friend"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" alt="" title="Foster a furry friend" data-type="image_tag" data-img-url="https://www.caymancompass.com/core/wp-content/uploads/2020/04/Humane-Society-1-100x70.jpg" width="100" height="70" /></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.caymancompass.com/2020/04/03/foster-a-furry-friend/" rel="bookmark" title="Foster a furry friend">Foster a furry friend</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-04-03T19:02:43+00:00">April 3, 2020</time></span></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.caymancompass.com/2020/04/04/sun-sea-and-sand-replaced-by-corona-covid-and-curfew/" rel="bookmark" class="td-image-wrap " title="Sun, sea and sand replaced by corona, COVID and curfew"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" alt="" title="Sun, sea and sand replaced by corona, COVID and curfew" data-type="image_tag" data-img-url="https://www.caymancompass.com/core/wp-content/uploads/2020/04/Elbowbeachbermuda-100x70.jpg" width="100" height="70" /></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.caymancompass.com/2020/04/04/sun-sea-and-sand-replaced-by-corona-covid-and-curfew/" rel="bookmark" title="Sun, sea and sand replaced by corona, COVID and curfew">Sun, sea and sand replaced by corona, COVID and curfew</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-04-04T09:00:44+00:00">April 4, 2020</time></span></div></div></div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_9_5cd" data-td_block_id="tdi_9_5cd"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-tdi_9_5cd" data-td_block_id="tdi_9_5cd"><i class="td-icon-font td-icon-menu-right"></i></a></div></div></div></div></div></div></div><div class="tdc-footer-wrap "><div class="td-footer-wrapper td-footer-container td-container-wrap td-footer-template-4 td_stretch_content"><div class="td-container"><div class="td-pb-row"><div class="td-pb-span12"></div></div><div class="td-pb-row"><div class="td-pb-span12"><div class="td-footer-info"><div class="footer-logo-wrap"><a href="https://www.caymancompass.com/"><img class="td-retina-data" src="https://www.caymancompass.com/core/wp-content/uploads/2019/10/CaymanCompassLogoWhiteNew140x48.png" data-retina="https://www.caymancompass.com/core/wp-content/uploads/2019/10/CaymanCompassLogoWhiteNew280x96.png" alt="Cayman Compass" title="Cayman Compass | Cayman Islands\' news leader." width="140" /></a></div><div class="footer-text-wrap">Cayman Compass is the Cayman Islands' most trusted news website. We provide you with the latest breaking news from the Cayman Islands, as well as other parts of the Caribbean.</div><div class="footer-social-wrap td-social-style-2"> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.facebook.com/caycompass" title="Facebook"> <i class="td-icon-font td-icon-facebook"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.instagram.com/cayman_compass/" title="Instagram"> <i class="td-icon-font td-icon-instagram"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://twitter.com/cayCompass" title="Twitter"> <i class="td-icon-font td-icon-twitter"></i> </a> </span></div></div><aside class="widget_text td_block_template_16 widget widget_custom_html"><div class="textwidget custom-html-widget"><style>.compass-media-footer-links {
	font-family: 'Open Sans', Arial, Helvetica, sans-serif !important;
	color: #fff !important;
	width: 100%;
	text-align: center;
}
.compass-media-footer-heading {
	width: 100%;
	text-align: center;
    border-bottom: 1px solid #fff; 
    line-height: 1px;
    margin: 10px 0 20px; 
}
.compass-media-footer-heading span {
	padding: 0 20px;
	background-color: #0e1523; 
	font-weight: bold;
    font-family: 'Open Sans', Arial, Helvetica, sans-serif !important;
	font-size: 10px;
}
.compass-media-footer-links a, .compass-media-footer-heading a {
  color: #fff !important;
  text-decoration: none;
}
.compass-link-item {
  display: inline-block;
  vertical-align: top;
  width: 10%;
  min-width: 93px;
  margin-bottom: 20px;
}
.compass-link-icon {
	width: 60px;
	height: 60px;
	margin: 0 auto;
}
.compass-link-text h6 {
  text-align: center;
  text-transform: uppercase;
  font-size: 9px !important;
  margin: 0;
  color: #fff !important;
  line-height: 10px !important;
}
.sprite-compass-media-icon-christmas-catalog, .sprite-compass-media-icon-christmascatalog, .sprite-compass-media-icon-whot, .sprite-compass-media-icon-cfr, .sprite-compass-media-icon-compass, 
.sprite-compass-media-icon-flava, .sprite-compass-media-icon-gcm, .sprite-compass-media-icon-health, .sprite-compass-media-icon-insideout, .sprite-compass-media-icon-journal, 
.sprite-compass-media-icon-keytocayman, .sprite-compass-media-icon-map
{ display: inline-block; background: url('/core/wp-content/uploads/footer-icons/footer-icons.png') no-repeat; overflow: hidden; text-indent: -9999px; text-align: left; }
 
.sprite-compass-media-icon-christmas-catalog { background-position: -10px -0px; width: 50px; height: 50px; }
.sprite-compass-media-icon-christmascatalog { background-position: -70px -0px; width: 50px; height: 50px; }
.sprite-compass-media-icon-whot { background-position: -130px -0px; width: 50px; height: 50px; }
.sprite-compass-media-icon-cfr { background-position: -10px -60px; width: 50px; height: 50px; }
.sprite-compass-media-icon-compass { background-position: -70px -60px; width: 50px; height: 50px; }
.sprite-compass-media-icon-flava { background-position: -130px -60px; width: 50px; height: 50px; }
.sprite-compass-media-icon-gcm { background-position: -10px -120px; width: 50px; height: 50px; }
.sprite-compass-media-icon-health { background-position: -70px -120px; width: 50px; height: 50px; }
.sprite-compass-media-icon-insideout { background-position: -130px -120px; width: 50px; height: 50px; }
.sprite-compass-media-icon-journal { background-position: -10px -180px; width: 50px; height: 50px; }
.sprite-compass-media-icon-keytocayman { background-position: -70px -180px; width: 50px; height: 50px; }
.sprite-compass-media-icon-map { background-position: -130px -180px; width: 50px; height: 50px; }</style><div class="compass-media-footer-links"><div class="compass-links-heading-container"><h6 class="compass-media-footer-heading"><a href="https://www.compassmedia.ky" target="_blank" rel="noopener noreferrer"><span>Compass Media Ltd. Brands</span></a></h6></div><div class="compass-link-item"><div class="compass-link-icon"> <a href="https://www.caymancompass.com/" target="_blank" rel="noopener noreferrer"><div class="sprite-compass-media-icon-compass"></div></a></div><div class="compass-link-text"> <a href="https://www.caymancompass.com/" target="_blank" rel="noopener noreferrer"><h6>Cayman Compass</h6></a></div></div><div class="compass-link-item"><div class="compass-link-icon"> <a href="https://www.caymanhealth.com/" target="_blank" rel="noopener noreferrer"><div class="sprite-compass-media-icon-health"></div></a></div><div class="compass-link-text"> <a href="https://www.caymanhealth.com/" target="_blank" rel="noopener noreferrer"><h6>Cayman Health</h6></a></div></div><div class="compass-link-item"><div class="compass-link-icon"> <a href="https://www.insideoutcayman.com/" target="_blank" rel="noopener noreferrer"><div class="sprite-compass-media-icon-insideout"></div></a></div><div class="compass-link-text"> <a href="https://www.insideoutcayman.com/" target="_blank" rel="noopener noreferrer"><h6>Inside Out</h6></a></div></div></div></div></aside></div></div></div></div><div class="td-sub-footer-container td-container-wrap td_stretch_content"><div class="td-container"><div class="td-pb-row"><div class="td-pb-span td-sub-footer-menu"><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="td-subfooter-menu"><li id="menu-item-470577" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-470577"><a href="https://www.caymancompass.com/community-standards/">Community Standards</a></li><li id="menu-item-188298" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188298"><a href="https://www.caymancompass.com/terms-of-use/">Terms and Conditions of Use</a></li><li id="menu-item-188297" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188297"><a href="https://www.caymancompass.com/privacy-policy/">Privacy Policy</a></li><li id="menu-item-188296" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188296"><a href="https://www.caymancompass.com/copyright-policy-2/">Copyright</a></li><li id="menu-item-316352" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-316352"><a href="https://www.caymancompass.com/faq/">FAQ</a></li><li id="menu-item-380097" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-380097"><a href="https://www.caymancompass.com/?page_id=608">Newsletter</a></li><li id="menu-item-389923" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-389923"><a href="https://www.caymancompass.com/advertise-with-us/">Advertise</a></li><li id="menu-item-470593" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-470593"><a href="https://www.caymancompass.com/compass-media-promotion-standard-terms-and-conditions/">Promotions T &#038; C</a></li></ul></div></div><div class="td-pb-span td-sub-footer-copy"> &copy; Cayman Compass Ltd.</div></div></div></div></div></div> <script type="text/javascript">var likebtn_wl = 1; (function(d, e, s) {a = d.createElement(e);m = d.getElementsByTagName(e)[0];a.async = 1;a.src = s;m.parentNode.insertBefore(a, m)})(document, 'script', '//w.likebtn.com/js/w/widget.js'); if (typeof(LikeBtn) != "undefined") { LikeBtn.init(); }</script> <div id="um_upload_single" style="display:none"></div><div id="um_view_photo" style="display:none"> <a href="javascript:void(0);" data-action="um_remove_modal" class="um-modal-close"><i class="um-faicon-times"></i></a><div class="um-modal-body photo"><div class="um-modal-photo"></div></div></div> <style type="text/css" media="screen">/* custom responsive css from theme panel (Advanced CSS) */
@media (min-width: 1141px) {
/* ADJUST FONT SIZE ON HOME PAGE FEATURES */
.td-grid-style-1 .td-big-thumb .entry-title {
  line-height: 32px !important;
}
/*  Trending Now align left and right  */
.td-trending-now-wrapper {
 padding-left: 24px !important;
}
.td-trending-now-wrapper .td-next-prev-wrap {
  right: 24px !important;
}
/* TRENDING NOW font adjust */
.td-trending-now-title {
  padding: 4px 12px;
}
.td-trending-now-wrapper {
    height: 29px;
}
}


/* custom responsive css from theme panel (Advanced CSS) */
@media (max-width: 767px) {
/* PUT LOGIN BACK INTO MOBILE MENU */
.td-header-top-menu-full, .td-header-sp-top-menu {
display: block !important;
}
.menu-top-container, .td-header-sp-top-widget {
display: none !important;
}
.td-header-wrap .td-header-main-menu {
    background-color: #00aeef !important;
}


}</style> <script type="text/javascript">var c = document.body.className;
		c = c.replace(/woocommerce-no-js/, 'woocommerce-js');
		document.body.className = c;</script> <script type='text/javascript'>var leadin_wordpress = {"userRole":"visitor","pageType":"post","leadinPluginVersion":"7.27.48"};</script> <script async defer id="hs-script-loader" type='text/javascript' src='//js.hs-scripts.com/5627643.js?integration=WordPress'></script> <script type='text/javascript'>var ctcc_vars = {"expiry":"90","method":"","version":"1"};</script> <script type='text/javascript' src='https://www.caymancompass.com/core/wp-content/plugins/uk-cookie-consent/assets/js/uk-cookie-consent-js.js?ver=2.3.0'></script> <script type='text/javascript' src='https://www.caymancompass.com/core/wp-content/plugins/woocommerce/assets/js/jquery-blockui/jquery.blockUI.min.js?ver=2.70'></script> <script type='text/javascript'>var wc_add_to_cart_params = {"ajax_url":"\/core\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","i18n_view_cart":"View cart","cart_url":"https:\/\/www.caymancompass.com\/cart\/","is_cart":"","cart_redirect_after_add":"no"};</script> <script type='text/javascript' src='https://www.caymancompass.com/core/wp-content/plugins/woocommerce/assets/js/frontend/add-to-cart.min.js?ver=4.0.1'></script> <script type='text/javascript' src='https://www.caymancompass.com/core/wp-content/plugins/woocommerce/assets/js/js-cookie/js.cookie.min.js?ver=2.1.4'></script> <script type='text/javascript'>var woocommerce_params = {"ajax_url":"\/core\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%"};</script> <script type='text/javascript' src='https://www.caymancompass.com/core/wp-content/plugins/woocommerce/assets/js/frontend/woocommerce.min.js?ver=4.0.1'></script> <script type='text/javascript'>var wc_cart_fragments_params = {"ajax_url":"\/core\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","cart_hash_key":"wc_cart_hash_99d5bbe2b9f1d228bbb2c9192503ef24","fragment_name":"wc_fragments_99d5bbe2b9f1d228bbb2c9192503ef24","request_timeout":"5000"};</script> <script type='text/javascript' src='https://www.caymancompass.com/core/wp-content/plugins/woocommerce/assets/js/frontend/cart-fragments.min.js?ver=4.0.1'></script> <script type='text/javascript' src='https://www.caymancompass.com/core/wp-includes/js/underscore.min.js?ver=1.8.3'></script> <script type='text/javascript' src='https://www.caymancompass.com/core/wp-content/plugins/td-cloud-library/assets/js/js_posts_autoload.min.js?ver=5a3020c6756b1af114549ea2a5ae6807'></script> <script type='text/javascript' src='https://www.caymancompass.com/core/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js?ver=10.3.2'></script> <script type='text/javascript' src='https://www.caymancompass.com/core/wp-includes/js/comment-reply.min.js?ver=7046c1370d646b344933e44fa737dfea'></script> <script type='text/javascript' src='https://www.caymancompass.com/core/wp-content/plugins/ultimate-member/assets/js/select2/select2.full.min.js?ver=2.1.4'></script> <script type='text/javascript'>var _wpUtilSettings = {"ajax":{"url":"\/core\/wp-admin\/admin-ajax.php"}};</script> <script type='text/javascript' src='https://www.caymancompass.com/core/wp-includes/js/wp-util.min.js?ver=7046c1370d646b344933e44fa737dfea'></script> <script type='text/javascript' src='https://www.caymancompass.com/core/wp-content/plugins/ultimate-member/assets/js/um-crop.min.js?ver=2.1.4'></script> <script type='text/javascript' src='https://www.caymancompass.com/core/wp-content/plugins/ultimate-member/assets/js/um-modal.min.js?ver=2.1.4'></script> <script type='text/javascript' src='https://www.caymancompass.com/core/wp-content/plugins/ultimate-member/assets/js/um-jquery-form.min.js?ver=2.1.4'></script> <script type='text/javascript' src='https://www.caymancompass.com/core/wp-content/plugins/ultimate-member/assets/js/um-fileupload.min.js?ver=2.1.4'></script> <script type='text/javascript' src='https://www.caymancompass.com/core/wp-content/plugins/ultimate-member/assets/js/pickadate/picker.js?ver=2.1.4'></script> <script type='text/javascript' src='https://www.caymancompass.com/core/wp-content/plugins/ultimate-member/assets/js/pickadate/picker.date.js?ver=2.1.4'></script> <script type='text/javascript' src='https://www.caymancompass.com/core/wp-content/plugins/ultimate-member/assets/js/pickadate/picker.time.js?ver=2.1.4'></script> <script type='text/javascript' src='https://www.caymancompass.com/core/wp-content/plugins/ultimate-member/assets/js/pickadate/legacy.js?ver=2.1.4'></script> <script type='text/javascript' src='https://www.caymancompass.com/core/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=7.4.4'></script> <script type='text/javascript'>( 'fetch' in window ) || document.write( '<script src="https://www.caymancompass.com/core/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://www.caymancompass.com/core/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script src="https://www.caymancompass.com/core/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="https://www.caymancompass.com/core/wp-includes/js/dist/vendor/wp-polyfill-url.min.js?ver=3.6.4"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://www.caymancompass.com/core/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://www.caymancompass.com/core/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );</script> <script type='text/javascript' src='https://www.caymancompass.com/core/wp-includes/js/dist/i18n.min.js?ver=cced130522e86c87a37cd7b8397b882c'></script> <script type='text/javascript' src='https://www.caymancompass.com/core/wp-content/plugins/ultimate-member/assets/js/um-raty.min.js?ver=2.1.4'></script> <script type='text/javascript' src='https://www.caymancompass.com/core/wp-content/plugins/ultimate-member/assets/js/um-tipsy.min.js?ver=2.1.4'></script> <script type='text/javascript' src='https://www.caymancompass.com/core/wp-includes/js/imagesloaded.min.js?ver=3.2.0'></script> <script type='text/javascript' src='https://www.caymancompass.com/core/wp-includes/js/masonry.min.js?ver=3.3.2'></script> <script type='text/javascript' src='https://www.caymancompass.com/core/wp-includes/js/jquery/jquery.masonry.min.js?ver=3.1.2b'></script> <script type='text/javascript' src='https://www.caymancompass.com/core/wp-content/plugins/ultimate-member/assets/js/simplebar.min.js?ver=2.1.4'></script> <script type='text/javascript' src='https://www.caymancompass.com/core/wp-content/plugins/ultimate-member/assets/js/um-functions.min.js?ver=2.1.4'></script> <script type='text/javascript' src='https://www.caymancompass.com/core/wp-content/plugins/ultimate-member/assets/js/um-responsive.min.js?ver=2.1.4'></script> <script type='text/javascript' src='https://www.caymancompass.com/core/wp-content/plugins/ultimate-member/assets/js/um-conditional.min.js?ver=2.1.4'></script> <script type='text/javascript'>var um_scripts = {"nonce":"73dd441608"};</script> <script type='text/javascript' src='https://www.caymancompass.com/core/wp-content/plugins/ultimate-member/assets/js/um-scripts.min.js?ver=2.1.4'></script> <script type='text/javascript' src='https://www.caymancompass.com/core/wp-content/plugins/ultimate-member/assets/js/um-profile.min.js?ver=2.1.4'></script> <script type='text/javascript' src='https://www.caymancompass.com/core/wp-content/plugins/ultimate-member/assets/js/um-account.min.js?ver=2.1.4'></script> <script type='text/javascript' src='https://www.caymancompass.com/core/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=5a3020c6756b1af114549ea2a5ae6807'></script> <script type='text/javascript' src='https://www.caymancompass.com/core/wp-includes/js/wp-embed.min.js?ver=7046c1370d646b344933e44fa737dfea'></script> <script type='text/javascript' src='https://www.caymancompass.com/core/wp-content/plugins/um-social-login/assets/js/um-social-connect.min.js?ver=2.3.2'></script> <script>jQuery().ready(function () {
					tdWeather.addItem({"block_uid":"td_top_weather_uid","location":"Cayman Islands,KY","api_location":"Cayman Islands","api_language":"en","api_key":"ae21a97d3f26a55d9b4e4d46d5846297","today_icon":"clear-sky-d","today_icon_text":"clear sky","today_temp":[28.300000000000000710542735760100185871124267578125,83],"today_humidity":74,"today_wind_speed":[3.600000000000000088817841970012523233890533447265625,2.20000000000000017763568394002504646778106689453125],"today_min":[28.300000000000000710542735760100185871124267578125,83],"today_max":[28.300000000000000710542735760100185871124267578125,83],"today_clouds":0,"current_unit":1,"forecast":[{"timestamp":1586304000,"day_name":"Wed","day_temp":[28,82],"owm_day_index":0},{"timestamp":1586390400,"day_name":"Thu","day_temp":[27,81],"owm_day_index":8},{"timestamp":1586476800,"day_name":"Fri","day_temp":[28,82],"owm_day_index":16},{"timestamp":1586563200,"day_name":"Sat","day_temp":[28,82],"owm_day_index":24},{"timestamp":1586649600,"day_name":"Sun","day_temp":[28,82],"owm_day_index":32}]});
				});</script> <script type="text/javascript">jQuery(document).ready(function($){
												if(!catapultReadCookie("catAccCookies")){ // If the cookie has not been set then show the bar
							$("html").addClass("has-cookie-bar");
							$("html").addClass("cookie-bar-bottom-bar");
							$("html").addClass("cookie-bar-bar");
													}
													$(window).scroll(function(){
								var scroll = $(window).scrollTop();
								if ( scroll > 700 ) {
									ctccCloseNotification();
								}
							});	
																	});</script> <div id="catapult-cookie-bar" class=""><div class="ctcc-inner "><span class="ctcc-left-side">This site uses cookies. <a class="ctcc-more-info-link" tabindex=0 target="_blank" href="https://www.caymancompass.com/cookie-policy/">Find out more.</a></span><span class="ctcc-right-side"><button id="catapultCookie" tabindex=0 onclick="catapultAcceptCookies();">CLOSE</button></span></div></div> <script type="text/javascript">jQuery( '#request' ).val( '' );</script> </body></html>


