<!doctype html > <!--[if IE 8]><html class="ie8" lang="en"> <![endif]--> <!--[if IE 9]><html class="ie9" lang="en"> <![endif]--> <!--[if gt IE 8]><!--><html lang="en-US"> <!--<![endif]--><head><script data-cfasync="false" id="ao_optimized_gfonts_config">WebFontConfig={google:{families:["Open Sans:400,600,700","Roboto:400,500,700"] },classes:false, events:false, timeout:1500};</script><link media="all" href="https://www.caymancompass.com/wp-content/cache/autoptimize/css/autoptimize_42a6603fdfd8900082a64d3bf07fb40a.css" rel="stylesheet" /><title>Digicel files for US bankruptcy protection - Cayman Compass</title><meta charset="UTF-8" /><meta name="viewport" content="width=device-width, initial-scale=1.0"><link rel="pingback" href="https://www.caymancompass.com/xmlrpc.php" /><meta name="robots" content="index, follow" /><meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://www.caymancompass.com/2020/05/19/digicel-files-for-us-bankruptcy-protection/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Digicel files for US bankruptcy protection - Cayman Compass" /><meta property="og:description" content="Telecommunications provider Digicel has filed for Chapter 15 recognition in a federal bankruptcy court in the Southern District of New York after it was granted an application for provisional liquidation in Bermuda." /><meta property="og:url" content="https://www.caymancompass.com/2020/05/19/digicel-files-for-us-bankruptcy-protection/" /><meta property="og:site_name" content="Cayman Compass" /><meta property="article:publisher" content="https://www.facebook.com/caycompass" /><meta property="article:published_time" content="2020-05-19T17:57:33+00:00" /><meta property="og:image" content="https://www.caymancompass.com/wp-content/uploads/2020/05/Digicel.jpg" /><meta property="og:image:width" content="1024" /><meta property="og:image:height" content="1024" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@cayCompass" /><meta name="twitter:site" content="@cayCompass" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.caymancompass.com/#organization","name":"Cayman Compass","url":"https://www.caymancompass.com/","sameAs":["https://www.facebook.com/caycompass","https://instagram.com/cayman_compass","https://www.youtube.com/caymancompas","https://twitter.com/cayCompass"],"logo":{"@type":"ImageObject","@id":"https://www.caymancompass.com/#logo","inLanguage":"en-US","url":"https://www.caymancompass.com/wp-content/uploads/2019/10/CompassLogo-white-bgd.gif","width":400,"height":275,"caption":"Cayman Compass"},"image":{"@id":"https://www.caymancompass.com/#logo"}},{"@type":"WebSite","@id":"https://www.caymancompass.com/#website","url":"https://www.caymancompass.com/","name":"Cayman Compass","description":"The Cayman Islands&#039; Most Trusted News Source","publisher":{"@id":"https://www.caymancompass.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://www.caymancompass.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.caymancompass.com/2020/05/19/digicel-files-for-us-bankruptcy-protection/#primaryimage","inLanguage":"en-US","url":"https://www.caymancompass.com/wp-content/uploads/2020/05/Digicel.jpg","width":1024,"height":1024},{"@type":"WebPage","@id":"https://www.caymancompass.com/2020/05/19/digicel-files-for-us-bankruptcy-protection/#webpage","url":"https://www.caymancompass.com/2020/05/19/digicel-files-for-us-bankruptcy-protection/","name":"Digicel files for US bankruptcy protection - Cayman Compass","isPartOf":{"@id":"https://www.caymancompass.com/#website"},"primaryImageOfPage":{"@id":"https://www.caymancompass.com/2020/05/19/digicel-files-for-us-bankruptcy-protection/#primaryimage"},"datePublished":"2020-05-19T17:57:33+00:00","dateModified":"2020-05-19T17:57:33+00:00","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.caymancompass.com/2020/05/19/digicel-files-for-us-bankruptcy-protection/"]}]},{"@type":"Article","@id":"https://www.caymancompass.com/2020/05/19/digicel-files-for-us-bankruptcy-protection/#article","isPartOf":{"@id":"https://www.caymancompass.com/2020/05/19/digicel-files-for-us-bankruptcy-protection/#webpage"},"author":{"@id":"https://www.caymancompass.com/#/schema/person/93a636ce4efacfb256aa64704a187691"},"headline":"Digicel files for US bankruptcy protection","datePublished":"2020-05-19T17:57:33+00:00","dateModified":"2020-05-19T17:57:33+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://www.caymancompass.com/2020/05/19/digicel-files-for-us-bankruptcy-protection/#webpage"},"publisher":{"@id":"https://www.caymancompass.com/#organization"},"image":{"@id":"https://www.caymancompass.com/2020/05/19/digicel-files-for-us-bankruptcy-protection/#primaryimage"},"keywords":"debt,Digicel,U.S. Bankruptcy Court","articleSection":"Business","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://www.caymancompass.com/2020/05/19/digicel-files-for-us-bankruptcy-protection/#respond"]}]},{"@type":["Person"],"@id":"https://www.caymancompass.com/#/schema/person/93a636ce4efacfb256aa64704a187691","name":"Michael Klein","description":"Editor"}]}</script> <link rel="icon" type="image/png" href="https://www.caymancompass.com/wp-content/uploads/2019/10/favicon.png"><link rel="apple-touch-icon-precomposed" sizes="76x76" href="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassSqareiOSBookmarklet-76x.png"/><link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassSqareiOSBookmarklet-114x.png"/><link rel="apple-touch-icon-precomposed" sizes="152x152" href="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassSqareiOSBookmarklet-152x.png"/><link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassSqareiOSBookmarklet-114x.png"/><link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassSqareiOSBookmarklet-144x.png"/><link rel='dns-prefetch' href='//ajax.googleapis.com' /><link rel='dns-prefetch' href='//js.hs-scripts.com' /><link rel='dns-prefetch' href='//s.w.org' /><link href='https://fonts.gstatic.com' crossorigin='anonymous' rel='preconnect' /><link href='https://ajax.googleapis.com' rel='preconnect' /><link href='https://fonts.googleapis.com' rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="Cayman Compass &raquo; Feed" href="https://www.caymancompass.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Cayman Compass &raquo; Comments Feed" href="https://www.caymancompass.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Cayman Compass &raquo; Digicel files for US bankruptcy protection Comments Feed" href="https://www.caymancompass.com/2020/05/19/digicel-files-for-us-bankruptcy-protection/feed/" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.caymancompass.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=1d94575c28a52d529613e47620a53900"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);</script> <style type="text/css">img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}</style><link rel='stylesheet' id='jqueryuicss-css'  href='https://ajax.googleapis.com/ajax/libs/jqueryui/1.11.4/themes/smoothness/jquery-ui.css?ver=1d94575c28a52d529613e47620a53900' type='text/css' media='all' /><style id='td-theme-inline-css' type='text/css'>@media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }</style> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/pinnacle-newsletter/pinnacle_javascript.js?ver=1d94575c28a52d529613e47620a53900'></script> <script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jqueryui/1.11.4/jquery-ui.min.js?ver=1d94575c28a52d529613e47620a53900'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script> <script type='text/javascript'>var likebtn_eh_data = {"ajaxurl":"https:\/\/www.caymancompass.com\/wp-admin\/admin-ajax.php","security":"778e0ac65d"};</script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/likebtn-like-button/public/js/frontend.js?ver=1d94575c28a52d529613e47620a53900'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/ultimate-member/assets/js/um-gdpr.min.js?ver=2.1.5'></script> <link rel='https://api.w.org/' href='https://www.caymancompass.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.caymancompass.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.caymancompass.com/wp-includes/wlwmanifest.xml" /><link rel='shortlink' href='https://www.caymancompass.com/?p=478569' /><link rel="alternate" type="application/json+oembed" href="https://www.caymancompass.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.caymancompass.com%2F2020%2F05%2F19%2Fdigicel-files-for-us-bankruptcy-protection%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.caymancompass.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.caymancompass.com%2F2020%2F05%2F19%2Fdigicel-files-for-us-bankruptcy-protection%2F&#038;format=xml" />  <script type="text/javascript">var _hsq = _hsq || [];
				_hsq.push(["setContentType", "blog-post"]);</script> <style type="text/css">.um_request_name {
				display: none !important;
			}</style><!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]--> <script>window.tdb_globals = {"wpRestNonce":"d5081d6846","wpRestUrl":"https:\/\/www.caymancompass.com\/wp-json\/","permalinkStructure":"\/%year%\/%monthnum%\/%day%\/%postname%\/","isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":50,"postAutoloadStatus":"off","origPostEditUrl":null};</script> <script>window.tdwGlobal = {"adminUrl":"https:\/\/www.caymancompass.com\/wp-admin\/","wpRestNonce":"d5081d6846","wpRestUrl":"https:\/\/www.caymancompass.com\/wp-json\/","permalinkStructure":"\/%year%\/%monthnum%\/%day%\/%postname%\/"};</script>  <script>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</script> <style>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</style> <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-PBNB99T');</script>  <script type="application/ld+json">{
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://www.caymancompass.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.caymancompass.com/category/business/",
                    "name": "Business"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.caymancompass.com/2020/05/19/digicel-files-for-us-bankruptcy-protection/",
                    "name": "Digicel files for US bankruptcy protection"                                
                }
            }    
        ]
    }</script> <style>.tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,
                .tds-button2 .tdm-btn-text,
                .tds-button2 i,
                .tds-button5:hover .tdm-btn-text,
                .tds-button5:hover i,
                .tds-button6 .tdm-btn-text,
                .tds-button6 i,
                .tdm_block_list .tdm-list-item i,
                .tdm_block_pricing .tdm-pricing-feature i,
                .tdm-social-item i {
                    color: #a0213f;
                }
                .tds-button1,
                .tds-button6:after,
                .tds-title2 .tdm-title-line:after,
                .tds-title3 .tdm-title-line:after,
                .tdm_block_pricing.tdm-pricing-featured:before,
                .tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,
                .tds-progress-bar1 .tdm-progress-bar:after,
                .tds-progress-bar2 .tdm-progress-bar:after,
                .tds-social3 .tdm-social-item {
                    background-color: #a0213f;
                }
                .tds-button2:before,
                .tds-button6:before,
                .tds-progress-bar3 .tdm-progress-bar:after {
                  border-color: #a0213f;
                }
                .tdm-btn-style1 {
					background-color: #a0213f;
				}
				.tdm-btn-style2:before {
				    border-color: #a0213f;
				}
				.tdm-btn-style2 {
				    color: #a0213f;
				}
				.tdm-btn-style3 {
				    -webkit-box-shadow: 0 2px 16px #a0213f;
                    -moz-box-shadow: 0 2px 16px #a0213f;
                    box-shadow: 0 2px 16px #a0213f;
				}
				.tdm-btn-style3:hover {
				    -webkit-box-shadow: 0 4px 26px #a0213f;
                    -moz-box-shadow: 0 4px 26px #a0213f;
                    box-shadow: 0 4px 26px #a0213f;
				}</style><style id="tdw-css-placeholder"></style><script data-cfasync="false" id="ao_optimized_gfonts_webfontloader">(function() {var wf = document.createElement('script');wf.src='https://ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';wf.type='text/javascript';wf.async='true';var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(wf, s);})();</script></head><body class="post-template-default single single-post postid-478569 single-format-standard td-standard-pack digicel-files-for-us-bankruptcy-protection global-block-template-16 cc single_template_5 white-menu td-animation-stack-type0 td-boxed-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage"><div class="td-scroll-up"><i class="td-icon-menu-up"></i></div><div class="td-menu-background"></div><div id="td-mobile-nav"><div class="td-mobile-container"><div class="td-menu-socials-wrap"><div class="td-menu-socials"> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.facebook.com/caycompass/" title="Facebook"> <i class="td-icon-font td-icon-facebook"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.instagram.com/cayman_compass/" title="Instagram"> <i class="td-icon-font td-icon-instagram"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://twitter.com/cayCompass" title="Twitter"> <i class="td-icon-font td-icon-twitter"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.youtube.com/user/caymancompas" title="Youtube"> <i class="td-icon-font td-icon-youtube"></i> </a> </span></div><div class="td-mobile-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div></div><div class="td-mobile-content"><div class="menu-main-menu-container"><ul id="menu-main-menu" class="td-mobile-main-menu"><li id="menu-item-187846" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first menu-item-187846"><a href="https://www.caymancompass.com/">Home</a></li><li id="menu-item-187847" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-187847"><a href="https://www.caymancompass.com/cayman-news/">News<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-471912" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-471912"><a href="https://www.caymancompass.com/issues/coronavirus-cayman/">Coronavirus (COVID-19) Cayman</a></li><li id="menu-item-187848" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-187848"><a href="https://www.caymancompass.com/cayman-news/">Cayman News</a></li><li id="menu-item-463399" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-463399"><a href="https://www.caymancompass.com/business/">Business</a></li><li id="menu-item-188240" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188240"><a href="https://www.caymancompass.com/crime-and-courts/">Crime and Courts</a></li><li id="menu-item-461693" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-461693"><a href="https://www.caymancompass.com/lifestyle/">Lifestyle</a></li><li id="menu-item-461689" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-461689"><a href="https://www.caymancompass.com/sports/">Sports</a></li><li id="menu-item-461691" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-461691"><a href="https://www.caymancompass.com/video/">Video</a></li><li id="menu-item-461692" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-461692"><a href="https://www.caymancompass.com/weather/">Weather</a></li><li id="menu-item-463093" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-463093"><a href="https://www.caymancompass.com/spotlight/">Spotlight and Features</a></li><li id="menu-item-467157" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-467157"><a href="https://www.caymancompass.com/podcasts/">Podcasts</a></li><li id="menu-item-464405" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-464405"><a href="https://www.caymancompass.com/interactive/">Interactive</a></li></ul></li><li id="menu-item-464189" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-464189"><a href="https://www.caymancompass.com/issues/">Issues<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-470185" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-470185"><a href="https://www.caymancompass.com/issues/coronavirus-cayman/">Coronavirus (COVID-19) Cayman</a></li><li id="menu-item-470131" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-470131"><a href="https://www.caymancompass.com/issues/climate-change/">Climate Change</a></li><li id="menu-item-466938" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-466938"><a href="https://www.caymancompass.com/issues/traffic/">Traffic</a></li><li id="menu-item-464188" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-464188"><a href="https://www.caymancompass.com/issues/founded-upon-the-seas/">Founded Upon the Seas</a></li><li id="menu-item-458002" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-458002"><a href="https://www.caymancompass.com/issues/port-vote-2019/">Port Vote 2019</a></li><li id="menu-item-458001" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-458001"><a href="https://www.caymancompass.com/issues/friday-features/">Friday Features</a></li><li id="menu-item-456066" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-456066"><a href="https://www.caymancompass.com/issues/sargassum/">Sargassum</a></li><li id="menu-item-471740" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-471740"><a href="https://www.caymancompass.com/issues/">All Issues Stories</a></li></ul></li><li id="menu-item-465716" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-465716"><a href="https://www.caymancompass.com/opinion/">Opinion<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-465705" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-465705"><a href="https://www.caymancompass.com/opinion/editoral/">Editorial</a></li><li id="menu-item-465695" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-465695"><a href="https://www.caymancompass.com/opinion/letters-to-the-editor/">Letters</a></li><li id="menu-item-465696" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-465696"><a href="https://www.caymancompass.com/opinion/columns/">Columns</a></li><li id="menu-item-461688" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-461688"><a href="https://www.caymancompass.com/cartoons/">Cartoons</a></li><li id="menu-item-188304" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188304"><a href="https://www.caymancompass.com/submit-letter-to-the-editor/">Write a Letter to the Editor</a></li></ul></li><li id="menu-item-188277" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-188277"><a href="/events/">Calendar<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-314306" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-314306"><a href="/events/">Event Listings</a></li><li id="menu-item-457157" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-457157"><a href="https://www.caymancompass.com/notices/">Notices</a></li><li id="menu-item-315091" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-315091"><a href="https://www.caymancompass.com/submit-event/">Submit an Event</a></li><li id="menu-item-463065" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-463065"><a href="https://www.caymancompass.com/cayman-islands-public-holidays-2020/">Cayman Islands Public Holidays 2020</a></li></ul></li><li id="menu-item-373520" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-373520"><a href="#">Our Brands<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-399126" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-399126"><a href="https://www.compassmedia.ky">All Publications</a></li><li id="menu-item-470176" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-470176"><a href="http://caymaniancompass.cay.newsmemory.com/?special=Careers">Careers Guide</a></li><li id="menu-item-466685" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-466685"><a href="https://www.caymancompass.com/wellness-feature/">Wellness Feature</a></li><li id="menu-item-460236" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-460236"><a href="https://www.caymancompass.com/women-in-business/">Women In Business</a></li><li id="menu-item-373529" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-373529"><a href="http://caymanhealth.com/">Cayman Health</a></li><li id="menu-item-373523" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-373523"><a href="http://www.flava.ky">Flava</a></li><li id="menu-item-450244" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-450244"><a href="http://caymaniancompass.cay.newsmemory.com/?special=Hurricane+Guide">Hurricane Guide 2019</a></li><li id="menu-item-373527" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-373527"><a href="http://www.insideoutcayman.com">Inside Out</a></li><li id="menu-item-188285" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188285"><a href="https://www.caymancompass.com/special-features-and-publications/">Special Features and Publications</a></li></ul></li><li id="menu-item-188276" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-188276"><a href="#">More<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-461690" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-461690"><a href="https://www.caymancompass.com/subscribe/">Subscribe to Newsletter</a></li><li id="menu-item-465825" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-465825"><a href="https://www.caymancompass.com/contact/">Contact</a></li><li id="menu-item-188275" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188275"><a href="https://www.caymancompass.com/contests/">Contests</a></li><li id="menu-item-465826" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-465826"><a href="https://www.caymancompass.com/view-eversion/">View the e-version of the current Friday edition of the Cayman Compass</a></li><li id="menu-item-188280" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188280"><a href="https://www.caymancompass.com/advertise-with-us/">Advertise With Us</a></li><li id="menu-item-371483" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-371483"><a target="_blank" href="https://www.caymancompass.com/wp-content/uploads/2019/12/Compass-Print-Media-Kit.pdf">Print Media Kit</a></li><li id="menu-item-389921" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-389921"><a href="https://www.caymancompass.com/wp-content/uploads/2020/05/CompassDigitalMediaKit-UpdatedInventory-2020b.pdf">Online Media Kit</a></li><li id="menu-item-359853" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-359853"><a href="https://www.caymancompass.com/editorial-staff/">Editorial Staff</a></li><li id="menu-item-188303" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188303"><a href="https://www.caymancompass.com/submit-a-story-idea/">Submit a Story Idea</a></li><li id="menu-item-374166" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-374166"><a href="https://www.caymancompass.com/online-subscriptions/">Online Subscriptions</a></li><li id="menu-item-471913" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-471913"><a href="https://www.caymancompass.com/newspaper-home-delivery/">Newspaper Home Delivery</a></li><li id="menu-item-188284" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-188284"><a href="https://www.caymancompass.com/privacy-policy/">Privacy Policy</a></li><li id="menu-item-188282" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188282"><a href="https://www.caymancompass.com/copyright-policy-2/">Copyright Policy</a></li><li id="menu-item-314305" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-314305"><a href="https://www.caymancompass.com/terms-of-use/">Terms and Conditions of Use</a></li><li id="menu-item-380233" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-380233"><a href="https://www.caymancompass.com/rss-feeds-information/">RSS Feed Information</a></li></ul></li></ul></div></div></div><div id="login-form-mobile" class="td-register-section"><div id="td-login-mob" class="td-login-animation td-login-hide-mob"><div class="td-login-close"> <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a><div class="td-login-title">Sign in</div><div class="td-mobile-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div></div><div class="td-login-form-wrap"><div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div><div class="td_display_err"></div><div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div><div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div> <input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN"><div class="td-login-info-text"> <a href="#" id="forgot-pass-link-mob">Forgot your password?</a></div><div class="td-login-register-link"> <a id="signin-register-link-mob" href="https://www.caymancompass.com/register/">Join</a></div><div class="td-login-info-text"><a class="privacy-policy-link" href="https://www.caymancompass.com/privacy-policy/">Privacy Policy</a></div></div></div><div id="td-register-mob" class="td-login-animation td-login-hide-mob"><div class="td-register-close"> <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a><div class="td-login-title">Sign up</div><div class="td-mobile-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div></div><div class="td-login-panel-title"><span>Redirecting...</div></div><div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob"><div class="td-forgot-pass-close"> <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a><div class="td-login-title">Password recovery</div></div><div class="td-login-form-wrap"><div class="td-login-panel-title">Recover your password</div><div class="td_display_err"></div><div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div> <input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass"></div></div></div></div><div class="td-search-background"></div><div class="td-search-wrap-mob"><div class="td-drop-down-search"><form method="get" class="td-search-form" action="https://www.caymancompass.com/"><div class="td-search-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div><div role="search" class="td-search-input"> <span>Search</span> <input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" /></div></form><div id="td-aj-search-mob" class="td-ajax-search-flex"></div></div></div><div id="td-outer-wrap" class="td-theme-wrap"><div class="tdc-header-wrap "><div class="td-header-wrap td-header-style-1 "><div class="td-header-top-menu-full td-container-wrap td_stretch_container"><div class="td-container td-header-row td-header-top-menu"><div class="top-bar-style-1"><div class="td-header-sp-top-menu"><div class="menu-top-container"><ul id="menu-top-menu" class="top-header-menu"><li id="menu-item-461694" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-461694"><a href="https://www.caymancompass.com/subscribe/">Subscribe</a></li><li id="menu-item-384346" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-384346"><a href="https://www.caymancompass.com/members/">Members</a><ul class="sub-menu"><li id="menu-item-384351" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-384351"><a href="https://www.caymancompass.com/login/">Login</a></li><li id="menu-item-384348" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-384348"><a href="https://www.caymancompass.com/password-reset/">Password Reset</a></li><li id="menu-item-384349" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-384349"><a href="https://www.caymancompass.com/register/">Register</a></li></ul></li><li id="menu-item-428186" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-428186"><a href="https://www.caymancompass.com/advertise-with-us/">Advertise</a></li><li id="menu-item-316348" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-316348"><a href="https://www.caymancompass.com/faq/">Help</a></li></ul></div></div><div class="td-header-sp-top-widget"> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.facebook.com/caycompass/" title="Facebook"> <i class="td-icon-font td-icon-facebook"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.instagram.com/cayman_compass/" title="Instagram"> <i class="td-icon-font td-icon-instagram"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://twitter.com/cayCompass" title="Twitter"> <i class="td-icon-font td-icon-twitter"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.youtube.com/user/caymancompas" title="Youtube"> <i class="td-icon-font td-icon-youtube"></i> </a> </span></div></div><div  id="login-form" class="white-popup-block mfp-hide mfp-with-anim"><div class="td-login-wrap"> <a href="#" class="td-back-button"><i class="td-icon-modal-back"></i></a><div id="td-login-div" class="td-login-form-div td-display-block"><div class="td-login-panel-title">Sign in</div><div class="td-login-panel-descr">Welcome. Log into your account</div><div class="td_display_err"></div><div class="mobile-facebook-login"style="margin-bottom: 10px;"><div class="um um-shortcode-social" id="um-shortcode-social-381831" style="padding:;margin:!important;"><div class="um-field"><div class="um-col-alt"><div  class="um-left um-half"> <a href="?oauthWindow=true&#038;provider=facebook&#038;um_sso=381831" title="Connect with Facebook"
 class="um-button um-alt um-button-social um-button-facebook" data-redirect-url="https://www.caymancompass.com/2020/05/19/digicel-files-for-us-bankruptcy-protection"  onclick="um_social_login_oauth_window( this.href,'authWindow', 'width=600,height=600,scrollbars=yes' );return false;"> <i class="um-faicon-facebook-square" style="margin-right: 8px;"></i> <span>Connect with Facebook</span> </a></div><div class="um-clear"></div></div></div><style type="text/css">div#um-shortcode-social-381831 div.um-field {padding: 0}

		div#um-shortcode-social-381831 a.um-button.um-button-social {
			font-size: 15px;
			padding: 16px 20px !important;
		}

		div#um-shortcode-social-381831 a.um-button.um-button-social i {
			font-size: 18px;
			width: 18px;
			top: auto;
			vertical-align: baseline !important;
			margin-right: 0;
		}

		
			div#um-shortcode-social-381831 div.um-field {margin:0 auto; max-width: 696px}

		
			div#um-shortcode-social-381831 a.um-button.um-button-facebook {background-color: #4267B2!important}
			div#um-shortcode-social-381831 a.um-button.um-button-facebook:hover {background-color: #365899!important}
			div#um-shortcode-social-381831 a.um-button.um-button-facebook {color: #fff!important}</style></div></div><div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email" value="" required><label>your username</label></div><div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" required><label>your password</label></div> <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login"><div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div> <a id="register-link" href="https://www.caymancompass.com/register/">Create an account</a><div class="td-login-info-text"><a class="privacy-policy-link" href="https://www.caymancompass.com/privacy-policy/">Privacy Policy</a></div></div><div id="td-register-div" class="td-login-form-div td-display-none"><div class="td-login-panel-title">Redirecting...</div></div><div id="td-forgot-pass-div" class="td-login-form-div td-display-none"><div class="td-login-panel-title">Password recovery</div><div class="td-login-panel-descr">Recover your password</div><div class="td_display_err"></div><div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label>your email</label></div> <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password"><div class="td-login-info-text">A password will be e-mailed to you.</div></div></div></div></div></div><div class="td-banner-wrap-full td-logo-wrap-full td-container-wrap td_stretch_container"><div class="td-container td-header-row td-header-header"><div class="td-header-sp-logo"> <a class="td-main-logo" href="https://www.caymancompass.com/"> <img class="td-retina-data" data-retina="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassLogoNew544x180.png" src="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassLogoNew-272x90.png" alt="Cayman Compass" title="The most trusted news source in the Cayman Islands"/> <span class="td-visual-hidden">Cayman Compass</span> </a></div><div class="td-header-sp-recs"><div class="td-header-rec-wrap"><div class="td-a-rec td-a-rec-id-header  tdi_1_15e td_block_template_16"><style>/* custom css */
.tdi_1_15e.td-a-rec{
					text-align: center;
				}.tdi_1_15e .td-element-style{
					z-index: -1;
				}.tdi_1_15e.td-a-rec-img{
				    text-align: left;
				}.tdi_1_15e.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_1_15e.td-a-rec-img {
				        text-align: center;
				    }
                }</style><div class="td-visible-all-devices">  <script type="text/javascript">if (!window.AdButler){(function(){var s = document.createElement("script"); s.async = true; s.type = "text/javascript";s.src = 'https://servedbyadbutler.com/app.js';var n = document.getElementsByTagName("script")[0]; n.parentNode.insertBefore(s, n);}());}</script> <script type="text/javascript">var AdButler = AdButler || {}; AdButler.ads = AdButler.ads || [];
var abkw = window.abkw || '';
var plc197225 = window.plc197225 || 0;
document.write('<'+'div id="placement_197225_'+plc197225+'"></'+'div>');
AdButler.ads.push({handler: function(opt){ AdButler.register(165413, 197225, [728,90], 'placement_197225_'+opt.place, opt); }, opt: { place: plc197225++, keywords: abkw, domain: 'servedbyadbutler.com', click:'CLICK_MACRO_PLACEHOLDER' }});</script> </div></div></div></div></div></div><div class="td-header-menu-wrap-full td-container-wrap td_stretch_container"><div class="td-header-menu-wrap td-header-gradient "><div class="td-container td-header-row td-header-main-menu"><div id="td-header-menu" role="navigation"><div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div><div class="td-main-menu-logo td-logo-in-header"> <a class="td-mobile-logo td-sticky-mobile" href="https://www.caymancompass.com/"> <img class="td-retina-data" data-retina="https://www.caymancompass.com/wp-content/uploads/2019/10/CaymanCompassLogoWhiteNew280x96.png" src="https://www.caymancompass.com/wp-content/uploads/2019/10/CaymanCompassLogoWhiteNew140x48.png" alt="Cayman Compass" title="The most trusted news source in the Cayman Islands"/> </a> <a class="td-header-logo td-sticky-mobile" href="https://www.caymancompass.com/"> <img class="td-retina-data" data-retina="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassLogoNew544x180.png" src="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassLogoNew-272x90.png" alt="Cayman Compass" title="The most trusted news source in the Cayman Islands"/> </a></div><div class="menu-main-menu-container"><ul id="menu-main-menu-1" class="sf-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-187846"><a href="https://www.caymancompass.com/">Home</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-187847"><a href="https://www.caymancompass.com/cayman-news/">News</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-471912"><a href="https://www.caymancompass.com/issues/coronavirus-cayman/">Coronavirus (COVID-19) Cayman</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-187848"><a href="https://www.caymancompass.com/cayman-news/">Cayman News</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-463399"><a href="https://www.caymancompass.com/business/">Business</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188240"><a href="https://www.caymancompass.com/crime-and-courts/">Crime and Courts</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-461693"><a href="https://www.caymancompass.com/lifestyle/">Lifestyle</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-461689"><a href="https://www.caymancompass.com/sports/">Sports</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-461691"><a href="https://www.caymancompass.com/video/">Video</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-461692"><a href="https://www.caymancompass.com/weather/">Weather</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-463093"><a href="https://www.caymancompass.com/spotlight/">Spotlight and Features</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-467157"><a href="https://www.caymancompass.com/podcasts/">Podcasts</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-464405"><a href="https://www.caymancompass.com/interactive/">Interactive</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-464189"><a href="https://www.caymancompass.com/issues/">Issues</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-470185"><a href="https://www.caymancompass.com/issues/coronavirus-cayman/">Coronavirus (COVID-19) Cayman</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-470131"><a href="https://www.caymancompass.com/issues/climate-change/">Climate Change</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-466938"><a href="https://www.caymancompass.com/issues/traffic/">Traffic</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-464188"><a href="https://www.caymancompass.com/issues/founded-upon-the-seas/">Founded Upon the Seas</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-458002"><a href="https://www.caymancompass.com/issues/port-vote-2019/">Port Vote 2019</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-458001"><a href="https://www.caymancompass.com/issues/friday-features/">Friday Features</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-456066"><a href="https://www.caymancompass.com/issues/sargassum/">Sargassum</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-471740"><a href="https://www.caymancompass.com/issues/">All Issues Stories</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-465716"><a href="https://www.caymancompass.com/opinion/">Opinion</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-465705"><a href="https://www.caymancompass.com/opinion/editoral/">Editorial</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-465695"><a href="https://www.caymancompass.com/opinion/letters-to-the-editor/">Letters</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-465696"><a href="https://www.caymancompass.com/opinion/columns/">Columns</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-461688"><a href="https://www.caymancompass.com/cartoons/">Cartoons</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188304"><a href="https://www.caymancompass.com/submit-letter-to-the-editor/">Write a Letter to the Editor</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-188277"><a href="/events/">Calendar</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-314306"><a href="/events/">Event Listings</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-457157"><a href="https://www.caymancompass.com/notices/">Notices</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-315091"><a href="https://www.caymancompass.com/submit-event/">Submit an Event</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-463065"><a href="https://www.caymancompass.com/cayman-islands-public-holidays-2020/">Cayman Islands Public Holidays 2020</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-373520"><a href="#">Our Brands</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-399126"><a href="https://www.compassmedia.ky">All Publications</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-470176"><a href="http://caymaniancompass.cay.newsmemory.com/?special=Careers">Careers Guide</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-466685"><a href="https://www.caymancompass.com/wellness-feature/">Wellness Feature</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-460236"><a href="https://www.caymancompass.com/women-in-business/">Women In Business</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-373529"><a href="http://caymanhealth.com/">Cayman Health</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-373523"><a href="http://www.flava.ky">Flava</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-450244"><a href="http://caymaniancompass.cay.newsmemory.com/?special=Hurricane+Guide">Hurricane Guide 2019</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-373527"><a href="http://www.insideoutcayman.com">Inside Out</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188285"><a href="https://www.caymancompass.com/special-features-and-publications/">Special Features and Publications</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-188276"><a href="#">More</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-461690"><a href="https://www.caymancompass.com/subscribe/">Subscribe to Newsletter</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-465825"><a href="https://www.caymancompass.com/contact/">Contact</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188275"><a href="https://www.caymancompass.com/contests/">Contests</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-465826"><a href="https://www.caymancompass.com/view-eversion/">View the e-version of the current Friday edition of the Cayman Compass</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188280"><a href="https://www.caymancompass.com/advertise-with-us/">Advertise With Us</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-371483"><a target="_blank" href="https://www.caymancompass.com/wp-content/uploads/2019/12/Compass-Print-Media-Kit.pdf">Print Media Kit</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-389921"><a href="https://www.caymancompass.com/wp-content/uploads/2020/05/CompassDigitalMediaKit-UpdatedInventory-2020b.pdf">Online Media Kit</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-359853"><a href="https://www.caymancompass.com/editorial-staff/">Editorial Staff</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188303"><a href="https://www.caymancompass.com/submit-a-story-idea/">Submit a Story Idea</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-374166"><a href="https://www.caymancompass.com/online-subscriptions/">Online Subscriptions</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-471913"><a href="https://www.caymancompass.com/newspaper-home-delivery/">Newspaper Home Delivery</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy td-menu-item td-normal-menu menu-item-188284"><a href="https://www.caymancompass.com/privacy-policy/">Privacy Policy</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188282"><a href="https://www.caymancompass.com/copyright-policy-2/">Copyright Policy</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-314305"><a href="https://www.caymancompass.com/terms-of-use/">Terms and Conditions of Use</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-380233"><a href="https://www.caymancompass.com/rss-feeds-information/">RSS Feed Information</a></li></ul></li></ul></div></div><div class="header-search-wrap"><div class="td-search-btns-wrap"> <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a> <a id="td-header-search-button-mob" href="#" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a></div><div class="td-drop-down-search" aria-labelledby="td-header-search-button"><form method="get" class="td-search-form" action="https://www.caymancompass.com/"><div role="search" class="td-head-form-search-wrap"> <input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" /></div></form><div id="td-aj-search"></div></div></div></div></div></div></div></div><div class="td-main-content-wrap td-container-wrap"><div class="td-container td-post-template-5 "><div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://www.caymancompass.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Business" class="entry-crumb" href="https://www.caymancompass.com/category/business/">Business</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Digicel files for US bankruptcy protection</span></div></div><div class="td-pb-row"><div class="td-pb-span8 td-main-content" role="main"><div class="td-ss-main-content"><article id="post-478569" class="post-478569 post type-post status-publish format-standard has-post-thumbnail category-business tag-debt tag-digicel tag-u-s-bankruptcy-court" itemscope itemtype="https://schema.org/Article"><div class="td-post-header"><ul class="td-category"><li class="entry-category"><a  href="https://www.caymancompass.com/category/business/">Business</a></li></ul><header class="td-post-title"><h1 class="entry-title">Digicel files for US bankruptcy protection</h1><p class="td-post-sub-title">Says decision will have 'no effect' on day-to-day operations</p><div class="td-module-meta-info"><div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://www.caymancompass.com/author/mklein/">Michael Klein</a><div class="td-author-line"> -</div></div> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-05-19T12:57:33-05:00" >May 19, 2020</time></span></div></header></div><div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-bg td-ps-notext td-ps-rounded td-post-sharing-style3 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.caymancompass.com%2F2020%2F05%2F19%2Fdigicel-files-for-us-bankruptcy-protection%2F"><div class="td-social-but-icon"><i class="td-icon-facebook"></i></div><div class="td-social-but-text">Facebook</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Digicel+files+for+US+bankruptcy+protection&url=https%3A%2F%2Fwww.caymancompass.com%2F2020%2F05%2F19%2Fdigicel-files-for-us-bankruptcy-protection%2F&via=cayCompass"><div class="td-social-but-icon"><i class="td-icon-twitter"></i></div><div class="td-social-but-text">Twitter</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=Digicel+files+for+US+bankruptcy+protection %0A%0A https://www.caymancompass.com/2020/05/19/digicel-files-for-us-bankruptcy-protection/"><div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div><div class="td-social-but-text">WhatsApp</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="/cdn-cgi/l/email-protection#2f105c5a4d454a4c5b126b4648464c4a430f4946434a5c0f49405d0f7a7c0f4d4e41445d5a5f5b4c560f5f5d405b4a4c5b464041094d404b5612475b5b5f5c150000585858014c4e56424e414c40425f4e5c5c014c4042001d1f1d1f001f1a001e16004b4648464c4a43024946434a5c0249405d025a5c024d4e41445d5a5f5b4c56025f5d405b4a4c5b46404100"><div class="td-social-but-icon"><i class="td-icon-mail"></i></div><div class="td-social-but-text">Email</div> </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top"><div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div> </a></div></div></div><div class="td-post-content tagdiv-type"><div class="td-a-rec td-a-rec-id-content_top  tdi_3_547 td_block_template_16"><style>/* custom css */
.tdi_3_547.td-a-rec{
					text-align: center;
				}.tdi_3_547 .td-element-style{
					z-index: -1;
				}.tdi_3_547.td-a-rec-img{
				    text-align: left;
				}.tdi_3_547.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_3_547.td-a-rec-img {
				        text-align: center;
				    }
                }</style><div id="isb_phone_advert" class="td-visible-phone">  <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">var elem = document.getElementById("isb_phone_advert");
var theCSSprop = window.getComputedStyle(elem,null).getPropertyValue("display");
if (theCSSprop!="none"){


var rnd = window.rnd || Math.floor(Math.random()*10e6);
var pid420687 = window.pid420687 || rnd;
var plc420687 = window.plc420687 || 0;
var abkw = window.abkw || '';
var absrc = 'https://servedbyadbutler.com/adserve/;ID=165413;size=0x0;setID=420687;type=js;sw='+screen.width+';sh='+screen.height+';spr='+window.devicePixelRatio+';kw='+abkw+';pid='+pid420687+';place='+(plc420687++)+';rnd='+rnd+';click=CLICK_MACRO_PLACEHOLDER';
document.write('<scr'+'ipt src="'+absrc+'" type="text/javascript"></scr'+'ipt>');

}else{
}</script> </div></div><p>Telecommunications provider Digicel has filed for Chapter 15 recognition in a federal bankruptcy court in the Southern District of New York after it was granted an application for provisional liquidation in Bermuda.</p><p>The filing by Digicel Group One Limited, a Bermudian non-operating intermediate holding company within Digicel Group, is part of a debt restructuring.</p><p>Digicel said the decision to liquidate one of its affiliates will have no effect on day-to-day operations.</p><p>The group had a total outstanding debt of $7.4 billion at the end of the third quarter of 2019. About $1 billion in debt is due to mature next year and about $4 billion by 2024.</p><p>For the financial year ending March 2019, Digicel’s annual turnover was reported as $2.3 billion with an operating profit of $479 million, according to the financial statements submitted to the court.</p><div class="td-a-rec td-a-rec-id-content_inline  tdi_2_3cb td_block_template_16"><style>/* custom css */
.tdi_2_3cb.td-a-rec{
					text-align: center;
				}.tdi_2_3cb .td-element-style{
					z-index: -1;
				}.tdi_2_3cb.td-a-rec-img{
				    text-align: left;
				}.tdi_2_3cb.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_2_3cb.td-a-rec-img {
				        text-align: center;
				    }
                }</style><div class="td-all-devices in-article-lb-ad">  <script type="text/javascript">var rnd = window.rnd || Math.floor(Math.random()*10e6);
var pid420688 = window.pid420688 || rnd;
var plc420688 = window.plc420688 || 0;
var abkw = window.abkw || '';
var absrc = 'https://servedbyadbutler.com/adserve/;ID=165413;size=0x0;setID=420688;type=js;sw='+screen.width+';sh='+screen.height+';spr='+window.devicePixelRatio+';kw='+abkw+';pid='+pid420688+';place='+(plc420688++)+';rnd='+rnd+';click=CLICK_MACRO_PLACEHOLDER';
document.write('<scr'+'ipt src="'+absrc+'" type="text/javascript"></scr'+'ipt>');</script> </div></div><p>Recently, Digicel’s debt-financing costs have increased significantly as the group faced declining revenues in key markets, such as Haiti, Jamaica and the French West Indies.</p><p>Like other telecommunications providers, Digicel has seen a reduction in voice call revenues as a result of new data services. But revenue growth from these data and other services, like business solution, broadband and cable, has not been enough to offset the decline.</p><p>The expansion of these services also required significant capital expenditures, which reduced Digicel’s ability to generate operating free cash flow and lower its finance costs.</p><p>“As a result, the Group finds itself with unsustainable levels of indebtedness,” the court filing stated.</p><p>In the six months ending at the end of September 2019, the group’s finance costs increased by $51.4 million, or 19.7%, to $312.9 million, compared to the same period a year earlier.</p><p>“In the face of near-term maturities, increasing finance costs and widening losses, the Group determined that there was a need for a comprehensive restructuring of its capital structure that would reduce aggregate liabilities, improve its liquidity profile and provide flexibility for the Group to access further capital in the future to fund its businesses,” the court filing said.</p><p>Earlier this year, Digicel entered into discussions with a group of holders of various bonds with a principal amount of about $1.51 billion to manage the maturity and interest expense of the debt and better manage cashflow.</p><p>This resulted in a Lockup and Support Agreement under which the debt holders tender their existing notes in exchange for new debt with longer maturities and different payment terms.</p><p>In a press statement, Digicel said the refinancing would reduce the company’s debt by $1.7 billion, extend debt maturities and lower ongoing financing costs.</p><p>“Following overwhelming support from our debtholders for these proposals, we are now progressing with the required administrative processes,” Digicel said.</p><p>This included a scheme of arrangement submitted to the Bermudian courts as well as the appointment of “light touch” provisional liquidators to oversee the scheme.</p><p>The US court filing, published by <em>Offshore Alert</em>, stated the recognition of the scheme as a foreign main proceeding under chapter 15 of the US Bankruptcy Code is necessary to ensure that scheme creditors are treated consistently, that the Bermuda Court’s sanction of the scheme is enforceable in the US, and that the company and its property are protected from seizure or lawsuits in the US.</p><p>In its press statement, Digicel said, “It’s important to point out that this will have no impact on our day to day operations, our staff, our suppliers, our customers or any aspect of our ongoing activities – it is business as usual.”</p><div class="likebtn_container" style="clear:both;"><span class="likebtn-wrapper"  data-identifier="post_478569"  data-site_id="5a6f97366fd08b0f18563396"  data-theme="custom"  data-icon_l="thmb4-u"  data-icon_d="thmb4-d"  data-icon_size="24"  data-icon_l_c_v="#00aeef"  data-icon_d_c_v="#00aeef"  data-counter_l_c="#222222"  data-counter_d_c="#222222"  data-bg_c="rgba(250,250,250,0)"  data-bg_c_v="rgba(250,250,250,0)"  data-brdr_c="rgba(255,255,255,0)"  data-f_size="14"  data-f_family="Georgia"  data-counter_fs="b"  data-show_like_label="false"  data-share_enabled="false"  data-voting_cancelable="false"  data-tooltip_enabled="false"  data-white_label="true"  data-popup_disabled="true"  data-style=""  data-unlike_allowed=""  data-show_copyright=""  data-item_url="https://www.caymancompass.com/2020/05/19/digicel-files-for-us-bankruptcy-protection/"  data-item_title="Digicel files for US bankruptcy protection"  data-item_image="https://www.caymancompass.com/wp-content/uploads/2020/05/Digicel.jpg"  data-item_date="2020-05-19T12:57:33-05:00"  data-engine="WordPress"  data-plugin_v="2.6.25"  data-prx="https://www.caymancompass.com/wp-admin/admin-ajax.php?action=likebtn_prx"  data-event_handler="likebtn_eh" ></span></div><div class="td-a-rec td-a-rec-id-content_bottom  tdi_4_c41 td_block_template_16"><style>/* custom css */
.tdi_4_c41.td-a-rec{
					text-align: center;
				}.tdi_4_c41 .td-element-style{
					z-index: -1;
				}.tdi_4_c41.td-a-rec-img{
				    text-align: left;
				}.tdi_4_c41.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_4_c41.td-a-rec-img {
				        text-align: center;
				    }
                }</style><div class="td-all-devices">  <script type="text/javascript">var rnd = window.rnd || Math.floor(Math.random()*10e6);
var pid421033 = window.pid421033 || rnd;
var plc421033 = window.plc421033 || 0;
var abkw = window.abkw || '';
var absrc = 'https://servedbyadbutler.com/adserve/;ID=165413;size=0x0;setID=421033;type=js;sw='+screen.width+';sh='+screen.height+';spr='+window.devicePixelRatio+';kw='+abkw+';pid='+pid421033+';place='+(plc421033++)+';rnd='+rnd+';click=CLICK_MACRO_PLACEHOLDER';
document.write('<scr'+'ipt src="'+absrc+'" type="text/javascript"></scr'+'ipt>');</script> </div><div style="background-color: #fffcbb; padding: 20px 20px 10px 20px; margin-top:30px; border: 1px solid #999; border-radius: 3px;"><p style="margin-bottom: 10px;">If you value our service, if you have turned to us in the past few days or weeks for verified, factual updates, if you have watched our live streaming of press conferences or sent an article to a friend... please consider a donation. Quality local journalism was at risk before the coronavirus crisis. It is now deeply threatened. Even a small amount can go a long way to sustaining our mission of informing the public. We need our readers’ financial support now more than ever.</p><h4 style="text-align: center; margin-top: 0 !important;"><a href="https://www.caymancompass.com/donate"><span class="td_btn td_btn_md td_outlined_btn" style="border-color: #e00606; color: #e00606;">Donate</span></a></h4></div></div></div><footer><div class="td-post-source-tags"><ul class="td-tags td-post-small-box clearfix"><li><span>Topics</span></li><li><a href="https://www.caymancompass.com/tag/debt/">debt</a></li><li><a href="https://www.caymancompass.com/tag/digicel/">Digicel</a></li><li><a href="https://www.caymancompass.com/tag/u-s-bankruptcy-court/">U.S. Bankruptcy Court</a></li></ul></div><div class="td-post-sharing-bottom"><div class="td-post-sharing-classic"><iframe frameBorder="0" src="https://www.facebook.com/plugins/like.php?href=https://www.caymancompass.com/2020/05/19/digicel-files-for-us-bankruptcy-protection/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:auto; height:21px; background-color:transparent;"></iframe></div><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-ps-rounded td-post-sharing-style3 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.caymancompass.com%2F2020%2F05%2F19%2Fdigicel-files-for-us-bankruptcy-protection%2F"><div class="td-social-but-icon"><i class="td-icon-facebook"></i></div><div class="td-social-but-text">Facebook</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Digicel+files+for+US+bankruptcy+protection&url=https%3A%2F%2Fwww.caymancompass.com%2F2020%2F05%2F19%2Fdigicel-files-for-us-bankruptcy-protection%2F&via=cayCompass"><div class="td-social-but-icon"><i class="td-icon-twitter"></i></div><div class="td-social-but-text">Twitter</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=Digicel+files+for+US+bankruptcy+protection %0A%0A https://www.caymancompass.com/2020/05/19/digicel-files-for-us-bankruptcy-protection/"><div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div><div class="td-social-but-text">WhatsApp</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="/cdn-cgi/l/email-protection#86b9f5f3e4ece3e5f2bbc2efe1efe5e3eaa6e0efeae3f5a6e0e9f4a6d3d5a6e4e7e8edf4f3f6f2e5ffa6f6f4e9f2e3e5f2efe9e8a0e4e9e2ffbbeef2f2f6f5bca9a9f1f1f1a8e5e7ffebe7e8e5e9ebf6e7f5f5a8e5e9eba9b4b6b4b6a9b6b3a9b7bfa9e2efe1efe5e3eaabe0efeae3f5abe0e9f4abf3f5abe4e7e8edf4f3f6f2e5ffabf6f4e9f2e3e5f2efe9e8a9"><div class="td-social-but-icon"><i class="td-icon-mail"></i></div><div class="td-social-but-text">Email</div> </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom"><div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div> </a></div></div></div><div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://www.caymancompass.com/2020/05/19/two-northward-inmates-test-positive-for-covid-19/">Two Northward inmates test positive for COVID-19</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="https://www.caymancompass.com/2020/05/19/local-animal-charities-worried-about-spike-in-abandoned-pets/">Local animal charities worried about spike in abandoned pets</a></div></div></div><div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="https://www.caymancompass.com/author/mklein/">Michael Klein</a></span></div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Michael Klein"></span><meta itemprop="datePublished" content="2020-05-19T12:57:33-05:00"><meta itemprop="dateModified" content="2020-05-19T12:57:33-05:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.caymancompass.com/2020/05/19/digicel-files-for-us-bankruptcy-protection/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassLogoNew-272x90.png"></span><meta itemprop="name" content="Cayman Compass"></span><meta itemprop="headline " content="Digicel files for US bankruptcy protection"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.caymancompass.com/wp-content/uploads/2020/05/Digicel.jpg"><meta itemprop="width" content="1024"><meta itemprop="height" content="1024"></span></footer></article><div class="td_block_wrap td_block_related_posts tdi_5_e7c td_with_ajax_pagination td-pb-border-top td_block_template_16"  data-td-block-uid="tdi_5_e7c" ><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>var block_tdi_5_e7c = new tdBlock();
block_tdi_5_e7c.id = "tdi_5_e7c";
block_tdi_5_e7c.atts = '{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"tdi_5_e7c","td_column_number":3,"live_filter_cur_post_id":478569,"live_filter_cur_post_author":"9","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"tdi_5_e7c","tdc_css_class_style":"tdi_5_e7c_rand_style"}';
block_tdi_5_e7c.td_column_number = "3";
block_tdi_5_e7c.block_type = "td_block_related_posts";
block_tdi_5_e7c.post_count = "3";
block_tdi_5_e7c.found_posts = "6186";
block_tdi_5_e7c.header_color = "";
block_tdi_5_e7c.ajax_pagination_infinite_stop = "";
block_tdi_5_e7c.max_num_pages = "2062";
tdBlocksArray.push(block_tdi_5_e7c);</script><h4 class="td-related-title td-block-title"><a id="tdi_6_b3a" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="tdi_5_e7c" href="#">Related articles</a><a id="tdi_7_03b" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="tdi_5_e7c" href="#">More from author</a></h4><div id=tdi_5_e7c class="td_block_inner"><div class="td-related-row"><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.caymancompass.com/2020/05/19/britcay-asks-for-patience-with-pension-withdrawals/" rel="bookmark" class="td-image-wrap " title="BritCay asks for patience with pension withdrawals" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="BritCay asks for patience with pension withdrawals" data-type="image_tag" data-img-url="https://www.caymancompass.com/wp-content/uploads/2018/10/Britcay-Building-1-Read-Only-218x150.gif"  width="218" height="150" /></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.caymancompass.com/2020/05/19/britcay-asks-for-patience-with-pension-withdrawals/" rel="bookmark" title="BritCay asks for patience with pension withdrawals">BritCay asks for patience with pension withdrawals</a></h3></div></div></div><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.caymancompass.com/2020/05/19/business-in-brief-184/" rel="bookmark" class="td-image-wrap " title="Business in brief" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Business in brief" data-type="image_tag" data-img-url="https://www.caymancompass.com/wp-content/uploads/2020/05/Ann-Alecia-Moore-218x150.jpg"  width="218" height="150" /></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.caymancompass.com/2020/05/19/business-in-brief-184/" rel="bookmark" title="Business in brief">Business in brief</a></h3></div></div></div><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.caymancompass.com/2020/05/14/economics-in-the-time-of-covid/" rel="bookmark" class="td-image-wrap " title="Economics in the time of COVID" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Economics in the time of COVID" data-type="image_tag" data-img-url="https://www.caymancompass.com/wp-content/uploads/2020/05/healthcare-team-2-e1589511264338-218x150.jpeg"  width="218" height="150" /></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.caymancompass.com/2020/05/14/economics-in-the-time-of-covid/" rel="bookmark" title="Economics in the time of COVID">Economics in the time of COVID</a></h3></div></div></div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_5_e7c" data-td_block_id="tdi_5_e7c"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-tdi_5_e7c" data-td_block_id="tdi_5_e7c"><i class="td-icon-font td-icon-menu-right"></i></a></div></div><div class="comments" id="comments"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/05/19/digicel-files-for-us-bankruptcy-protection/#respond" style="display:none;">Cancel reply</a></small></h3><p class="must-log-in td-login-comment"><a class="td-login-modal-js" data-effect="mpf-td-login-effect" href="#login-form">Log in to leave a comment </a></p></div></div></div></div><div class="td-pb-span4 td-main-sidebar" role="complementary"><div class="td-ss-main-sidebar"><div class="td-a-rec td-a-rec-id-sidebar  tdi_8_a71 td_block_template_16"><style>/* custom css */
.tdi_8_a71.td-a-rec{
					text-align: center;
				}.tdi_8_a71 .td-element-style{
					z-index: -1;
				}.tdi_8_a71.td-a-rec-img{
				    text-align: left;
				}.tdi_8_a71.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_8_a71.td-a-rec-img {
				        text-align: center;
				    }
                }</style><div id="isb_desktop_advert" class="td-visible-desktop sidebar-ad-compass-fix">  <script type="text/javascript">var elem = document.getElementById("isb_desktop_advert");
var theCSSprop = window.getComputedStyle(elem,null).getPropertyValue("display");

if (theCSSprop!="none"){


var rnd = window.rnd || Math.floor(Math.random()*10e6);
var pid420687 = window.pid420687 || rnd;
var plc420687 = window.plc420687 || 0;
var abkw = window.abkw || '';
var absrc = 'https://servedbyadbutler.com/adserve/;ID=165413;size=0x0;setID=420687;type=js;sw='+screen.width+';sh='+screen.height+';spr='+window.devicePixelRatio+';kw='+abkw+';pid='+pid420687+';place='+(plc420687++)+';rnd='+rnd+';click=CLICK_MACRO_PLACEHOLDER';
document.write('<scr'+'ipt src="'+absrc+'" type="text/javascript"></scr'+'ipt>');

}else{
}</script> </div><div id="isb_tablet_portrait_advert" class="td-visible-tablet-portrait sidebar-ad-compass-fix">  <script type="text/javascript">var elem = document.getElementById("isb_tablet_portrait_advert");
var theCSSprop = window.getComputedStyle(elem,null).getPropertyValue("display");
if (theCSSprop!="none"){


var rnd = window.rnd || Math.floor(Math.random()*10e6);
var pid420687 = window.pid420687 || rnd;
var plc420687 = window.plc420687 || 0;
var abkw = window.abkw || '';
var absrc = 'https://servedbyadbutler.com/adserve/;ID=165413;size=0x0;setID=420687;type=js;sw='+screen.width+';sh='+screen.height+';spr='+window.devicePixelRatio+';kw='+abkw+';pid='+pid420687+';place='+(plc420687++)+';rnd='+rnd+';click=CLICK_MACRO_PLACEHOLDER';
document.write('<scr'+'ipt src="'+absrc+'" type="text/javascript"></scr'+'ipt>');


}else{

}</script> </div><div id="isb_tablet_landscape_advert" class="td-visible-tablet-landscape sidebar-ad-compass-fix">  <script type="text/javascript">var elem = document.getElementById("isb_tablet_landscape_advert");
var theCSSprop = window.getComputedStyle(elem,null).getPropertyValue("display");
if (theCSSprop!="none"){


var rnd = window.rnd || Math.floor(Math.random()*10e6);
var pid420687 = window.pid420687 || rnd;
var plc420687 = window.plc420687 || 0;
var abkw = window.abkw || '';
var absrc = 'https://servedbyadbutler.com/adserve/;ID=165413;size=0x0;setID=420687;type=js;sw='+screen.width+';sh='+screen.height+';spr='+window.devicePixelRatio+';kw='+abkw+';pid='+pid420687+';place='+(plc420687++)+';rnd='+rnd+';click=CLICK_MACRO_PLACEHOLDER';
document.write('<scr'+'ipt src="'+absrc+'" type="text/javascript"></scr'+'ipt>');

}else{
}</script> </div></div><aside id="text-6" class="td_block_template_16 widget text-6 widget_text"><div class="textwidget"><div class="td_block_social_counter newsletter-addon newsletter-sidebar"><div class="td_social_type td-pb-margin-side td-social-newsletter"><div class="td-social-box"><div class="td-sp td-sp-newsletter"><i class="td-icon-mail"></i></div><span class="td_social_button"><a href="https://www.caymancompass.com/subscribe/" target="_blank" rel="noopener noreferrer">SUBSCRIBE TO<span class="sublongtext"> THE COMPASS</span> NEWSLETTER</a></span></div></div></div></div></aside><div class="td_block_wrap td_block_7 td_block_widget tdi_9_3a4 td_with_ajax_pagination td-pb-border-top td_block_template_16 td-column-1 td_block_padding"  data-td-block-uid="tdi_9_3a4" ><script>var block_tdi_9_3a4 = new tdBlock();
block_tdi_9_3a4.id = "tdi_9_3a4";
block_tdi_9_3a4.atts = '{"custom_title":"This week","custom_url":"","block_template_id":"","header_text_color":"#","border_color":"#","accent_text_color":"#","m6_tl":"","limit":"3","offset":"","el_class":"","post_ids":"","category_id":"","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","sort":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"next_prev","ajax_pagination_infinite_stop":"","class":"td_block_widget tdi_9_3a4","separator":"","show_modified_date":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m6f_title_font_header":"","m6f_title_font_title":"Article title","m6f_title_font_settings":"","m6f_title_font_family":"","m6f_title_font_size":"","m6f_title_font_line_height":"","m6f_title_font_style":"","m6f_title_font_weight":"","m6f_title_font_transform":"","m6f_title_font_spacing":"","m6f_title_":"","m6f_cat_font_title":"Article category tag","m6f_cat_font_settings":"","m6f_cat_font_family":"","m6f_cat_font_size":"","m6f_cat_font_line_height":"","m6f_cat_font_style":"","m6f_cat_font_weight":"","m6f_cat_font_transform":"","m6f_cat_font_spacing":"","m6f_cat_":"","m6f_meta_font_title":"Article meta info","m6f_meta_font_settings":"","m6f_meta_font_family":"","m6f_meta_font_size":"","m6f_meta_font_line_height":"","m6f_meta_font_style":"","m6f_meta_font_weight":"","m6f_meta_font_transform":"","m6f_meta_font_spacing":"","m6f_meta_":"","css":"","tdc_css":"","td_column_number":1,"header_color":"","color_preset":"","border_top":"","tdc_css_class":"tdi_9_3a4","tdc_css_class_style":"tdi_9_3a4_rand_style"}';
block_tdi_9_3a4.td_column_number = "1";
block_tdi_9_3a4.block_type = "td_block_7";
block_tdi_9_3a4.post_count = "3";
block_tdi_9_3a4.found_posts = "88708";
block_tdi_9_3a4.header_color = "";
block_tdi_9_3a4.ajax_pagination_infinite_stop = "";
block_tdi_9_3a4.max_num_pages = "29570";
tdBlocksArray.push(block_tdi_9_3a4);</script><div class="td-block-title-wrap"><h4 class="td-block-title"><span class="td-pulldown-size">This week</span></h4></div><div id=tdi_9_3a4 class="td_block_inner"><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.caymancompass.com/2020/05/19/17-new-covid-19-cases-reported-as-restrictions-rolled-back/" rel="bookmark" class="td-image-wrap " title="17 new COVID-19 cases reported as restrictions rolled back" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" alt="" title="17 new COVID-19 cases reported as restrictions rolled back" data-type="image_tag" data-img-url="https://www.caymancompass.com/wp-content/uploads/2020/05/DSC_1225-100x70.jpg"  width="100" height="70" /></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.caymancompass.com/2020/05/19/17-new-covid-19-cases-reported-as-restrictions-rolled-back/" rel="bookmark" title="17 new COVID-19 cases reported as restrictions rolled back">17 new COVID-19 cases reported as restrictions rolled back</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-05-19T14:26:49-05:00" >May 19, 2020</time></span></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.caymancompass.com/2020/05/19/local-animal-charities-worried-about-spike-in-abandoned-pets/" rel="bookmark" class="td-image-wrap " title="Local animal charities worried about spike in abandoned pets" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" alt="" title="Local animal charities worried about spike in abandoned pets" data-type="image_tag" data-img-url="https://www.caymancompass.com/wp-content/uploads/2020/05/Riggs-in-the-yard-100x70.jpeg"  width="100" height="70" /></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.caymancompass.com/2020/05/19/local-animal-charities-worried-about-spike-in-abandoned-pets/" rel="bookmark" title="Local animal charities worried about spike in abandoned pets">Local animal charities worried about spike in abandoned pets</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-05-19T13:22:40-05:00" >May 19, 2020</time></span></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.caymancompass.com/2020/05/19/digicel-files-for-us-bankruptcy-protection/" rel="bookmark" class="td-image-wrap " title="Digicel files for US bankruptcy protection" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" alt="" title="Digicel files for US bankruptcy protection" data-type="image_tag" data-img-url="https://www.caymancompass.com/wp-content/uploads/2020/05/Digicel-100x70.jpg"  width="100" height="70" /></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.caymancompass.com/2020/05/19/digicel-files-for-us-bankruptcy-protection/" rel="bookmark" title="Digicel files for US bankruptcy protection">Digicel files for US bankruptcy protection</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-05-19T12:57:33-05:00" >May 19, 2020</time></span></div></div></div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_9_3a4" data-td_block_id="tdi_9_3a4"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-tdi_9_3a4" data-td_block_id="tdi_9_3a4"><i class="td-icon-font td-icon-menu-right"></i></a></div></div></div></div></div></div></div><div class="tdc-footer-wrap "><div class="td-footer-wrapper td-footer-container td-container-wrap td_stretch_container"><div class="td-container"><div class="td-pb-row"><div class="td-pb-span12"></div></div><div class="td-pb-row"><div class="td-pb-span12"><aside class="widget_text td_block_template_16 widget widget_custom_html"><div class="textwidget custom-html-widget"><style>.compass-media-footer-links {
	font-family: 'Open Sans', Arial, Helvetica, sans-serif !important;
	color: #fff !important;
	width: 100%;
	text-align: center;
}
.compass-media-footer-heading {
	width: 100%;
	text-align: center;
    border-bottom: 1px solid #fff; 
    line-height: 1px;
    margin: 10px 0 20px; 
}
.compass-media-footer-heading span {
	padding: 0 20px;
	background-color: #0e1523; 
	font-weight: bold;
    font-family: 'Open Sans', Arial, Helvetica, sans-serif !important;
	font-size: 10px;
}
.compass-media-footer-links a, .compass-media-footer-heading a {
  color: #fff !important;
  text-decoration: none;
}
.compass-link-item {
  display: inline-block;
  vertical-align: top;
  width: 10%;
  min-width: 93px;
  margin-bottom: 20px;
}
.compass-link-icon {
	width: 60px;
	height: 60px;
	margin: 0 auto;
}
.compass-link-text h6 {
  text-align: center;
  text-transform: uppercase;
  font-size: 9px !important;
  margin: 0;
  color: #fff !important;
  line-height: 10px !important;
}
.sprite-compass-media-icon-christmas-catalog, .sprite-compass-media-icon-christmascatalog, .sprite-compass-media-icon-whot, .sprite-compass-media-icon-cfr, .sprite-compass-media-icon-compass, 
.sprite-compass-media-icon-flava, .sprite-compass-media-icon-gcm, .sprite-compass-media-icon-health, .sprite-compass-media-icon-insideout, .sprite-compass-media-icon-journal, 
.sprite-compass-media-icon-keytocayman, .sprite-compass-media-icon-map
{ display: inline-block; background: url('/wp-content/uploads/footer-icons/footer-icons.png') no-repeat; overflow: hidden; text-indent: -9999px; text-align: left; }
 
.sprite-compass-media-icon-christmas-catalog { background-position: -10px -0px; width: 50px; height: 50px; }
.sprite-compass-media-icon-christmascatalog { background-position: -70px -0px; width: 50px; height: 50px; }
.sprite-compass-media-icon-whot { background-position: -130px -0px; width: 50px; height: 50px; }
.sprite-compass-media-icon-cfr { background-position: -10px -60px; width: 50px; height: 50px; }
.sprite-compass-media-icon-compass { background-position: -70px -60px; width: 50px; height: 50px; }
.sprite-compass-media-icon-flava { background-position: -130px -60px; width: 50px; height: 50px; }
.sprite-compass-media-icon-gcm { background-position: -10px -120px; width: 50px; height: 50px; }
.sprite-compass-media-icon-health { background-position: -70px -120px; width: 50px; height: 50px; }
.sprite-compass-media-icon-insideout { background-position: -130px -120px; width: 50px; height: 50px; }
.sprite-compass-media-icon-journal { background-position: -10px -180px; width: 50px; height: 50px; }
.sprite-compass-media-icon-keytocayman { background-position: -70px -180px; width: 50px; height: 50px; }
.sprite-compass-media-icon-map { background-position: -130px -180px; width: 50px; height: 50px; }</style><div class="compass-media-footer-links"><div class="compass-links-heading-container"><h6 class="compass-media-footer-heading"><a href="https://www.compassmedia.ky" target="_blank" rel="noopener noreferrer"><span>Compass Media Ltd. Brands</span></a></h6></div><div class="compass-link-item"><div class="compass-link-icon"> <a href="https://www.caymancompass.com/" target="_blank" rel="noopener noreferrer"><div class="sprite-compass-media-icon-compass"></div></a></div><div class="compass-link-text"> <a href="https://www.caymancompass.com/" target="_blank" rel="noopener noreferrer"><h6>Cayman Compass</h6></a></div></div><div class="compass-link-item"><div class="compass-link-icon"> <a href="https://www.caymanhealth.com/" target="_blank" rel="noopener noreferrer"><div class="sprite-compass-media-icon-health"></div></a></div><div class="compass-link-text"> <a href="https://www.caymanhealth.com/" target="_blank" rel="noopener noreferrer"><h6>Cayman Health</h6></a></div></div></div></div></aside></div></div></div></div><div class="td-sub-footer-container td-container-wrap td_stretch_container"><div class="td-container"><div class="td-pb-row"><div class="td-pb-span td-sub-footer-menu"><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="td-subfooter-menu"><li id="menu-item-470577" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-470577"><a href="https://www.caymancompass.com/community-standards/">Community Standards</a></li><li id="menu-item-188298" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188298"><a href="https://www.caymancompass.com/terms-of-use/">Terms and Conditions of Use</a></li><li id="menu-item-188297" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy td-menu-item td-normal-menu menu-item-188297"><a href="https://www.caymancompass.com/privacy-policy/">Privacy Policy</a></li><li id="menu-item-188296" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188296"><a href="https://www.caymancompass.com/copyright-policy-2/">Copyright</a></li><li id="menu-item-316352" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-316352"><a href="https://www.caymancompass.com/faq/">FAQ</a></li><li id="menu-item-476042" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-476042"><a href="https://www.caymancompass.com/subscribe/">Newsletter</a></li><li id="menu-item-389923" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-389923"><a href="https://www.caymancompass.com/advertise-with-us/">Advertise</a></li><li id="menu-item-470593" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-470593"><a href="https://www.caymancompass.com/compass-media-promotion-standard-terms-and-conditions/">Promotions T &#038; C</a></li></ul></div></div><div class="td-pb-span td-sub-footer-copy"> &copy; Copyright Cayman Compass Ltd.</div></div></div></div></div></div>  <script type="text/javascript">var likebtn_wl = 1; (function(d, e, s) {a = d.createElement(e);m = d.getElementsByTagName(e)[0];a.async = 1;a.src = s;m.parentNode.insertBefore(a, m)})(document, 'script', '//w.likebtn.com/js/w/widget.js'); if (typeof(LikeBtn) != "undefined") { LikeBtn.init(); }</script> <div id="um_upload_single" style="display:none"></div><div id="um_view_photo" style="display:none"> <a href="javascript:void(0);" data-action="um_remove_modal" class="um-modal-close"><i class="um-faicon-times"></i></a><div class="um-modal-body photo"><div class="um-modal-photo"></div></div></div>  <script type='text/javascript'>var leadin_wordpress = {"userRole":"visitor","pageType":"post","leadinPluginVersion":"7.31.1"};</script> <script async defer id="hs-script-loader" type='text/javascript' src='//js.hs-scripts.com/5627643.js?integration=WordPress'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-includes/js/underscore.min.js?ver=1.8.3'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/td-cloud-library/assets/js/js_posts_autoload.min.js?ver=243b277d395aac11337949f2c0b8e89c'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js?ver=10.3.3'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-includes/js/comment-reply.min.js?ver=1d94575c28a52d529613e47620a53900'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/ultimate-member/assets/js/select2/select2.full.min.js?ver=2.1.5'></script> <script type='text/javascript'>var _wpUtilSettings = {"ajax":{"url":"\/wp-admin\/admin-ajax.php"}};</script> <script type='text/javascript' src='https://www.caymancompass.com/wp-includes/js/wp-util.min.js?ver=1d94575c28a52d529613e47620a53900'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/ultimate-member/assets/js/um-crop.min.js?ver=2.1.5'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/ultimate-member/assets/js/um-modal.min.js?ver=2.1.5'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/ultimate-member/assets/js/um-jquery-form.min.js?ver=2.1.5'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/ultimate-member/assets/js/um-fileupload.min.js?ver=2.1.5'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/ultimate-member/assets/js/pickadate/picker.js?ver=2.1.5'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/ultimate-member/assets/js/pickadate/picker.date.js?ver=2.1.5'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/ultimate-member/assets/js/pickadate/picker.time.js?ver=2.1.5'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/ultimate-member/assets/js/pickadate/legacy.js?ver=2.1.5'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=7.4.4'></script> <script type='text/javascript'>( 'fetch' in window ) || document.write( '<script src="https://www.caymancompass.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://www.caymancompass.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script src="https://www.caymancompass.com/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="https://www.caymancompass.com/wp-includes/js/dist/vendor/wp-polyfill-url.min.js?ver=3.6.4"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://www.caymancompass.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://www.caymancompass.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );</script> <script type='text/javascript' src='https://www.caymancompass.com/wp-includes/js/dist/i18n.min.js?ver=cced130522e86c87a37cd7b8397b882c'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/ultimate-member/assets/js/um-raty.min.js?ver=2.1.5'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/ultimate-member/assets/js/um-tipsy.min.js?ver=2.1.5'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-includes/js/imagesloaded.min.js?ver=3.2.0'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-includes/js/masonry.min.js?ver=3.3.2'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-includes/js/jquery/jquery.masonry.min.js?ver=3.1.2b'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/ultimate-member/assets/js/simplebar.min.js?ver=2.1.5'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/ultimate-member/assets/js/um-functions.min.js?ver=2.1.5'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/ultimate-member/assets/js/um-responsive.min.js?ver=2.1.5'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/ultimate-member/assets/js/um-conditional.min.js?ver=2.1.5'></script> <script type='text/javascript'>var um_scripts = {"nonce":"5b36ebf467"};</script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/ultimate-member/assets/js/um-scripts.min.js?ver=2.1.5'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/ultimate-member/assets/js/um-profile.min.js?ver=2.1.5'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/ultimate-member/assets/js/um-account.min.js?ver=2.1.5'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=243b277d395aac11337949f2c0b8e89c'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-includes/js/wp-embed.min.js?ver=1d94575c28a52d529613e47620a53900'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/um-social-login/assets/js/um-social-connect.min.js?ver=2.3.3'></script>  <script type="text/javascript" src="//script.crazyegg.com/pages/scripts/0094/0967.js" async="async"></script>  <script type="text/javascript" id="hs-script-loader" async defer src="//js.hs-scripts.com/5627643.js"></script>    <script type="text/javascript" src="https://app.adsalesgenius.com/marketing/website/main.js"></script> <script type="text/javascript">new VisitorLog(1272);</script>  <script></script> <script type="text/javascript">jQuery(window).load(function() {
				jQuery("input[name='um_request']").val('');
			});</script> </body></html>
<!-- Dynamic page generated in 0.865 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2020-05-19 14:58:41 -->

<!-- Compression = gzip -->