<!doctype html > <!--[if IE 8]><html class="ie8" lang="en"> <![endif]--> <!--[if IE 9]><html class="ie9" lang="en"> <![endif]--> <!--[if gt IE 8]><!--><html lang="en-US"> <!--<![endif]--><head><script data-cfasync="false" id="ao_optimized_gfonts_config">WebFontConfig={google:{families:["Open Sans:400,600,700","Roboto:400,500,700"] },classes:false, events:false, timeout:1500};</script><link media="all" href="https://www.caymancompass.com/wp-content/cache/autoptimize/css/autoptimize_3904ae8e146d53f277862a6cc37e990c.css" rel="stylesheet" /><link media="only screen and (max-width: 768px)" href="https://www.caymancompass.com/wp-content/cache/autoptimize/css/autoptimize_dcb2de333eec7ab4ae31385ed8d6a393.css" rel="stylesheet" /><title>Teen charged with stabbing - Cayman Compass</title><meta charset="UTF-8" /><meta name="viewport" content="width=device-width, initial-scale=1.0"><link rel="pingback" href="https://www.caymancompass.com/xmlrpc.php" /><link rel="icon" type="image/png" href="https://www.caymancompass.com/wp-content/uploads/2019/10/favicon.png"><link rel="apple-touch-icon-precomposed" sizes="76x76" href="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassSqareiOSBookmarklet-76x.png"/><link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassSqareiOSBookmarklet-114x.png"/><link rel="apple-touch-icon-precomposed" sizes="152x152" href="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassSqareiOSBookmarklet-152x.png"/><link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassSqareiOSBookmarklet-114x.png"/><link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassSqareiOSBookmarklet-144x.png"/><meta name="description" content="A 19-year-old man from George Town has been remanded in custody after appearing in court Monday on a charge of wounding in relation to a stabbing on 31 Aug." /><meta name="robots" content="index, follow" /><meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://www.caymancompass.com/2020/09/08/teen-charged-with-stabbing/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Teen charged with stabbing - Cayman Compass" /><meta property="og:description" content="A 19-year-old man from George Town has been remanded in custody after appearing in court Monday on a charge of wounding in relation to a stabbing on 31 Aug." /><meta property="og:url" content="https://www.caymancompass.com/2020/09/08/teen-charged-with-stabbing/" /><meta property="og:site_name" content="Cayman Compass" /><meta property="article:publisher" content="https://www.facebook.com/caycompass" /><meta property="article:published_time" content="2020-09-08T22:50:11+00:00" /><meta property="og:image" content="https://www.caymancompass.com/wp-content/uploads/2019/05/court-ahouse-211-Read-Only.jpg" /><meta property="og:image:width" content="1400" /><meta property="og:image:height" content="933" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@cayCompass" /><meta name="twitter:site" content="@cayCompass" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.caymancompass.com/#organization","name":"Cayman Compass","url":"https://www.caymancompass.com/","sameAs":["https://www.facebook.com/caycompass","https://instagram.com/cayman_compass","https://www.youtube.com/caymancompas","https://twitter.com/cayCompass"],"logo":{"@type":"ImageObject","@id":"https://www.caymancompass.com/#logo","inLanguage":"en-US","url":"https://www.caymancompass.com/wp-content/uploads/2019/10/CompassLogo-white-bgd.gif","width":400,"height":275,"caption":"Cayman Compass"},"image":{"@id":"https://www.caymancompass.com/#logo"}},{"@type":"WebSite","@id":"https://www.caymancompass.com/#website","url":"https://www.caymancompass.com/","name":"Cayman Compass","description":"The Cayman Islands&#039; Most Trusted News Source","publisher":{"@id":"https://www.caymancompass.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://www.caymancompass.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.caymancompass.com/2020/09/08/teen-charged-with-stabbing/#primaryimage","inLanguage":"en-US","url":"https://www.caymancompass.com/wp-content/uploads/2019/05/court-ahouse-211-Read-Only.jpg","width":1400,"height":933},{"@type":"WebPage","@id":"https://www.caymancompass.com/2020/09/08/teen-charged-with-stabbing/#webpage","url":"https://www.caymancompass.com/2020/09/08/teen-charged-with-stabbing/","name":"Teen charged with stabbing - Cayman Compass","isPartOf":{"@id":"https://www.caymancompass.com/#website"},"primaryImageOfPage":{"@id":"https://www.caymancompass.com/2020/09/08/teen-charged-with-stabbing/#primaryimage"},"datePublished":"2020-09-08T22:50:11+00:00","dateModified":"2020-09-08T22:50:11+00:00","description":"A 19-year-old man from George Town has been remanded in custody after appearing in court Monday on a charge of wounding in relation to a stabbing on 31 Aug.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.caymancompass.com/2020/09/08/teen-charged-with-stabbing/"]}]},{"@type":"Article","@id":"https://www.caymancompass.com/2020/09/08/teen-charged-with-stabbing/#article","isPartOf":{"@id":"https://www.caymancompass.com/2020/09/08/teen-charged-with-stabbing/#webpage"},"author":{"@id":"https://www.caymancompass.com/#/schema/person/52c356c79047a04f2687933740b1fc50"},"headline":"Teen charged with stabbing","datePublished":"2020-09-08T22:50:11+00:00","dateModified":"2020-09-08T22:50:11+00:00","mainEntityOfPage":{"@id":"https://www.caymancompass.com/2020/09/08/teen-charged-with-stabbing/#webpage"},"commentCount":0,"publisher":{"@id":"https://www.caymancompass.com/#organization"},"image":{"@id":"https://www.caymancompass.com/2020/09/08/teen-charged-with-stabbing/#primaryimage"},"keywords":"court,stabbing","articleSection":"Crime and Courts,Featured Local Home Page","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://www.caymancompass.com/2020/09/08/teen-charged-with-stabbing/#respond"]}]},{"@type":["Person"],"@id":"https://www.caymancompass.com/#/schema/person/52c356c79047a04f2687933740b1fc50","name":"Norma Connolly","description":"Managing Editor"}]}</script> <link rel='dns-prefetch' href='//ajax.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link href='https://fonts.gstatic.com' crossorigin='anonymous' rel='preconnect' /><link href='https://ajax.googleapis.com' rel='preconnect' /><link href='https://fonts.googleapis.com' rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="Cayman Compass &raquo; Feed" href="https://www.caymancompass.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Cayman Compass &raquo; Comments Feed" href="https://www.caymancompass.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Cayman Compass &raquo; Teen charged with stabbing Comments Feed" href="https://www.caymancompass.com/2020/09/08/teen-charged-with-stabbing/feed/" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.caymancompass.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=26c26769a97238a1e4f42d2485e91f67"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);</script> <style type="text/css">img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}</style><link rel='stylesheet' id='jqueryuicss-css'  href='https://ajax.googleapis.com/ajax/libs/jqueryui/1.11.4/themes/smoothness/jquery-ui.css?ver=26c26769a97238a1e4f42d2485e91f67' type='text/css' media='all' /><style id='woocommerce-inline-inline-css' type='text/css'>.woocommerce form .form-row .required { visibility: visible; }</style><style id='td-theme-inline-css' type='text/css'>@media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }</style> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/pinnacle-newsletter/pinnacle_javascript.js?ver=26c26769a97238a1e4f42d2485e91f67' id='script1-js'></script> <script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jqueryui/1.11.4/jquery-ui.min.js?ver=26c26769a97238a1e4f42d2485e91f67' id='jqueryui-js'></script> <script type='text/javascript' id='compass_piano-js-before'>var tp = window.tp || [];
            var subscriptionsTemplateId = 'OTYU83ND4XJZ';
            var subscriptionsOfferId = 'OFSX9O2BRA8Y';
            tp.push(['setUseTinypassAccounts', false]);
            tp.push(['setUsePianoIdUserProvider', false]);
            tp.push(['setUsePianoIdLiteUserProvider', true]);

            
            tp.push(['setTags', ['court', 'stabbing', 'Crime and Courts', 'Featured Local Home Page']]);
            tp.push(['setContentCreated', '2020-09-08T17:50:11-05:00']);
            tp.push(['setContentAuthor', 'Norma Connolly']);

            document.cookie = '__adblocker=; expires=Thu, 01 Jan 1970 00:00:00 GMT; path=/';
            var setNptTechAdblockerCookie = function(adblocker) {
                var d = new Date();
                d.setTime(d.getTime() + 60 * 5 * 1000);
                document.cookie = '__adblocker=' + (adblocker ? 'true' : 'false') + '; expires=' + d.toUTCString() + '; path=/';
            };
            var script = document.createElement('script');
            script.setAttribute('async', true);
            script.setAttribute('src', '//www.npttech.com/advertising.js');
            script.setAttribute('onerror', 'setNptTechAdblockerCookie(true);');
            document.getElementsByTagName('head')[0].appendChild(script);

            (function(src) {
                var a = document.createElement('script');
                a.type = 'text/javascript';
                a.async = true;
                a.src = src;
                var b = document.getElementsByTagName('script')[0];
                b.parentNode.insertBefore(a, b)
            })('//api.tinypass.com/xbuilder/experience/load?aid=wmD32Scjpu');</script> <script type='text/javascript' src='https://www.caymancompass.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp' id='jquery-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/flowpaper-lite-pdf-flipbook/assets/lity/lity.min.js' id='lity-js-js'></script> <script type='text/javascript' id='likebtn_frontend-js-extra'>var likebtn_eh_data = {"ajaxurl":"https:\/\/www.caymancompass.com\/wp-admin\/admin-ajax.php","security":"17f39491f2"};</script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/likebtn-like-button/public/js/frontend.js?ver=26c26769a97238a1e4f42d2485e91f67' id='likebtn_frontend-js'></script> <link rel="https://api.w.org/" href="https://www.caymancompass.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.caymancompass.com/wp-json/wp/v2/posts/491131" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.caymancompass.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.caymancompass.com/wp-includes/wlwmanifest.xml" /><link rel='shortlink' href='https://www.caymancompass.com/?p=491131' /><link rel="alternate" type="application/json+oembed" href="https://www.caymancompass.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.caymancompass.com%2F2020%2F09%2F08%2Fteen-charged-with-stabbing%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.caymancompass.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.caymancompass.com%2F2020%2F09%2F08%2Fteen-charged-with-stabbing%2F&#038;format=xml" /> <script type="text/javascript">var ajax_url = "https://www.caymancompass.com/wp-admin/admin-ajax.php";</script><!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]--> <script>window.tdb_globals = {"wpRestNonce":"ca4413c9ae","wpRestUrl":"https:\/\/www.caymancompass.com\/wp-json\/","permalinkStructure":"\/%year%\/%monthnum%\/%day%\/%postname%\/","isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":50,"postAutoloadStatus":"off","origPostEditUrl":null};</script> <script>window.tdwGlobal = {"adminUrl":"https:\/\/www.caymancompass.com\/wp-admin\/","wpRestNonce":"ca4413c9ae","wpRestUrl":"https:\/\/www.caymancompass.com\/wp-json\/","permalinkStructure":"\/%year%\/%monthnum%\/%day%\/%postname%\/"};</script> <noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript>  <script>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</script> <style>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</style> <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-PBNB99T');</script>  <script type="application/ld+json">{
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://www.caymancompass.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.caymancompass.com/category/crime-and-courts/",
                    "name": "Crime and Courts"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.caymancompass.com/2020/09/08/teen-charged-with-stabbing/",
                    "name": "Teen charged with stabbing"                                
                }
            }    
        ]
    }</script> <style>.tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,
                .tds-button2 .tdm-btn-text,
                .tds-button2 i,
                .tds-button5:hover .tdm-btn-text,
                .tds-button5:hover i,
                .tds-button6 .tdm-btn-text,
                .tds-button6 i,
                .tdm_block_list .tdm-list-item i,
                .tdm_block_pricing .tdm-pricing-feature i,
                .tdm-social-item i {
                    color: #a0213f;
                }
                .tds-button1,
                .tds-button6:after,
                .tds-title2 .tdm-title-line:after,
                .tds-title3 .tdm-title-line:after,
                .tdm_block_pricing.tdm-pricing-featured:before,
                .tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,
                .tds-progress-bar1 .tdm-progress-bar:after,
                .tds-progress-bar2 .tdm-progress-bar:after,
                .tds-social3 .tdm-social-item {
                    background-color: #a0213f;
                }
                .tds-button2:before,
                .tds-button6:before,
                .tds-progress-bar3 .tdm-progress-bar:after {
                  border-color: #a0213f;
                }
                .tdm-btn-style1 {
					background-color: #a0213f;
				}
				.tdm-btn-style2:before {
				    border-color: #a0213f;
				}
				.tdm-btn-style2 {
				    color: #a0213f;
				}
				.tdm-btn-style3 {
				    -webkit-box-shadow: 0 2px 16px #a0213f;
                    -moz-box-shadow: 0 2px 16px #a0213f;
                    box-shadow: 0 2px 16px #a0213f;
				}
				.tdm-btn-style3:hover {
				    -webkit-box-shadow: 0 4px 26px #a0213f;
                    -moz-box-shadow: 0 4px 26px #a0213f;
                    box-shadow: 0 4px 26px #a0213f;
				}</style><style id="tdw-css-placeholder"></style><script data-cfasync="false" id="ao_optimized_gfonts_webfontloader">(function() {var wf = document.createElement('script');wf.src='https://ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';wf.type='text/javascript';wf.async='true';var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(wf, s);})();</script></head><body class="post-template-default single single-post postid-491131 single-format-standard theme-Newspaper td-standard-pack woocommerce-no-js woocommerce-multicurrency-KYD teen-charged-with-stabbing global-block-template-16 cc single_template_5 white-menu td-animation-stack-type0 td-boxed-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage"><div class="td-scroll-up"><i class="td-icon-menu-up"></i></div><div class="td-menu-background"></div><div id="td-mobile-nav"><div class="td-mobile-container"><div class="td-menu-socials-wrap"><div class="td-menu-socials"> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.facebook.com/caycompass/" title="Facebook"> <i class="td-icon-font td-icon-facebook"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.instagram.com/cayman_compass/" title="Instagram"> <i class="td-icon-font td-icon-instagram"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://twitter.com/cayCompass" title="Twitter"> <i class="td-icon-font td-icon-twitter"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.youtube.com/user/caymancompas" title="Youtube"> <i class="td-icon-font td-icon-youtube"></i> </a> </span></div><div class="td-mobile-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div></div><div class="td-mobile-content"><div class="menu-main-menu-container"><ul id="menu-main-menu" class="td-mobile-main-menu"><li id="menu-item-187846" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first menu-item-187846"><a href="https://www.caymancompass.com/">Home</a></li><li id="menu-item-489485" class="hide-for-desktop menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-489485"><a href="/account/profile">Members<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-489489" class="s-trigger-login s-logged-out menu-item menu-item-type-custom menu-item-object-custom menu-item-489489"><a href="#login">Login/Register</a></li><li id="menu-item-490096" class="s-logged-in menu-item menu-item-type-custom menu-item-object-custom menu-item-490096"><a href="https://www.caymancompass.com/wp-login.php?action=logout&#038;redirect_to=%2F">Logout</a></li><li id="menu-item-489486" class="s-logged-in menu-item menu-item-type-custom menu-item-object-custom menu-item-489486"><a href="/account/profile">Profile</a></li><li id="menu-item-489487" class="s-logged-in menu-item menu-item-type-custom menu-item-object-custom menu-item-489487"><a href="/account/subscription">Subscription</a></li><li id="menu-item-489488" class="s-logged-in menu-item menu-item-type-custom menu-item-object-custom menu-item-489488"><a href="/account/update-password">Update password</a></li></ul></li><li id="menu-item-187847" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-187847"><a href="https://www.caymancompass.com/cayman-news/">News<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-187848" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-187848"><a href="https://www.caymancompass.com/cayman-news/">Cayman News</a></li><li id="menu-item-471912" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-471912"><a href="https://www.caymancompass.com/issues/coronavirus-cayman/">Coronavirus (COVID-19)</a></li><li id="menu-item-484447" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-484447"><a href="https://www.caymancompass.com/storm-centre/">Cayman Storm Centre</a></li><li id="menu-item-463399" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-463399"><a href="https://www.caymancompass.com/business/">Business</a></li><li id="menu-item-188240" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188240"><a href="https://www.caymancompass.com/crime-and-courts/">Crime and Courts</a></li><li id="menu-item-461693" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-461693"><a href="https://www.caymancompass.com/lifestyle/">Lifestyle</a></li><li id="menu-item-461689" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-461689"><a href="https://www.caymancompass.com/sports/">Sports</a></li><li id="menu-item-485925" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-485925"><a href="https://www.caymancompass.com/tourism/">Travel and Tourism</a></li><li id="menu-item-489131" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-489131"><a href="https://www.caymancompass.com/world/">World News</a></li><li id="menu-item-461692" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-461692"><a href="https://www.caymancompass.com/weather/">Weather</a></li><li id="menu-item-461691" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-461691"><a href="https://www.caymancompass.com/video/">Video</a></li><li id="menu-item-467157" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-467157"><a href="https://www.caymancompass.com/podcasts/">Podcasts</a></li><li id="menu-item-464405" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-464405"><a href="https://www.caymancompass.com/interactive/">Interactive</a></li></ul></li><li id="menu-item-464189" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-464189"><a href="https://www.caymancompass.com/issues/">Issues<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-470185" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-470185"><a href="https://www.caymancompass.com/issues/coronavirus-cayman/">Coronavirus (COVID-19)</a></li><li id="menu-item-486325" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-486325"><a href="https://www.caymancompass.com/issues/cayman2-0/">Cayman 2.0</a></li><li id="menu-item-470131" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-470131"><a href="https://www.caymancompass.com/issues/climate-change/">Climate Change</a></li><li id="menu-item-466938" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-466938"><a href="https://www.caymancompass.com/issues/traffic/">Traffic</a></li><li id="menu-item-464188" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-464188"><a href="https://www.caymancompass.com/issues/founded-upon-the-seas/">Founded Upon the Seas</a></li><li id="menu-item-458002" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-458002"><a href="https://www.caymancompass.com/issues/port-vote-2019/">Port Vote 2019</a></li><li id="menu-item-458001" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-458001"><a href="https://www.caymancompass.com/issues/friday-features/">Friday Features</a></li><li id="menu-item-456066" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-456066"><a href="https://www.caymancompass.com/issues/sargassum/">Sargassum</a></li><li id="menu-item-471740" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-471740"><a href="https://www.caymancompass.com/issues/">All Issues Stories</a></li></ul></li><li id="menu-item-465716" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-465716"><a href="https://www.caymancompass.com/opinion/">Opinion<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-465705" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-465705"><a href="https://www.caymancompass.com/opinion/editoral/">Editorial</a></li><li id="menu-item-465695" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-465695"><a href="https://www.caymancompass.com/opinion/letters-to-the-editor/">Letters</a></li><li id="menu-item-465696" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-465696"><a href="https://www.caymancompass.com/opinion/columns/">Columns</a></li><li id="menu-item-461688" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-461688"><a href="https://www.caymancompass.com/cartoons/">Cartoons</a></li><li id="menu-item-188304" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188304"><a href="https://www.caymancompass.com/submit-letter-to-the-editor/">Write a Letter to the Editor</a></li></ul></li><li id="menu-item-188277" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-188277"><a href="/events/">Calendar<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-314306" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-314306"><a href="/events/">Event Listings</a></li><li id="menu-item-457157" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-457157"><a href="https://www.caymancompass.com/notices/">Notices</a></li><li id="menu-item-315091" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-315091"><a href="https://www.caymancompass.com/submit-event/">Submit an Event</a></li><li id="menu-item-463065" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-463065"><a href="https://www.caymancompass.com/cayman-islands-public-holidays-2020/">Cayman Islands Public Holidays 2020</a></li></ul></li><li id="menu-item-373520" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-373520"><a href="#">Our Brands<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-483740" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-483740"><a href="https://www.caymancompass.com/emergency-guide/">Emergency Guide</a></li><li id="menu-item-480091" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-480091"><a href="http://caymaniancompass.cay.newsmemory.com/?special=Hailing+our+Heroes">Hailing Our Heroes</a></li><li id="menu-item-373529" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-373529"><a href="http://caymanhealth.com/">Cayman Health</a></li><li id="menu-item-470176" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-470176"><a href="http://caymaniancompass.cay.newsmemory.com/?special=Careers">Careers Guide</a></li><li id="menu-item-466685" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-466685"><a href="https://www.caymancompass.com/wellness-feature/">Wellness Feature</a></li><li id="menu-item-460236" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-460236"><a href="https://www.caymancompass.com/women-in-business/">Women In Business</a></li><li id="menu-item-188285" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188285"><a href="https://www.caymancompass.com/special-features-and-publications/">Special Features and Publications</a></li><li id="menu-item-399126" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-399126"><a href="https://www.compassmedia.ky">All Publications</a></li></ul></li><li id="menu-item-188276" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-188276"><a href="#">More<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-461690" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-461690"><a href="https://www.caymancompass.com/subscribe/">Subscribe</a></li><li id="menu-item-465825" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-465825"><a href="https://www.caymancompass.com/contact/">Contact</a></li><li id="menu-item-188280" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188280"><a href="https://www.caymancompass.com/advertise-with-us/">Advertise With Us</a></li><li id="menu-item-482735" class="menu-item menu-item-type-post_type menu-item-object-product menu-item-482735"><a href="https://www.caymancompass.com/store/donate/">Donate &#8211; Support Local Journalism</a></li><li id="menu-item-482734" class="menu-item menu-item-type-post_type menu-item-object-product menu-item-482734"><a href="https://www.caymancompass.com/store/pay-bill/">Pay Bill</a></li><li id="menu-item-371483" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-371483"><a target="_blank" href="https://www.caymancompass.com/wp-content/uploads/2019/12/Compass-Print-Media-Kit.pdf">Print Media Kit</a></li><li id="menu-item-389921" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-389921"><a href="https://www.caymancompass.com/wp-content/uploads/2020/05/CompassDigitalMediaKit-UpdatedInventory-2020b.pdf">Online Media Kit</a></li><li id="menu-item-489945" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-489945"><a href="https://www.caymancompass.com/e-versions/">E-versions</a></li><li id="menu-item-188275" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188275"><a href="https://www.caymancompass.com/contests/">Contests</a></li><li id="menu-item-359853" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-359853"><a href="https://www.caymancompass.com/editorial-staff/">Editorial Staff</a></li><li id="menu-item-188303" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188303"><a href="https://www.caymancompass.com/submit-a-story-idea/">Submit a Story Idea</a></li></ul></li><li id="menu-item-490102" class="s-logged-in hide-for-desktop menu-item menu-item-type-custom menu-item-object-custom menu-item-490102"><a href="https://www.caymancompass.com/wp-login.php?action=logout&#038;redirect_to=%2F">Logout</a></li></ul></div></div></div><div id="login-form-mobile" class="td-register-section"><div id="td-login-mob" class="td-login-animation td-login-hide-mob"><div class="td-login-close"> <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a><div class="td-login-title">Sign in</div><div class="td-mobile-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div></div><div class="td-login-form-wrap"><div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div><div class="td_display_err"></div><div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div><div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div> <input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN"><div class="td-login-info-text"> <a href="#" id="forgot-pass-link-mob">Forgot your password?</a></div><div class="td-login-register-link"> <a id="signin-register-link-mob" href="https://www.caymancompass.com/register/">Join</a></div><div class="td-login-info-text"><a class="privacy-policy-link" href="https://www.caymancompass.com/privacy-policy/">Privacy Policy</a></div></div></div><div id="td-register-mob" class="td-login-animation td-login-hide-mob"><div class="td-register-close"> <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a><div class="td-login-title">Sign up</div><div class="td-mobile-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div></div><div class="td-login-panel-title"><span>Redirecting...</div></div><div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob"><div class="td-forgot-pass-close"> <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a><div class="td-login-title">Password recovery</div></div><div class="td-login-form-wrap"><div class="td-login-panel-title">Recover your password</div><div class="td_display_err"></div><div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div> <input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass"></div></div></div></div><div class="td-search-background"></div><div class="td-search-wrap-mob"><div class="td-drop-down-search"><form method="get" class="td-search-form" action="https://www.caymancompass.com/"><div class="td-search-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div><div role="search" class="td-search-input"> <span>Search</span> <input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" /></div></form><div id="td-aj-search-mob" class="td-ajax-search-flex"></div></div></div><div id="td-outer-wrap" class="td-theme-wrap"><div class="tdc-header-wrap "><div class="td-header-wrap td-header-style-1 "><div class="td-header-top-menu-full td-container-wrap td_stretch_container"><div class="td-container td-header-row td-header-top-menu"><div class="top-bar-style-1"><div class="td-header-sp-top-menu"><div class="menu-top-container"><ul id="menu-top-menu" class="top-header-menu"><li id="menu-item-461694" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-461694"><a href="https://www.caymancompass.com/subscribe/">Subscribe</a></li><li id="menu-item-489480" class="top-menu-red-button menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-489480"><a href="/account/profile">Members</a><ul class="sub-menu"><li id="menu-item-489484" class="s-logged-out s-trigger-login menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-489484"><a href="#login">Login/Register</a></li><li id="menu-item-490099" class="s-logged-in menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-490099"><a href="https://www.caymancompass.com/wp-login.php?action=logout&#038;redirect_to=%2F">Logout</a></li><li id="menu-item-489481" class="s-logged-in menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-489481"><a href="/account/profile">Profile</a></li><li id="menu-item-489482" class="s-logged-in menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-489482"><a href="/account/subscription">Subscription</a></li><li id="menu-item-489483" class="s-logged-in menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-489483"><a href="/account/update-password">Update password</a></li></ul></li><li id="menu-item-428186" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-428186"><a href="https://www.caymancompass.com/advertise-with-us/">Advertise</a></li><li id="menu-item-316348" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-316348"><a href="https://www.caymancompass.com/faq-2/">Help</a></li></ul></div></div><div class="td-header-sp-top-widget"> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.facebook.com/caycompass/" title="Facebook"> <i class="td-icon-font td-icon-facebook"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.instagram.com/cayman_compass/" title="Instagram"> <i class="td-icon-font td-icon-instagram"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://twitter.com/cayCompass" title="Twitter"> <i class="td-icon-font td-icon-twitter"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.youtube.com/user/caymancompas" title="Youtube"> <i class="td-icon-font td-icon-youtube"></i> </a> </span></div></div><div  id="login-form" class="white-popup-block mfp-hide mfp-with-anim"><div class="td-login-wrap"> <a href="#" class="td-back-button"><i class="td-icon-modal-back"></i></a><div id="td-login-div" class="td-login-form-div td-display-block"><div class="td-login-panel-title">Sign in</div><div class="td-login-panel-descr">Welcome. Log into your account</div><div class="td_display_err"></div><div class="mobile-facebook-login"style="margin-bottom: 10px;">[ultimatemember_social_login id=381831]</div><div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email" value="" required><label>your username</label></div><div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" required><label>your password</label></div> <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login"><div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div> <a id="register-link" href="https://www.caymancompass.com/register/">Create an account</a><div class="td-login-info-text"><a class="privacy-policy-link" href="https://www.caymancompass.com/privacy-policy/">Privacy Policy</a></div></div><div id="td-register-div" class="td-login-form-div td-display-none"><div class="td-login-panel-title">Redirecting...</div></div><div id="td-forgot-pass-div" class="td-login-form-div td-display-none"><div class="td-login-panel-title">Password recovery</div><div class="td-login-panel-descr">Recover your password</div><div class="td_display_err"></div><div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label>your email</label></div> <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password"><div class="td-login-info-text">A password will be e-mailed to you.</div></div></div></div></div></div><div class="td-banner-wrap-full td-logo-wrap-full td-container-wrap td_stretch_container"><div class="td-container td-header-row td-header-header"><div class="td-header-sp-logo"> <a class="td-main-logo" href="https://www.caymancompass.com/"> <img class="td-retina-data" data-retina="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassLogoNew544x180.png" src="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassLogoNew-272x90.png" alt="Cayman Compass" title="The most trusted news source in the Cayman Islands"/> <span class="td-visual-hidden">Cayman Compass</span> </a></div><div class="td-header-sp-recs"><div class="td-header-rec-wrap"><div class="td-a-rec td-a-rec-id-header  tdi_1_585 td_block_template_16"><style>/* custom css */
.tdi_1_585.td-a-rec{
					text-align: center;
				}.tdi_1_585 .td-element-style{
					z-index: -1;
				}.tdi_1_585.td-a-rec-img{
				    text-align: left;
				}.tdi_1_585.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_1_585.td-a-rec-img {
				        text-align: center;
				    }
                }</style><div class="td-visible-all-devices">  <script type="text/javascript">if (!window.AdButler){(function(){var s = document.createElement("script"); s.async = true; s.type = "text/javascript";s.src = 'https://servedbyadbutler.com/app.js';var n = document.getElementsByTagName("script")[0]; n.parentNode.insertBefore(s, n);}());}</script> <script type="text/javascript">var AdButler = AdButler || {}; AdButler.ads = AdButler.ads || [];
var abkw = window.abkw || '';
var plc197225 = window.plc197225 || 0;
document.write('<'+'div id="placement_197225_'+plc197225+'"></'+'div>');
AdButler.ads.push({handler: function(opt){ AdButler.register(165413, 197225, [728,90], 'placement_197225_'+opt.place, opt); }, opt: { place: plc197225++, keywords: abkw, domain: 'servedbyadbutler.com', click:'CLICK_MACRO_PLACEHOLDER' }});</script> </div></div></div></div></div></div><div class="td-header-menu-wrap-full td-container-wrap td_stretch_container"><div class="td-header-menu-wrap td-header-gradient "><div class="td-container td-header-row td-header-main-menu"><div id="td-header-menu" role="navigation"><div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div><div class="td-main-menu-logo td-logo-in-header"> <a class="td-mobile-logo td-sticky-header" href="https://www.caymancompass.com/"> <img class="td-retina-data" data-retina="https://www.caymancompass.com/wp-content/uploads/2019/10/CaymanCompassLogoWhiteNew280x96.png" src="https://www.caymancompass.com/wp-content/uploads/2019/10/CaymanCompassLogoWhiteNew140x48.png" alt="Cayman Compass" title="The most trusted news source in the Cayman Islands"/> </a> <a class="td-header-logo td-sticky-header" href="https://www.caymancompass.com/"> <img class="td-retina-data" data-retina="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassLogoNew544x180.png" src="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassLogoNew-272x90.png" alt="Cayman Compass" title="The most trusted news source in the Cayman Islands"/> </a></div><div class="menu-main-menu-container"><ul id="menu-main-menu-1" class="sf-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-187846"><a href="https://www.caymancompass.com/">Home</a></li><li class="hide-for-desktop menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-489485"><a href="/account/profile">Members</a><ul class="sub-menu"><li class="s-trigger-login s-logged-out menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-489489"><a href="#login">Login/Register</a></li><li class="s-logged-in menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-490096"><a href="https://www.caymancompass.com/wp-login.php?action=logout&#038;redirect_to=%2F">Logout</a></li><li class="s-logged-in menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-489486"><a href="/account/profile">Profile</a></li><li class="s-logged-in menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-489487"><a href="/account/subscription">Subscription</a></li><li class="s-logged-in menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-489488"><a href="/account/update-password">Update password</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-187847"><a href="https://www.caymancompass.com/cayman-news/">News</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-187848"><a href="https://www.caymancompass.com/cayman-news/">Cayman News</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-471912"><a href="https://www.caymancompass.com/issues/coronavirus-cayman/">Coronavirus (COVID-19)</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-484447"><a href="https://www.caymancompass.com/storm-centre/">Cayman Storm Centre</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-463399"><a href="https://www.caymancompass.com/business/">Business</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188240"><a href="https://www.caymancompass.com/crime-and-courts/">Crime and Courts</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-461693"><a href="https://www.caymancompass.com/lifestyle/">Lifestyle</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-461689"><a href="https://www.caymancompass.com/sports/">Sports</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-485925"><a href="https://www.caymancompass.com/tourism/">Travel and Tourism</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-489131"><a href="https://www.caymancompass.com/world/">World News</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-461692"><a href="https://www.caymancompass.com/weather/">Weather</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-461691"><a href="https://www.caymancompass.com/video/">Video</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-467157"><a href="https://www.caymancompass.com/podcasts/">Podcasts</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-464405"><a href="https://www.caymancompass.com/interactive/">Interactive</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-464189"><a href="https://www.caymancompass.com/issues/">Issues</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-470185"><a href="https://www.caymancompass.com/issues/coronavirus-cayman/">Coronavirus (COVID-19)</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-486325"><a href="https://www.caymancompass.com/issues/cayman2-0/">Cayman 2.0</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-470131"><a href="https://www.caymancompass.com/issues/climate-change/">Climate Change</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-466938"><a href="https://www.caymancompass.com/issues/traffic/">Traffic</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-464188"><a href="https://www.caymancompass.com/issues/founded-upon-the-seas/">Founded Upon the Seas</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-458002"><a href="https://www.caymancompass.com/issues/port-vote-2019/">Port Vote 2019</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-458001"><a href="https://www.caymancompass.com/issues/friday-features/">Friday Features</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-456066"><a href="https://www.caymancompass.com/issues/sargassum/">Sargassum</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-471740"><a href="https://www.caymancompass.com/issues/">All Issues Stories</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-465716"><a href="https://www.caymancompass.com/opinion/">Opinion</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-465705"><a href="https://www.caymancompass.com/opinion/editoral/">Editorial</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-465695"><a href="https://www.caymancompass.com/opinion/letters-to-the-editor/">Letters</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-465696"><a href="https://www.caymancompass.com/opinion/columns/">Columns</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-461688"><a href="https://www.caymancompass.com/cartoons/">Cartoons</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188304"><a href="https://www.caymancompass.com/submit-letter-to-the-editor/">Write a Letter to the Editor</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-188277"><a href="/events/">Calendar</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-314306"><a href="/events/">Event Listings</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-457157"><a href="https://www.caymancompass.com/notices/">Notices</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-315091"><a href="https://www.caymancompass.com/submit-event/">Submit an Event</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-463065"><a href="https://www.caymancompass.com/cayman-islands-public-holidays-2020/">Cayman Islands Public Holidays 2020</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-373520"><a href="#">Our Brands</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-483740"><a href="https://www.caymancompass.com/emergency-guide/">Emergency Guide</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-480091"><a href="http://caymaniancompass.cay.newsmemory.com/?special=Hailing+our+Heroes">Hailing Our Heroes</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-373529"><a href="http://caymanhealth.com/">Cayman Health</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-470176"><a href="http://caymaniancompass.cay.newsmemory.com/?special=Careers">Careers Guide</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-466685"><a href="https://www.caymancompass.com/wellness-feature/">Wellness Feature</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-460236"><a href="https://www.caymancompass.com/women-in-business/">Women In Business</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188285"><a href="https://www.caymancompass.com/special-features-and-publications/">Special Features and Publications</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-399126"><a href="https://www.compassmedia.ky">All Publications</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-188276"><a href="#">More</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-461690"><a href="https://www.caymancompass.com/subscribe/">Subscribe</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-465825"><a href="https://www.caymancompass.com/contact/">Contact</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188280"><a href="https://www.caymancompass.com/advertise-with-us/">Advertise With Us</a></li><li class="menu-item menu-item-type-post_type menu-item-object-product td-menu-item td-normal-menu menu-item-482735"><a href="https://www.caymancompass.com/store/donate/">Donate &#8211; Support Local Journalism</a></li><li class="menu-item menu-item-type-post_type menu-item-object-product td-menu-item td-normal-menu menu-item-482734"><a href="https://www.caymancompass.com/store/pay-bill/">Pay Bill</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-371483"><a target="_blank" href="https://www.caymancompass.com/wp-content/uploads/2019/12/Compass-Print-Media-Kit.pdf">Print Media Kit</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-389921"><a href="https://www.caymancompass.com/wp-content/uploads/2020/05/CompassDigitalMediaKit-UpdatedInventory-2020b.pdf">Online Media Kit</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-489945"><a href="https://www.caymancompass.com/e-versions/">E-versions</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188275"><a href="https://www.caymancompass.com/contests/">Contests</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-359853"><a href="https://www.caymancompass.com/editorial-staff/">Editorial Staff</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188303"><a href="https://www.caymancompass.com/submit-a-story-idea/">Submit a Story Idea</a></li></ul></li><li class="s-logged-in hide-for-desktop menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-490102"><a href="https://www.caymancompass.com/wp-login.php?action=logout&#038;redirect_to=%2F">Logout</a></li></ul></div></div><div class="header-search-wrap"><div class="td-search-btns-wrap"> <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a> <a id="td-header-search-button-mob" href="#" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a></div><div class="td-drop-down-search" aria-labelledby="td-header-search-button"><form method="get" class="td-search-form" action="https://www.caymancompass.com/"><div role="search" class="td-head-form-search-wrap"> <input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" /></div></form><div id="td-aj-search"></div></div></div></div></div></div></div></div><div class="td-main-content-wrap td-container-wrap"><div class="td-container td-post-template-5 "><div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://www.caymancompass.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Crime and Courts" class="entry-crumb" href="https://www.caymancompass.com/category/crime-and-courts/">Crime and Courts</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Teen charged with stabbing</span></div></div><div class="td-pb-row"><div class="td-pb-span8 td-main-content" role="main"><div class="td-ss-main-content"><article id="post-491131" class="post-491131 post type-post status-publish format-standard has-post-thumbnail category-crime-and-courts category-featured-local-home-page tag-court tag-stabbing" itemscope itemtype="https://schema.org/Article"><div class="td-post-header"><ul class="td-category"><li class="entry-category"><a  href="https://www.caymancompass.com/category/crime-and-courts/">Crime and Courts</a></li></ul><header class="td-post-title"><h1 class="entry-title">Teen charged with stabbing</h1><div class="td-module-meta-info"><div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://www.caymancompass.com/author/nconnolly/">Norma Connolly</a><div class="td-author-line"> -</div></div> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-09-08T17:50:11-05:00" >September 8, 2020</time></span></div></header></div><div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-bg td-ps-notext td-ps-rounded td-post-sharing-style3 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.caymancompass.com%2F2020%2F09%2F08%2Fteen-charged-with-stabbing%2F"><div class="td-social-but-icon"><i class="td-icon-facebook"></i></div><div class="td-social-but-text">Facebook</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Teen+charged+with+stabbing&url=https%3A%2F%2Fwww.caymancompass.com%2F2020%2F09%2F08%2Fteen-charged-with-stabbing%2F&via=cayCompass"><div class="td-social-but-icon"><i class="td-icon-twitter"></i></div><div class="td-social-but-text">Twitter</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=Teen+charged+with+stabbing %0A%0A https://www.caymancompass.com/2020/09/08/teen-charged-with-stabbing/"><div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div><div class="td-social-but-text">WhatsApp</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="/cdn-cgi/l/email-protection#ecd39f998e86898f98d1b8898982cc8f848d9e8b8988cc9b859884cc9f988d8e8e85828bca8e838895d18498989c9fd6c3c39b9b9bc28f8d95818d828f83819c8d9f9fc28f8381c3dedcdedcc3dcd5c3dcd4c398898982c18f848d9e8b8988c19b859884c19f988d8e8e85828bc3"><div class="td-social-but-icon"><i class="td-icon-mail"></i></div><div class="td-social-but-text">Email</div> </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top"><div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div> </a></div></div></div><div class="td-post-content tagdiv-type"><div class="td-a-rec td-a-rec-id-content_top  tdi_2_5fe td_block_template_16"><style>/* custom css */
.tdi_2_5fe.td-a-rec{
					text-align: center;
				}.tdi_2_5fe .td-element-style{
					z-index: -1;
				}.tdi_2_5fe.td-a-rec-img{
				    text-align: left;
				}.tdi_2_5fe.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_2_5fe.td-a-rec-img {
				        text-align: center;
				    }
                }</style><div id="isb_phone_advert" class="td-visible-phone">  <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">var elem = document.getElementById("isb_phone_advert");
var theCSSprop = window.getComputedStyle(elem,null).getPropertyValue("display");
if (theCSSprop!="none"){


var rnd = window.rnd || Math.floor(Math.random()*10e6);
var pid420687 = window.pid420687 || rnd;
var plc420687 = window.plc420687 || 0;
var abkw = window.abkw || '';
var absrc = 'https://servedbyadbutler.com/adserve/;ID=165413;size=0x0;setID=420687;type=js;sw='+screen.width+';sh='+screen.height+';spr='+window.devicePixelRatio+';kw='+abkw+';pid='+pid420687+';place='+(plc420687++)+';rnd='+rnd+';click=CLICK_MACRO_PLACEHOLDER';
document.write('<scr'+'ipt src="'+absrc+'" type="text/javascript"></scr'+'ipt>');

}else{
}</script> </div></div><p>A 19-year-old man from George Town has been remanded in custody after appearing in court Monday on a charge of wounding in relation to a stabbing on 31 Aug.</p><p>The man was ordered to appear again before the court on 18 Sept. He initially appeared in court on Friday, 4 Sept., when he was released on bail.</p><p>He is charged in relation to the stabbing of a man on Sound Way shortly before 5pm on 31 Aug. following an altercation between him and the victim, who police said was stabbed multiple times.</p><p>The injured man was transported to the Cayman Islands Hospital for treatment for life-threatening injuries where he was described as being in a serious but stable condition.</p><div class="likebtn_container" style="clear:both;"><span class="likebtn-wrapper"  data-identifier="post_491131"  data-site_id="5a6f97366fd08b0f18563396"  data-theme="custom"  data-icon_l="thmb4-u"  data-icon_d="thmb4-d"  data-icon_size="24"  data-icon_l_c_v="#00aeef"  data-icon_d_c_v="#00aeef"  data-counter_l_c="#222222"  data-counter_d_c="#222222"  data-bg_c="rgba(250,250,250,0)"  data-bg_c_v="rgba(250,250,250,0)"  data-brdr_c="rgba(255,255,255,0)"  data-f_size="14"  data-f_family="Georgia"  data-counter_fs="b"  data-show_like_label="false"  data-share_enabled="false"  data-voting_cancelable="false"  data-tooltip_enabled="false"  data-white_label="true"  data-popup_disabled="true"  data-style=""  data-unlike_allowed=""  data-show_copyright=""  data-item_url="https://www.caymancompass.com/2020/09/08/teen-charged-with-stabbing/"  data-item_title="Teen charged with stabbing"  data-item_image="https://www.caymancompass.com/wp-content/uploads/2019/05/court-ahouse-211-Read-Only.jpg"  data-item_date="2020-09-08T17:50:11-05:00"  data-engine="WordPress"  data-plugin_v="2.6.28"  data-prx="https://www.caymancompass.com/wp-admin/admin-ajax.php?action=likebtn_prx"  data-event_handler="likebtn_eh" ></span></div><div class="td-a-rec td-a-rec-id-content_bottom  tdi_3_8f7 td_block_template_16"><style>/* custom css */
.tdi_3_8f7.td-a-rec{
					text-align: center;
				}.tdi_3_8f7 .td-element-style{
					z-index: -1;
				}.tdi_3_8f7.td-a-rec-img{
				    text-align: left;
				}.tdi_3_8f7.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_3_8f7.td-a-rec-img {
				        text-align: center;
				    }
                }</style><div class="td-all-devices">  <script type="text/javascript">var rnd = window.rnd || Math.floor(Math.random()*10e6);
var pid421033 = window.pid421033 || rnd;
var plc421033 = window.plc421033 || 0;
var abkw = window.abkw || '';
var absrc = 'https://servedbyadbutler.com/adserve/;ID=165413;size=0x0;setID=421033;type=js;sw='+screen.width+';sh='+screen.height+';spr='+window.devicePixelRatio+';kw='+abkw+';pid='+pid421033+';place='+(plc421033++)+';rnd='+rnd+';click=CLICK_MACRO_PLACEHOLDER';
document.write('<scr'+'ipt src="'+absrc+'" type="text/javascript"></scr'+'ipt>');</script> </div></div></div><footer><div class="td-post-source-tags"><ul class="td-tags td-post-small-box clearfix"><li><span>Topics</span></li><li><a href="https://www.caymancompass.com/tag/court/">court</a></li><li><a href="https://www.caymancompass.com/tag/stabbing/">stabbing</a></li></ul></div><div class="td-post-sharing-bottom"><div class="td-post-sharing-classic"><iframe frameBorder="0" src="https://www.facebook.com/plugins/like.php?href=https://www.caymancompass.com/2020/09/08/teen-charged-with-stabbing/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:auto; height:21px; background-color:transparent;"></iframe></div><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-ps-rounded td-post-sharing-style3 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.caymancompass.com%2F2020%2F09%2F08%2Fteen-charged-with-stabbing%2F"><div class="td-social-but-icon"><i class="td-icon-facebook"></i></div><div class="td-social-but-text">Facebook</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Teen+charged+with+stabbing&url=https%3A%2F%2Fwww.caymancompass.com%2F2020%2F09%2F08%2Fteen-charged-with-stabbing%2F&via=cayCompass"><div class="td-social-but-icon"><i class="td-icon-twitter"></i></div><div class="td-social-but-text">Twitter</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=Teen+charged+with+stabbing %0A%0A https://www.caymancompass.com/2020/09/08/teen-charged-with-stabbing/"><div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div><div class="td-social-but-text">WhatsApp</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="/cdn-cgi/l/email-protection#90afe3e5f2faf5f3e4adc4f5f5feb0f3f8f1e2f7f5f4b0e7f9e4f8b0e3e4f1f2f2f9fef7b6f2fff4e9adf8e4e4e0e3aabfbfe7e7e7bef3f1e9fdf1fef3fffde0f1e3e3bef3fffdbfa2a0a2a0bfa0a9bfa0a8bfe4f5f5febdf3f8f1e2f7f5f4bde7f9e4f8bde3e4f1f2f2f9fef7bf"><div class="td-social-but-icon"><i class="td-icon-mail"></i></div><div class="td-social-but-text">Email</div> </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom"><div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div> </a></div></div></div><div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://www.caymancompass.com/2020/09/08/eire-og-take-lead-in-gaelic-football-standings/">Éire Óg take lead in Gaelic football standings</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="https://www.caymancompass.com/2020/09/08/balboa-beachs-granted-after-the-fact-approval-for-building-on-ironshore/">Balboa Beach&#8217;s granted after-the-fact approval for building on ironshore</a></div></div></div><div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="https://www.caymancompass.com/author/nconnolly/">Norma Connolly</a></span></div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Norma Connolly"></span><meta itemprop="datePublished" content="2020-09-08T17:50:11-05:00"><meta itemprop="dateModified" content="2020-09-08T17:50:11-05:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.caymancompass.com/2020/09/08/teen-charged-with-stabbing/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassLogoNew-272x90.png"></span><meta itemprop="name" content="Cayman Compass"></span><meta itemprop="headline " content="Teen charged with stabbing"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.caymancompass.com/wp-content/uploads/2019/05/court-ahouse-211-Read-Only.jpg"><meta itemprop="width" content="1400"><meta itemprop="height" content="933"></span></footer></article><div class="td_block_wrap td_block_related_posts tdi_4_fa5 td_with_ajax_pagination td-pb-border-top td_block_template_16"  data-td-block-uid="tdi_4_fa5" ><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>var block_tdi_4_fa5 = new tdBlock();
block_tdi_4_fa5.id = "tdi_4_fa5";
block_tdi_4_fa5.atts = '{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_tags","td_ajax_filter_type":"td_custom_related","class":"tdi_4_fa5","td_column_number":3,"live_filter_cur_post_id":491131,"live_filter_cur_post_author":"18","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"tdi_4_fa5","tdc_css_class_style":"tdi_4_fa5_rand_style"}';
block_tdi_4_fa5.td_column_number = "3";
block_tdi_4_fa5.block_type = "td_block_related_posts";
block_tdi_4_fa5.post_count = "3";
block_tdi_4_fa5.found_posts = "4129";
block_tdi_4_fa5.header_color = "";
block_tdi_4_fa5.ajax_pagination_infinite_stop = "";
block_tdi_4_fa5.max_num_pages = "1377";
tdBlocksArray.push(block_tdi_4_fa5);</script><h4 class="td-related-title td-block-title"><a id="tdi_5_bf1" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="tdi_4_fa5" href="#">Related articles</a><a id="tdi_6_199" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="tdi_4_fa5" href="#">More from author</a></h4><div id=tdi_4_fa5 class="td_block_inner"><div class="td-related-row"><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.caymancompass.com/2020/09/08/man-injured-in-machete-attack-2/" rel="bookmark" class="td-image-wrap " title="Man injured in machete attack" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="RCIPS" title="Man injured in machete attack" data-type="image_tag" data-img-url="https://www.caymancompass.com/wp-content/uploads/2019/11/Police-Car-3-218x150.jpg"  width="218" height="150" /></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.caymancompass.com/2020/09/08/man-injured-in-machete-attack-2/" rel="bookmark" title="Man injured in machete attack">Man injured in machete attack</a></h3></div></div></div><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.caymancompass.com/2020/09/03/police-clampdown-after-alarming-rise-in-knife-crime/" rel="bookmark" class="td-image-wrap " title="Police clampdown after alarming rise in knife crime" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Police clampdown after alarming rise in knife crime" data-type="image_tag" data-img-url="https://www.caymancompass.com/wp-content/uploads/2020/09/Knife-002-218x150.jpg"  width="218" height="150" /></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.caymancompass.com/2020/09/03/police-clampdown-after-alarming-rise-in-knife-crime/" rel="bookmark" title="Police clampdown after alarming rise in knife crime">Police clampdown after alarming rise in knife crime</a></h3></div></div></div><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.caymancompass.com/2020/09/01/man-in-serious-condition-after-being-stabbed-several-times/" rel="bookmark" class="td-image-wrap " title="Man in serious condition after being stabbed several times" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Man in serious condition after being stabbed several times" data-type="image_tag" data-img-url="https://www.caymancompass.com/wp-content/uploads/2015/03/police-tape-sml-1-218x150.jpg"  width="218" height="150" /></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.caymancompass.com/2020/09/01/man-in-serious-condition-after-being-stabbed-several-times/" rel="bookmark" title="Man in serious condition after being stabbed several times">Man in serious condition after being stabbed several times</a></h3></div></div></div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_4_fa5" data-td_block_id="tdi_4_fa5"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-tdi_4_fa5" data-td_block_id="tdi_4_fa5"><i class="td-icon-font td-icon-menu-right"></i></a></div></div><div class="comments" id="comments"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">LEAVE A REPLY <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/09/08/teen-charged-with-stabbing/#respond" style="display:none;">Cancel reply</a></small></h3><p class="must-log-in td-login-comment"><a class="s-trigger-login" data-effect="mpf-td-login-effect" href="#">Log in to leave a comment </a></p></div></div></div></div><div class="td-pb-span4 td-main-sidebar" role="complementary"><div class="td-ss-main-sidebar"><div class="td-a-rec td-a-rec-id-sidebar  tdi_7_5ff td_block_template_16"><style>/* custom css */
.tdi_7_5ff.td-a-rec{
					text-align: center;
				}.tdi_7_5ff .td-element-style{
					z-index: -1;
				}.tdi_7_5ff.td-a-rec-img{
				    text-align: left;
				}.tdi_7_5ff.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_7_5ff.td-a-rec-img {
				        text-align: center;
				    }
                }</style><div id="isb_desktop_advert" class="td-visible-desktop sidebar-ad-compass-fix">  <script type="text/javascript">var elem = document.getElementById("isb_desktop_advert");
var theCSSprop = window.getComputedStyle(elem,null).getPropertyValue("display");

if (theCSSprop!="none"){


var rnd = window.rnd || Math.floor(Math.random()*10e6);
var pid420687 = window.pid420687 || rnd;
var plc420687 = window.plc420687 || 0;
var abkw = window.abkw || '';
var absrc = 'https://servedbyadbutler.com/adserve/;ID=165413;size=0x0;setID=420687;type=js;sw='+screen.width+';sh='+screen.height+';spr='+window.devicePixelRatio+';kw='+abkw+';pid='+pid420687+';place='+(plc420687++)+';rnd='+rnd+';click=CLICK_MACRO_PLACEHOLDER';
document.write('<scr'+'ipt src="'+absrc+'" type="text/javascript"></scr'+'ipt>');

}else{
}</script> </div><div id="isb_tablet_portrait_advert" class="td-visible-tablet-portrait sidebar-ad-compass-fix">  <script type="text/javascript">var elem = document.getElementById("isb_tablet_portrait_advert");
var theCSSprop = window.getComputedStyle(elem,null).getPropertyValue("display");
if (theCSSprop!="none"){


var rnd = window.rnd || Math.floor(Math.random()*10e6);
var pid420687 = window.pid420687 || rnd;
var plc420687 = window.plc420687 || 0;
var abkw = window.abkw || '';
var absrc = 'https://servedbyadbutler.com/adserve/;ID=165413;size=0x0;setID=420687;type=js;sw='+screen.width+';sh='+screen.height+';spr='+window.devicePixelRatio+';kw='+abkw+';pid='+pid420687+';place='+(plc420687++)+';rnd='+rnd+';click=CLICK_MACRO_PLACEHOLDER';
document.write('<scr'+'ipt src="'+absrc+'" type="text/javascript"></scr'+'ipt>');


}else{

}</script> </div><div id="isb_tablet_landscape_advert" class="td-visible-tablet-landscape sidebar-ad-compass-fix">  <script type="text/javascript">var elem = document.getElementById("isb_tablet_landscape_advert");
var theCSSprop = window.getComputedStyle(elem,null).getPropertyValue("display");
if (theCSSprop!="none"){


var rnd = window.rnd || Math.floor(Math.random()*10e6);
var pid420687 = window.pid420687 || rnd;
var plc420687 = window.plc420687 || 0;
var abkw = window.abkw || '';
var absrc = 'https://servedbyadbutler.com/adserve/;ID=165413;size=0x0;setID=420687;type=js;sw='+screen.width+';sh='+screen.height+';spr='+window.devicePixelRatio+';kw='+abkw+';pid='+pid420687+';place='+(plc420687++)+';rnd='+rnd+';click=CLICK_MACRO_PLACEHOLDER';
document.write('<scr'+'ipt src="'+absrc+'" type="text/javascript"></scr'+'ipt>');

}else{
}</script> </div></div><aside id="text-6" class="td_block_template_16 widget text-6 widget_text"><div class="textwidget"><div class="td_block_social_counter newsletter-addon newsletter-sidebar"><div class="td_social_type td-pb-margin-side td-social-newsletter"><div class="td-social-box"><div class="td-sp td-sp-newsletter"><i class="td-icon-mail"></i></div><span class="td_social_button"><a href="https://www.caymancompass.com/subscribe/" target="_blank" rel="noopener noreferrer">SUBSCRIBE TO<span class="sublongtext"> THE COMPASS</span> NEWSLETTER</a></span></div></div></div></div></aside><div class="td_block_wrap td_block_7 td_block_widget tdi_8_b8b td_with_ajax_pagination td-pb-border-top td_block_template_16 td-column-1 td_block_padding"  data-td-block-uid="tdi_8_b8b" ><script>var block_tdi_8_b8b = new tdBlock();
block_tdi_8_b8b.id = "tdi_8_b8b";
block_tdi_8_b8b.atts = '{"custom_title":"This week","custom_url":"","block_template_id":"","header_text_color":"#","border_color":"#","accent_text_color":"#","m6_tl":"","limit":"3","offset":"","el_class":"","post_ids":"","category_id":"","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","sort":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"next_prev","ajax_pagination_infinite_stop":"","class":"td_block_widget tdi_8_b8b","separator":"","show_modified_date":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m6f_title_font_header":"","m6f_title_font_title":"Article title","m6f_title_font_settings":"","m6f_title_font_family":"","m6f_title_font_size":"","m6f_title_font_line_height":"","m6f_title_font_style":"","m6f_title_font_weight":"","m6f_title_font_transform":"","m6f_title_font_spacing":"","m6f_title_":"","m6f_cat_font_title":"Article category tag","m6f_cat_font_settings":"","m6f_cat_font_family":"","m6f_cat_font_size":"","m6f_cat_font_line_height":"","m6f_cat_font_style":"","m6f_cat_font_weight":"","m6f_cat_font_transform":"","m6f_cat_font_spacing":"","m6f_cat_":"","m6f_meta_font_title":"Article meta info","m6f_meta_font_settings":"","m6f_meta_font_family":"","m6f_meta_font_size":"","m6f_meta_font_line_height":"","m6f_meta_font_style":"","m6f_meta_font_weight":"","m6f_meta_font_transform":"","m6f_meta_font_spacing":"","m6f_meta_":"","css":"","tdc_css":"","td_column_number":1,"header_color":"","color_preset":"","border_top":"","tdc_css_class":"tdi_8_b8b","tdc_css_class_style":"tdi_8_b8b_rand_style"}';
block_tdi_8_b8b.td_column_number = "1";
block_tdi_8_b8b.block_type = "td_block_7";
block_tdi_8_b8b.post_count = "3";
block_tdi_8_b8b.found_posts = "89769";
block_tdi_8_b8b.header_color = "";
block_tdi_8_b8b.ajax_pagination_infinite_stop = "";
block_tdi_8_b8b.max_num_pages = "29923";
tdBlocksArray.push(block_tdi_8_b8b);</script><div class="td-block-title-wrap"><h4 class="td-block-title"><span class="td-pulldown-size">This week</span></h4></div><div id=tdi_8_b8b class="td_block_inner"><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.caymancompass.com/2020/09/08/balboa-beachs-granted-after-the-fact-approval-for-building-on-ironshore/" rel="bookmark" class="td-image-wrap " title="Balboa Beach&#8217;s granted after-the-fact approval for building on ironshore" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" alt="" title="Balboa Beach&#8217;s granted after-the-fact approval for building on ironshore" data-type="image_tag" data-img-url="https://www.caymancompass.com/wp-content/uploads/2020/09/Balboa-100x70.jpg"  width="100" height="70" /></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.caymancompass.com/2020/09/08/balboa-beachs-granted-after-the-fact-approval-for-building-on-ironshore/" rel="bookmark" title="Balboa Beach&#8217;s granted after-the-fact approval for building on ironshore">Balboa Beach&#8217;s granted after-the-fact approval for building on ironshore</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-09-08T18:59:22-05:00" >September 8, 2020</time></span></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.caymancompass.com/2020/09/08/teen-charged-with-stabbing/" rel="bookmark" class="td-image-wrap " title="Teen charged with stabbing" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" alt="" title="Teen charged with stabbing" data-type="image_tag" data-img-url="https://www.caymancompass.com/wp-content/uploads/2019/05/court-ahouse-211-Read-Only-100x70.jpg"  width="100" height="70" /></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.caymancompass.com/2020/09/08/teen-charged-with-stabbing/" rel="bookmark" title="Teen charged with stabbing">Teen charged with stabbing</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-09-08T17:50:11-05:00" >September 8, 2020</time></span></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.caymancompass.com/2020/09/08/eire-og-take-lead-in-gaelic-football-standings/" rel="bookmark" class="td-image-wrap " title="Éire Óg take lead in Gaelic football standings" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" alt="" title="Éire Óg take lead in Gaelic football standings" data-type="image_tag" data-img-url="https://www.caymancompass.com/wp-content/uploads/2020/09/shutterstock_1345674650-100x70.jpg"  width="100" height="70" /></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.caymancompass.com/2020/09/08/eire-og-take-lead-in-gaelic-football-standings/" rel="bookmark" title="Éire Óg take lead in Gaelic football standings">Éire Óg take lead in Gaelic football standings</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-09-08T17:28:13-05:00" >September 8, 2020</time></span></div></div></div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_8_b8b" data-td_block_id="tdi_8_b8b"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-tdi_8_b8b" data-td_block_id="tdi_8_b8b"><i class="td-icon-font td-icon-menu-right"></i></a></div></div></div></div></div></div></div><div id="s-login-modal"></div><div id="s-checkout-modal"></div><div class="tdc-footer-wrap "><div class="td-footer-wrapper td-footer-container td-container-wrap td_stretch_container"><div class="td-container"><div class="td-pb-row"><div class="td-pb-span12"></div></div><div class="td-pb-row"><div class="td-pb-span12"><aside class="widget_text td_block_template_16 widget widget_custom_html"><div class="textwidget custom-html-widget"><style>.compass-media-footer-links {
	font-family: 'Open Sans', Arial, Helvetica, sans-serif !important;
	color: #fff !important;
	width: 100%;
	text-align: center;
	margin-bottom: 30px;
}
.compass-media-footer-heading {
	width: 100%;
	text-align: center;
    border-bottom: 1px solid #fff; 
    line-height: 1px;
    margin: 10px 0 20px; 
}
.compass-media-footer-heading span {
	padding: 0 20px;
	background-color: #0e1523; 
	font-weight: bold;
    font-family: 'Open Sans', Arial, Helvetica, sans-serif !important;
	font-size: 10px;
}
.compass-media-footer-links a, .compass-media-footer-heading a {
  color: #fff !important;
  text-decoration: none;
}
.compass-link-item {
  display: inline-block;
  vertical-align: top;
  width: 10%;
  min-width: 93px;
  margin-bottom: 20px;
}
.compass-link-icon {
	width: 60px;
	height: 60px;
	margin: 0 auto;
}
.compass-link-text h6 {
  text-align: center;
  text-transform: uppercase;
  font-size: 9px !important;
  margin: 0;
  color: #fff !important;
  line-height: 10px !important;
}
.sprite-compass-media-icon-christmas-catalog, .sprite-compass-media-icon-christmascatalog, .sprite-compass-media-icon-whot, .sprite-compass-media-icon-cfr, .sprite-compass-media-icon-compass, 
.sprite-compass-media-icon-flava, .sprite-compass-media-icon-gcm, .sprite-compass-media-icon-health, .sprite-compass-media-icon-insideout, .sprite-compass-media-icon-journal, 
.sprite-compass-media-icon-keytocayman, .sprite-compass-media-icon-map
{ display: inline-block; background: url('/wp-content/uploads/footer-icons/footer-icons.png') no-repeat; overflow: hidden; text-indent: -9999px; text-align: left; }
 
.sprite-compass-media-icon-christmas-catalog { background-position: -10px -0px; width: 50px; height: 50px; }
.sprite-compass-media-icon-christmascatalog { background-position: -70px -0px; width: 50px; height: 50px; }
.sprite-compass-media-icon-whot { background-position: -130px -0px; width: 50px; height: 50px; }
.sprite-compass-media-icon-cfr { background-position: -10px -60px; width: 50px; height: 50px; }
.sprite-compass-media-icon-compass { background-position: -70px -60px; width: 50px; height: 50px; }
.sprite-compass-media-icon-flava { background-position: -130px -60px; width: 50px; height: 50px; }
.sprite-compass-media-icon-gcm { background-position: -10px -120px; width: 50px; height: 50px; }
.sprite-compass-media-icon-health { background-position: -70px -120px; width: 50px; height: 50px; }
.sprite-compass-media-icon-insideout { background-position: -130px -120px; width: 50px; height: 50px; }
.sprite-compass-media-icon-journal { background-position: -10px -180px; width: 50px; height: 50px; }
.sprite-compass-media-icon-keytocayman { background-position: -70px -180px; width: 50px; height: 50px; }
.sprite-compass-media-icon-map { background-position: -130px -180px; width: 50px; height: 50px; }</style><div class="compass-media-footer-links"><div class="compass-links-heading-container"><h6 class="compass-media-footer-heading"><a href="https://www.compassmedia.ky" target="_blank" rel="noopener noreferrer"><span>Compass Media Ltd. Brands</span></a></h6></div><div class="compass-link-item"><div class="compass-link-icon"> <a href="https://www.caymancompass.com/" target="_blank" rel="noopener noreferrer"><div class="sprite-compass-media-icon-compass"></div></a></div><div class="compass-link-text"> <a href="https://www.caymancompass.com/" target="_blank" rel="noopener noreferrer"><h6>Cayman Compass</h6></a></div></div><div class="compass-link-item"><div class="compass-link-icon"> <a href="https://www.caymanhealth.com/" target="_blank" rel="noopener noreferrer"><div class="sprite-compass-media-icon-health"></div></a></div><div class="compass-link-text"> <a href="https://www.caymanhealth.com/" target="_blank" rel="noopener noreferrer"><h6>Cayman Health</h6></a></div></div></div></div></aside><aside class="widget_text td_block_template_16 widget widget_custom_html"><div class="textwidget custom-html-widget"><div style="display: table; margin: auto;"><div class="footer-payment-logos" style="position:relative; display: inline;"><img class="alignnone size-full wp-image-482000" src="https://www.caymancompass.com/wp-content/uploads/2020/06/american_express.png" alt="" style="margin-top:10px;" width="46" height="24"> <img class="alignnone size-full wp-image-480084" src="https://www.caymancompass.com/wp-content/uploads/2020/06/visa.png" alt="" style="margin-top:10px;" width="46" height="24"> <img class="size-full wp-image-480085" src="https://www.caymancompass.com/wp-content/uploads/2020/06/mastercard.png" alt="" width="46" height="24"></div><div class="footer-payment-links-text" style="position:relative; display: inline;"> <span style="font-weight: bold; font-family: 'Open Sans', Arial, Helvetica, sans-serif !important; font-size: 10px;text-align:center; line-height: 0; position: relative;top: -7px;">Pay securely with your Credit Card. <a href="https://www.caymancompass.com/refund-policy/">Click here to view our Refund Policy</a>.</span></div></div></div></aside></div></div></div></div><div class="td-sub-footer-container td-container-wrap td_stretch_container"><div class="td-container"><div class="td-pb-row"><div class="td-pb-span td-sub-footer-menu"><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="td-subfooter-menu"><li id="menu-item-470577" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-470577"><a href="https://www.caymancompass.com/community-standards/">Community Standards</a></li><li id="menu-item-188298" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188298"><a href="https://www.caymancompass.com/terms-of-use/">Terms and Conditions</a></li><li id="menu-item-470593" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-470593"><a href="https://www.caymancompass.com/compass-media-promotion-standard-terms-and-conditions/">Promotions T &#038; C</a></li><li id="menu-item-480083" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-480083"><a href="https://www.caymancompass.com/refund-policy/">Refund Policy</a></li><li id="menu-item-188297" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy td-menu-item td-normal-menu menu-item-188297"><a href="https://www.caymancompass.com/privacy-policy/">Privacy Policy</a></li><li id="menu-item-188296" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188296"><a href="https://www.caymancompass.com/copyright-policy-2/">Copyright</a></li><li id="menu-item-316352" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-316352"><a href="https://www.caymancompass.com/faq-2/">FAQ</a></li><li id="menu-item-480188" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-480188"><a href="https://www.caymancompass.com/contact/">Contact</a></li></ul></div></div><div class="td-pb-span td-sub-footer-copy"> &copy; Copyright Cayman Compass Ltd.</div></div></div></div></div></div>  <script type="text/javascript">var likebtn_wl = 1; (function(d, e, s) {a = d.createElement(e);m = d.getElementsByTagName(e)[0];a.async = 1;a.src = s;m.parentNode.insertBefore(a, m)})(document, 'script', '//w.likebtn.com/js/w/widget.js'); if (typeof(LikeBtn) != "undefined") { LikeBtn.init(); }</script>  
<style type="text/css" media="screen">/* custom css theme panel */
/* WOOCOMMERCE LIGHTBOX BEHIND HEADER */

.pswp {
z-index: 9999;
}
.woocommerce .product .woocommerce-tabs .panel {
    margin-top: 2em !important;
}

/* TOP MENU SUBSCRIBE BUTTON */

.top-header-menu li {
    display: inline-block;
    position: relative;
    margin-left: 0 !important;
    padding: 4px 14px;
}
.top-header-menu li.menu-item-first  {
    background-color: #a0213f !important;
}

.top-header-menu li a {
    margin-right: 0 !important;
}

.td-header-top-menu .menu-item-first {
    color: #fff;
    font-size: 13px;
    text-align: center;
    font-weight: bold;
    text-transform: uppercase;
}

.td-header-top-menu .menu-item-first, 
.td-header-top-menu .menu-item-first a, 
.td-header-wrap .td-header-top-menu-full .td-header-top-menu .menu-item-first, 
.td-header-wrap .td-header-top-menu-full .menu-item-first a,
.td-header-style-8 .td-header-top-menu .menu-item-first, 
.td-header-style-8 .td-header-top-menu .menu-item-first a, 
.td-header-top-menu .td-drop-down-search .entry-title .menu-item-first a {
    color: #fff;
}

.top-header-menu .menu-item-first.current-menu-item > a, 
/* .top-header-menu .menu-item-first .current-menu-ancestor > a, 
.top-header-menu .menu-item-first .current-category-ancestor > a, 
.td-header-sp-top-widget .menu-item-first .td-icon-search:hover*/
.top-header-menu li.menu-item-first a:hover {
    color: #eabfbf;
}</style> <script type="text/javascript">var c = document.body.className;
		c = c.replace(/woocommerce-no-js/, 'woocommerce-js');
		document.body.className = c;</script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/themes/newspaper-child/assets/js/dist/bundle.js?ver=7634365bf7d49c28fa3caebe9d3c6380b40bfd93' id='compass_front_js-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/woocommerce/assets/js/jquery-blockui/jquery.blockUI.min.js?ver=2.70' id='jquery-blockui-js'></script> <script type='text/javascript' id='wc-add-to-cart-js-extra'>var wc_add_to_cart_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","i18n_view_cart":"View cart","cart_url":"https:\/\/www.caymancompass.com\/cart\/","is_cart":"","cart_redirect_after_add":"no"};</script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/woocommerce/assets/js/frontend/add-to-cart.min.js?ver=4.3.2' id='wc-add-to-cart-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/woocommerce/assets/js/js-cookie/js.cookie.min.js?ver=2.1.4' id='js-cookie-js'></script> <script type='text/javascript' id='woocommerce-js-extra'>var woocommerce_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%"};</script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/woocommerce/assets/js/frontend/woocommerce.min.js?ver=4.3.2' id='woocommerce-js'></script> <script type='text/javascript' id='wc-cart-fragments-js-extra'>var wc_cart_fragments_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","cart_hash_key":"wc_cart_hash_4437ba34d6b5d70623e49270760f1a5e","fragment_name":"wc_fragments_4437ba34d6b5d70623e49270760f1a5e","request_timeout":"5000"};</script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/woocommerce/assets/js/frontend/cart-fragments.min.js?ver=4.3.2' id='wc-cart-fragments-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-includes/js/underscore.min.js?ver=1.8.3' id='underscore-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/td-cloud-library/assets/js/js_posts_autoload.min.js?ver=a336a33b491e4d82f056f6bf77847b68' id='tdb_js_posts_autoload-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js?ver=10.3.6.1' id='td-site-min-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-includes/js/comment-reply.min.js?ver=26c26769a97238a1e4f42d2485e91f67' id='comment-reply-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=a336a33b491e4d82f056f6bf77847b68' id='tdb_js_files_for_front-js'></script> <script type='text/javascript' id='woomc-frontend-js-extra'>var woomc = {"currentURL":"https:\/\/www.caymancompass.com\/2020\/09\/08\/teen-charged-with-stabbing\/","currency":"KYD","cookieSettings":{"name":"woocommerce_multicurrency_forced_currency","expires":31536000},"console_log":"N","settings":{"woocommerce_default_customer_address":"***"}};</script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/woocommerce-multicurrency/src/WOOMC/Frontend/dist/frontend.js?ver=2.6.3' id='woomc-frontend-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-includes/js/wp-embed.min.js?ver=26c26769a97238a1e4f42d2485e91f67' id='wp-embed-js'></script>  <script></script> </body></html>
<!-- Dynamic page generated in 0.649 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2020-09-08 19:03:36 -->

<!-- Compression = gzip -->