<!doctype html > <!--[if IE 8]><html class="ie8" lang="en"> <![endif]--> <!--[if IE 9]><html class="ie9" lang="en"> <![endif]--> <!--[if gt IE 8]><!--><html lang="en-US"> <!--<![endif]--><head><script data-cfasync="false" id="ao_optimized_gfonts_config">WebFontConfig={google:{families:["Open Sans:400,600,700","Roboto:400,500,700"] },classes:false, events:false, timeout:1500};</script><link media="all" href="https://www.caymancompass.com/wp-content/cache/autoptimize/css/autoptimize_665a9f09e2b0a955275841362009797e.css" rel="stylesheet" /><link media="only screen and (max-width: 768px)" href="https://www.caymancompass.com/wp-content/cache/autoptimize/css/autoptimize_dcb2de333eec7ab4ae31385ed8d6a393.css" rel="stylesheet" /><title>Cayman Regiment reservists showcase skills - Cayman Compass</title><meta charset="UTF-8" /><meta name="viewport" content="width=device-width, initial-scale=1.0"><link rel="pingback" href="https://www.caymancompass.com/xmlrpc.php" /><link rel="icon" type="image/png" href="https://www.caymancompass.com/wp-content/uploads/2019/10/favicon.png"><link rel="apple-touch-icon-precomposed" sizes="76x76" href="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassSqareiOSBookmarklet-76x.png"/><link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassSqareiOSBookmarklet-114x.png"/><link rel="apple-touch-icon-precomposed" sizes="152x152" href="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassSqareiOSBookmarklet-152x.png"/><link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassSqareiOSBookmarklet-114x.png"/><link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassSqareiOSBookmarklet-144x.png"/><meta name="description" content="Reservists with the Cayman Regiment put their training to the test this week as they ran through a mock hurricane exercise, together with aerial support from the RCIPS Air Operations Unit." /><meta name="robots" content="index, follow" /><meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://www.caymancompass.com/2020/08/15/cayman-regiment-reservists-showcase-skills/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Cayman Regiment reservists showcase skills - Cayman Compass" /><meta property="og:description" content="Reservists with the Cayman Regiment put their training to the test this week as they ran through a mock hurricane exercise, together with aerial support from the RCIPS Air Operations Unit." /><meta property="og:url" content="https://www.caymancompass.com/2020/08/15/cayman-regiment-reservists-showcase-skills/" /><meta property="og:site_name" content="Cayman Compass" /><meta property="article:publisher" content="https://www.facebook.com/caycompass" /><meta property="article:published_time" content="2020-08-15T21:11:41+00:00" /><meta property="og:image" content="https://www.caymancompass.com/wp-content/uploads/2020/08/10.jpeg" /><meta property="og:image:width" content="2560" /><meta property="og:image:height" content="1255" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@cayCompass" /><meta name="twitter:site" content="@cayCompass" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.caymancompass.com/#organization","name":"Cayman Compass","url":"https://www.caymancompass.com/","sameAs":["https://www.facebook.com/caycompass","https://instagram.com/cayman_compass","https://www.youtube.com/caymancompas","https://twitter.com/cayCompass"],"logo":{"@type":"ImageObject","@id":"https://www.caymancompass.com/#logo","inLanguage":"en-US","url":"https://www.caymancompass.com/wp-content/uploads/2019/10/CompassLogo-white-bgd.gif","width":400,"height":275,"caption":"Cayman Compass"},"image":{"@id":"https://www.caymancompass.com/#logo"}},{"@type":"WebSite","@id":"https://www.caymancompass.com/#website","url":"https://www.caymancompass.com/","name":"Cayman Compass","description":"The Cayman Islands&#039; Most Trusted News Source","publisher":{"@id":"https://www.caymancompass.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://www.caymancompass.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.caymancompass.com/2020/08/15/cayman-regiment-reservists-showcase-skills/#primaryimage","inLanguage":"en-US","url":"https://www.caymancompass.com/wp-content/uploads/2020/08/10.jpeg","width":2560,"height":1255},{"@type":"WebPage","@id":"https://www.caymancompass.com/2020/08/15/cayman-regiment-reservists-showcase-skills/#webpage","url":"https://www.caymancompass.com/2020/08/15/cayman-regiment-reservists-showcase-skills/","name":"Cayman Regiment reservists showcase skills - Cayman Compass","isPartOf":{"@id":"https://www.caymancompass.com/#website"},"primaryImageOfPage":{"@id":"https://www.caymancompass.com/2020/08/15/cayman-regiment-reservists-showcase-skills/#primaryimage"},"datePublished":"2020-08-15T21:11:41+00:00","dateModified":"2020-08-15T21:11:41+00:00","description":"Reservists with the Cayman Regiment put their training to the test this week as they ran through a mock hurricane exercise, together with aerial support from the RCIPS Air Operations Unit.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.caymancompass.com/2020/08/15/cayman-regiment-reservists-showcase-skills/"]}]},{"@type":"Article","@id":"https://www.caymancompass.com/2020/08/15/cayman-regiment-reservists-showcase-skills/#article","isPartOf":{"@id":"https://www.caymancompass.com/2020/08/15/cayman-regiment-reservists-showcase-skills/#webpage"},"author":{"@id":"https://www.caymancompass.com/#/schema/person/f4581e27e20096d0b0d3db81ab8b0490"},"headline":"Cayman Regiment reservists showcase skills","datePublished":"2020-08-15T21:11:41+00:00","dateModified":"2020-08-15T21:11:41+00:00","mainEntityOfPage":{"@id":"https://www.caymancompass.com/2020/08/15/cayman-regiment-reservists-showcase-skills/#webpage"},"commentCount":0,"publisher":{"@id":"https://www.caymancompass.com/#organization"},"image":{"@id":"https://www.caymancompass.com/2020/08/15/cayman-regiment-reservists-showcase-skills/#primaryimage"},"keywords":"Cayman Islands Regiment,Danielle Coleman,Governor Martyn Roper,Hazard Management Cayman Islands,Simon Watson","articleSection":"Featured,Local,Video","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://www.caymancompass.com/2020/08/15/cayman-regiment-reservists-showcase-skills/#respond"]}]},{"@type":["Person"],"@id":"https://www.caymancompass.com/#/schema/person/f4581e27e20096d0b0d3db81ab8b0490","name":"Reshma Ragoonath"}]}</script> <link rel='dns-prefetch' href='//ajax.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link href='https://fonts.gstatic.com' crossorigin='anonymous' rel='preconnect' /><link href='https://ajax.googleapis.com' rel='preconnect' /><link href='https://fonts.googleapis.com' rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="Cayman Compass &raquo; Feed" href="https://www.caymancompass.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Cayman Compass &raquo; Comments Feed" href="https://www.caymancompass.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Cayman Compass &raquo; Cayman Regiment reservists showcase skills Comments Feed" href="https://www.caymancompass.com/2020/08/15/cayman-regiment-reservists-showcase-skills/feed/" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.caymancompass.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=96176e5596a8802d2c6dc6f1cc6c8dbf"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);</script> <style type="text/css">img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}</style><link rel='stylesheet' id='jqueryuicss-css'  href='https://ajax.googleapis.com/ajax/libs/jqueryui/1.11.4/themes/smoothness/jquery-ui.css?ver=96176e5596a8802d2c6dc6f1cc6c8dbf' type='text/css' media='all' /><style id='woocommerce-inline-inline-css' type='text/css'>.woocommerce form .form-row .required { visibility: visible; }</style><style id='td-theme-inline-css' type='text/css'>@media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }</style> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/pinnacle-newsletter/pinnacle_javascript.js?ver=96176e5596a8802d2c6dc6f1cc6c8dbf' id='script1-js'></script> <script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jqueryui/1.11.4/jquery-ui.min.js?ver=96176e5596a8802d2c6dc6f1cc6c8dbf' id='jqueryui-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp' id='jquery-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/flowpaper-lite-pdf-flipbook/assets/lity/lity.min.js' id='lity-js-js'></script> <script type='text/javascript' id='likebtn_frontend-js-extra'>var likebtn_eh_data = {"ajaxurl":"https:\/\/www.caymancompass.com\/wp-admin\/admin-ajax.php","security":"5b80bee490"};</script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/likebtn-like-button/public/js/frontend.js?ver=96176e5596a8802d2c6dc6f1cc6c8dbf' id='likebtn_frontend-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/woocommerce-fac-gateways/js/tipr.min.js?ver=96176e5596a8802d2c6dc6f1cc6c8dbf' id='tipr-js-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/woocommerce-fac-gateways/js/fac-custome.js?ver=96176e5596a8802d2c6dc6f1cc6c8dbf' id='fac-custome-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/ultimate-member/assets/js/um-gdpr.min.js?ver=2.1.6' id='um-gdpr-js'></script> <link rel="https://api.w.org/" href="https://www.caymancompass.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.caymancompass.com/wp-json/wp/v2/posts/487607" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.caymancompass.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.caymancompass.com/wp-includes/wlwmanifest.xml" /><link rel='shortlink' href='https://www.caymancompass.com/?p=487607' /><link rel="alternate" type="application/json+oembed" href="https://www.caymancompass.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.caymancompass.com%2F2020%2F08%2F15%2Fcayman-regiment-reservists-showcase-skills%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.caymancompass.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.caymancompass.com%2F2020%2F08%2F15%2Fcayman-regiment-reservists-showcase-skills%2F&#038;format=xml" /><style type="text/css">.um_request_name {
				display: none !important;
			}</style><!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]--> <script>window.tdb_globals = {"wpRestNonce":"b0ab0bef41","wpRestUrl":"https:\/\/www.caymancompass.com\/wp-json\/","permalinkStructure":"\/%year%\/%monthnum%\/%day%\/%postname%\/","isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":50,"postAutoloadStatus":"off","origPostEditUrl":null};</script> <script>window.tdwGlobal = {"adminUrl":"https:\/\/www.caymancompass.com\/wp-admin\/","wpRestNonce":"b0ab0bef41","wpRestUrl":"https:\/\/www.caymancompass.com\/wp-json\/","permalinkStructure":"\/%year%\/%monthnum%\/%day%\/%postname%\/"};</script> <noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript>  <script>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</script> <style>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</style> <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-PBNB99T');</script>  <script type="application/ld+json">{
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://www.caymancompass.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.caymancompass.com/category/localnews/",
                    "name": "Local"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.caymancompass.com/2020/08/15/cayman-regiment-reservists-showcase-skills/",
                    "name": "Cayman Regiment reservists showcase skills"                                
                }
            }    
        ]
    }</script> <style>.tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,
                .tds-button2 .tdm-btn-text,
                .tds-button2 i,
                .tds-button5:hover .tdm-btn-text,
                .tds-button5:hover i,
                .tds-button6 .tdm-btn-text,
                .tds-button6 i,
                .tdm_block_list .tdm-list-item i,
                .tdm_block_pricing .tdm-pricing-feature i,
                .tdm-social-item i {
                    color: #a0213f;
                }
                .tds-button1,
                .tds-button6:after,
                .tds-title2 .tdm-title-line:after,
                .tds-title3 .tdm-title-line:after,
                .tdm_block_pricing.tdm-pricing-featured:before,
                .tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,
                .tds-progress-bar1 .tdm-progress-bar:after,
                .tds-progress-bar2 .tdm-progress-bar:after,
                .tds-social3 .tdm-social-item {
                    background-color: #a0213f;
                }
                .tds-button2:before,
                .tds-button6:before,
                .tds-progress-bar3 .tdm-progress-bar:after {
                  border-color: #a0213f;
                }
                .tdm-btn-style1 {
					background-color: #a0213f;
				}
				.tdm-btn-style2:before {
				    border-color: #a0213f;
				}
				.tdm-btn-style2 {
				    color: #a0213f;
				}
				.tdm-btn-style3 {
				    -webkit-box-shadow: 0 2px 16px #a0213f;
                    -moz-box-shadow: 0 2px 16px #a0213f;
                    box-shadow: 0 2px 16px #a0213f;
				}
				.tdm-btn-style3:hover {
				    -webkit-box-shadow: 0 4px 26px #a0213f;
                    -moz-box-shadow: 0 4px 26px #a0213f;
                    box-shadow: 0 4px 26px #a0213f;
				}</style><style id="tdw-css-placeholder"></style><script data-cfasync="false" id="ao_optimized_gfonts_webfontloader">(function() {var wf = document.createElement('script');wf.src='https://ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';wf.type='text/javascript';wf.async='true';var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(wf, s);})();</script></head><body class="post-template-default single single-post postid-487607 single-format-video theme-Newspaper td-standard-pack woocommerce-no-js woocommerce-multicurrency-KYD cayman-regiment-reservists-showcase-skills global-block-template-16 cc single_template_9 white-menu td-animation-stack-type0 td-boxed-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage"><div class="td-scroll-up"><i class="td-icon-menu-up"></i></div><div class="td-menu-background"></div><div id="td-mobile-nav"><div class="td-mobile-container"><div class="td-menu-socials-wrap"><div class="td-menu-socials"> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.facebook.com/caycompass/" title="Facebook"> <i class="td-icon-font td-icon-facebook"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.instagram.com/cayman_compass/" title="Instagram"> <i class="td-icon-font td-icon-instagram"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://twitter.com/cayCompass" title="Twitter"> <i class="td-icon-font td-icon-twitter"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.youtube.com/user/caymancompas" title="Youtube"> <i class="td-icon-font td-icon-youtube"></i> </a> </span></div><div class="td-mobile-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div></div><div class="td-mobile-content"><div class="menu-main-menu-container"><ul id="menu-main-menu" class="td-mobile-main-menu"><li id="menu-item-187846" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first menu-item-187846"><a href="https://www.caymancompass.com/">Home</a></li><li id="menu-item-187847" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-187847"><a href="https://www.caymancompass.com/cayman-news/">News<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-187848" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-187848"><a href="https://www.caymancompass.com/cayman-news/">Cayman News</a></li><li id="menu-item-471912" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-471912"><a href="https://www.caymancompass.com/issues/coronavirus-cayman/">Coronavirus (COVID-19)</a></li><li id="menu-item-463399" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-463399"><a href="https://www.caymancompass.com/business/">Business</a></li><li id="menu-item-188240" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188240"><a href="https://www.caymancompass.com/crime-and-courts/">Crime and Courts</a></li><li id="menu-item-461693" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-461693"><a href="https://www.caymancompass.com/lifestyle/">Lifestyle</a></li><li id="menu-item-461689" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-461689"><a href="https://www.caymancompass.com/sports/">Sports</a></li><li id="menu-item-485925" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-485925"><a href="https://www.caymancompass.com/tourism/">Travel and Tourism</a></li><li id="menu-item-461691" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-461691"><a href="https://www.caymancompass.com/video/">Video</a></li><li id="menu-item-461692" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-461692"><a href="https://www.caymancompass.com/weather/">Weather</a></li><li id="menu-item-484447" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-484447"><a href="https://www.caymancompass.com/storm-centre/">Cayman Storm Centre</a></li><li id="menu-item-467157" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-467157"><a href="https://www.caymancompass.com/podcasts/">Podcasts</a></li><li id="menu-item-464405" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-464405"><a href="https://www.caymancompass.com/interactive/">Interactive</a></li></ul></li><li id="menu-item-464189" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-464189"><a href="https://www.caymancompass.com/issues/">Issues<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-470185" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-470185"><a href="https://www.caymancompass.com/issues/coronavirus-cayman/">Coronavirus (COVID-19)</a></li><li id="menu-item-486325" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-486325"><a href="https://www.caymancompass.com/issues/cayman2-0/">Cayman 2.0</a></li><li id="menu-item-470131" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-470131"><a href="https://www.caymancompass.com/issues/climate-change/">Climate Change</a></li><li id="menu-item-466938" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-466938"><a href="https://www.caymancompass.com/issues/traffic/">Traffic</a></li><li id="menu-item-464188" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-464188"><a href="https://www.caymancompass.com/issues/founded-upon-the-seas/">Founded Upon the Seas</a></li><li id="menu-item-458002" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-458002"><a href="https://www.caymancompass.com/issues/port-vote-2019/">Port Vote 2019</a></li><li id="menu-item-458001" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-458001"><a href="https://www.caymancompass.com/issues/friday-features/">Friday Features</a></li><li id="menu-item-456066" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-456066"><a href="https://www.caymancompass.com/issues/sargassum/">Sargassum</a></li><li id="menu-item-471740" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-471740"><a href="https://www.caymancompass.com/issues/">All Issues Stories</a></li></ul></li><li id="menu-item-465716" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-465716"><a href="https://www.caymancompass.com/opinion/">Opinion<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-465705" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-465705"><a href="https://www.caymancompass.com/opinion/editoral/">Editorial</a></li><li id="menu-item-465695" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-465695"><a href="https://www.caymancompass.com/opinion/letters-to-the-editor/">Letters</a></li><li id="menu-item-465696" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-465696"><a href="https://www.caymancompass.com/opinion/columns/">Columns</a></li><li id="menu-item-461688" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-461688"><a href="https://www.caymancompass.com/cartoons/">Cartoons</a></li><li id="menu-item-188304" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188304"><a href="https://www.caymancompass.com/submit-letter-to-the-editor/">Write a Letter to the Editor</a></li></ul></li><li id="menu-item-188277" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-188277"><a href="/events/">Calendar<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-314306" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-314306"><a href="/events/">Event Listings</a></li><li id="menu-item-457157" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-457157"><a href="https://www.caymancompass.com/notices/">Notices</a></li><li id="menu-item-315091" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-315091"><a href="https://www.caymancompass.com/submit-event/">Submit an Event</a></li><li id="menu-item-463065" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-463065"><a href="https://www.caymancompass.com/cayman-islands-public-holidays-2020/">Cayman Islands Public Holidays 2020</a></li></ul></li><li id="menu-item-373520" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-373520"><a href="#">Our Brands<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-483740" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-483740"><a href="https://www.caymancompass.com/emergency-guide/">Emergency Guide</a></li><li id="menu-item-480091" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-480091"><a href="http://caymaniancompass.cay.newsmemory.com/?special=Hailing+our+Heroes">Hailing Our Heroes</a></li><li id="menu-item-373529" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-373529"><a href="http://caymanhealth.com/">Cayman Health</a></li><li id="menu-item-470176" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-470176"><a href="http://caymaniancompass.cay.newsmemory.com/?special=Careers">Careers Guide</a></li><li id="menu-item-466685" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-466685"><a href="https://www.caymancompass.com/wellness-feature/">Wellness Feature</a></li><li id="menu-item-460236" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-460236"><a href="https://www.caymancompass.com/women-in-business/">Women In Business</a></li><li id="menu-item-373523" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-373523"><a href="http://www.flava.ky">Flava</a></li><li id="menu-item-188285" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188285"><a href="https://www.caymancompass.com/special-features-and-publications/">Special Features and Publications</a></li><li id="menu-item-399126" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-399126"><a href="https://www.compassmedia.ky">All Publications</a></li></ul></li><li id="menu-item-188276" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-188276"><a href="#">More<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-461690" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-461690"><a href="https://www.caymancompass.com/subscribe/">Subscribe to Newsletter</a></li><li id="menu-item-465825" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-465825"><a href="https://www.caymancompass.com/contact/">Contact</a></li><li id="menu-item-482735" class="menu-item menu-item-type-post_type menu-item-object-product menu-item-482735"><a href="https://www.caymancompass.com/store/donate/">Donate &#8211; Support Local Journalism</a></li><li id="menu-item-188280" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188280"><a href="https://www.caymancompass.com/advertise-with-us/">Advertise With Us</a></li><li id="menu-item-482734" class="menu-item menu-item-type-post_type menu-item-object-product menu-item-482734"><a href="https://www.caymancompass.com/store/pay-bill/">Pay Bill</a></li><li id="menu-item-371483" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-371483"><a target="_blank" href="https://www.caymancompass.com/wp-content/uploads/2019/12/Compass-Print-Media-Kit.pdf">Print Media Kit</a></li><li id="menu-item-389921" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-389921"><a href="https://www.caymancompass.com/wp-content/uploads/2020/05/CompassDigitalMediaKit-UpdatedInventory-2020b.pdf">Online Media Kit</a></li><li id="menu-item-188275" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188275"><a href="https://www.caymancompass.com/contests/">Contests</a></li><li id="menu-item-359853" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-359853"><a href="https://www.caymancompass.com/editorial-staff/">Editorial Staff</a></li><li id="menu-item-188303" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188303"><a href="https://www.caymancompass.com/submit-a-story-idea/">Submit a Story Idea</a></li><li id="menu-item-471913" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-471913"><a href="https://www.caymancompass.com/newspaper-home-delivery/">Newspaper Home Delivery</a></li><li id="menu-item-188284" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-188284"><a href="https://www.caymancompass.com/privacy-policy/">Privacy Policy</a></li><li id="menu-item-188282" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188282"><a href="https://www.caymancompass.com/copyright-policy-2/">Copyright Policy</a></li><li id="menu-item-314305" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-314305"><a href="https://www.caymancompass.com/terms-of-use/">Terms and Conditions of Use</a></li><li id="menu-item-380233" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-380233"><a href="https://www.caymancompass.com/rss-feeds-information/">RSS Feed Information</a></li></ul></li></ul></div></div></div><div id="login-form-mobile" class="td-register-section"><div id="td-login-mob" class="td-login-animation td-login-hide-mob"><div class="td-login-close"> <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a><div class="td-login-title">Sign in</div><div class="td-mobile-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div></div><div class="td-login-form-wrap"><div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div><div class="td_display_err"></div><div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div><div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div> <input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN"><div class="td-login-info-text"> <a href="#" id="forgot-pass-link-mob">Forgot your password?</a></div><div class="td-login-register-link"> <a id="signin-register-link-mob" href="https://www.caymancompass.com/register/">Join</a></div><div class="td-login-info-text"><a class="privacy-policy-link" href="https://www.caymancompass.com/privacy-policy/">Privacy Policy</a></div></div></div><div id="td-register-mob" class="td-login-animation td-login-hide-mob"><div class="td-register-close"> <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a><div class="td-login-title">Sign up</div><div class="td-mobile-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div></div><div class="td-login-panel-title"><span>Redirecting...</div></div><div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob"><div class="td-forgot-pass-close"> <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a><div class="td-login-title">Password recovery</div></div><div class="td-login-form-wrap"><div class="td-login-panel-title">Recover your password</div><div class="td_display_err"></div><div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div> <input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass"></div></div></div></div><div class="td-search-background"></div><div class="td-search-wrap-mob"><div class="td-drop-down-search"><form method="get" class="td-search-form" action="https://www.caymancompass.com/"><div class="td-search-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div><div role="search" class="td-search-input"> <span>Search</span> <input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" /></div></form><div id="td-aj-search-mob" class="td-ajax-search-flex"></div></div></div><div id="td-outer-wrap" class="td-theme-wrap"><div class="tdc-header-wrap "><div class="td-header-wrap td-header-style-1 "><div class="td-header-top-menu-full td-container-wrap td_stretch_container"><div class="td-container td-header-row td-header-top-menu"><div class="top-bar-style-1"><div class="td-header-sp-top-menu"><div class="menu-top-container"><ul id="menu-top-menu" class="top-header-menu"><li id="menu-item-461694" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-461694"><a href="https://www.caymancompass.com/subscribe/">Subscribe</a></li><li id="menu-item-384346" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-384346"><a href="https://www.caymancompass.com/members/">Members</a><ul class="sub-menu"><li id="menu-item-384351" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-384351"><a href="https://www.caymancompass.com/login/">Login</a></li><li id="menu-item-384348" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-384348"><a href="https://www.caymancompass.com/password-reset/">Password Reset</a></li><li id="menu-item-384349" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-384349"><a href="https://www.caymancompass.com/register/">Register</a></li></ul></li><li id="menu-item-428186" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-428186"><a href="https://www.caymancompass.com/advertise-with-us/">Advertise</a></li><li id="menu-item-316348" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-316348"><a href="https://www.caymancompass.com/faq/">Help</a></li></ul></div></div><div class="td-header-sp-top-widget"> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.facebook.com/caycompass/" title="Facebook"> <i class="td-icon-font td-icon-facebook"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.instagram.com/cayman_compass/" title="Instagram"> <i class="td-icon-font td-icon-instagram"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://twitter.com/cayCompass" title="Twitter"> <i class="td-icon-font td-icon-twitter"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.youtube.com/user/caymancompas" title="Youtube"> <i class="td-icon-font td-icon-youtube"></i> </a> </span></div></div><div  id="login-form" class="white-popup-block mfp-hide mfp-with-anim"><div class="td-login-wrap"> <a href="#" class="td-back-button"><i class="td-icon-modal-back"></i></a><div id="td-login-div" class="td-login-form-div td-display-block"><div class="td-login-panel-title">Sign in</div><div class="td-login-panel-descr">Welcome. Log into your account</div><div class="td_display_err"></div><div class="mobile-facebook-login"style="margin-bottom: 10px;"><div class="um um-shortcode-social" id="um-shortcode-social-381831" style="padding:;margin:!important;"><div class="um-field"><div class="um-col-alt"><div  class="um-left um-half"> <a href="?oauthWindow=true&#038;provider=facebook&#038;um_sso=381831" title="Connect with Facebook"
 class="um-button um-alt um-button-social um-button-facebook" data-redirect-url="https://www.caymancompass.com/2020/08/15/cayman-regiment-reservists-showcase-skills"  onclick="um_social_login_oauth_window( this.href,'authWindow', 'width=600,height=600,scrollbars=yes' );return false;"> <i class="um-faicon-facebook-square" style="margin-right: 8px;"></i> <span>Connect with Facebook</span> </a></div><div class="um-clear"></div></div></div><style type="text/css">div#um-shortcode-social-381831 div.um-field {padding: 0}

		div#um-shortcode-social-381831 a.um-button.um-button-social {
			font-size: 15px;
			padding: 16px 20px !important;
		}

		div#um-shortcode-social-381831 a.um-button.um-button-social i {
			font-size: 18px;
			width: 18px;
			top: auto;
			vertical-align: baseline !important;
			margin-right: 0;
		}

		
			div#um-shortcode-social-381831 div.um-field {margin:0 auto; max-width: 696px}

		
			div#um-shortcode-social-381831 a.um-button.um-button-facebook {background-color: #4267B2!important}
			div#um-shortcode-social-381831 a.um-button.um-button-facebook:hover {background-color: #365899!important}
			div#um-shortcode-social-381831 a.um-button.um-button-facebook {color: #fff!important}</style></div></div><div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email" value="" required><label>your username</label></div><div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" required><label>your password</label></div> <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login"><div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div> <a id="register-link" href="https://www.caymancompass.com/register/">Create an account</a><div class="td-login-info-text"><a class="privacy-policy-link" href="https://www.caymancompass.com/privacy-policy/">Privacy Policy</a></div></div><div id="td-register-div" class="td-login-form-div td-display-none"><div class="td-login-panel-title">Redirecting...</div></div><div id="td-forgot-pass-div" class="td-login-form-div td-display-none"><div class="td-login-panel-title">Password recovery</div><div class="td-login-panel-descr">Recover your password</div><div class="td_display_err"></div><div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label>your email</label></div> <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password"><div class="td-login-info-text">A password will be e-mailed to you.</div></div></div></div></div></div><div class="td-banner-wrap-full td-logo-wrap-full td-container-wrap td_stretch_container"><div class="td-container td-header-row td-header-header"><div class="td-header-sp-logo"> <a class="td-main-logo" href="https://www.caymancompass.com/"> <img class="td-retina-data" data-retina="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassLogoNew544x180.png" src="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassLogoNew-272x90.png" alt="Cayman Compass" title="The most trusted news source in the Cayman Islands"/> <span class="td-visual-hidden">Cayman Compass</span> </a></div><div class="td-header-sp-recs"><div class="td-header-rec-wrap"><div class="td-a-rec td-a-rec-id-header  tdi_1_28c td_block_template_16"><style>/* custom css */
.tdi_1_28c.td-a-rec{
					text-align: center;
				}.tdi_1_28c .td-element-style{
					z-index: -1;
				}.tdi_1_28c.td-a-rec-img{
				    text-align: left;
				}.tdi_1_28c.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_1_28c.td-a-rec-img {
				        text-align: center;
				    }
                }</style><div class="td-visible-all-devices">  <script type="text/javascript">if (!window.AdButler){(function(){var s = document.createElement("script"); s.async = true; s.type = "text/javascript";s.src = 'https://servedbyadbutler.com/app.js';var n = document.getElementsByTagName("script")[0]; n.parentNode.insertBefore(s, n);}());}</script> <script type="text/javascript">var AdButler = AdButler || {}; AdButler.ads = AdButler.ads || [];
var abkw = window.abkw || '';
var plc197225 = window.plc197225 || 0;
document.write('<'+'div id="placement_197225_'+plc197225+'"></'+'div>');
AdButler.ads.push({handler: function(opt){ AdButler.register(165413, 197225, [728,90], 'placement_197225_'+opt.place, opt); }, opt: { place: plc197225++, keywords: abkw, domain: 'servedbyadbutler.com', click:'CLICK_MACRO_PLACEHOLDER' }});</script> </div></div></div></div></div></div><div class="td-header-menu-wrap-full td-container-wrap td_stretch_container"><div class="td-header-menu-wrap td-header-gradient "><div class="td-container td-header-row td-header-main-menu"><div id="td-header-menu" role="navigation"><div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div><div class="td-main-menu-logo td-logo-in-header"> <a class="td-mobile-logo td-sticky-header" href="https://www.caymancompass.com/"> <img class="td-retina-data" data-retina="https://www.caymancompass.com/wp-content/uploads/2019/10/CaymanCompassLogoWhiteNew280x96.png" src="https://www.caymancompass.com/wp-content/uploads/2019/10/CaymanCompassLogoWhiteNew140x48.png" alt="Cayman Compass" title="The most trusted news source in the Cayman Islands"/> </a> <a class="td-header-logo td-sticky-header" href="https://www.caymancompass.com/"> <img class="td-retina-data" data-retina="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassLogoNew544x180.png" src="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassLogoNew-272x90.png" alt="Cayman Compass" title="The most trusted news source in the Cayman Islands"/> </a></div><div class="menu-main-menu-container"><ul id="menu-main-menu-1" class="sf-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-187846"><a href="https://www.caymancompass.com/">Home</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-187847"><a href="https://www.caymancompass.com/cayman-news/">News</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-187848"><a href="https://www.caymancompass.com/cayman-news/">Cayman News</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-471912"><a href="https://www.caymancompass.com/issues/coronavirus-cayman/">Coronavirus (COVID-19)</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-463399"><a href="https://www.caymancompass.com/business/">Business</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188240"><a href="https://www.caymancompass.com/crime-and-courts/">Crime and Courts</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-461693"><a href="https://www.caymancompass.com/lifestyle/">Lifestyle</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-461689"><a href="https://www.caymancompass.com/sports/">Sports</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-485925"><a href="https://www.caymancompass.com/tourism/">Travel and Tourism</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-461691"><a href="https://www.caymancompass.com/video/">Video</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-461692"><a href="https://www.caymancompass.com/weather/">Weather</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-484447"><a href="https://www.caymancompass.com/storm-centre/">Cayman Storm Centre</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-467157"><a href="https://www.caymancompass.com/podcasts/">Podcasts</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-464405"><a href="https://www.caymancompass.com/interactive/">Interactive</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-464189"><a href="https://www.caymancompass.com/issues/">Issues</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-470185"><a href="https://www.caymancompass.com/issues/coronavirus-cayman/">Coronavirus (COVID-19)</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-486325"><a href="https://www.caymancompass.com/issues/cayman2-0/">Cayman 2.0</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-470131"><a href="https://www.caymancompass.com/issues/climate-change/">Climate Change</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-466938"><a href="https://www.caymancompass.com/issues/traffic/">Traffic</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-464188"><a href="https://www.caymancompass.com/issues/founded-upon-the-seas/">Founded Upon the Seas</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-458002"><a href="https://www.caymancompass.com/issues/port-vote-2019/">Port Vote 2019</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-458001"><a href="https://www.caymancompass.com/issues/friday-features/">Friday Features</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-456066"><a href="https://www.caymancompass.com/issues/sargassum/">Sargassum</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-471740"><a href="https://www.caymancompass.com/issues/">All Issues Stories</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-465716"><a href="https://www.caymancompass.com/opinion/">Opinion</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-465705"><a href="https://www.caymancompass.com/opinion/editoral/">Editorial</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-465695"><a href="https://www.caymancompass.com/opinion/letters-to-the-editor/">Letters</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-465696"><a href="https://www.caymancompass.com/opinion/columns/">Columns</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-461688"><a href="https://www.caymancompass.com/cartoons/">Cartoons</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188304"><a href="https://www.caymancompass.com/submit-letter-to-the-editor/">Write a Letter to the Editor</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-188277"><a href="/events/">Calendar</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-314306"><a href="/events/">Event Listings</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-457157"><a href="https://www.caymancompass.com/notices/">Notices</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-315091"><a href="https://www.caymancompass.com/submit-event/">Submit an Event</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-463065"><a href="https://www.caymancompass.com/cayman-islands-public-holidays-2020/">Cayman Islands Public Holidays 2020</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-373520"><a href="#">Our Brands</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-483740"><a href="https://www.caymancompass.com/emergency-guide/">Emergency Guide</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-480091"><a href="http://caymaniancompass.cay.newsmemory.com/?special=Hailing+our+Heroes">Hailing Our Heroes</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-373529"><a href="http://caymanhealth.com/">Cayman Health</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-470176"><a href="http://caymaniancompass.cay.newsmemory.com/?special=Careers">Careers Guide</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-466685"><a href="https://www.caymancompass.com/wellness-feature/">Wellness Feature</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-460236"><a href="https://www.caymancompass.com/women-in-business/">Women In Business</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-373523"><a href="http://www.flava.ky">Flava</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188285"><a href="https://www.caymancompass.com/special-features-and-publications/">Special Features and Publications</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-399126"><a href="https://www.compassmedia.ky">All Publications</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-188276"><a href="#">More</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-461690"><a href="https://www.caymancompass.com/subscribe/">Subscribe to Newsletter</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-465825"><a href="https://www.caymancompass.com/contact/">Contact</a></li><li class="menu-item menu-item-type-post_type menu-item-object-product td-menu-item td-normal-menu menu-item-482735"><a href="https://www.caymancompass.com/store/donate/">Donate &#8211; Support Local Journalism</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188280"><a href="https://www.caymancompass.com/advertise-with-us/">Advertise With Us</a></li><li class="menu-item menu-item-type-post_type menu-item-object-product td-menu-item td-normal-menu menu-item-482734"><a href="https://www.caymancompass.com/store/pay-bill/">Pay Bill</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-371483"><a target="_blank" href="https://www.caymancompass.com/wp-content/uploads/2019/12/Compass-Print-Media-Kit.pdf">Print Media Kit</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-389921"><a href="https://www.caymancompass.com/wp-content/uploads/2020/05/CompassDigitalMediaKit-UpdatedInventory-2020b.pdf">Online Media Kit</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188275"><a href="https://www.caymancompass.com/contests/">Contests</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-359853"><a href="https://www.caymancompass.com/editorial-staff/">Editorial Staff</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188303"><a href="https://www.caymancompass.com/submit-a-story-idea/">Submit a Story Idea</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-471913"><a href="https://www.caymancompass.com/newspaper-home-delivery/">Newspaper Home Delivery</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy td-menu-item td-normal-menu menu-item-188284"><a href="https://www.caymancompass.com/privacy-policy/">Privacy Policy</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188282"><a href="https://www.caymancompass.com/copyright-policy-2/">Copyright Policy</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-314305"><a href="https://www.caymancompass.com/terms-of-use/">Terms and Conditions of Use</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-380233"><a href="https://www.caymancompass.com/rss-feeds-information/">RSS Feed Information</a></li></ul></li></ul></div></div><div class="header-search-wrap"><div class="td-search-btns-wrap"> <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a> <a id="td-header-search-button-mob" href="#" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a></div><div class="td-drop-down-search" aria-labelledby="td-header-search-button"><form method="get" class="td-search-form" action="https://www.caymancompass.com/"><div role="search" class="td-head-form-search-wrap"> <input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" /></div></form><div id="td-aj-search"></div></div></div></div></div></div></div></div><article id="post-487607" class="td-post-template-9 post-487607 post type-post status-publish format-video has-post-thumbnail category-featured category-localnews category-video tag-cayman-islands-regiment tag-danielle-coleman tag-governor-martyn-roper tag-hazard-management-cayman-islands tag-simon-watson post_format-post-format-video td-container-wrap" itemscope itemtype="https://schema.org/Article"><div class="td-container"><div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://www.caymancompass.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Local" class="entry-crumb" href="https://www.caymancompass.com/category/localnews/">Local</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Cayman Regiment reservists showcase skills</span></div></div><div class="td-post-featured-video"><div class="wpb_video_wrapper"> <iframe class="td-youtube-player" width="600" height="560" src="https://www.youtube.com/embed/3BhNDpeiKtE?enablejsapi=1&feature=oembed&wmode=opaque&vq=hd720&&&" frameborder="0" allowfullscreen="" allow="autoplay"></iframe></div> <script type="text/javascript">jQuery().ready(function() {
                            tdShowVideo.loadApiYoutube(); 
                        });</script> </div></div><div class="td-container"><div class="td-pb-row"><div class="td-pb-span8 td-main-content" role="main"><div class="td-ss-main-content"><div class="td-post-header"><ul class="td-category"><li class="entry-category"><a  href="https://www.caymancompass.com/category/localnews/">Local</a></li><li class="entry-category"><a  href="https://www.caymancompass.com/category/video/">Video</a></li></ul><header class="td-post-title"><h1 class="entry-title">Cayman Regiment reservists showcase skills</h1><div class="td-module-meta-info"><div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://www.caymancompass.com/author/rragoonath/">Reshma Ragoonath</a><div class="td-author-line"> -</div></div> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-08-15T16:11:41-05:00" >August 15, 2020</time></span></div></header></div><div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-bg td-ps-notext td-ps-rounded td-post-sharing-style3 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.caymancompass.com%2F2020%2F08%2F15%2Fcayman-regiment-reservists-showcase-skills%2F"><div class="td-social-but-icon"><i class="td-icon-facebook"></i></div><div class="td-social-but-text">Facebook</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Cayman+Regiment+reservists+showcase+skills&url=https%3A%2F%2Fwww.caymancompass.com%2F2020%2F08%2F15%2Fcayman-regiment-reservists-showcase-skills%2F&via=cayCompass"><div class="td-social-but-icon"><i class="td-icon-twitter"></i></div><div class="td-social-but-text">Twitter</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=Cayman+Regiment+reservists+showcase+skills %0A%0A https://www.caymancompass.com/2020/08/15/cayman-regiment-reservists-showcase-skills/"><div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div><div class="td-social-but-text">WhatsApp</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="/cdn-cgi/l/email-protection#201f5355424a4543541d6341594d414e00724547494d454e5400524553455256495354530053484f574341534500534b494c4c5306424f44591d48545450531a0f0f5757570e4341594d414e434f4d504153530e434f4d0f121012100f10180f11150f4341594d414e0d524547494d454e540d524553455256495354530d53484f57434153450d534b494c4c530f"><div class="td-social-but-icon"><i class="td-icon-mail"></i></div><div class="td-social-but-text">Email</div> </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top"><div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div> </a></div></div></div><div class="td-post-content tagdiv-type"><div class="td-a-rec td-a-rec-id-content_top  tdi_4_558 td_block_template_16"><style>/* custom css */
.tdi_4_558.td-a-rec{
					text-align: center;
				}.tdi_4_558 .td-element-style{
					z-index: -1;
				}.tdi_4_558.td-a-rec-img{
				    text-align: left;
				}.tdi_4_558.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_4_558.td-a-rec-img {
				        text-align: center;
				    }
                }</style><div id="isb_phone_advert" class="td-visible-phone">  <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">var elem = document.getElementById("isb_phone_advert");
var theCSSprop = window.getComputedStyle(elem,null).getPropertyValue("display");
if (theCSSprop!="none"){


var rnd = window.rnd || Math.floor(Math.random()*10e6);
var pid420687 = window.pid420687 || rnd;
var plc420687 = window.plc420687 || 0;
var abkw = window.abkw || '';
var absrc = 'https://servedbyadbutler.com/adserve/;ID=165413;size=0x0;setID=420687;type=js;sw='+screen.width+';sh='+screen.height+';spr='+window.devicePixelRatio+';kw='+abkw+';pid='+pid420687+';place='+(plc420687++)+';rnd='+rnd+';click=CLICK_MACRO_PLACEHOLDER';
document.write('<scr'+'ipt src="'+absrc+'" type="text/javascript"></scr'+'ipt>');

}else{
}</script> </div></div><p>Reservists with the Cayman Regiment put their training to the test this week as they ran through a mock hurricane exercise, together with aerial support from the RCIPS Air Operations Unit.</p><p>The 51-strong platoon is nearing the end of its two weeks of training, and the reservists are set to graduate on Sunday.</p><p>This week, Cabinet published a special exemption to the current COVID-19 regulations to permit &#8216;a uniformed service to hold a procession&#8217;. Under the regulation exemption, a uniformed service means &#8216;(a) a naval force, including the Coast Guard; (b) a regiment; and (c) a police force, fire service or prison service&#8217;. This will allow for a regiment passing-out ceremony.</p><p>On Wednesday, the reservists set up camp at the Agriculture Grounds in Lower Valley where they executed the mock exercises. They installed shelters, &#8216;roughed it&#8217; without modern-day comforts such as electricity and running water, and even had to eat food from ration packs as part of their preparation for their new role.</p><p>They also had to liaise with the Air Operations Unit to carry out a medevac which was executed with the use of one of the two police helicopters.</p><div class="td-a-rec td-a-rec-id-content_inline  tdi_3_333 td_block_template_16"><style>/* custom css */
.tdi_3_333.td-a-rec{
					text-align: center;
				}.tdi_3_333 .td-element-style{
					z-index: -1;
				}.tdi_3_333.td-a-rec-img{
				    text-align: left;
				}.tdi_3_333.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_3_333.td-a-rec-img {
				        text-align: center;
				    }
                }</style><div class="td-all-devices in-article-lb-ad">  <script type="text/javascript">var rnd = window.rnd || Math.floor(Math.random()*10e6);
var pid420688 = window.pid420688 || rnd;
var plc420688 = window.plc420688 || 0;
var abkw = window.abkw || '';
var absrc = 'https://servedbyadbutler.com/adserve/;ID=165413;size=0x0;setID=420688;type=js;sw='+screen.width+';sh='+screen.height+';spr='+window.devicePixelRatio+';kw='+abkw+';pid='+pid420688+';place='+(plc420688++)+';rnd='+rnd+';click=CLICK_MACRO_PLACEHOLDER';
document.write('<scr'+'ipt src="'+absrc+'" type="text/javascript"></scr'+'ipt>');</script> </div></div><p>Governor Martyn Roper, who was on hand for part of the training exercise, told the <em>Cayman Compass</em> he was pleased by what he saw and the progress the regiment has made.</p><p>“I&#8217;m very proud and I know that the premier is very proud,” he said.</p><p>He said the passing-out ceremony for the reservists this weekend will be a historic one for Cayman and the new defence entity.</p><style type="text/css">#tdi_2_8f7  .td-doubleSlider-2 .td-item1 {
                        background: url(https://www.caymancompass.com/wp-content/uploads/2020/08/1-80x60.jpeg) 0 0 no-repeat;
                    }
                    #tdi_2_8f7  .td-doubleSlider-2 .td-item2 {
                        background: url(https://www.caymancompass.com/wp-content/uploads/2020/08/2-80x60.jpeg) 0 0 no-repeat;
                    }
                    #tdi_2_8f7  .td-doubleSlider-2 .td-item3 {
                        background: url(https://www.caymancompass.com/wp-content/uploads/2020/08/3-80x60.jpeg) 0 0 no-repeat;
                    }
                    #tdi_2_8f7  .td-doubleSlider-2 .td-item4 {
                        background: url(https://www.caymancompass.com/wp-content/uploads/2020/08/4-80x60.jpeg) 0 0 no-repeat;
                    }
                    #tdi_2_8f7  .td-doubleSlider-2 .td-item5 {
                        background: url(https://www.caymancompass.com/wp-content/uploads/2020/08/5-80x60.jpeg) 0 0 no-repeat;
                    }
                    #tdi_2_8f7  .td-doubleSlider-2 .td-item6 {
                        background: url(https://www.caymancompass.com/wp-content/uploads/2020/08/6-80x60.jpeg) 0 0 no-repeat;
                    }
                    #tdi_2_8f7  .td-doubleSlider-2 .td-item7 {
                        background: url(https://www.caymancompass.com/wp-content/uploads/2020/08/7-80x60.jpeg) 0 0 no-repeat;
                    }
                    #tdi_2_8f7  .td-doubleSlider-2 .td-item8 {
                        background: url(https://www.caymancompass.com/wp-content/uploads/2020/08/8-80x60.jpeg) 0 0 no-repeat;
                    }
                    #tdi_2_8f7  .td-doubleSlider-2 .td-item9 {
                        background: url(https://www.caymancompass.com/wp-content/uploads/2020/08/9-80x60.jpeg) 0 0 no-repeat;
                    }
                    #tdi_2_8f7  .td-doubleSlider-2 .td-item10 {
                        background: url(https://www.caymancompass.com/wp-content/uploads/2020/08/10-80x60.jpeg) 0 0 no-repeat;
                    }
                    #tdi_2_8f7  .td-doubleSlider-2 .td-item11 {
                        background: url(https://www.caymancompass.com/wp-content/uploads/2020/08/11-80x60.jpeg) 0 0 no-repeat;
                    }
                    #tdi_2_8f7  .td-doubleSlider-2 .td-item12 {
                        background: url(https://www.caymancompass.com/wp-content/uploads/2020/08/12-80x60.jpeg) 0 0 no-repeat;
                    }</style><div id="tdi_2_8f7" class="td-gallery td-slide-on-2-columns"><div class="post_td_gallery"><div class="td-gallery-slide-top"><div class="td-gallery-title"></div><div class="td-gallery-controls-wrapper"><div class="td-gallery-slide-count"><span class="td-gallery-slide-item-focus">1</span> of 12</div><div class="td-gallery-slide-prev-next-but"> <i class = "td-icon-left doubleSliderPrevButton"></i> <i class = "td-icon-right doubleSliderNextButton"></i></div></div></div><div class = "td-doubleSlider-1 "><div class = "td-slider"><div class = "td-slide-item td-item1"><figure class="td-slide-galery-figure td-slide-popup-gallery"> <a class="slide-gallery-image-link" href="https://www.caymancompass.com/wp-content/uploads/2020/08/1.jpeg" title="1"  data-caption="The Cayman Islands Regiment take part in a training exercise on Wednesday. Photos: Alvaro Serey."  data-description=""> <img src="https://www.caymancompass.com/wp-content/uploads/2020/08/1-697x420.jpeg" srcset="https://www.caymancompass.com/wp-content/uploads/2020/08/1-697x420.jpeg 697w, https://www.caymancompass.com/wp-content/uploads/2020/08/1-300x181.jpeg 300w, https://www.caymancompass.com/wp-content/uploads/2020/08/1-1536x925.jpeg 1536w, https://www.caymancompass.com/wp-content/uploads/2020/08/1-2048x1234.jpeg 2048w, https://www.caymancompass.com/wp-content/uploads/2020/08/1-696x419.jpeg 696w, https://www.caymancompass.com/wp-content/uploads/2020/08/1-1068x643.jpeg 1068w, https://www.caymancompass.com/wp-content/uploads/2020/08/1-1920x1157.jpeg 1920w, https://www.caymancompass.com/wp-content/uploads/2020/08/1-600x361.jpeg 600w" sizes="(max-width: 697px) 100vw, 697px" alt=""> </a><figcaption class = "td-slide-caption td-gallery-slide-content"><div class = "td-gallery-slide-copywrite">The Cayman Islands Regiment take part in a training exercise on Wednesday. Photos: Alvaro Serey.</div></figcaption></figure></div><div class = "td-slide-item td-item2"><figure class="td-slide-galery-figure td-slide-popup-gallery"> <a class="slide-gallery-image-link" href="https://www.caymancompass.com/wp-content/uploads/2020/08/2.jpeg" title="2"  data-caption=""  data-description=""> <img src="https://www.caymancompass.com/wp-content/uploads/2020/08/2-630x420.jpeg" srcset="https://www.caymancompass.com/wp-content/uploads/2020/08/2-630x420.jpeg 630w, https://www.caymancompass.com/wp-content/uploads/2020/08/2-300x200.jpeg 300w, https://www.caymancompass.com/wp-content/uploads/2020/08/2-1536x1025.jpeg 1536w, https://www.caymancompass.com/wp-content/uploads/2020/08/2-2048x1366.jpeg 2048w, https://www.caymancompass.com/wp-content/uploads/2020/08/2-696x464.jpeg 696w, https://www.caymancompass.com/wp-content/uploads/2020/08/2-1068x713.jpeg 1068w, https://www.caymancompass.com/wp-content/uploads/2020/08/2-1920x1281.jpeg 1920w, https://www.caymancompass.com/wp-content/uploads/2020/08/2-600x400.jpeg 600w" sizes="(max-width: 630px) 100vw, 630px" alt=""> </a></figure></div><div class = "td-slide-item td-item3"><figure class="td-slide-galery-figure td-slide-popup-gallery"> <a class="slide-gallery-image-link" href="https://www.caymancompass.com/wp-content/uploads/2020/08/3.jpeg" title="3"  data-caption=""  data-description=""> <img src="https://www.caymancompass.com/wp-content/uploads/2020/08/3-608x420.jpeg" srcset="https://www.caymancompass.com/wp-content/uploads/2020/08/3-608x420.jpeg 608w, https://www.caymancompass.com/wp-content/uploads/2020/08/3-300x207.jpeg 300w, https://www.caymancompass.com/wp-content/uploads/2020/08/3-1536x1061.jpeg 1536w, https://www.caymancompass.com/wp-content/uploads/2020/08/3-2048x1415.jpeg 2048w, https://www.caymancompass.com/wp-content/uploads/2020/08/3-218x150.jpeg 218w, https://www.caymancompass.com/wp-content/uploads/2020/08/3-696x481.jpeg 696w, https://www.caymancompass.com/wp-content/uploads/2020/08/3-1068x738.jpeg 1068w, https://www.caymancompass.com/wp-content/uploads/2020/08/3-1920x1327.jpeg 1920w, https://www.caymancompass.com/wp-content/uploads/2020/08/3-100x70.jpeg 100w, https://www.caymancompass.com/wp-content/uploads/2020/08/3-600x415.jpeg 600w" sizes="(max-width: 608px) 100vw, 608px" alt=""> </a></figure></div><div class = "td-slide-item td-item4"><figure class="td-slide-galery-figure td-slide-popup-gallery"> <a class="slide-gallery-image-link" href="https://www.caymancompass.com/wp-content/uploads/2020/08/4.jpeg" title="4"  data-caption=""  data-description=""> <img src="https://www.caymancompass.com/wp-content/uploads/2020/08/4-677x420.jpeg" srcset="https://www.caymancompass.com/wp-content/uploads/2020/08/4-677x420.jpeg 677w, https://www.caymancompass.com/wp-content/uploads/2020/08/4-300x186.jpeg 300w, https://www.caymancompass.com/wp-content/uploads/2020/08/4-1536x953.jpeg 1536w, https://www.caymancompass.com/wp-content/uploads/2020/08/4-2048x1271.jpeg 2048w, https://www.caymancompass.com/wp-content/uploads/2020/08/4-696x432.jpeg 696w, https://www.caymancompass.com/wp-content/uploads/2020/08/4-1068x663.jpeg 1068w, https://www.caymancompass.com/wp-content/uploads/2020/08/4-1920x1192.jpeg 1920w, https://www.caymancompass.com/wp-content/uploads/2020/08/4-356x220.jpeg 356w, https://www.caymancompass.com/wp-content/uploads/2020/08/4-600x372.jpeg 600w" sizes="(max-width: 677px) 100vw, 677px" alt=""> </a></figure></div><div class = "td-slide-item td-item5"><figure class="td-slide-galery-figure td-slide-popup-gallery"> <a class="slide-gallery-image-link" href="https://www.caymancompass.com/wp-content/uploads/2020/08/5.jpeg" title="5"  data-caption=""  data-description=""> <img src="https://www.caymancompass.com/wp-content/uploads/2020/08/5-758x420.jpeg" srcset="https://www.caymancompass.com/wp-content/uploads/2020/08/5-758x420.jpeg 758w, https://www.caymancompass.com/wp-content/uploads/2020/08/5-300x166.jpeg 300w, https://www.caymancompass.com/wp-content/uploads/2020/08/5-1536x851.jpeg 1536w, https://www.caymancompass.com/wp-content/uploads/2020/08/5-2048x1134.jpeg 2048w, https://www.caymancompass.com/wp-content/uploads/2020/08/5-696x385.jpeg 696w, https://www.caymancompass.com/wp-content/uploads/2020/08/5-1068x592.jpeg 1068w, https://www.caymancompass.com/wp-content/uploads/2020/08/5-1920x1064.jpeg 1920w, https://www.caymancompass.com/wp-content/uploads/2020/08/5-600x332.jpeg 600w" sizes="(max-width: 758px) 100vw, 758px" alt=""> </a></figure></div><div class = "td-slide-item td-item6"><figure class="td-slide-galery-figure td-slide-popup-gallery"> <a class="slide-gallery-image-link" href="https://www.caymancompass.com/wp-content/uploads/2020/08/6.jpeg" title="6"  data-caption=""  data-description=""> <img src="https://www.caymancompass.com/wp-content/uploads/2020/08/6-627x420.jpeg" srcset="https://www.caymancompass.com/wp-content/uploads/2020/08/6-627x420.jpeg 627w, https://www.caymancompass.com/wp-content/uploads/2020/08/6-300x201.jpeg 300w, https://www.caymancompass.com/wp-content/uploads/2020/08/6-1536x1028.jpeg 1536w, https://www.caymancompass.com/wp-content/uploads/2020/08/6-2048x1371.jpeg 2048w, https://www.caymancompass.com/wp-content/uploads/2020/08/6-696x466.jpeg 696w, https://www.caymancompass.com/wp-content/uploads/2020/08/6-1068x715.jpeg 1068w, https://www.caymancompass.com/wp-content/uploads/2020/08/6-1920x1286.jpeg 1920w, https://www.caymancompass.com/wp-content/uploads/2020/08/6-600x402.jpeg 600w" sizes="(max-width: 627px) 100vw, 627px" alt=""> </a></figure></div><div class = "td-slide-item td-item7"><figure class="td-slide-galery-figure td-slide-popup-gallery"> <a class="slide-gallery-image-link" href="https://www.caymancompass.com/wp-content/uploads/2020/08/7.jpeg" title="7"  data-caption=""  data-description=""> <img src="https://www.caymancompass.com/wp-content/uploads/2020/08/7-777x420.jpeg" srcset="https://www.caymancompass.com/wp-content/uploads/2020/08/7-777x420.jpeg 777w, https://www.caymancompass.com/wp-content/uploads/2020/08/7-300x162.jpeg 300w, https://www.caymancompass.com/wp-content/uploads/2020/08/7-1536x830.jpeg 1536w, https://www.caymancompass.com/wp-content/uploads/2020/08/7-2048x1106.jpeg 2048w, https://www.caymancompass.com/wp-content/uploads/2020/08/7-696x376.jpeg 696w, https://www.caymancompass.com/wp-content/uploads/2020/08/7-1068x577.jpeg 1068w, https://www.caymancompass.com/wp-content/uploads/2020/08/7-1920x1037.jpeg 1920w, https://www.caymancompass.com/wp-content/uploads/2020/08/7-600x324.jpeg 600w" sizes="(max-width: 777px) 100vw, 777px" alt=""> </a></figure></div><div class = "td-slide-item td-item8"><figure class="td-slide-galery-figure td-slide-popup-gallery"> <a class="slide-gallery-image-link" href="https://www.caymancompass.com/wp-content/uploads/2020/08/8.jpeg" title="8"  data-caption=""  data-description=""> <img src="https://www.caymancompass.com/wp-content/uploads/2020/08/8-679x420.jpeg" srcset="https://www.caymancompass.com/wp-content/uploads/2020/08/8-679x420.jpeg 679w, https://www.caymancompass.com/wp-content/uploads/2020/08/8-300x186.jpeg 300w, https://www.caymancompass.com/wp-content/uploads/2020/08/8-1536x950.jpeg 1536w, https://www.caymancompass.com/wp-content/uploads/2020/08/8-2048x1267.jpeg 2048w, https://www.caymancompass.com/wp-content/uploads/2020/08/8-696x431.jpeg 696w, https://www.caymancompass.com/wp-content/uploads/2020/08/8-1068x661.jpeg 1068w, https://www.caymancompass.com/wp-content/uploads/2020/08/8-1920x1188.jpeg 1920w, https://www.caymancompass.com/wp-content/uploads/2020/08/8-356x220.jpeg 356w, https://www.caymancompass.com/wp-content/uploads/2020/08/8-600x371.jpeg 600w" sizes="(max-width: 679px) 100vw, 679px" alt=""> </a></figure></div><div class = "td-slide-item td-item9"><figure class="td-slide-galery-figure td-slide-popup-gallery"> <a class="slide-gallery-image-link" href="https://www.caymancompass.com/wp-content/uploads/2020/08/9.jpeg" title="9"  data-caption=""  data-description=""> <img src="https://www.caymancompass.com/wp-content/uploads/2020/08/9-756x420.jpeg" srcset="https://www.caymancompass.com/wp-content/uploads/2020/08/9-756x420.jpeg 756w, https://www.caymancompass.com/wp-content/uploads/2020/08/9-300x167.jpeg 300w, https://www.caymancompass.com/wp-content/uploads/2020/08/9-1536x853.jpeg 1536w, https://www.caymancompass.com/wp-content/uploads/2020/08/9-2048x1138.jpeg 2048w, https://www.caymancompass.com/wp-content/uploads/2020/08/9-696x387.jpeg 696w, https://www.caymancompass.com/wp-content/uploads/2020/08/9-1068x593.jpeg 1068w, https://www.caymancompass.com/wp-content/uploads/2020/08/9-1920x1067.jpeg 1920w, https://www.caymancompass.com/wp-content/uploads/2020/08/9-600x333.jpeg 600w" sizes="(max-width: 756px) 100vw, 756px" alt=""> </a></figure></div><div class = "td-slide-item td-item10"><figure class="td-slide-galery-figure td-slide-popup-gallery"> <a class="slide-gallery-image-link" href="https://www.caymancompass.com/wp-content/uploads/2020/08/10.jpeg" title="10"  data-caption=""  data-description=""> <img src="https://www.caymancompass.com/wp-content/uploads/2020/08/10-857x420.jpeg" srcset="https://www.caymancompass.com/wp-content/uploads/2020/08/10-857x420.jpeg 857w, https://www.caymancompass.com/wp-content/uploads/2020/08/10-300x147.jpeg 300w, https://www.caymancompass.com/wp-content/uploads/2020/08/10-1536x753.jpeg 1536w, https://www.caymancompass.com/wp-content/uploads/2020/08/10-2048x1004.jpeg 2048w, https://www.caymancompass.com/wp-content/uploads/2020/08/10-696x341.jpeg 696w, https://www.caymancompass.com/wp-content/uploads/2020/08/10-1068x524.jpeg 1068w, https://www.caymancompass.com/wp-content/uploads/2020/08/10-1920x941.jpeg 1920w, https://www.caymancompass.com/wp-content/uploads/2020/08/10-324x160.jpeg 324w, https://www.caymancompass.com/wp-content/uploads/2020/08/10-533x261.jpeg 533w, https://www.caymancompass.com/wp-content/uploads/2020/08/10-600x294.jpeg 600w" sizes="(max-width: 857px) 100vw, 857px" alt=""> </a></figure></div><div class = "td-slide-item td-item11"><figure class="td-slide-galery-figure td-slide-popup-gallery"> <a class="slide-gallery-image-link" href="https://www.caymancompass.com/wp-content/uploads/2020/08/11.jpeg" title="11"  data-caption=""  data-description=""> <img src="https://www.caymancompass.com/wp-content/uploads/2020/08/11-631x420.jpeg" srcset="https://www.caymancompass.com/wp-content/uploads/2020/08/11-631x420.jpeg 631w, https://www.caymancompass.com/wp-content/uploads/2020/08/11-300x200.jpeg 300w, https://www.caymancompass.com/wp-content/uploads/2020/08/11-1536x1022.jpeg 1536w, https://www.caymancompass.com/wp-content/uploads/2020/08/11-2048x1362.jpeg 2048w, https://www.caymancompass.com/wp-content/uploads/2020/08/11-696x463.jpeg 696w, https://www.caymancompass.com/wp-content/uploads/2020/08/11-1068x710.jpeg 1068w, https://www.caymancompass.com/wp-content/uploads/2020/08/11-1920x1277.jpeg 1920w, https://www.caymancompass.com/wp-content/uploads/2020/08/11-600x399.jpeg 600w" sizes="(max-width: 631px) 100vw, 631px" alt=""> </a></figure></div><div class = "td-slide-item td-item12"><figure class="td-slide-galery-figure td-slide-popup-gallery"> <a class="slide-gallery-image-link" href="https://www.caymancompass.com/wp-content/uploads/2020/08/12.jpeg" title="12"  data-caption=""  data-description=""> <img src="https://www.caymancompass.com/wp-content/uploads/2020/08/12-733x420.jpeg" srcset="https://www.caymancompass.com/wp-content/uploads/2020/08/12-733x420.jpeg 733w, https://www.caymancompass.com/wp-content/uploads/2020/08/12-300x172.jpeg 300w, https://www.caymancompass.com/wp-content/uploads/2020/08/12-1536x880.jpeg 1536w, https://www.caymancompass.com/wp-content/uploads/2020/08/12-2048x1173.jpeg 2048w, https://www.caymancompass.com/wp-content/uploads/2020/08/12-696x399.jpeg 696w, https://www.caymancompass.com/wp-content/uploads/2020/08/12-1068x612.jpeg 1068w, https://www.caymancompass.com/wp-content/uploads/2020/08/12-1920x1100.jpeg 1920w, https://www.caymancompass.com/wp-content/uploads/2020/08/12-600x344.jpeg 600w" sizes="(max-width: 733px) 100vw, 733px" alt=""> </a></figure></div></div></div><div class = "td-doubleSlider-2"><div class = "td-slider"><div class = "td-button td-item1"><div class = "td-border"></div></div><div class = "td-button td-item2"><div class = "td-border"></div></div><div class = "td-button td-item3"><div class = "td-border"></div></div><div class = "td-button td-item4"><div class = "td-border"></div></div><div class = "td-button td-item5"><div class = "td-border"></div></div><div class = "td-button td-item6"><div class = "td-border"></div></div><div class = "td-button td-item7"><div class = "td-border"></div></div><div class = "td-button td-item8"><div class = "td-border"></div></div><div class = "td-button td-item9"><div class = "td-border"></div></div><div class = "td-button td-item10"><div class = "td-border"></div></div><div class = "td-button td-item11"><div class = "td-border"></div></div><div class = "td-button td-item12"><div class = "td-border"></div></div></div></div></div></div><p>“It&#8217;s a big moment. I think everybody in the island will be very proud of our reservists. The large majority of them are Caymanians and they are really keen to make a contribution to our Island,” he said.</p><p>He said the Defence Law still needs to be passed to formalise the regiment.</p><p>The governor said that Premier Alden McLaughlin is keen to take that law to the Legislative Assembly, “which will give us the legal basis for the operations of the regiment”.</p><p>He added that the regiment is primarily there to help Cayman respond to disasters such as hurricanes.</p><p>“But it would also be available to help any of our regional neighbours if they were to suffer  disasters or hurricanes. So still very early days, but I&#8217;m just delighted that we&#8217;ve been able to get this far,” Roper said.</p><p>The creation of the regiment was announced late last year during a visit from then UK Minister of State for the Armed Forces, Mark Lancaster.</p><p>Roper said Cayman was “really fortunate” that despite the pandemic it was able to get a UK Ministry of Defence team to come to the island to train the first 51 part-time reservists.</p><p>The governor chatted with the reservists about what they have been doing and their first aid training which is aimed at helping them to respond to disasters if they were to happen to Cayman.</p><p>“They&#8217;re really enthusiastic, really positive and really proud to be part of the Cayman Regiment,” he added.</p><p>Roper said there will be a further recruiting exercise coming up in the next couple of months for more part-time reservists.</p><p>“It&#8217;s really up to Cayman where this now goes from here. I think we are keen to get to about 175 people initially, because we think that will be about the right size to really be able to make a very effective contribution,” he said.</p><p>Hazard Management Cayman Islands Director Danielle Coleman said the regiment is going to add a lot of resources to the actual national response to emergencies and disasters.</p><p>“We&#8217;re really excited that we have so many more hands to help with this and obviously multi-agency coordination is really key, and we&#8217;ll be working that out in the next few weeks. But we&#8217;re really excited about it,” she said.</p><p>She commended the reservists for their commitment.</p><p>Regiment Commander Simon Watson said he was pleased that Cayman was able to get the regiment up and running for the peak of the hurricane season.</p><p>“The regiment is constantly on standby. So, from 1st September going forward we will be on standby 24 hours a day. So, whether it is a hurricane, earthquake, pandemic, large major fire… whatever issue that needs looking at then the regiment will be there to help support,” Watson said.</p><div class="likebtn_container" style="clear:both;"><span class="likebtn-wrapper"  data-identifier="post_487607"  data-site_id="5a6f97366fd08b0f18563396"  data-theme="custom"  data-icon_l="thmb4-u"  data-icon_d="thmb4-d"  data-icon_size="24"  data-icon_l_c_v="#00aeef"  data-icon_d_c_v="#00aeef"  data-counter_l_c="#222222"  data-counter_d_c="#222222"  data-bg_c="rgba(250,250,250,0)"  data-bg_c_v="rgba(250,250,250,0)"  data-brdr_c="rgba(255,255,255,0)"  data-f_size="14"  data-f_family="Georgia"  data-counter_fs="b"  data-show_like_label="false"  data-share_enabled="false"  data-voting_cancelable="false"  data-tooltip_enabled="false"  data-white_label="true"  data-popup_disabled="true"  data-style=""  data-unlike_allowed=""  data-show_copyright=""  data-item_url="https://www.caymancompass.com/2020/08/15/cayman-regiment-reservists-showcase-skills/"  data-item_title="Cayman Regiment reservists showcase skills"  data-item_image="https://www.caymancompass.com/wp-content/uploads/2020/08/10.jpeg"  data-item_date="2020-08-15T16:11:41-05:00"  data-engine="WordPress"  data-plugin_v="2.6.28"  data-prx="https://www.caymancompass.com/wp-admin/admin-ajax.php?action=likebtn_prx"  data-event_handler="likebtn_eh" ></span></div><div class="td-a-rec td-a-rec-id-content_bottom  tdi_5_347 td_block_template_16"><style>/* custom css */
.tdi_5_347.td-a-rec{
					text-align: center;
				}.tdi_5_347 .td-element-style{
					z-index: -1;
				}.tdi_5_347.td-a-rec-img{
				    text-align: left;
				}.tdi_5_347.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_5_347.td-a-rec-img {
				        text-align: center;
				    }
                }</style><div class="td-all-devices">  <script type="text/javascript">var rnd = window.rnd || Math.floor(Math.random()*10e6);
var pid421033 = window.pid421033 || rnd;
var plc421033 = window.plc421033 || 0;
var abkw = window.abkw || '';
var absrc = 'https://servedbyadbutler.com/adserve/;ID=165413;size=0x0;setID=421033;type=js;sw='+screen.width+';sh='+screen.height+';spr='+window.devicePixelRatio+';kw='+abkw+';pid='+pid421033+';place='+(plc421033++)+';rnd='+rnd+';click=CLICK_MACRO_PLACEHOLDER';
document.write('<scr'+'ipt src="'+absrc+'" type="text/javascript"></scr'+'ipt>');</script> </div><div style="background-color: #fffcbb; padding: 20px 20px 10px 20px; margin-top:30px; border: 1px solid #999; border-radius: 3px;"><p style="margin-bottom: 10px;">If you value our service, if you have turned to us in the past few days or weeks for verified, factual updates, if you have watched our live streaming of press conferences or sent an article to a friend... please consider a donation. Quality local journalism was at risk before the coronavirus crisis. It is now deeply threatened. Even a small amount can go a long way to sustaining our mission of informing the public. We need our readers’ financial support now more than ever.</p><h4 style="text-align: center; margin-top: 0 !important;"><a href="https://www.caymancompass.com/store/donate"><span class="td_btn td_btn_md td_outlined_btn" style="border-color: #e00606; color: #e00606;">Donate</span></a></h4></div></div></div><footer><div class="td-post-source-tags"><ul class="td-tags td-post-small-box clearfix"><li><span>Topics</span></li><li><a href="https://www.caymancompass.com/tag/cayman-islands-regiment/">Cayman Islands Regiment</a></li><li><a href="https://www.caymancompass.com/tag/danielle-coleman/">Danielle Coleman</a></li><li><a href="https://www.caymancompass.com/tag/governor-martyn-roper/">Governor Martyn Roper</a></li><li><a href="https://www.caymancompass.com/tag/hazard-management-cayman-islands/">Hazard Management Cayman Islands</a></li><li><a href="https://www.caymancompass.com/tag/simon-watson/">Simon Watson</a></li></ul></div><div class="td-post-sharing-bottom"><div class="td-post-sharing-classic"><iframe frameBorder="0" src="https://www.facebook.com/plugins/like.php?href=https://www.caymancompass.com/2020/08/15/cayman-regiment-reservists-showcase-skills/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:auto; height:21px; background-color:transparent;"></iframe></div><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-ps-rounded td-post-sharing-style3 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.caymancompass.com%2F2020%2F08%2F15%2Fcayman-regiment-reservists-showcase-skills%2F"><div class="td-social-but-icon"><i class="td-icon-facebook"></i></div><div class="td-social-but-text">Facebook</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Cayman+Regiment+reservists+showcase+skills&url=https%3A%2F%2Fwww.caymancompass.com%2F2020%2F08%2F15%2Fcayman-regiment-reservists-showcase-skills%2F&via=cayCompass"><div class="td-social-but-icon"><i class="td-icon-twitter"></i></div><div class="td-social-but-text">Twitter</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=Cayman+Regiment+reservists+showcase+skills %0A%0A https://www.caymancompass.com/2020/08/15/cayman-regiment-reservists-showcase-skills/"><div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div><div class="td-social-but-text">WhatsApp</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="/cdn-cgi/l/email-protection#a798d4d2c5cdc2c4d39ae4c6decac6c987f5c2c0cecac2c9d387d5c2d4c2d5d1ced4d3d487d4cfc8d0c4c6d4c287d4cccecbcbd481c5c8c3de9acfd3d3d7d49d8888d0d0d089c4c6decac6c9c4c8cad7c6d4d489c4c8ca889597959788979f88969288c4c6decac6c98ad5c2c0cecac2c9d38ad5c2d4c2d5d1ced4d3d48ad4cfc8d0c4c6d4c28ad4cccecbcbd488"><div class="td-social-but-icon"><i class="td-icon-mail"></i></div><div class="td-social-but-text">Email</div> </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom"><div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div> </a></div></div></div><div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://www.caymancompass.com/2020/08/15/two-vehicle-collision-on-crewe-road/">Three injured in two-vehicle collision on Crewe Road</a></div></div><div class="td-next-prev-separator"></div></div><div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="https://www.caymancompass.com/author/rragoonath/">Reshma Ragoonath</a></span></div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Reshma Ragoonath"></span><meta itemprop="datePublished" content="2020-08-15T16:11:41-05:00"><meta itemprop="dateModified" content="2020-08-15T16:11:41-05:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.caymancompass.com/2020/08/15/cayman-regiment-reservists-showcase-skills/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassLogoNew-272x90.png"></span><meta itemprop="name" content="Cayman Compass"></span><meta itemprop="headline " content="Cayman Regiment reservists showcase skills"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.caymancompass.com/wp-content/uploads/2020/08/10.jpeg"><meta itemprop="width" content="2560"><meta itemprop="height" content="1255"></span></footer><div class="td_block_wrap td_block_related_posts tdi_6_73c td_with_ajax_pagination td-pb-border-top td_block_template_16"  data-td-block-uid="tdi_6_73c" ><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>var block_tdi_6_73c = new tdBlock();
block_tdi_6_73c.id = "tdi_6_73c";
block_tdi_6_73c.atts = '{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"tdi_6_73c","td_column_number":3,"live_filter_cur_post_id":487607,"live_filter_cur_post_author":"9892","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"tdi_6_73c","tdc_css_class_style":"tdi_6_73c_rand_style"}';
block_tdi_6_73c.td_column_number = "3";
block_tdi_6_73c.block_type = "td_block_related_posts";
block_tdi_6_73c.post_count = "3";
block_tdi_6_73c.found_posts = "55539";
block_tdi_6_73c.header_color = "";
block_tdi_6_73c.ajax_pagination_infinite_stop = "";
block_tdi_6_73c.max_num_pages = "18513";
tdBlocksArray.push(block_tdi_6_73c);</script><h4 class="td-related-title td-block-title"><a id="tdi_7_66f" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="tdi_6_73c" href="#">Related articles</a><a id="tdi_8_515" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="tdi_6_73c" href="#">More from author</a></h4><div id=tdi_6_73c class="td_block_inner"><div class="td-related-row"><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.caymancompass.com/2020/08/15/two-vehicle-collision-on-crewe-road/" rel="bookmark" class="td-image-wrap " title="Three injured in two-vehicle collision on Crewe Road" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Three injured in two-vehicle collision on Crewe Road" data-type="image_tag" data-img-url="https://www.caymancompass.com/wp-content/uploads/2020/08/WhatsApp-Image-2020-08-15-at-2.01.02-PM-218x150.jpeg"  width="218" height="150" /></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.caymancompass.com/2020/08/15/two-vehicle-collision-on-crewe-road/" rel="bookmark" title="Three injured in two-vehicle collision on Crewe Road">Three injured in two-vehicle collision on Crewe Road</a></h3></div></div></div><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.caymancompass.com/2020/08/14/top-stories-14-august/" rel="bookmark" class="td-image-wrap " title="Top Stories 14 August" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Top Stories 14 August" data-type="image_tag" data-img-url="https://www.caymancompass.com/wp-content/uploads/2020/05/Screenshot-2020-05-09-at-12.11.42-PM-1-218x150.png"  width="218" height="150" /><span class="td-video-play-ico"><i class="td-icon-video-thumb-play"></i></span></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.caymancompass.com/2020/08/14/top-stories-14-august/" rel="bookmark" title="Top Stories 14 August">Top Stories 14 August</a></h3></div></div></div><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.caymancompass.com/2020/08/14/cdc-classifies-cayman-as-very-low-covid-risk/" rel="bookmark" class="td-image-wrap " title="CDC classifies Cayman as &#8216;very low&#8217; COVID risk" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="CDC classifies Cayman as &#8216;very low&#8217; COVID risk" data-type="image_tag" data-img-url="https://www.caymancompass.com/wp-content/uploads/2020/07/shutterstock_1729230634-218x150.jpg"  width="218" height="150" /></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.caymancompass.com/2020/08/14/cdc-classifies-cayman-as-very-low-covid-risk/" rel="bookmark" title="CDC classifies Cayman as &#8216;very low&#8217; COVID risk">CDC classifies Cayman as &#8216;very low&#8217; COVID risk</a></h3></div></div></div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_6_73c" data-td_block_id="tdi_6_73c"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-tdi_6_73c" data-td_block_id="tdi_6_73c"><i class="td-icon-font td-icon-menu-right"></i></a></div></div><div class="comments" id="comments"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/08/15/cayman-regiment-reservists-showcase-skills/#respond" style="display:none;">Cancel reply</a></small></h3><p class="must-log-in td-login-comment"><a class="td-login-modal-js" data-effect="mpf-td-login-effect" href="#login-form">Log in to leave a comment </a></p></div></div></div></div><div class="td-pb-span4 td-main-sidebar" role="complementary"><div class="td-ss-main-sidebar"><div class="td-a-rec td-a-rec-id-sidebar  tdi_9_5f8 td_block_template_16"><style>/* custom css */
.tdi_9_5f8.td-a-rec{
					text-align: center;
				}.tdi_9_5f8 .td-element-style{
					z-index: -1;
				}.tdi_9_5f8.td-a-rec-img{
				    text-align: left;
				}.tdi_9_5f8.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_9_5f8.td-a-rec-img {
				        text-align: center;
				    }
                }</style><div id="isb_desktop_advert" class="td-visible-desktop sidebar-ad-compass-fix">  <script type="text/javascript">var elem = document.getElementById("isb_desktop_advert");
var theCSSprop = window.getComputedStyle(elem,null).getPropertyValue("display");

if (theCSSprop!="none"){


var rnd = window.rnd || Math.floor(Math.random()*10e6);
var pid420687 = window.pid420687 || rnd;
var plc420687 = window.plc420687 || 0;
var abkw = window.abkw || '';
var absrc = 'https://servedbyadbutler.com/adserve/;ID=165413;size=0x0;setID=420687;type=js;sw='+screen.width+';sh='+screen.height+';spr='+window.devicePixelRatio+';kw='+abkw+';pid='+pid420687+';place='+(plc420687++)+';rnd='+rnd+';click=CLICK_MACRO_PLACEHOLDER';
document.write('<scr'+'ipt src="'+absrc+'" type="text/javascript"></scr'+'ipt>');

}else{
}</script> </div><div id="isb_tablet_portrait_advert" class="td-visible-tablet-portrait sidebar-ad-compass-fix">  <script type="text/javascript">var elem = document.getElementById("isb_tablet_portrait_advert");
var theCSSprop = window.getComputedStyle(elem,null).getPropertyValue("display");
if (theCSSprop!="none"){


var rnd = window.rnd || Math.floor(Math.random()*10e6);
var pid420687 = window.pid420687 || rnd;
var plc420687 = window.plc420687 || 0;
var abkw = window.abkw || '';
var absrc = 'https://servedbyadbutler.com/adserve/;ID=165413;size=0x0;setID=420687;type=js;sw='+screen.width+';sh='+screen.height+';spr='+window.devicePixelRatio+';kw='+abkw+';pid='+pid420687+';place='+(plc420687++)+';rnd='+rnd+';click=CLICK_MACRO_PLACEHOLDER';
document.write('<scr'+'ipt src="'+absrc+'" type="text/javascript"></scr'+'ipt>');


}else{

}</script> </div><div id="isb_tablet_landscape_advert" class="td-visible-tablet-landscape sidebar-ad-compass-fix">  <script type="text/javascript">var elem = document.getElementById("isb_tablet_landscape_advert");
var theCSSprop = window.getComputedStyle(elem,null).getPropertyValue("display");
if (theCSSprop!="none"){


var rnd = window.rnd || Math.floor(Math.random()*10e6);
var pid420687 = window.pid420687 || rnd;
var plc420687 = window.plc420687 || 0;
var abkw = window.abkw || '';
var absrc = 'https://servedbyadbutler.com/adserve/;ID=165413;size=0x0;setID=420687;type=js;sw='+screen.width+';sh='+screen.height+';spr='+window.devicePixelRatio+';kw='+abkw+';pid='+pid420687+';place='+(plc420687++)+';rnd='+rnd+';click=CLICK_MACRO_PLACEHOLDER';
document.write('<scr'+'ipt src="'+absrc+'" type="text/javascript"></scr'+'ipt>');

}else{
}</script> </div></div><aside id="text-6" class="td_block_template_16 widget text-6 widget_text"><div class="textwidget"><div class="td_block_social_counter newsletter-addon newsletter-sidebar"><div class="td_social_type td-pb-margin-side td-social-newsletter"><div class="td-social-box"><div class="td-sp td-sp-newsletter"><i class="td-icon-mail"></i></div><span class="td_social_button"><a href="https://www.caymancompass.com/subscribe/" target="_blank" rel="noopener noreferrer">SUBSCRIBE TO<span class="sublongtext"> THE COMPASS</span> NEWSLETTER</a></span></div></div></div></div></aside><div class="td_block_wrap td_block_7 td_block_widget tdi_10_2f3 td_with_ajax_pagination td-pb-border-top td_block_template_16 td-column-1 td_block_padding"  data-td-block-uid="tdi_10_2f3" ><script>var block_tdi_10_2f3 = new tdBlock();
block_tdi_10_2f3.id = "tdi_10_2f3";
block_tdi_10_2f3.atts = '{"custom_title":"This week","custom_url":"","block_template_id":"","header_text_color":"#","border_color":"#","accent_text_color":"#","m6_tl":"","limit":"3","offset":"","el_class":"","post_ids":"","category_id":"","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","sort":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"next_prev","ajax_pagination_infinite_stop":"","class":"td_block_widget tdi_10_2f3","separator":"","show_modified_date":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m6f_title_font_header":"","m6f_title_font_title":"Article title","m6f_title_font_settings":"","m6f_title_font_family":"","m6f_title_font_size":"","m6f_title_font_line_height":"","m6f_title_font_style":"","m6f_title_font_weight":"","m6f_title_font_transform":"","m6f_title_font_spacing":"","m6f_title_":"","m6f_cat_font_title":"Article category tag","m6f_cat_font_settings":"","m6f_cat_font_family":"","m6f_cat_font_size":"","m6f_cat_font_line_height":"","m6f_cat_font_style":"","m6f_cat_font_weight":"","m6f_cat_font_transform":"","m6f_cat_font_spacing":"","m6f_cat_":"","m6f_meta_font_title":"Article meta info","m6f_meta_font_settings":"","m6f_meta_font_family":"","m6f_meta_font_size":"","m6f_meta_font_line_height":"","m6f_meta_font_style":"","m6f_meta_font_weight":"","m6f_meta_font_transform":"","m6f_meta_font_spacing":"","m6f_meta_":"","css":"","tdc_css":"","td_column_number":1,"header_color":"","color_preset":"","border_top":"","tdc_css_class":"tdi_10_2f3","tdc_css_class_style":"tdi_10_2f3_rand_style"}';
block_tdi_10_2f3.td_column_number = "1";
block_tdi_10_2f3.block_type = "td_block_7";
block_tdi_10_2f3.post_count = "3";
block_tdi_10_2f3.found_posts = "89522";
block_tdi_10_2f3.header_color = "";
block_tdi_10_2f3.ajax_pagination_infinite_stop = "";
block_tdi_10_2f3.max_num_pages = "29841";
tdBlocksArray.push(block_tdi_10_2f3);</script><div class="td-block-title-wrap"><h4 class="td-block-title"><span class="td-pulldown-size">This week</span></h4></div><div id=tdi_10_2f3 class="td_block_inner"><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.caymancompass.com/2020/08/15/cayman-regiment-reservists-showcase-skills/" rel="bookmark" class="td-image-wrap " title="Cayman Regiment reservists showcase skills" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" alt="" title="Cayman Regiment reservists showcase skills" data-type="image_tag" data-img-url="https://www.caymancompass.com/wp-content/uploads/2020/08/10-100x70.jpeg"  width="100" height="70" /><span class="td-video-play-ico td-video-small"><i class="td-icon-video-thumb-play"></i></span></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.caymancompass.com/2020/08/15/cayman-regiment-reservists-showcase-skills/" rel="bookmark" title="Cayman Regiment reservists showcase skills">Cayman Regiment reservists showcase skills</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-08-15T16:11:41-05:00" >August 15, 2020</time></span></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.caymancompass.com/2020/08/15/two-vehicle-collision-on-crewe-road/" rel="bookmark" class="td-image-wrap " title="Three injured in two-vehicle collision on Crewe Road" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" alt="" title="Three injured in two-vehicle collision on Crewe Road" data-type="image_tag" data-img-url="https://www.caymancompass.com/wp-content/uploads/2020/08/WhatsApp-Image-2020-08-15-at-2.01.02-PM-100x70.jpeg"  width="100" height="70" /></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.caymancompass.com/2020/08/15/two-vehicle-collision-on-crewe-road/" rel="bookmark" title="Three injured in two-vehicle collision on Crewe Road">Three injured in two-vehicle collision on Crewe Road</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-08-15T16:02:27-05:00" >August 15, 2020</time></span></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.caymancompass.com/2020/08/14/top-stories-14-august/" rel="bookmark" class="td-image-wrap " title="Top Stories 14 August" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" alt="" title="Top Stories 14 August" data-type="image_tag" data-img-url="https://www.caymancompass.com/wp-content/uploads/2020/05/Screenshot-2020-05-09-at-12.11.42-PM-1-100x70.png"  width="100" height="70" /><span class="td-video-play-ico td-video-small"><i class="td-icon-video-thumb-play"></i></span></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.caymancompass.com/2020/08/14/top-stories-14-august/" rel="bookmark" title="Top Stories 14 August">Top Stories 14 August</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-08-14T19:37:21-05:00" >August 14, 2020</time></span></div></div></div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_10_2f3" data-td_block_id="tdi_10_2f3"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-tdi_10_2f3" data-td_block_id="tdi_10_2f3"><i class="td-icon-font td-icon-menu-right"></i></a></div></div></div></div></div></div></article><div class="tdc-footer-wrap "><div class="td-footer-wrapper td-footer-container td-container-wrap td_stretch_container"><div class="td-container"><div class="td-pb-row"><div class="td-pb-span12"></div></div><div class="td-pb-row"><div class="td-pb-span12"><aside class="widget_text td_block_template_16 widget widget_custom_html"><div class="textwidget custom-html-widget"><style>.compass-media-footer-links {
	font-family: 'Open Sans', Arial, Helvetica, sans-serif !important;
	color: #fff !important;
	width: 100%;
	text-align: center;
	margin-bottom: 30px;
}
.compass-media-footer-heading {
	width: 100%;
	text-align: center;
    border-bottom: 1px solid #fff; 
    line-height: 1px;
    margin: 10px 0 20px; 
}
.compass-media-footer-heading span {
	padding: 0 20px;
	background-color: #0e1523; 
	font-weight: bold;
    font-family: 'Open Sans', Arial, Helvetica, sans-serif !important;
	font-size: 10px;
}
.compass-media-footer-links a, .compass-media-footer-heading a {
  color: #fff !important;
  text-decoration: none;
}
.compass-link-item {
  display: inline-block;
  vertical-align: top;
  width: 10%;
  min-width: 93px;
  margin-bottom: 20px;
}
.compass-link-icon {
	width: 60px;
	height: 60px;
	margin: 0 auto;
}
.compass-link-text h6 {
  text-align: center;
  text-transform: uppercase;
  font-size: 9px !important;
  margin: 0;
  color: #fff !important;
  line-height: 10px !important;
}
.sprite-compass-media-icon-christmas-catalog, .sprite-compass-media-icon-christmascatalog, .sprite-compass-media-icon-whot, .sprite-compass-media-icon-cfr, .sprite-compass-media-icon-compass, 
.sprite-compass-media-icon-flava, .sprite-compass-media-icon-gcm, .sprite-compass-media-icon-health, .sprite-compass-media-icon-insideout, .sprite-compass-media-icon-journal, 
.sprite-compass-media-icon-keytocayman, .sprite-compass-media-icon-map
{ display: inline-block; background: url('/wp-content/uploads/footer-icons/footer-icons.png') no-repeat; overflow: hidden; text-indent: -9999px; text-align: left; }
 
.sprite-compass-media-icon-christmas-catalog { background-position: -10px -0px; width: 50px; height: 50px; }
.sprite-compass-media-icon-christmascatalog { background-position: -70px -0px; width: 50px; height: 50px; }
.sprite-compass-media-icon-whot { background-position: -130px -0px; width: 50px; height: 50px; }
.sprite-compass-media-icon-cfr { background-position: -10px -60px; width: 50px; height: 50px; }
.sprite-compass-media-icon-compass { background-position: -70px -60px; width: 50px; height: 50px; }
.sprite-compass-media-icon-flava { background-position: -130px -60px; width: 50px; height: 50px; }
.sprite-compass-media-icon-gcm { background-position: -10px -120px; width: 50px; height: 50px; }
.sprite-compass-media-icon-health { background-position: -70px -120px; width: 50px; height: 50px; }
.sprite-compass-media-icon-insideout { background-position: -130px -120px; width: 50px; height: 50px; }
.sprite-compass-media-icon-journal { background-position: -10px -180px; width: 50px; height: 50px; }
.sprite-compass-media-icon-keytocayman { background-position: -70px -180px; width: 50px; height: 50px; }
.sprite-compass-media-icon-map { background-position: -130px -180px; width: 50px; height: 50px; }</style><div class="compass-media-footer-links"><div class="compass-links-heading-container"><h6 class="compass-media-footer-heading"><a href="https://www.compassmedia.ky" target="_blank" rel="noopener noreferrer"><span>Compass Media Ltd. Brands</span></a></h6></div><div class="compass-link-item"><div class="compass-link-icon"> <a href="https://www.caymancompass.com/" target="_blank" rel="noopener noreferrer"><div class="sprite-compass-media-icon-compass"></div></a></div><div class="compass-link-text"> <a href="https://www.caymancompass.com/" target="_blank" rel="noopener noreferrer"><h6>Cayman Compass</h6></a></div></div><div class="compass-link-item"><div class="compass-link-icon"> <a href="https://www.caymanhealth.com/" target="_blank" rel="noopener noreferrer"><div class="sprite-compass-media-icon-health"></div></a></div><div class="compass-link-text"> <a href="https://www.caymanhealth.com/" target="_blank" rel="noopener noreferrer"><h6>Cayman Health</h6></a></div></div></div></div></aside><aside class="widget_text td_block_template_16 widget widget_custom_html"><div class="textwidget custom-html-widget"><div style="display: table; margin: auto;"><div class="footer-payment-logos" style="position:relative; display: inline;"><img class="alignnone size-full wp-image-482000" src="https://www.caymancompass.com/wp-content/uploads/2020/06/american_express.png" alt="" style="margin-top:10px;" width="46" height="24"> <img class="alignnone size-full wp-image-480084" src="https://www.caymancompass.com/wp-content/uploads/2020/06/visa.png" alt="" style="margin-top:10px;" width="46" height="24"> <img class="size-full wp-image-480085" src="https://www.caymancompass.com/wp-content/uploads/2020/06/mastercard.png" alt="" width="46" height="24"></div><div class="footer-payment-links-text" style="position:relative; display: inline;"> <span style="font-weight: bold; font-family: 'Open Sans', Arial, Helvetica, sans-serif !important; font-size: 10px;text-align:center; line-height: 0; position: relative;top: -7px;">Pay securely with your Credit Card. <a href="https://www.caymancompass.com/refund-policy/">Click here to view our Refund Policy</a>.</span></div></div></div></aside></div></div></div></div><div class="td-sub-footer-container td-container-wrap td_stretch_container"><div class="td-container"><div class="td-pb-row"><div class="td-pb-span td-sub-footer-menu"><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="td-subfooter-menu"><li id="menu-item-470577" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-470577"><a href="https://www.caymancompass.com/community-standards/">Community Standards</a></li><li id="menu-item-188298" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188298"><a href="https://www.caymancompass.com/terms-of-use/">Terms and Conditions</a></li><li id="menu-item-470593" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-470593"><a href="https://www.caymancompass.com/compass-media-promotion-standard-terms-and-conditions/">Promotions T &#038; C</a></li><li id="menu-item-480083" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-480083"><a href="https://www.caymancompass.com/refund-policy/">Refund Policy</a></li><li id="menu-item-188297" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy td-menu-item td-normal-menu menu-item-188297"><a href="https://www.caymancompass.com/privacy-policy/">Privacy Policy</a></li><li id="menu-item-188296" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188296"><a href="https://www.caymancompass.com/copyright-policy-2/">Copyright</a></li><li id="menu-item-316352" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-316352"><a href="https://www.caymancompass.com/faq/">FAQ</a></li><li id="menu-item-480188" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-480188"><a href="https://www.caymancompass.com/contact/">Contact</a></li></ul></div></div><div class="td-pb-span td-sub-footer-copy"> &copy; Copyright Cayman Compass Ltd.</div></div></div></div></div></div>  <script type="text/javascript">var likebtn_wl = 1; (function(d, e, s) {a = d.createElement(e);m = d.getElementsByTagName(e)[0];a.async = 1;a.src = s;m.parentNode.insertBefore(a, m)})(document, 'script', '//w.likebtn.com/js/w/widget.js'); if (typeof(LikeBtn) != "undefined") { LikeBtn.init(); }</script> <div id="um_upload_single" style="display:none"></div><div id="um_view_photo" style="display:none"> <a href="javascript:void(0);" data-action="um_remove_modal" class="um-modal-close"><i class="um-faicon-times"></i></a><div class="um-modal-body photo"><div class="um-modal-photo"></div></div></div> <style type="text/css" media="screen">/* custom css theme panel */
/* WOOCOMMERCE LIGHTBOX BEHIND HEADER */

.pswp {
z-index: 9999;
}</style> <script type="text/javascript">var c = document.body.className;
		c = c.replace(/woocommerce-no-js/, 'woocommerce-js');
		document.body.className = c;</script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/woocommerce/assets/js/jquery-blockui/jquery.blockUI.min.js?ver=2.70' id='jquery-blockui-js'></script> <script type='text/javascript' id='wc-add-to-cart-js-extra'>var wc_add_to_cart_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","i18n_view_cart":"View cart","cart_url":"https:\/\/www.caymancompass.com\/cart\/","is_cart":"","cart_redirect_after_add":"no"};</script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/woocommerce/assets/js/frontend/add-to-cart.min.js?ver=4.3.2' id='wc-add-to-cart-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/woocommerce/assets/js/js-cookie/js.cookie.min.js?ver=2.1.4' id='js-cookie-js'></script> <script type='text/javascript' id='woocommerce-js-extra'>var woocommerce_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%"};</script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/woocommerce/assets/js/frontend/woocommerce.min.js?ver=4.3.2' id='woocommerce-js'></script> <script type='text/javascript' id='wc-cart-fragments-js-extra'>var wc_cart_fragments_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","cart_hash_key":"wc_cart_hash_4437ba34d6b5d70623e49270760f1a5e","fragment_name":"wc_fragments_4437ba34d6b5d70623e49270760f1a5e","request_timeout":"5000"};</script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/woocommerce/assets/js/frontend/cart-fragments.min.js?ver=4.3.2' id='wc-cart-fragments-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-includes/js/underscore.min.js?ver=1.8.3' id='underscore-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/td-cloud-library/assets/js/js_posts_autoload.min.js?ver=a336a33b491e4d82f056f6bf77847b68' id='tdb_js_posts_autoload-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js?ver=10.3.6.1' id='td-site-min-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-includes/js/comment-reply.min.js?ver=96176e5596a8802d2c6dc6f1cc6c8dbf' id='comment-reply-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/ultimate-member/assets/js/select2/select2.full.min.js?ver=2.1.6' id='select2-js'></script> <script type='text/javascript' id='wp-util-js-extra'>var _wpUtilSettings = {"ajax":{"url":"\/wp-admin\/admin-ajax.php"}};</script> <script type='text/javascript' src='https://www.caymancompass.com/wp-includes/js/wp-util.min.js?ver=96176e5596a8802d2c6dc6f1cc6c8dbf' id='wp-util-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/ultimate-member/assets/js/um-crop.min.js?ver=2.1.6' id='um_crop-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/ultimate-member/assets/js/um-modal.min.js?ver=2.1.6' id='um_modal-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/ultimate-member/assets/js/um-jquery-form.min.js?ver=2.1.6' id='um_jquery_form-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/ultimate-member/assets/js/um-fileupload.min.js?ver=2.1.6' id='um_fileupload-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/ultimate-member/assets/js/pickadate/picker.js?ver=2.1.6' id='um_datetime-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/ultimate-member/assets/js/pickadate/picker.date.js?ver=2.1.6' id='um_datetime_date-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/ultimate-member/assets/js/pickadate/picker.time.js?ver=2.1.6' id='um_datetime_time-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/ultimate-member/assets/js/pickadate/legacy.js?ver=2.1.6' id='um_datetime_legacy-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=7.4.4' id='wp-polyfill-js'></script> <script type='text/javascript' id='wp-polyfill-js-after'>( 'fetch' in window ) || document.write( '<script src="https://www.caymancompass.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://www.caymancompass.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script src="https://www.caymancompass.com/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="https://www.caymancompass.com/wp-includes/js/dist/vendor/wp-polyfill-url.min.js?ver=3.6.4"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://www.caymancompass.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://www.caymancompass.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );</script> <script type='text/javascript' src='https://www.caymancompass.com/wp-includes/js/dist/i18n.min.js?ver=bb7c3c45d012206bfcd73d6a31f84d9e' id='wp-i18n-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/ultimate-member/assets/js/um-raty.min.js?ver=2.1.6' id='um_raty-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/ultimate-member/assets/js/um-tipsy.min.js?ver=2.1.6' id='um_tipsy-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-includes/js/imagesloaded.min.js?ver=4.1.4' id='imagesloaded-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-includes/js/masonry.min.js?ver=4.2.2' id='masonry-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-includes/js/jquery/jquery.masonry.min.js?ver=3.1.2b' id='jquery-masonry-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/ultimate-member/assets/js/simplebar.min.js?ver=2.1.6' id='um_scrollbar-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/ultimate-member/assets/js/um-functions.min.js?ver=2.1.6' id='um_functions-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/ultimate-member/assets/js/um-responsive.min.js?ver=2.1.6' id='um_responsive-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-includes/js/dist/hooks.min.js?ver=b4778690e29d8a2b7518413652ba30c4' id='wp-hooks-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/ultimate-member/assets/js/um-conditional.min.js?ver=2.1.6' id='um_conditional-js'></script> <script type='text/javascript' id='um_scripts-js-extra'>var um_scripts = {"nonce":"2159b74e22"};</script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/ultimate-member/assets/js/um-scripts.min.js?ver=2.1.6' id='um_scripts-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/ultimate-member/assets/js/um-profile.min.js?ver=2.1.6' id='um_profile-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/ultimate-member/assets/js/um-account.min.js?ver=2.1.6' id='um_account-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=a336a33b491e4d82f056f6bf77847b68' id='tdb_js_files_for_front-js'></script> <script type='text/javascript' id='woomc-frontend-js-extra'>var woomc = {"currentURL":"https:\/\/www.caymancompass.com\/2020\/08\/15\/cayman-regiment-reservists-showcase-skills\/","currency":"KYD","cookieSettings":{"name":"woocommerce_multicurrency_forced_currency","expires":31536000},"console_log":"N","settings":{"woocommerce_default_customer_address":"***"}};</script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/woocommerce-multicurrency/src/WOOMC/Frontend/dist/frontend.js?ver=2.6.3' id='woomc-frontend-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-includes/js/wp-embed.min.js?ver=96176e5596a8802d2c6dc6f1cc6c8dbf' id='wp-embed-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/um-social-login/assets/js/um-social-connect.min.js?ver=2.3.3' id='um-social-login-js'></script>  <script type="text/javascript" src="//downloads.mailchimp.com/js/signup-forms/popup/unique-methods/embed.js" data-dojo-config="usePlainJson: true, isDebug: false"></script><script type="text/javascript">window.dojoRequire(["mojo/signup-forms/Loader"], function(L) { L.start({"baseUrl":"mc.us20.list-manage.com","uuid":"b144ccc8214e0a3588b280790","lid":"c81a5c8936","uniqueMethods":true}) })</script>  <script>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</script> <script type="text/javascript">jQuery( window ).on( 'load', function() {
				jQuery("input[name='um_request']").val('');
			});</script> </body></html>
<!-- Dynamic page generated in 0.676 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2020-08-15 19:00:50 -->

<!-- Compression = gzip -->