<!doctype html > <!--[if IE 8]><html class="ie8" lang="en"> <![endif]--> <!--[if IE 9]><html class="ie9" lang="en"> <![endif]--> <!--[if gt IE 8]><!--><html lang="en-GB"> <!--<![endif]--><head> <script type="text/javascript">if(!gform){document.addEventListener("gform_main_scripts_loaded",function(){gform.scriptsLoaded=!0}),window.addEventListener("DOMContentLoaded",function(){gform.domLoaded=!0});var gform={domLoaded:!1,scriptsLoaded:!1,initializeOnLoaded:function(o){gform.domLoaded&&gform.scriptsLoaded?o():!gform.domLoaded&&gform.scriptsLoaded?window.addEventListener("DOMContentLoaded",o):document.addEventListener("gform_main_scripts_loaded",o)},hooks:{action:{},filter:{}},addAction:function(o,n,r,t){gform.addHook("action",o,n,r,t)},addFilter:function(o,n,r,t){gform.addHook("filter",o,n,r,t)},doAction:function(o){gform.doHook("action",o,arguments)},applyFilters:function(o){return gform.doHook("filter",o,arguments)},removeAction:function(o,n){gform.removeHook("action",o,n)},removeFilter:function(o,n,r){gform.removeHook("filter",o,n,r)},addHook:function(o,n,r,t,i){null==gform.hooks[o][n]&&(gform.hooks[o][n]=[]);var e=gform.hooks[o][n];null==i&&(i=n+"_"+e.length),null==t&&(t=10),gform.hooks[o][n].push({tag:i,callable:r,priority:t})},doHook:function(o,n,r){if(r=Array.prototype.slice.call(r,1),null!=gform.hooks[o][n]){var t,i=gform.hooks[o][n];i.sort(function(o,n){return o.priority-n.priority});for(var e=0;e<i.length;e++)"function"!=typeof(t=i[e].callable)&&(t=window[t]),"action"==o?t.apply(null,r):r[0]=t.apply(null,r)}if("filter"==o)return r[0]},removeHook:function(o,n,r,t){if(null!=gform.hooks[o][n])for(var i=gform.hooks[o][n],e=i.length-1;0<=e;e--)null!=t&&t!=i[e].tag||null!=r&&r!=i[e].priority||i.splice(e,1)}}}</script><script data-cfasync="false" id="ao_optimized_gfonts_config">WebFontConfig={google:{families:["Open Sans:400,600,700","Roboto:400,500,700"] },classes:false, events:false, timeout:1500};</script><link media="all" href="https://www.caymancompass.com/wp-content/cache/autoptimize/css/autoptimize_f02eacd4f63f8b9e8988215ca326796b.css" rel="stylesheet" /><link media="only screen and (max-width: 768px)" href="https://www.caymancompass.com/wp-content/cache/autoptimize/css/autoptimize_2e61cf55767583ee8f53abbd2039ead1.css" rel="stylesheet" /><link media=" print" href="https://www.caymancompass.com/wp-content/cache/autoptimize/css/autoptimize_af3f06c364b63b8f7839aa5d50777c54.css" rel="stylesheet" /><title>CITA: Expanded vaccine list a &#039;small step&#039; but not enough - Cayman Compass</title><meta charset="UTF-8" /><meta name="viewport" content="width=device-width, initial-scale=1.0"><link rel="pingback" href="https://www.caymancompass.com/xmlrpc.php" /> <script type='text/javascript' src='https://servedbyadbutler.com/hb_app.js' async></script><link rel="icon" type="image/png" href="https://www.caymancompass.com/wp-content/uploads/2021/01/Compass-Favicon-round-32x.png"><link rel="apple-touch-icon-precomposed" sizes="76x76" href="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassSqareiOSBookmarklet-76x.png"/><link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassSqareiOSBookmarklet-114x.png"/><link rel="apple-touch-icon-precomposed" sizes="152x152" href="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassSqareiOSBookmarklet-152x.png"/><link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassSqareiOSBookmarklet-114x.png"/><link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassSqareiOSBookmarklet-144x.png"/><meta name="description" content="Cayman Islands Tourism Association President Marc Langevin says that while the tourism industry welcomes the government&#039;s expansion of the types of securely verifiable COVID-19 vaccination records it is now accepting, the process does not go far enough." /><meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://www.caymancompass.com/2021/07/27/cita-expanded-vaccine-list-a-small-step-but-not-enough/" /><meta property="og:locale" content="en_GB" /><meta property="og:type" content="article" /><meta property="og:title" content="CITA: Expanded vaccine list a &#039;small step&#039; but not enough" /><meta property="og:description" content="Cayman Islands Tourism Association President Marc Langevin says that while the tourism industry welcomes the government&#039;s expansion of the types of securely verifiable COVID-19 vaccination records it is now accepting, the process does not go far enough." /><meta property="og:url" content="https://www.caymancompass.com/2021/07/27/cita-expanded-vaccine-list-a-small-step-but-not-enough/" /><meta property="og:site_name" content="Cayman Compass" /><meta property="article:publisher" content="https://www.facebook.com/caycompass" /><meta property="article:published_time" content="2021-07-27T22:24:06+00:00" /><meta property="og:image" content="https://www.caymancompass.com/wp-content/uploads/2020/06/Marc-Langevin-General-Manager-The-Ritz-Carlton-Grand-Cayman3.jpeg" /><meta property="og:image:width" content="2560" /><meta property="og:image:height" content="1703" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@cayCompass" /><meta name="twitter:site" content="@cayCompass" /><meta name="twitter:label1" content="Written by" /><meta name="twitter:data1" content="Norma Connolly" /><meta name="twitter:label2" content="Est. reading time" /><meta name="twitter:data2" content="4 minutes" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.caymancompass.com/#organization","name":"Cayman Compass","url":"https://www.caymancompass.com/","sameAs":["https://www.facebook.com/caycompass","https://instagram.com/cayman_compass","https://www.youtube.com/caymancompas","https://twitter.com/cayCompass"],"logo":{"@type":"ImageObject","@id":"https://www.caymancompass.com/#logo","inLanguage":"en-GB","url":"https://www.caymancompass.com/wp-content/uploads/2019/10/CompassLogo-white-bgd.gif","contentUrl":"https://www.caymancompass.com/wp-content/uploads/2019/10/CompassLogo-white-bgd.gif","width":400,"height":275,"caption":"Cayman Compass"},"image":{"@id":"https://www.caymancompass.com/#logo"}},{"@type":"WebSite","@id":"https://www.caymancompass.com/#website","url":"https://www.caymancompass.com/","name":"Cayman Compass","description":"The Cayman Islands&#039; Most Trusted News Source","publisher":{"@id":"https://www.caymancompass.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.caymancompass.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-GB"},{"@type":"ImageObject","@id":"https://www.caymancompass.com/2021/07/27/cita-expanded-vaccine-list-a-small-step-but-not-enough/#primaryimage","inLanguage":"en-GB","url":"https://www.caymancompass.com/wp-content/uploads/2020/06/Marc-Langevin-General-Manager-The-Ritz-Carlton-Grand-Cayman3.jpeg","contentUrl":"https://www.caymancompass.com/wp-content/uploads/2020/06/Marc-Langevin-General-Manager-The-Ritz-Carlton-Grand-Cayman3.jpeg","width":2560,"height":1703,"caption":"Marc Langevin"},{"@type":"WebPage","@id":"https://www.caymancompass.com/2021/07/27/cita-expanded-vaccine-list-a-small-step-but-not-enough/#webpage","url":"https://www.caymancompass.com/2021/07/27/cita-expanded-vaccine-list-a-small-step-but-not-enough/","name":"CITA: Expanded vaccine list a 'small step' but not enough - Cayman Compass","isPartOf":{"@id":"https://www.caymancompass.com/#website"},"primaryImageOfPage":{"@id":"https://www.caymancompass.com/2021/07/27/cita-expanded-vaccine-list-a-small-step-but-not-enough/#primaryimage"},"datePublished":"2021-07-27T22:24:06+00:00","dateModified":"2021-07-27T22:24:06+00:00","description":"Cayman Islands Tourism Association President Marc Langevin says that while the tourism industry welcomes the government's expansion of the types of securely verifiable COVID-19 vaccination records it is now accepting, the process does not go far enough.","breadcrumb":{"@id":"https://www.caymancompass.com/2021/07/27/cita-expanded-vaccine-list-a-small-step-but-not-enough/#breadcrumb"},"inLanguage":"en-GB","potentialAction":[{"@type":"ReadAction","target":["https://www.caymancompass.com/2021/07/27/cita-expanded-vaccine-list-a-small-step-but-not-enough/"]}]},{"@type":"BreadcrumbList","@id":"https://www.caymancompass.com/2021/07/27/cita-expanded-vaccine-list-a-small-step-but-not-enough/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.caymancompass.com/"},{"@type":"ListItem","position":2,"name":"CITA: Expanded vaccine list a &#8216;small step&#8217; but not enough"}]},{"@type":"Article","@id":"https://www.caymancompass.com/2021/07/27/cita-expanded-vaccine-list-a-small-step-but-not-enough/#article","isPartOf":{"@id":"https://www.caymancompass.com/2021/07/27/cita-expanded-vaccine-list-a-small-step-but-not-enough/#webpage"},"author":{"@id":"https://www.caymancompass.com/#/schema/person/52c356c79047a04f2687933740b1fc50"},"headline":"CITA: Expanded vaccine list a &#8216;small step&#8217; but not enough","datePublished":"2021-07-27T22:24:06+00:00","dateModified":"2021-07-27T22:24:06+00:00","mainEntityOfPage":{"@id":"https://www.caymancompass.com/2021/07/27/cita-expanded-vaccine-list-a-small-step-but-not-enough/#webpage"},"wordCount":766,"commentCount":3,"publisher":{"@id":"https://www.caymancompass.com/#organization"},"image":{"@id":"https://www.caymancompass.com/2021/07/27/cita-expanded-vaccine-list-a-small-step-but-not-enough/#primaryimage"},"thumbnailUrl":"https://www.caymancompass.com/wp-content/uploads/2020/06/Marc-Langevin-General-Manager-The-Ritz-Carlton-Grand-Cayman3.jpeg","keywords":["CITA","Marc Langevin","reopening"],"articleSection":["Local"],"inLanguage":"en-GB","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://www.caymancompass.com/2021/07/27/cita-expanded-vaccine-list-a-small-step-but-not-enough/#respond"]}]},{"@type":"Person","@id":"https://www.caymancompass.com/#/schema/person/52c356c79047a04f2687933740b1fc50","name":"Norma Connolly","description":"Managing Editor","url":"https://www.caymancompass.com/author/nconnolly/"}]}</script> <link rel='dns-prefetch' href='//ajax.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link href='https://fonts.gstatic.com' crossorigin='anonymous' rel='preconnect' /><link href='https://ajax.googleapis.com' rel='preconnect' /><link href='https://fonts.googleapis.com' rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="Cayman Compass &raquo; Feed" href="https://www.caymancompass.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Cayman Compass &raquo; Comments Feed" href="https://www.caymancompass.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Cayman Compass &raquo; CITA: Expanded vaccine list a &#8216;small step&#8217; but not enough Comments Feed" href="https://www.caymancompass.com/2021/07/27/cita-expanded-vaccine-list-a-small-step-but-not-enough/feed/" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.caymancompass.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=01c406beee79eb478b26e999eb5427ea"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);</script> <style type="text/css">img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}</style><link rel='stylesheet' id='jqueryuicss-css'  href='https://ajax.googleapis.com/ajax/libs/jqueryui/1.11.4/themes/smoothness/jquery-ui.css?ver=01c406beee79eb478b26e999eb5427ea' type='text/css' media='all' /><style id='woocommerce-inline-inline-css' type='text/css'>.woocommerce form .form-row .required { visibility: visible; }</style><style id='td-theme-inline-css' type='text/css'>@media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }</style> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/pinnacle-newsletter/pinnacle_javascript.js?ver=01c406beee79eb478b26e999eb5427ea' id='script1-js'></script> <script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jqueryui/1.11.4/jquery-ui.min.js?ver=01c406beee79eb478b26e999eb5427ea' id='jqueryui-js'></script> <script type='text/javascript' id='compass_piano-js-before'>var tp = window.tp || [];
            var subscriptionsTemplateId = 'OTYU83ND4XJZ';
            var subscriptionsOfferId = 'OFSX9O2BRA8Y';
            tp.push(['setUseTinypassAccounts', false]);
            tp.push(['setUsePianoIdUserProvider', false]);
            tp.push(['setUsePianoIdLiteUserProvider', true]);

            
            tp.push(['setTags', ['CITA', 'Marc Langevin', 'reopening', 'Local']]);
            tp.push(['setContentCreated', '2021-07-27T17:24:06-05:00']);
            tp.push(['setContentAuthor', 'Norma Connolly']);

            document.cookie = '__adblocker=; expires=Thu, 01 Jan 1970 00:00:00 GMT; path=/';
            var setNptTechAdblockerCookie = function(adblocker) {
                var d = new Date();
                d.setTime(d.getTime() + 60 * 5 * 1000);
                document.cookie = '__adblocker=' + (adblocker ? 'true' : 'false') + '; expires=' + d.toUTCString() + '; path=/';
            };
            var script = document.createElement('script');
            script.setAttribute('async', true);
            script.setAttribute('src', '//www.npttech.com/advertising.js');
            script.setAttribute('onerror', 'setNptTechAdblockerCookie(true);');
            document.getElementsByTagName('head')[0].appendChild(script);

            (function(src) {
                var a = document.createElement('script');
                a.type = 'text/javascript';
                a.async = true;
                a.src = src;
                var b = document.getElementsByTagName('script')[0];
                b.parentNode.insertBefore(a, b)
            })('//api.tinypass.com/xbuilder/experience/load?aid=wmD32Scjpu');</script> <script type='text/javascript' src='https://www.caymancompass.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script> <script type='text/javascript' id='enr-frontend-js-extra'>var enr_frontend_params = {"ajax_url":"https:\/\/www.caymancompass.com\/wp-admin\/admin-ajax.php","subscribe_now_nonce":"917abb79a1","single_add_to_cart_text":"Add to cart","subscribe_now_button_text":"Sign up now","hide_variable_limited_notice":""};</script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/enhancer-for-woocommerce-subscriptions/assets/js/frontend.js?ver=2.5' id='enr-frontend-js'></script> <link rel="https://api.w.org/" href="https://www.caymancompass.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.caymancompass.com/wp-json/wp/v2/posts/536319" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.caymancompass.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.caymancompass.com/wp-includes/wlwmanifest.xml" /><link rel='shortlink' href='https://www.caymancompass.com/?p=536319' /><link rel="alternate" type="application/json+oembed" href="https://www.caymancompass.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.caymancompass.com%2F2021%2F07%2F27%2Fcita-expanded-vaccine-list-a-small-step-but-not-enough%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.caymancompass.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.caymancompass.com%2F2021%2F07%2F27%2Fcita-expanded-vaccine-list-a-small-step-but-not-enough%2F&#038;format=xml" />  <script type="text/javascript">var cffsiteurl = "https://www.caymancompass.com/wp-content/plugins";
var cffajaxurl = "https://www.caymancompass.com/wp-admin/admin-ajax.php";


var cfflinkhashtags = "false";</script> <style id="ctcc-css" type="text/css" media="screen">#catapult-cookie-bar {
					box-sizing: border-box;
					max-height: 0;
					opacity: 0;
					z-index: 99999;
					overflow: hidden;
					color: #ffffff;
					position: fixed;
					left: 0;
					bottom: 0;
					width: 100%;
					background-color: #0e1523;
				}
				#catapult-cookie-bar a {
					color: #c6e9ff;
				}
				#catapult-cookie-bar .x_close span {
					background-color: #ffffff;
				}
				button#catapultCookie {
					background:#00aeef;
					color: #ffffff;
					border: 0; padding: 6px 9px; border-radius: 3px;
				}
				#catapult-cookie-bar h3 {
					color: #ffffff;
				}
				.has-cookie-bar #catapult-cookie-bar {
					opacity: 1;
					max-height: 999px;
					min-height: 30px;
				}</style> <script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/www.caymancompass.com\/2021\/07\/27\/cita-expanded-vaccine-list-a-small-step-but-not-enough\/"},"headline":"CITA: Expanded vaccine list a &#8216;small step&#8217; but not enough","url":"https:\/\/www.caymancompass.com\/2021\/07\/27\/cita-expanded-vaccine-list-a-small-step-but-not-enough\/","thumbnailUrl":"https:\/\/www.caymancompass.com\/wp-content\/uploads\/2020\/06\/Marc-Langevin-General-Manager-The-Ritz-Carlton-Grand-Cayman3-150x150.jpeg","image":{"@type":"ImageObject","url":"https:\/\/www.caymancompass.com\/wp-content\/uploads\/2020\/06\/Marc-Langevin-General-Manager-The-Ritz-Carlton-Grand-Cayman3-150x150.jpeg"},"dateCreated":"2021-07-27T22:24:06Z","datePublished":"2021-07-27T22:24:06Z","dateModified":"2021-07-27T22:24:06Z","articleSection":"Local","author":[{"@type":"Person","name":"Norma Connolly"}],"creator":["Norma Connolly"],"publisher":{"@type":"Organization","name":"Cayman Compass","logo":"https:\/\/www.caymancompass.com\/wp-content\/uploads\/2019\/10\/CompassLogoNew544x180.png"},"keywords":["cita","marc langevin","reopening"]}</script>  <script type="text/javascript">var ajax_url = "https://www.caymancompass.com/wp-admin/admin-ajax.php";</script><!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]--> <script>window.tdb_globals = {"wpRestNonce":"196ffe0ef9","wpRestUrl":"https:\/\/www.caymancompass.com\/wp-json\/","permalinkStructure":"\/%year%\/%monthnum%\/%day%\/%postname%\/","isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":50,"postAutoloadStatus":"off","origPostEditUrl":null};</script> <script>window.tdwGlobal = {"adminUrl":"https:\/\/www.caymancompass.com\/wp-admin\/","wpRestNonce":"196ffe0ef9","wpRestUrl":"https:\/\/www.caymancompass.com\/wp-json\/","permalinkStructure":"\/%year%\/%monthnum%\/%day%\/%postname%\/"};</script> <noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript>  <script>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</script> <style>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</style> <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-PBNB99T');</script>    <script type="text/javascript" id="hs-script-loader" async defer src="//js.hs-scripts.com/5627643.js"></script>    <script id="mcjs">!function(c,h,i,m,p){m=c.createElement(h),p=c.getElementsByTagName(h)[0],m.async=1,m.src=i,p.parentNode.insertBefore(m,p)}(document,"script","https://chimpstatic.com/mcjs-connected/js/users/b144ccc8214e0a3588b280790/225c3aaa4ffba0c893d5e5913.js");</script>  <script type="application/ld+json">{
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://www.caymancompass.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.caymancompass.com/category/localnews/",
                    "name": "Local"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.caymancompass.com/2021/07/27/cita-expanded-vaccine-list-a-small-step-but-not-enough/",
                    "name": "CITA: Expanded vaccine list a &#8216;small step&#8217; but not enough"                                
                }
            }    
        ]
    }</script> <style>.tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,
                .tds-button2 .tdm-btn-text,
                .tds-button2 i,
                .tds-button5:hover .tdm-btn-text,
                .tds-button5:hover i,
                .tds-button6 .tdm-btn-text,
                .tds-button6 i,
                .tdm_block_list .tdm-list-item i,
                .tdm_block_pricing .tdm-pricing-feature i,
                .tdm-social-item i {
                    color: #a0213f;
                }
                .tds-button1,
                .tds-button6:after,
                .tds-title2 .tdm-title-line:after,
                .tds-title3 .tdm-title-line:after,
                .tdm_block_pricing.tdm-pricing-featured:before,
                .tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,
                .tds-progress-bar1 .tdm-progress-bar:after,
                .tds-progress-bar2 .tdm-progress-bar:after,
                .tds-social3 .tdm-social-item {
                    background-color: #a0213f;
                }
                .tds-button2:before,
                .tds-button6:before,
                .tds-progress-bar3 .tdm-progress-bar:after {
                  border-color: #a0213f;
                }
                .tdm-btn-style1 {
					background-color: #a0213f;
				}
				.tdm-btn-style2:before {
				    border-color: #a0213f;
				}
				.tdm-btn-style2 {
				    color: #a0213f;
				}
				.tdm-btn-style3 {
				    -webkit-box-shadow: 0 2px 16px #a0213f;
                    -moz-box-shadow: 0 2px 16px #a0213f;
                    box-shadow: 0 2px 16px #a0213f;
				}
				.tdm-btn-style3:hover {
				    -webkit-box-shadow: 0 4px 26px #a0213f;
                    -moz-box-shadow: 0 4px 26px #a0213f;
                    box-shadow: 0 4px 26px #a0213f;
				}</style><style id="tdw-css-placeholder">/* GRAVITY FORM POLL CONFIRMATION WINDOW */
.gpoll_container {
  font-size: 15px;
}
/* REMOVE LINES BETWEEN STORIES IN BLOCK 7 */
.td_module_6 {
  border-bottom: none !important;
}
body .tds-button1 .tdm-btn-text {
  color: #fff !important;
}
.finance-hp-highlight .td-post-date {
  color: #777 !important;
}
.finance-hp-highlight .td_module_mx1 .td-post-date {
  color: #fff !important;
}
body .td-trending-now-wrapper .td-trending-now-title {
  font-family: "Open Sans", arial, sans-serif;
  font-weight: bold !important;
}
.td-big-grid-wrapper .td-module-meta-info .td-post-author-name a {
  color: #fff !important;
}
.home-pg-max-height {
  max-height: 620px !important;
  overflow: hidden;
}
.home-pg-top-features h4 {
  margin-bottom: 5px !important;
}
.home-pg-top-features img {
  float: left !important;
  margin-right: 12px !important;
}
.home-pg-top-features {
  min-height: 90px;
}
/* PARTNER CONTENT HOME PG TITLE BLOCK 12 */
.partner-content h3 a {
  color: #00325e !important;
}
.partner-content .td-module-meta-info {
  display: none;
}
/* election menu button */
/* .election-nav-btn > a {
    color: #fff !important;
    background-color: #a0213f !important;
    background-image: url('https://www.caymancompass.com/wp-content/uploads/2016/12/CaymanFlag-background-blurred-696x343.jpg');
    background-size: cover;
} */
/* REMOVE BOTTOM SHADOW FROM MODAL POPUP IMAGES */
.mfp-figure::before {
  display: none !important;
}
.mfp-counter,
.mfp-title {
  background: #0007 !important;
  line-height: 30px !important;
  padding-left: 10px;
  font-size: 15px;
}</style><script data-cfasync="false" id="ao_optimized_gfonts_webfontloader">(function() {var wf = document.createElement('script');wf.src='https://ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';wf.type='text/javascript';wf.async='true';var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(wf, s);})();</script><script async src='/cdn-cgi/bm/cv/669835187/api.js'></script></head><body class="post-template-default single single-post postid-536319 single-format-standard theme-Newspaper td-standard-pack woocommerce-no-js woocommerce-multicurrency-KYD cita-expanded-vaccine-list-a-small-step-but-not-enough global-block-template-16 cc single_template_5 white-menu td-animation-stack-type0 td-boxed-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage"><div class="td-scroll-up"><i class="td-icon-menu-up"></i></div><div class="td-menu-background"></div><div id="td-mobile-nav"><div class="td-mobile-container"><div class="td-menu-socials-wrap"><div class="td-menu-socials"> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.facebook.com/caycompass/" title="Facebook"> <i class="td-icon-font td-icon-facebook"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.instagram.com/cayman_compass/" title="Instagram"> <i class="td-icon-font td-icon-instagram"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://twitter.com/cayCompass" title="Twitter"> <i class="td-icon-font td-icon-twitter"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.youtube.com/user/caymancompas" title="Youtube"> <i class="td-icon-font td-icon-youtube"></i> </a> </span></div><div class="td-mobile-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div></div><div class="td-mobile-content"><div class="menu-main-menu-container"><ul id="menu-main-menu" class="td-mobile-main-menu"><li id="menu-item-489487" class="hide-for-desktop menu-item menu-item-type-custom menu-item-object-custom menu-item-first menu-item-489487"><a href="/?s=">Search</a></li><li id="menu-item-489489" class="hide-for-desktop s-trigger-login s-logged-out menu-item menu-item-type-custom menu-item-object-custom menu-item-489489"><a href="#login">Login/Register</a></li><li id="menu-item-490096" class="hide-for-desktop s-logged-in menu-item menu-item-type-custom menu-item-object-custom menu-item-490096"><a href="https://www.caymancompass.com/wp-login.php?action=logout&#038;redirect_to=%2F">Logout</a></li><li id="menu-item-187847" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-187847"><a href="https://www.caymancompass.com/cayman-news/">News<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-187848" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-187848"><a href="https://www.caymancompass.com/cayman-news/">Cayman News</a></li><li id="menu-item-531530" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-531530"><a href="https://www.caymancompass.com/storm-centre/">Storm Centre</a></li><li id="menu-item-470185" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-470185"><a href="https://www.caymancompass.com/coronavirus-cayman/">Coronavirus (COVID-19)</a></li><li id="menu-item-463399" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-463399"><a href="https://www.caymancompass.com/business/">Business<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-512427" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-512427"><a href="https://www.caymancompass.com/business/">Cayman Business</a></li><li id="menu-item-512428" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-512428"><a href="https://www.caymancompass.com/business/compass-finance/">Compass  Finance</a></li><li id="menu-item-512426" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-512426"><a href="https://www.caymancompass.com/women-in-business/">Women In Business</a></li></ul></li><li id="menu-item-188240" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188240"><a href="https://www.caymancompass.com/crime-and-courts/">Crime and Courts</a></li><li id="menu-item-461693" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-461693"><a href="https://www.caymancompass.com/living/">Living</a></li><li id="menu-item-465716" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-465716"><a href="https://www.caymancompass.com/opinion/">Opinion<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-465705" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-465705"><a href="https://www.caymancompass.com/opinion/editoral/">Editorial</a></li><li id="menu-item-465695" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-465695"><a href="https://www.caymancompass.com/opinion/letters-to-the-editor/">Letters</a></li><li id="menu-item-465696" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-465696"><a href="https://www.caymancompass.com/opinion/columns/">Columns</a></li><li id="menu-item-461688" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-461688"><a href="https://www.caymancompass.com/cartoons/">Cartoons</a></li><li id="menu-item-188304" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188304"><a href="https://www.caymancompass.com/submit-letter-to-the-editor/">Write a Letter to the Editor</a></li></ul></li><li id="menu-item-461689" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-461689"><a href="https://www.caymancompass.com/sports/">Sports</a></li><li id="menu-item-512411" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-512411"><a href="https://www.caymancompass.com/politics/">Politics</a></li><li id="menu-item-461692" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-461692"><a href="https://www.caymancompass.com/weather/">Weather</a></li><li id="menu-item-529560" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-529560"><a href="https://www.caymancompass.com/cayman-real-estate/">Cayman Real Estate</a></li><li id="menu-item-489131" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-489131"><a href="https://www.caymancompass.com/world/">World</a></li><li id="menu-item-513522" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-513522"><a href="https://www.caymancompass.com/vote-cayman/">2021 Election Coverage<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-522073" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-522073"><a href="https://www.caymancompass.com/vote-cayman/districts/">Results by District<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-515288" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515288"><a href="https://www.caymancompass.com/vote-cayman/bodden-town-east/">Bodden Town East</a></li><li id="menu-item-515289" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515289"><a href="https://www.caymancompass.com/vote-cayman/bodden-town-west/">Bodden Town West</a></li><li id="menu-item-515290" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515290"><a href="https://www.caymancompass.com/vote-cayman/cayman-brac-east/">Cayman Brac East</a></li><li id="menu-item-515286" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515286"><a href="https://www.caymancompass.com/vote-cayman/cayman-brac-west-and-little-cayman/">Cayman Brac West and Little Cayman</a></li><li id="menu-item-516473" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-516473"><a href="https://www.caymancompass.com/vote-cayman/east-end/">East End</a></li><li id="menu-item-515285" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515285"><a href="https://www.caymancompass.com/vote-cayman/george-town-central/">George Town Central</a></li><li id="menu-item-515284" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515284"><a href="https://www.caymancompass.com/vote-cayman/george-town-east/">George Town East</a></li><li id="menu-item-515283" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515283"><a href="https://www.caymancompass.com/vote-cayman/george-town-north/">George Town North</a></li><li id="menu-item-515282" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515282"><a href="https://www.caymancompass.com/vote-cayman/george-town-south/">George Town South</a></li><li id="menu-item-515281" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515281"><a href="https://www.caymancompass.com/vote-cayman/george-town-west/">George Town West</a></li><li id="menu-item-515280" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515280"><a href="https://www.caymancompass.com/vote-cayman/newlands/">Newlands</a></li><li id="menu-item-515279" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515279"><a href="https://www.caymancompass.com/vote-cayman/north-side/">North Side</a></li><li id="menu-item-515278" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515278"><a href="https://www.caymancompass.com/vote-cayman/prospect/">Prospect</a></li><li id="menu-item-515277" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515277"><a href="https://www.caymancompass.com/vote-cayman/red-bay/">Red Bay</a></li><li id="menu-item-515276" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515276"><a href="https://www.caymancompass.com/vote-cayman/savannah/">Savannah</a></li><li id="menu-item-515275" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515275"><a href="https://www.caymancompass.com/vote-cayman/west-bay-central/">West Bay Central</a></li><li id="menu-item-515274" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515274"><a href="https://www.caymancompass.com/vote-cayman/west-bay-north/">West Bay North</a></li><li id="menu-item-515273" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515273"><a href="https://www.caymancompass.com/vote-cayman/west-bay-south/">West Bay South</a></li><li id="menu-item-515272" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515272"><a href="https://www.caymancompass.com/vote-cayman/west-bay-west/">West Bay West</a></li></ul></li><li id="menu-item-514647" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-514647"><a href="https://www.caymancompass.com/vote-cayman/candidates/">Candidates</a></li></ul></li></ul></li><li id="menu-item-464189" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-464189"><a href="https://www.caymancompass.com/issues/">Issues<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-529956" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-529956"><a href="https://www.caymancompass.com/issues/sexual-harassment-in-cayman/">Sexual Harassment in Cayman</a></li><li id="menu-item-514433" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-514433"><a href="https://www.caymancompass.com/issues/cost-of-living-cayman/">Cost of Living</a></li><li id="menu-item-486325" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-486325"><a href="https://www.caymancompass.com/issues/cayman2-0/">Cayman 2.0</a></li><li id="menu-item-470131" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-470131"><a href="https://www.caymancompass.com/issues/climate-change/">Climate Change</a></li><li id="menu-item-466938" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-466938"><a href="https://www.caymancompass.com/issues/traffic/">Traffic</a></li><li id="menu-item-464188" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-464188"><a href="https://www.caymancompass.com/issues/founded-upon-the-seas/">Founded Upon the Seas</a></li><li id="menu-item-458002" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-458002"><a href="https://www.caymancompass.com/issues/port-vote-2019/">Port Vote 2019</a></li><li id="menu-item-458001" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-458001"><a href="https://www.caymancompass.com/issues/friday-features/">Friday Features</a></li><li id="menu-item-456066" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-456066"><a href="https://www.caymancompass.com/issues/sargassum/">Sargassum</a></li><li id="menu-item-471740" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-471740"><a href="https://www.caymancompass.com/issues/">All Issues Stories</a></li></ul></li><li id="menu-item-529561" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-529561"><a href="https://www.caymancompass.com/tourism/">Travel</a></li><li id="menu-item-512410" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-512410"><a href="https://www.caymancompass.com/jobs/">Jobs<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-512433" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-512433"><a href="https://www.caymancompass.com/jobs/">Employment News</a></li><li id="menu-item-512432" class="s-trigger-login s-logged-out menu-item menu-item-type-post_type menu-item-object-page menu-item-512432"><a href="https://www.caymancompass.com/e-versions/">E-versions &#038; Classifieds</a></li></ul></li><li id="menu-item-512421" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-512421"><a href="https://www.caymancompass.com/health-and-wellness/">Health<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-512478" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-512478"><a href="https://www.caymancompass.com/coronavirus-cayman/">Coronavirus (COVID-19) Cayman</a></li><li id="menu-item-512424" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-512424"><a href="https://www.caymancompass.com/health-and-wellness/">Health &#038; Wellness</a></li><li id="menu-item-512423" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-512423"><a href="https://www.caymancompass.com/healthcare-in-a-pandemic/">Healthcare in a Pandemic</a></li><li id="menu-item-512422" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-512422"><a target="_blank" href="https://www.caymanhealth.com/">Cayman Health Directory</a></li></ul></li><li id="menu-item-512412" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-512412"><a href="https://www.caymancompass.com/community/">Community<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-188277" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-188277"><a href="/events/">Calendar<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-314306" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-314306"><a href="/events/">Event Listings</a></li><li id="menu-item-315091" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-315091"><a href="https://www.caymancompass.com/submit-event/">Submit an Event</a></li></ul></li><li id="menu-item-457157" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-457157"><a href="https://www.caymancompass.com/notices/">Notices</a></li><li id="menu-item-515426" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515426"><a href="https://www.caymancompass.com/press-releases/">Press Releases</a></li><li id="menu-item-512415" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-512415"><a href="https://www.caymancompass.com/opinion/letters-to-the-editor/">Letters</a></li><li id="menu-item-188303" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188303"><a href="https://www.caymancompass.com/submit-a-story-idea/">Submit a Story Idea</a></li><li id="menu-item-512413" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-512413"><a href="https://www.caymancompass.com/submit-letter-to-the-editor/">Submit Letter to the Editor</a></li><li id="menu-item-534831" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-534831"><a href="https://www.caymancompass.com/tag/cayman-marine-lab/">Cayman Marine World Tidbits</a></li><li id="menu-item-508585" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-508585"><a href="https://www.caymancompass.com/cayman-islands-public-holidays-2021/">Cayman Islands Public Holidays 2021</a></li><li id="menu-item-500450" class="menu-item menu-item-type-post_type menu-item-object-product menu-item-500450"><a href="https://www.caymancompass.com/store/cayman-islands-2021-calendar/">Cayman Islands 2021 Printed Calendar</a></li><li id="menu-item-188275" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188275"><a href="https://www.caymancompass.com/contests/">Contests</a></li></ul></li><li id="menu-item-512430" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-512430"><a href="#">Watch/Listen<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-461691" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-461691"><a href="https://www.caymancompass.com/video/">Video</a></li><li id="menu-item-467157" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-467157"><a href="https://www.caymancompass.com/podcasts/">Podcasts</a></li><li id="menu-item-464405" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-464405"><a href="https://www.caymancompass.com/interactive/">Interactive</a></li></ul></li><li id="menu-item-188276" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-188276"><a href="#">More<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-461690" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-461690"><a href="https://www.caymancompass.com/subscribe/">Subscribe</a></li><li id="menu-item-482735" class="menu-item menu-item-type-post_type menu-item-object-product menu-item-482735"><a href="https://www.caymancompass.com/store/donate/">Donate &#8211; Support Local Journalism</a></li><li id="menu-item-489945" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-489945"><a href="https://www.caymancompass.com/e-versions/">E-versions</a></li><li id="menu-item-359853" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-359853"><a href="https://www.caymancompass.com/editorial-staff/">Editorial Staff</a></li><li id="menu-item-499356" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-499356"><a href="https://www.caymancompass.com/faq/">Help &#038; FAQ</a></li><li id="menu-item-465825" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-465825"><a href="https://www.caymancompass.com/contact/">Contact</a></li><li id="menu-item-188280" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188280"><a href="https://www.caymancompass.com/advertise-with-us/">Advertise With Us</a></li><li id="menu-item-371483" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-371483"><a target="_blank" href="https://www.caymancompass.com/wp-content/uploads/2021/01/CompassMediaKit_JUL_2020-Print.pdf">Print Media Kit</a></li><li id="menu-item-389921" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-389921"><a href="https://www.caymancompass.com/wp-content/uploads/2020/09/CompassDigitalMediaKit2020-July-v2.pdf">Online Media Kit</a></li><li id="menu-item-511478" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-511478"><a href="https://www.caymancompass.com/wp-content/uploads/2021/01/Compass-Classifieds-Rate-Sheet-Jan2021.pdf">Classifieds Rate Sheet</a></li><li id="menu-item-482734" class="menu-item menu-item-type-post_type menu-item-object-product menu-item-482734"><a href="https://www.caymancompass.com/store/pay-bill/">Pay Bill</a></li><li id="menu-item-492594" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-492594"><a href="https://www.caymancompass.com/legal/">Legal</a></li></ul></li><li id="menu-item-490102" class="s-logged-in hide-for-desktop menu-item menu-item-type-custom menu-item-object-custom menu-item-490102"><a href="https://www.caymancompass.com/wp-login.php?action=logout&#038;redirect_to=%2F">Logout</a></li></ul></div></div></div><div id="login-form-mobile" class="td-register-section"><div id="td-login-mob" class="td-login-animation td-login-hide-mob"><div class="td-login-close"> <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a><div class="td-login-title">Sign in</div><div class="td-mobile-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div></div><div class="td-login-form-wrap"><div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div><div class="td_display_err"></div><div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div><div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div> <input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN"><div class="td-login-info-text"> <a href="#" id="forgot-pass-link-mob">Forgot your password?</a></div><div class="td-login-register-link"> <a id="signin-register-link-mob">Create an account</a></div><div class="td-login-info-text"><a class="privacy-policy-link" href="https://www.caymancompass.com/privacy-policy/">Privacy Policy</a></div></div></div><div id="td-register-mob" class="td-login-animation td-login-hide-mob"><div class="td-register-close"> <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a><div class="td-login-title">Sign up</div><div class="td-mobile-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div></div><div class="td-login-panel-title"><span>Welcome!</span>Register for an account</div><div class="td-login-form-wrap"><div class="td_display_err"></div><div class="td-login-inputs"><input class="td-login-input" type="text" name="register_email" id="register_email-mob" value="" required><label>your email</label></div><div class="td-login-inputs"><input class="td-login-input" type="text" name="register_user" id="register_user-mob" value="" required><label>your username</label></div> <input type="button" name="register_button" id="register_button-mob" class="td-login-button" value="REGISTER"><div class="td-login-info-text">A password will be e-mailed to you.</div><div class="td-login-info-text"><a class="privacy-policy-link" href="https://www.caymancompass.com/privacy-policy/">Privacy Policy</a></div></div></div><div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob"><div class="td-forgot-pass-close"> <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a><div class="td-login-title">Password recovery</div></div><div class="td-login-form-wrap"><div class="td-login-panel-title">Recover your password</div><div class="td_display_err"></div><div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div> <input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass"></div></div></div></div><div class="td-search-background"></div><div class="td-search-wrap-mob"><div class="td-drop-down-search"><form method="get" class="td-search-form" action="https://www.caymancompass.com/"><div class="td-search-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div><div role="search" class="td-search-input"> <span>Search</span> <input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" /></div></form><div id="td-aj-search-mob" class="td-ajax-search-flex"></div></div></div><div id="td-outer-wrap" class="td-theme-wrap"><div class="tdc-header-wrap "><div class="compass-header"><div class="td-header-top-menu-full td-container-wrap td_stretch_container"><div class="top-bar-container td-container td-header-row td-header-top-menu"><div class="compass-top-bar"><div class="cell top-menu-container"><div class="menu-top-container"><ul id="menu-top-menu" class="top-menu"><li id="menu-item-428186" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-428186"><a href="https://www.caymancompass.com/advertise-with-us/">Advertise</a></li><li id="menu-item-316348" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-316348"><a href="https://www.caymancompass.com/faq/">Help</a></li></ul></div> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.facebook.com/caycompass/" title="Facebook"> <i class="td-icon-font td-icon-facebook"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.instagram.com/cayman_compass/" title="Instagram"> <i class="td-icon-font td-icon-instagram"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://twitter.com/cayCompass" title="Twitter"> <i class="td-icon-font td-icon-twitter"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.youtube.com/user/caymancompas" title="Youtube"> <i class="td-icon-font td-icon-youtube"></i> </a> </span></div><div class="cell profile-menu-container s-profile-menu"></div></div></div></div><div class="grid-container header-container"> <a href="https://www.caymancompass.com" class="logo"> <img srcset="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassLogoNew-272x90.png 1x, https://www.caymancompass.com/wp-content/uploads/2019/10/CompassLogoNew544x180.png 2x" alt="Cayman Compass Logo"> </a><div class="recs"><div class="td-header-rec-wrap"><div class="td-a-rec td-a-rec-id-header  tdi_1_4c4 td_block_template_16"><style>/* custom css */
.tdi_1_4c4.td-a-rec{
					text-align: center;
				}.tdi_1_4c4 .td-element-style{
					z-index: -1;
				}.tdi_1_4c4.td-a-rec-img{
				    text-align: left;
				}.tdi_1_4c4.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_1_4c4.td-a-rec-img {
				        text-align: center;
				    }
                }</style> <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PBNB99T"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><div class="ad-delay-fix-for-mobile" style="min-height:50px;height:auto;"><div class="td-visible-all-devices" id="placement_197225_container">  <script type="text/javascript">if (!window.AdButler){(function(){var s = document.createElement("script"); s.async = true; s.type = "text/javascript";s.src = 'https://servedbyadbutler.com/app.js';var n = document.getElementsByTagName("script")[0]; n.parentNode.insertBefore(s, n);}());}</script> <script type="text/javascript">if (typeof _la === 'undefined' || !Array.isArray(_la)) _la = []; _la.push(function() {
    console.log('Loading header ad');
    var abkw = window.abkw || '';
    var plc197225 = window.plc197225 || 0;
    var dom = document.querySelector('#placement_197225_container');

    dom.innerHTML = '<div id="placement_197225_'+plc197225+'"></div>';
    window.AdButler.ads.push({
        handler: function(opt){
            window.AdButler.register(165413, 197225, [728,90], 'placement_197225_' + opt.place, opt);
        }, opt: {
            place: plc197225++,
            keywords: abkw,
            domain: 'servedbyadbutler.com',
            click:'CLICK_MACRO_PLACEHOLDER'
        }
    });
});</script> </div></div></div></div></div></div><div class="menu-row sticky-navbar"><div class="grid-container menu-container"> <a href="https://www.caymancompass.com" class="sticky-logo"> <img srcset="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassLogoNew-272x90.png 1x, https://www.caymancompass.com/wp-content/uploads/2019/10/CompassLogoNew544x180.png 2x" alt="Cayman Compass Logo"> </a><div class="menu-main-menu-container"><ul id="menu-main-menu-1" class="sf-menu"><li class="hide-for-desktop menu-item menu-item-type-custom menu-item-object-custom menu-item-first td-menu-item td-normal-menu menu-item-489487"><a href="/?s=">Search</a></li><li class="hide-for-desktop s-trigger-login s-logged-out menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-489489"><a href="#login">Login/Register</a></li><li class="hide-for-desktop s-logged-in menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-490096"><a href="https://www.caymancompass.com/wp-login.php?action=logout&#038;redirect_to=%2F">Logout</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-187847"><a href="https://www.caymancompass.com/cayman-news/">News</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-187848"><a href="https://www.caymancompass.com/cayman-news/">Cayman News</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-531530"><a href="https://www.caymancompass.com/storm-centre/">Storm Centre</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-470185"><a href="https://www.caymancompass.com/coronavirus-cayman/">Coronavirus (COVID-19)</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-463399"><a href="https://www.caymancompass.com/business/">Business</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-512427"><a href="https://www.caymancompass.com/business/">Cayman Business</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-512428"><a href="https://www.caymancompass.com/business/compass-finance/">Compass  Finance</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-512426"><a href="https://www.caymancompass.com/women-in-business/">Women In Business</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188240"><a href="https://www.caymancompass.com/crime-and-courts/">Crime and Courts</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-461693"><a href="https://www.caymancompass.com/living/">Living</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-465716"><a href="https://www.caymancompass.com/opinion/">Opinion</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-465705"><a href="https://www.caymancompass.com/opinion/editoral/">Editorial</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-465695"><a href="https://www.caymancompass.com/opinion/letters-to-the-editor/">Letters</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-465696"><a href="https://www.caymancompass.com/opinion/columns/">Columns</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-461688"><a href="https://www.caymancompass.com/cartoons/">Cartoons</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188304"><a href="https://www.caymancompass.com/submit-letter-to-the-editor/">Write a Letter to the Editor</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-461689"><a href="https://www.caymancompass.com/sports/">Sports</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-512411"><a href="https://www.caymancompass.com/politics/">Politics</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-461692"><a href="https://www.caymancompass.com/weather/">Weather</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-529560"><a href="https://www.caymancompass.com/cayman-real-estate/">Cayman Real Estate</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-489131"><a href="https://www.caymancompass.com/world/">World</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-513522"><a href="https://www.caymancompass.com/vote-cayman/">2021 Election Coverage</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-522073"><a href="https://www.caymancompass.com/vote-cayman/districts/">Results by District</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-515288"><a href="https://www.caymancompass.com/vote-cayman/bodden-town-east/">Bodden Town East</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-515289"><a href="https://www.caymancompass.com/vote-cayman/bodden-town-west/">Bodden Town West</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-515290"><a href="https://www.caymancompass.com/vote-cayman/cayman-brac-east/">Cayman Brac East</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-515286"><a href="https://www.caymancompass.com/vote-cayman/cayman-brac-west-and-little-cayman/">Cayman Brac West and Little Cayman</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-516473"><a href="https://www.caymancompass.com/vote-cayman/east-end/">East End</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-515285"><a href="https://www.caymancompass.com/vote-cayman/george-town-central/">George Town Central</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-515284"><a href="https://www.caymancompass.com/vote-cayman/george-town-east/">George Town East</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-515283"><a href="https://www.caymancompass.com/vote-cayman/george-town-north/">George Town North</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-515282"><a href="https://www.caymancompass.com/vote-cayman/george-town-south/">George Town South</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-515281"><a href="https://www.caymancompass.com/vote-cayman/george-town-west/">George Town West</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-515280"><a href="https://www.caymancompass.com/vote-cayman/newlands/">Newlands</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-515279"><a href="https://www.caymancompass.com/vote-cayman/north-side/">North Side</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-515278"><a href="https://www.caymancompass.com/vote-cayman/prospect/">Prospect</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-515277"><a href="https://www.caymancompass.com/vote-cayman/red-bay/">Red Bay</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-515276"><a href="https://www.caymancompass.com/vote-cayman/savannah/">Savannah</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-515275"><a href="https://www.caymancompass.com/vote-cayman/west-bay-central/">West Bay Central</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-515274"><a href="https://www.caymancompass.com/vote-cayman/west-bay-north/">West Bay North</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-515273"><a href="https://www.caymancompass.com/vote-cayman/west-bay-south/">West Bay South</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-515272"><a href="https://www.caymancompass.com/vote-cayman/west-bay-west/">West Bay West</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-514647"><a href="https://www.caymancompass.com/vote-cayman/candidates/">Candidates</a></li></ul></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-464189"><a href="https://www.caymancompass.com/issues/">Issues</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-529956"><a href="https://www.caymancompass.com/issues/sexual-harassment-in-cayman/">Sexual Harassment in Cayman</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-514433"><a href="https://www.caymancompass.com/issues/cost-of-living-cayman/">Cost of Living</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-486325"><a href="https://www.caymancompass.com/issues/cayman2-0/">Cayman 2.0</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-470131"><a href="https://www.caymancompass.com/issues/climate-change/">Climate Change</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-466938"><a href="https://www.caymancompass.com/issues/traffic/">Traffic</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-464188"><a href="https://www.caymancompass.com/issues/founded-upon-the-seas/">Founded Upon the Seas</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-458002"><a href="https://www.caymancompass.com/issues/port-vote-2019/">Port Vote 2019</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-458001"><a href="https://www.caymancompass.com/issues/friday-features/">Friday Features</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-456066"><a href="https://www.caymancompass.com/issues/sargassum/">Sargassum</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-471740"><a href="https://www.caymancompass.com/issues/">All Issues Stories</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-529561"><a href="https://www.caymancompass.com/tourism/">Travel</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-512410"><a href="https://www.caymancompass.com/jobs/">Jobs</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-512433"><a href="https://www.caymancompass.com/jobs/">Employment News</a></li><li class="s-trigger-login s-logged-out menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-512432"><a href="https://www.caymancompass.com/e-versions/">E-versions &#038; Classifieds</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-512421"><a href="https://www.caymancompass.com/health-and-wellness/">Health</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-512478"><a href="https://www.caymancompass.com/coronavirus-cayman/">Coronavirus (COVID-19) Cayman</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-512424"><a href="https://www.caymancompass.com/health-and-wellness/">Health &#038; Wellness</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-512423"><a href="https://www.caymancompass.com/healthcare-in-a-pandemic/">Healthcare in a Pandemic</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-512422"><a target="_blank" href="https://www.caymanhealth.com/">Cayman Health Directory</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-512412"><a href="https://www.caymancompass.com/community/">Community</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-188277"><a href="/events/">Calendar</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-314306"><a href="/events/">Event Listings</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-315091"><a href="https://www.caymancompass.com/submit-event/">Submit an Event</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-457157"><a href="https://www.caymancompass.com/notices/">Notices</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-515426"><a href="https://www.caymancompass.com/press-releases/">Press Releases</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-512415"><a href="https://www.caymancompass.com/opinion/letters-to-the-editor/">Letters</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188303"><a href="https://www.caymancompass.com/submit-a-story-idea/">Submit a Story Idea</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-512413"><a href="https://www.caymancompass.com/submit-letter-to-the-editor/">Submit Letter to the Editor</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag td-menu-item td-normal-menu menu-item-534831"><a href="https://www.caymancompass.com/tag/cayman-marine-lab/">Cayman Marine World Tidbits</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-508585"><a href="https://www.caymancompass.com/cayman-islands-public-holidays-2021/">Cayman Islands Public Holidays 2021</a></li><li class="menu-item menu-item-type-post_type menu-item-object-product td-menu-item td-normal-menu menu-item-500450"><a href="https://www.caymancompass.com/store/cayman-islands-2021-calendar/">Cayman Islands 2021 Printed Calendar</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188275"><a href="https://www.caymancompass.com/contests/">Contests</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-512430"><a href="#">Watch/Listen</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-461691"><a href="https://www.caymancompass.com/video/">Video</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-467157"><a href="https://www.caymancompass.com/podcasts/">Podcasts</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-464405"><a href="https://www.caymancompass.com/interactive/">Interactive</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-188276"><a href="#">More</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-461690"><a href="https://www.caymancompass.com/subscribe/">Subscribe</a></li><li class="menu-item menu-item-type-post_type menu-item-object-product td-menu-item td-normal-menu menu-item-482735"><a href="https://www.caymancompass.com/store/donate/">Donate &#8211; Support Local Journalism</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-489945"><a href="https://www.caymancompass.com/e-versions/">E-versions</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-359853"><a href="https://www.caymancompass.com/editorial-staff/">Editorial Staff</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-499356"><a href="https://www.caymancompass.com/faq/">Help &#038; FAQ</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-465825"><a href="https://www.caymancompass.com/contact/">Contact</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-188280"><a href="https://www.caymancompass.com/advertise-with-us/">Advertise With Us</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-371483"><a target="_blank" href="https://www.caymancompass.com/wp-content/uploads/2021/01/CompassMediaKit_JUL_2020-Print.pdf">Print Media Kit</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-389921"><a href="https://www.caymancompass.com/wp-content/uploads/2020/09/CompassDigitalMediaKit2020-July-v2.pdf">Online Media Kit</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-511478"><a href="https://www.caymancompass.com/wp-content/uploads/2021/01/Compass-Classifieds-Rate-Sheet-Jan2021.pdf">Classifieds Rate Sheet</a></li><li class="menu-item menu-item-type-post_type menu-item-object-product td-menu-item td-normal-menu menu-item-482734"><a href="https://www.caymancompass.com/store/pay-bill/">Pay Bill</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-492594"><a href="https://www.caymancompass.com/legal/">Legal</a></li></ul></li><li class="s-logged-in hide-for-desktop menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-490102"><a href="https://www.caymancompass.com/wp-login.php?action=logout&#038;redirect_to=%2F">Logout</a></li></ul></div><div class="search-container td-header-wrap"><div class="header-search-wrap"><div class="td-search-btns-wrap"> <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a> <a id="td-header-search-button-mob" href="#" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a></div><div class="td-drop-down-search" aria-labelledby="td-header-search-button"><form method="get" class="td-search-form" action="https://www.caymancompass.com/"><div role="search" class="td-head-form-search-wrap"> <input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" /></div></form><div id="td-aj-search"></div></div></div></div></div></div><div class="mobile-header sticky-navbar"><div class="cell header-left"><div id="td-top-mobile-toggle" class="menu-opener"> <a> <svg width="17" height="15" viewBox="0 0 17 15" fill="none" xmlns="http://www.w3.org/2000/svg"><path d="M1.36001 0.149902C0.664381 0.149902 0.100006 0.714277 0.100006 1.4099C0.100006 2.10553 0.664381 2.6699 1.36001 2.6699H15.64C16.3356 2.6699 16.9 2.10553 16.9 1.4099C16.9 0.714277 16.3356 0.149902 15.64 0.149902H1.36001ZM1.36001 6.2399C0.664381 6.2399 0.100006 6.80428 0.100006 7.4999C0.100006 8.19553 0.664381 8.7599 1.36001 8.7599H15.64C16.3356 8.7599 16.9 8.19553 16.9 7.4999C16.9 6.80428 16.3356 6.2399 15.64 6.2399H1.36001ZM1.36001 12.3299C0.664381 12.3299 0.100006 12.8943 0.100006 13.5899C0.100006 14.2855 0.664381 14.8499 1.36001 14.8499H15.64C16.3356 14.8499 16.9 14.2855 16.9 13.5899C16.9 12.8943 16.3356 12.3299 15.64 12.3299H1.36001Z" fill="#242424"/></svg> </a></div> <a href="https://www.caymancompass.com" class="mobile-logo"> <img srcset="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassLogoNew-272x90.png 1x, https://www.caymancompass.com/wp-content/uploads/2019/10/CompassLogoNew544x180.png 2x" alt="Cayman Compass Logo"> </a></div><div class="cell header-right"><div class="account-container s-profile-menu"></div><div class="search-icon-container"> <a id="td-header-search-button-mob" href="#" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a></div></div></div></div></div><div class="td-main-content-wrap td-container-wrap"><div class="td-container td-post-template-5 "><div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://www.caymancompass.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Local" class="entry-crumb" href="https://www.caymancompass.com/category/localnews/">Local</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">CITA: Expanded vaccine list a &#8216;small step&#8217; but not enough</span></div></div><div class="td-pb-row"><div class="td-pb-span8 td-main-content" role="main"><div class="td-ss-main-content"><article id="post-536319" class="post-536319 post type-post status-publish format-standard has-post-thumbnail category-localnews tag-cita tag-marc-langevin tag-reopening" itemscope itemtype="https://schema.org/Article"><div class="td-post-header"><ul class="td-category"><li class="entry-category"><a  href="https://www.caymancompass.com/category/localnews/">Local</a></li></ul><header class="td-post-title"><h1 class="entry-title">CITA: Expanded vaccine list a &#8216;small step&#8217; but not enough</h1><div class="td-module-meta-info"><div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://www.caymancompass.com/author/nconnolly/">Norma Connolly</a><div class="td-author-line"> -</div></div> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-07-27T17:24:06-05:00" >July 27, 2021</time></span></div></header></div><div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-bg td-ps-notext td-ps-rounded td-post-sharing-style3 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.caymancompass.com%2F2021%2F07%2F27%2Fcita-expanded-vaccine-list-a-small-step-but-not-enough%2F"><div class="td-social-but-icon"><i class="td-icon-facebook"></i></div><div class="td-social-but-text">Facebook</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=CITA%3A+Expanded+vaccine+list+a+%E2%80%98small+step%E2%80%99+but+not+enough&url=https%3A%2F%2Fwww.caymancompass.com%2F2021%2F07%2F27%2Fcita-expanded-vaccine-list-a-small-step-but-not-enough%2F&via=cayCompass"><div class="td-social-but-icon"><i class="td-icon-twitter"></i></div><div class="td-social-but-text">Twitter</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="https://api.whatsapp.com/send?text=CITA%3A+Expanded+vaccine+list+a+%E2%80%98small+step%E2%80%99+but+not+enough %0A%0A https://www.caymancompass.com/2021/07/27/cita-expanded-vaccine-list-a-small-step-but-not-enough/"><div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div><div class="td-social-but-text">WhatsApp</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="/cdn-cgi/l/email-protection#e3dc90968189868097dea0aab7a2d9c3a69b93828d878687c3958280808a8d86c38f8a9097c382c3c5c0dbd1d2d5d8908e828f8fc390978693c5c0dbd1d2d4d8c3819697c38d8c97c3868d8c96848bc5818c879ade8b97979390d9cccc949494cd80829a8e828d808c8e93829090cd808c8eccd1d3d1d2ccd3d4ccd1d4cc808a9782ce869b93828d878687ce958280808a8d86ce8f8a9097ce82ce908e828f8fce90978693ce819697ce8d8c97ce868d8c96848bcc"><div class="td-social-but-icon"><i class="td-icon-mail"></i></div><div class="td-social-but-text">Email</div> </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top"><div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div> </a></div></div></div><div class="td-post-content tagdiv-type"><div class="td-a-rec td-a-rec-id-content_top  tdi_3_2c1 td_block_template_16"><style>/* custom css */
.tdi_3_2c1.td-a-rec{
					text-align: center;
				}.tdi_3_2c1 .td-element-style{
					z-index: -1;
				}.tdi_3_2c1.td-a-rec-img{
				    text-align: left;
				}.tdi_3_2c1.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_3_2c1.td-a-rec-img {
				        text-align: center;
				    }
                }</style><div id="isb_phone_advert" class="td-visible-phone">  <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">if (typeof _la === 'undefined' || !Array.isArray(_la)) _la = [];

        _la.push(function() {
            var elem = document.getElementById("isb_phone_advert");
            var theCSSprop = window.getComputedStyle(elem,null).getPropertyValue("display");

            if (theCSSprop != "none") {
                window.loadAdZone(420687, 'isb_phone_advert');
            }
        });</script> </div></div><figure id="attachment_482693" aria-describedby="caption-attachment-482693" style="width: 300px" class="wp-caption alignright"><img loading="lazy" class="size-medium wp-image-482693" src="https://www.caymancompass.com/wp-content/uploads/2020/06/Marc-Langevin-General-Manager-The-Ritz-Carlton-Grand-Cayman3-300x200.jpeg" alt="" width="300" height="200" srcset="https://www.caymancompass.com/wp-content/uploads/2020/06/Marc-Langevin-General-Manager-The-Ritz-Carlton-Grand-Cayman3-300x200.jpeg 300w, https://www.caymancompass.com/wp-content/uploads/2020/06/Marc-Langevin-General-Manager-The-Ritz-Carlton-Grand-Cayman3-600x399.jpeg 600w, https://www.caymancompass.com/wp-content/uploads/2020/06/Marc-Langevin-General-Manager-The-Ritz-Carlton-Grand-Cayman3-1536x1022.jpeg 1536w, https://www.caymancompass.com/wp-content/uploads/2020/06/Marc-Langevin-General-Manager-The-Ritz-Carlton-Grand-Cayman3-2048x1362.jpeg 2048w, https://www.caymancompass.com/wp-content/uploads/2020/06/Marc-Langevin-General-Manager-The-Ritz-Carlton-Grand-Cayman3-696x463.jpeg 696w, https://www.caymancompass.com/wp-content/uploads/2020/06/Marc-Langevin-General-Manager-The-Ritz-Carlton-Grand-Cayman3-1068x710.jpeg 1068w, https://www.caymancompass.com/wp-content/uploads/2020/06/Marc-Langevin-General-Manager-The-Ritz-Carlton-Grand-Cayman3-1920x1277.jpeg 1920w, https://www.caymancompass.com/wp-content/uploads/2020/06/Marc-Langevin-General-Manager-The-Ritz-Carlton-Grand-Cayman3-631x420.jpeg 631w" sizes="(max-width: 300px) 100vw, 300px" /><figcaption id="caption-attachment-482693" class="wp-caption-text">Marc Langevin</figcaption></figure><p>Cayman Islands Tourism Association President Marc Langevin says that while the tourism industry welcomes the government&#8217;s expansion of the types of securely verifiable COVID-19 vaccination records it is now accepting, the process does not go far enough.</p><p>On Monday, the <a href="https://www.caymancompass.com/2021/07/26/cayman-expands-list-of-countries-with-verifiable-vaccinations/">government announced</a> that it was now accepting from incoming travellers SMART Health Cards from the US and records from European countries that meet the &#8216;EU Digital COVID Certificate&#8217; standard which shows vaccination information. Travellers who present those documents can avail of a five-day quarantine upon arrival here, rather than the 10-day isolation for those with vaccination certificates from other places, or the 14-day quarantine for unvaccinated travellers.</p><p>Langevin said while expanding the list was a step in the right direction, it did not provide travellers or Cayman&#8217;s tourism businesses with any reassurance about how the government plans to proceed with accepting vaccination certificates from other locations.</p><p>&#8220;Not everyone who wants to come here is from Louisiana or California or got their vaccinations at Walmart, or Sam&#8217;s Club, or CVS,&#8221; Langevin said in an interview with the <em>Compass</em> on Tuesday. &#8220;What if they got it somewhere else? It is a small step, but we&#8217;re not seeing the total scope [of the government&#8217;s plan].&#8221;</p><p>He added, &#8220;It does not give us, or travel agents, a level of confidence of where we will be in the future. It is a small piece of the puzzle but we don&#8217;t see the whole game. Will there be another 10 states or organisations accepted next week? Who knows? We are left in the dark and trying to guess where we will be in September or October or later. We need more information so we can convey that information to our business partners &#8211; the travel agents, the meeting planners, our direct customers.&#8221;</p><div class="td-a-rec td-a-rec-id-content_inline  tdi_2_11c td_block_template_16"><style>/* custom css */
.tdi_2_11c.td-a-rec{
					text-align: center;
				}.tdi_2_11c .td-element-style{
					z-index: -1;
				}.tdi_2_11c.td-a-rec-img{
				    text-align: left;
				}.tdi_2_11c.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_2_11c.td-a-rec-img {
				        text-align: center;
				    }
                }</style><div id="in_article_ad" class="td-all-devices in-article-lb-ad">  <script type="text/javascript">if (typeof _la === 'undefined' || !Array.isArray(_la)) _la = [];

        _la.push(function() {
            window.loadAdZone(420688, 'in_article_ad');
        });</script> </div></div><p>Since 23 June, for the purposes of the five-day quarantine, Cayman has only been accepting vaccination certificates or cards issued by the local Health Services Authority or the UK&#8217;s National Health Service. From Friday, 23 July, that list was expanded to:</p><ul><li>Issuers who use <a href="https://smarthealth.cards/">SMART Health Cards</a> and are a part of the <a href="https://www.commontrustnetwork.org/">CommonTrust Network</a>. This includes North American issuers, such as:<ul><li>Walmart Pharmacy</li><li>Sam&#8217;s Club Pharmacy</li><li>State of California</li><li>State of Louisiana</li><li>UC San Diego Health</li><li>CVS Health</li><li>UC Health</li></ul></li><li>Vaccination records from the European Union Member States and other countries that meet the EU Digital COVID Certificate standard.</li></ul><p>In a statement, the government said it anticipates that the approved list will grow as other vaccination issuers develop ways to produce securely verifiable vaccination records.</p><p>Currently, incoming travellers must obtain permission from Travel Cayman before they can fly to Cayman. Langevin has suggested that Cayman could use that avenue as a means of getting vaccination documentation verified before the passengers even get on the plane.</p><p>&#8220;Maybe we could create a system for Travel Cayman to do the validation of the certificates,&#8221; he said. &#8220;It happens in other destinations&#8230; you upload your certificate and they check it before you arrive and say if it is acceptable or not. So, basically, you&#8217;re reversing the process.</p><p>&#8220;Why not ask potential visitors to provide the vaccination documentation and see how you can validate it. &#8230; Everything should be done prior to arriving so that the experience is very painless.&#8221;</p><h2>Concerns with government&#8217;s reopening plan</h2><p><a href="https://www.caymancompass.com/2021/07/13/tourism-association-responds-to-cayman-reopening-plan/">CITA has previously complained</a> that it was not consulted by government in relation to <a href="https://www.caymancompass.com/2021/07/08/live-chamber-of-commerce-legislative-luncheon/">Cayman&#8217;s reopening plan</a>, which was announced by Premier Wayne Panton at a Chamber of Commerce luncheon earlier this month. In an interview with the <em>Compass</em> Tuesday, Langevin reiterated that he believes CITA&#8217;s expertise and knowledge could be of benefit to Cayman&#8217;s decision-makers when it comes to the timing of and procedures for allowing tourists to return to the islands.</p><p>&#8220;I understand there is a process for everything,&#8221; he said, &#8220;but at least, get us involved so we can share our views about getting to the next target, and how to make it easier for customers. Yes, there are a lot of logistics involved, but we&#8217;re not privy to the conversations that are going on. We&#8217;ve been working with government on the Caymanian employment drive and have made great progress, &#8230; but from a remobilisation and recovery point of view, we have not been consulted.&#8221;</p><p>Members of CITA will get to put their views and questions about the new list and the government&#8217;s border-reopening plan to officials at a meeting of the association&#8217;s membership on Thursday. Langevin said Panton, Deputy Premier Chris Saunders and Tourism Minister Kenneth Bryan are expected to attend.</p><div class="td-a-rec td-a-rec-id-content_bottom  tdi_4_ca0 td_block_template_16"><style>/* custom css */
.tdi_4_ca0.td-a-rec{
					text-align: center;
				}.tdi_4_ca0 .td-element-style{
					z-index: -1;
				}.tdi_4_ca0.td-a-rec-img{
				    text-align: left;
				}.tdi_4_ca0.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_4_ca0.td-a-rec-img {
				        text-align: center;
				    }
                }</style><div id="bottom_article_ad" class="td-all-devices">  <script type="text/javascript">if (typeof _la === 'undefined' || !Array.isArray(_la)) _la = [];

        _la.push(function() {
            window.loadAdZone(421033, 'bottom_article_ad');
        });</script> </div><div class="s-logged-out" style="margin-top:50px; border: 1px solid #ddd; background-color: #fff; padding: 30px 30px 10px 30px;"><p style="text-align:center;">Support local journalism. Subscribe to the all-access pass for the Cayman Compass.</p><p style="text-align:center;"><span class="td_btn td_btn_lg td_default_btn s-trigger-subscriptions"><a><span style="color: #ffffff;">Subscribe now</span></a></span></p></div></div></div><footer><div class="td-post-source-tags"><ul class="td-tags td-post-small-box clearfix"><li><span>Topics</span></li><li><a href="https://www.caymancompass.com/tag/cita/">CITA</a></li><li><a href="https://www.caymancompass.com/tag/marc-langevin/">Marc Langevin</a></li><li><a href="https://www.caymancompass.com/tag/reopening/">reopening</a></li></ul></div><div class="td-post-sharing-bottom"><div class="td-post-sharing-classic"><iframe frameBorder="0" src="https://www.facebook.com/plugins/like.php?href=https://www.caymancompass.com/2021/07/27/cita-expanded-vaccine-list-a-small-step-but-not-enough/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:auto; height:21px; background-color:transparent;"></iframe></div><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-ps-rounded td-post-sharing-style3 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.caymancompass.com%2F2021%2F07%2F27%2Fcita-expanded-vaccine-list-a-small-step-but-not-enough%2F"><div class="td-social-but-icon"><i class="td-icon-facebook"></i></div><div class="td-social-but-text">Facebook</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=CITA%3A+Expanded+vaccine+list+a+%E2%80%98small+step%E2%80%99+but+not+enough&url=https%3A%2F%2Fwww.caymancompass.com%2F2021%2F07%2F27%2Fcita-expanded-vaccine-list-a-small-step-but-not-enough%2F&via=cayCompass"><div class="td-social-but-icon"><i class="td-icon-twitter"></i></div><div class="td-social-but-text">Twitter</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="https://api.whatsapp.com/send?text=CITA%3A+Expanded+vaccine+list+a+%E2%80%98small+step%E2%80%99+but+not+enough %0A%0A https://www.caymancompass.com/2021/07/27/cita-expanded-vaccine-list-a-small-step-but-not-enough/"><div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div><div class="td-social-but-text">WhatsApp</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="/cdn-cgi/l/email-protection#18276b6d7a727d7b6c255b514c5922385d606879767c7d7c386e797b7b71767d3874716b6c3879383e3b202a292e236b75797474386b6c7d683e3b202a292f23387a6d6c3876776c387d76776d7f703e7a777c6125706c6c686b2237376f6f6f367b79617579767b777568796b6b367b7775372a282a2937282f372a2f377b716c79357d606879767c7d7c356e797b7b71767d3574716b6c3579356b75797474356b6c7d68357a6d6c3576776c357d76776d7f7037"><div class="td-social-but-icon"><i class="td-icon-mail"></i></div><div class="td-social-but-text">Email</div> </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom"><div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div> </a></div></div></div><div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://www.caymancompass.com/2021/07/27/court-grants-doctors-hospital-leave-to-continue-with-legal-action/">Court grants Doctors Hospital leave to continue with legal action</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="https://www.caymancompass.com/2021/07/27/public-health-letter-required-for-uk-entry-if-travelling-via-amber-list-countries/">Public Health letter required for UK entry if travelling via amber list countries</a></div></div></div><div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="https://www.caymancompass.com/author/nconnolly/">Norma Connolly</a></span></div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Norma Connolly"></span><meta itemprop="datePublished" content="2021-07-27T17:24:06-05:00"><meta itemprop="dateModified" content="2021-07-27T17:24:06-05:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.caymancompass.com/2021/07/27/cita-expanded-vaccine-list-a-small-step-but-not-enough/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.caymancompass.com/wp-content/uploads/2019/10/CompassLogoNew-272x90.png"></span><meta itemprop="name" content="Cayman Compass"></span><meta itemprop="headline " content="CITA: Expanded vaccine list a &#039;small step&#039; but not enough"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.caymancompass.com/wp-content/uploads/2020/06/Marc-Langevin-General-Manager-The-Ritz-Carlton-Grand-Cayman3.jpeg"><meta itemprop="width" content="2560"><meta itemprop="height" content="1703"></span></footer></article><div class="td_block_wrap td_block_related_posts tdi_5_c11 td_with_ajax_pagination td-pb-border-top td_block_template_16"  data-td-block-uid="tdi_5_c11" ><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>var block_tdi_5_c11 = new tdBlock();
block_tdi_5_c11.id = "tdi_5_c11";
block_tdi_5_c11.atts = '{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_tags","td_ajax_filter_type":"td_custom_related","class":"tdi_5_c11","td_column_number":3,"block_type":"td_block_related_posts","live_filter_cur_post_id":536319,"live_filter_cur_post_author":"18","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"tdi_5_c11","tdc_css_class_style":"tdi_5_c11_rand_style"}';
block_tdi_5_c11.td_column_number = "3";
block_tdi_5_c11.block_type = "td_block_related_posts";
block_tdi_5_c11.post_count = "3";
block_tdi_5_c11.found_posts = "35";
block_tdi_5_c11.header_color = "";
block_tdi_5_c11.ajax_pagination_infinite_stop = "";
block_tdi_5_c11.max_num_pages = "12";
tdBlocksArray.push(block_tdi_5_c11);</script><h4 class="td-related-title td-block-title"><a id="tdi_6_144" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="tdi_5_c11" href="#">Related articles</a><a id="tdi_7_c22" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="tdi_5_c11" href="#">More from author</a></h4><div id=tdi_5_c11 class="td_block_inner"><div class="td-related-row"><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.caymancompass.com/2021/07/23/cita-boss-suggests-strict-covid-jab-policy/" rel="bookmark" class="td-image-wrap " title="CITA boss suggests strict COVID-jab policy" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="CITA boss suggests strict COVID-jab policy" data-type="image_tag" data-img-url="https://www.caymancompass.com/wp-content/uploads/2021/05/C4D1EA49-DC91-4E2F-A035-A10FF690D823-218x150.jpeg"  width="218" height="150" /></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.caymancompass.com/2021/07/23/cita-boss-suggests-strict-covid-jab-policy/" rel="bookmark" title="CITA boss suggests strict COVID-jab policy">CITA boss suggests strict COVID-jab policy</a></h3></div></div></div><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.caymancompass.com/2021/07/22/the-resh-hour-with-cita-president-marc-langevin/" rel="bookmark" class="td-image-wrap " title="The Resh Hour with CITA president Marc Langevin" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="The Resh Hour with CITA president Marc Langevin" data-type="image_tag" data-img-url="https://www.caymancompass.com/wp-content/uploads/2021/07/maxresdefault-18-e1626992727558-218x150.jpg"  width="218" height="150" /><span class="td-video-play-ico"><i class="td-icon-video-thumb-play"></i></span></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.caymancompass.com/2021/07/22/the-resh-hour-with-cita-president-marc-langevin/" rel="bookmark" title="The Resh Hour with CITA president Marc Langevin">The Resh Hour with CITA president Marc Langevin</a></h3></div></div></div><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.caymancompass.com/2021/07/13/tourism-association-responds-to-cayman-reopening-plan/" rel="bookmark" class="td-image-wrap " title="Tourism association responds to Cayman reopening plan" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Tourism association responds to Cayman reopening plan" data-type="image_tag" data-img-url="https://www.caymancompass.com/wp-content/uploads/2021/01/Empty-Beach-7-218x150.jpg"  width="218" height="150" /></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.caymancompass.com/2021/07/13/tourism-association-responds-to-cayman-reopening-plan/" rel="bookmark" title="Tourism association responds to Cayman reopening plan">Tourism association responds to Cayman reopening plan</a></h3></div></div></div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_5_c11" data-td_block_id="tdi_5_c11"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-tdi_5_c11" data-td_block_id="tdi_5_c11"><i class="td-icon-font td-icon-menu-right"></i></a></div></div><div class="comments" id="comments"><div class="td-comments-title-wrap td-pb-padding-side"><h4 class="td-comments-title block-title"><span>3 COMMENTS</span></h4></div><ol class="comment-list td-pb-padding-side"><li class="comment " id="comment-95855"><article><footer> <cite>Irl E.</cite> <a class="comment-link" href="#comment-95855"> <time pubdate="1627425807"> July 27, 2021                            At                            5:43 pm</time> </a></footer><div class="comment-content tagdiv-type"><p>Langevin for Premier&#8230;.</p></div><div class="comment-meta" id="comment-95855"> <a rel="nofollow" class="comment-reply-login" href="https://www.caymancompass.com/wp-login.php?redirect_to=https%3A%2F%2Fwww.caymancompass.com%2F2021%2F07%2F27%2Fcita-expanded-vaccine-list-a-small-step-but-not-enough%2F">Log in to leave a comment</a></div></article></li><li class="comment " id="comment-95856"><article><footer> <cite>Dan K.</cite> <a class="comment-link" href="#comment-95856"> <time pubdate="1627427020"> July 27, 2021                            At                            6:03 pm</time> </a></footer><div class="comment-content tagdiv-type"><p>Caymanians should be ashamed of their &#8220;stay closed&#8221; plan.</p><p>By the way, why the five day quarantine again?</p><p>Approved vaccinated people can&#8217;t get a flight anyways so may as well put a fork in Caymanian tourism, it&#8217;s cooked for this holiday season.</p></div><div class="comment-meta" id="comment-95856"> <a rel="nofollow" class="comment-reply-login" href="https://www.caymancompass.com/wp-login.php?redirect_to=https%3A%2F%2Fwww.caymancompass.com%2F2021%2F07%2F27%2Fcita-expanded-vaccine-list-a-small-step-but-not-enough%2F">Log in to leave a comment</a></div></article></li><li class="comment " id="comment-95858"><article><footer> <cite>Carter P.</cite> <a class="comment-link" href="#comment-95858"> <time pubdate="1627427379"> July 27, 2021                            At                            6:09 pm</time> </a></footer><div class="comment-content tagdiv-type"><p>CVS, Walgreens, Sam’s, Walmart were among the last to get the Vaccine for distribution in the US. The state’s Public Health Care authorities and major Healthcare providers distributed the vaccine for months until summer.<br /> I wish this government would FOCUS on identifying a 3rd party service who will validate  the vaccine white card for a modest fee with appropriate documentation.</p></div><div class="comment-meta" id="comment-95858"> <a rel="nofollow" class="comment-reply-login" href="https://www.caymancompass.com/wp-login.php?redirect_to=https%3A%2F%2Fwww.caymancompass.com%2F2021%2F07%2F27%2Fcita-expanded-vaccine-list-a-small-step-but-not-enough%2F">Log in to leave a comment</a></div></article></li></ol><div class="comment-pagination"></div><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">LEAVE A REPLY <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2021/07/27/cita-expanded-vaccine-list-a-small-step-but-not-enough/#respond" style="display:none;">Cancel reply</a></small></h3><p class="must-log-in td-login-comment"><a class="s-trigger-login" data-effect="mpf-td-login-effect" href="#">Log in to leave a comment </a></p></div></div></div></div><div class="td-pb-span4 td-main-sidebar" role="complementary"><div class="td-ss-main-sidebar"><div class="td-a-rec td-a-rec-id-sidebar  tdi_8_144 td_block_template_16"><style>/* custom css */
.tdi_8_144.td-a-rec{
					text-align: center;
				}.tdi_8_144 .td-element-style{
					z-index: -1;
				}.tdi_8_144.td-a-rec-img{
				    text-align: left;
				}.tdi_8_144.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_8_144.td-a-rec-img {
				        text-align: center;
				    }
                }</style><div id="isb_desktop_advert" class="td-visible-desktop sidebar-ad-compass-fix">  <script type="text/javascript">if (typeof _la === 'undefined' || !Array.isArray(_la)) _la = [];

        _la.push(function() {
            var elem = document.getElementById("isb_desktop_advert");
            var theCSSprop = window.getComputedStyle(elem,null).getPropertyValue("display");

            if (theCSSprop != "none") {
                window.loadAdZone(420687, 'isb_desktop_advert');
            }
        });</script> </div><div id="isb_tablet_portrait_advert" class="td-visible-tablet-portrait sidebar-ad-compass-fix">  <script type="text/javascript">if (typeof _la === 'undefined' || !Array.isArray(_la)) _la = [];

        _la.push(function() {
            var elem = document.getElementById("isb_tablet_portrait_advert");
            var theCSSprop = window.getComputedStyle(elem,null).getPropertyValue("display");

            if (theCSSprop != "none") {
                window.loadAdZone(420687, 'isb_tablet_portrait_advert');
            }
        });</script> </div><div id="isb_tablet_landscape_advert" class="td-visible-tablet-landscape sidebar-ad-compass-fix">  <script type="text/javascript">if (typeof _la === 'undefined' || !Array.isArray(_la)) _la = [];

        _la.push(function() {
            var elem = document.getElementById("isb_tablet_landscape_advert");
            var theCSSprop = window.getComputedStyle(elem,null).getPropertyValue("display");

            if (theCSSprop != "none") {
                window.loadAdZone(420687, 'isb_tablet_landscape_advert');
            }
        });</script> </div></div><aside id="custom_html-4" class="widget_text td_block_template_16 widget custom_html-4 widget_custom_html"><h4 class="td-block-title"><span>Daily newsletter</span></h4><div class="textwidget custom-html-widget"><div id="hs_embed_signup" style="margin-top: -10px;"> <!--[if lte IE 8]> <script charset="utf-8" type="text/javascript" src="//js.hsforms.net/forms/v2-legacy.js"></script> <![endif]--> <script charset="utf-8" type="text/javascript" src="//js.hsforms.net/forms/v2.js"></script> <script>hbspt.forms.create({
	portalId: "5627643",
	formId: "1cc15e7f-bbe8-4430-aa57-9225745cb133"
});</script> </div></div></aside><div class="td_block_wrap td_block_7 td_block_widget tdi_9_67b td_with_ajax_pagination td-pb-border-top td_block_template_16 td-column-1 td_block_padding"  data-td-block-uid="tdi_9_67b" ><style>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</style><script>var block_tdi_9_67b = new tdBlock();
block_tdi_9_67b.id = "tdi_9_67b";
block_tdi_9_67b.atts = '{"custom_title":"This week","custom_url":"","block_template_id":"","header_text_color":"#","border_color":"#","accent_text_color":"#","m6_tl":"","limit":"3","offset":"","el_class":"","post_ids":"","category_id":"","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","sort":"random_7_day","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"next_prev","ajax_pagination_infinite_stop":"","class":"td_block_widget tdi_9_67b","block_type":"td_block_7","separator":"","show_modified_date":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m6f_title_font_header":"","m6f_title_font_title":"Article title","m6f_title_font_settings":"","m6f_title_font_family":"","m6f_title_font_size":"","m6f_title_font_line_height":"","m6f_title_font_style":"","m6f_title_font_weight":"","m6f_title_font_transform":"","m6f_title_font_spacing":"","m6f_title_":"","m6f_cat_font_title":"Article category tag","m6f_cat_font_settings":"","m6f_cat_font_family":"","m6f_cat_font_size":"","m6f_cat_font_line_height":"","m6f_cat_font_style":"","m6f_cat_font_weight":"","m6f_cat_font_transform":"","m6f_cat_font_spacing":"","m6f_cat_":"","m6f_meta_font_title":"Article meta info","m6f_meta_font_settings":"","m6f_meta_font_family":"","m6f_meta_font_size":"","m6f_meta_font_line_height":"","m6f_meta_font_style":"","m6f_meta_font_weight":"","m6f_meta_font_transform":"","m6f_meta_font_spacing":"","m6f_meta_":"","css":"","tdc_css":"","td_column_number":1,"header_color":"","color_preset":"","border_top":"","tdc_css_class":"tdi_9_67b","tdc_css_class_style":"tdi_9_67b_rand_style"}';
block_tdi_9_67b.td_column_number = "1";
block_tdi_9_67b.block_type = "td_block_7";
block_tdi_9_67b.post_count = "3";
block_tdi_9_67b.found_posts = "63";
block_tdi_9_67b.header_color = "";
block_tdi_9_67b.ajax_pagination_infinite_stop = "";
block_tdi_9_67b.max_num_pages = "21";
tdBlocksArray.push(block_tdi_9_67b);</script><div class="td-block-title-wrap"><h4 class="td-block-title"><span class="td-pulldown-size">This week</span></h4></div><div id=tdi_9_67b class="td_block_inner"><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.caymancompass.com/2021/07/26/vapes-cigarettes-and-alcohol-drugs-of-choice-for-caymans-teens/" rel="bookmark" class="td-image-wrap " title="Vapes, cigarettes and alcohol: drugs of choice for Cayman&#8217;s teens" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" alt="" title="Vapes, cigarettes and alcohol: drugs of choice for Cayman&#8217;s teens" data-type="image_tag" data-img-url="https://www.caymancompass.com/wp-content/uploads/2021/07/vaping-100x70.jpg"  width="100" height="70" /></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.caymancompass.com/2021/07/26/vapes-cigarettes-and-alcohol-drugs-of-choice-for-caymans-teens/" rel="bookmark" title="Vapes, cigarettes and alcohol: drugs of choice for Cayman&#8217;s teens">Vapes, cigarettes and alcohol: drugs of choice for Cayman&#8217;s teens</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-07-26T00:01:09-05:00" >July 26, 2021</time></span></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.caymancompass.com/2021/07/21/report-police-stop-suspect-from-swallowing-cocaine/" rel="bookmark" class="td-image-wrap " title="Report: Police stop suspect from swallowing cocaine" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" alt="" title="Report: Police stop suspect from swallowing cocaine" data-type="image_tag" data-img-url="https://www.caymancompass.com/wp-content/uploads/2019/11/handcuffs-100x70.jpg"  width="100" height="70" /></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.caymancompass.com/2021/07/21/report-police-stop-suspect-from-swallowing-cocaine/" rel="bookmark" title="Report: Police stop suspect from swallowing cocaine">Report: Police stop suspect from swallowing cocaine</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-07-21T10:33:42-05:00" >July 21, 2021</time></span></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.caymancompass.com/2021/07/21/ruptured-tank-caused-2019-explosion-on-cayman-flagged-ship/" rel="bookmark" class="td-image-wrap " title="Ruptured tank caused 2019 explosion on Cayman-flagged ship" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" alt="" title="Ruptured tank caused 2019 explosion on Cayman-flagged ship" data-type="image_tag" data-img-url="https://www.caymancompass.com/wp-content/uploads/2021/07/EFhPs8jUUAAd9ed-e1626902490388-100x70.jpg"  width="100" height="70" /></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.caymancompass.com/2021/07/21/ruptured-tank-caused-2019-explosion-on-cayman-flagged-ship/" rel="bookmark" title="Ruptured tank caused 2019 explosion on Cayman-flagged ship">Ruptured tank caused 2019 explosion on Cayman-flagged ship</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-07-21T18:24:58-05:00" >July 21, 2021</time></span></div></div></div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_9_67b" data-td_block_id="tdi_9_67b"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-tdi_9_67b" data-td_block_id="tdi_9_67b"><i class="td-icon-font td-icon-menu-right"></i></a></div></div></div></div></div></div></div><div id="s-login-modal"></div><div id="s-checkout-modal"></div><div class="tdc-footer-wrap "><div class="td-footer-wrapper td-footer-container td-container-wrap td_stretch_container"><div class="td-container"><div class="td-pb-row"><div class="td-pb-span12"></div></div><div class="td-pb-row"><div class="td-pb-span4"><aside class="td_block_template_16 widget widget_nav_menu"><h4 class="td-block-title"><span>Useful Links</span></h4><div class="menu-footer-links-container"><ul id="menu-footer-links" class="menu"><li id="menu-item-511412" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-511412"><a href="https://www.caymancompass.com/advertise-with-us/">Advertise With Us</a></li><li id="menu-item-510665" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-510665"><a href="https://www.caymancompass.com/faq/">Help &#038; FAQ</a></li><li id="menu-item-510654" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-510654"><a href="https://www.caymancompass.com/issues/cayman2-0/">Cayman 2.0</a></li><li id="menu-item-510667" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-510667"><a href="https://www.caymancompass.com/video/">Video and Live Streams</a></li><li id="menu-item-510659" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-510659"><a href="https://www.caymancompass.com/interactive/">Interactive</a></li><li id="menu-item-510653" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-510653"><a href="https://www.caymancompass.com/cayman-real-estate/">Cayman Real Estate</a></li><li id="menu-item-510655" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-510655"><a href="https://www.caymancompass.com/tourism/">Cayman Islands Travel and Tourism News</a></li><li id="menu-item-510657" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-510657"><a href="https://www.caymancompass.com/e-versions/">E-versions</a></li><li id="menu-item-510663" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-510663"><a href="https://www.caymancompass.com/opinion/letters-to-the-editor/">Letters to the Editor</a></li><li id="menu-item-510682" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-510682"><a href="https://www.caymancompass.com/opinion/">Opinion</a></li><li id="menu-item-510652" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-510652"><a href="https://www.caymancompass.com/traffic-map-cayman/">Grand Cayman Traffic Map</a></li></ul></div></aside></div><div class="td-pb-span4"><aside class="td_block_template_16 widget widget_nav_menu"><h4 class="td-block-title"><span>Compass Media</span></h4><div class="menu-footer-brand-links-container"><ul id="menu-footer-brand-links" class="menu"><li id="menu-item-510670" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-first td-menu-item td-normal-menu menu-item-510670"><a target="_blank" rel="noopener" href="https://www.compassmedia.ky">About Compass Media</a></li><li id="menu-item-519808" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-519808"><a href="https://www.compassmedia.ky/our-brands/">Our Brands</a></li><li id="menu-item-519812" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-519812"><a href="https://www.compassmedia.ky/what-we-do/#our_platforms">Our Platforms</a></li><li id="menu-item-519813" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-519813"><a href="https://www.compassmedia.ky/what-we-do/#our_platforms">Radio</a></li><li id="menu-item-519805" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-519805"><a href="https://www.compassmedia.ky/print-shop/">Print Shop</a></li><li id="menu-item-510684" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-510684"><a target="_blank" rel="noopener" href="https://www.compassmedia.ky/compass-content/">Content Creation</a></li><li id="menu-item-519817" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-519817"><a href="https://www.compassmedia.ky/advertise/">Advertising</a></li><li id="menu-item-510675" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-510675"><a target="_blank" rel="noopener" href="https://www.caymanhealth.com">Cayman Health Directory</a></li><li id="menu-item-510674" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-510674"><a href="https://www.caymancompass.com/cayman-real-estate/">Cayman Real Estate &#038; InsideOut Magazine</a></li><li id="menu-item-510678" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-510678"><a href="https://www.caymancompass.com/special-features-and-publications/">Special Features and Publications</a></li><li id="menu-item-510673" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-510673"><a href="https://www.caymancompass.com/emergency-guide/">Emergency Guide</a></li></ul></div></aside></div><div class="td-pb-span4"><aside class="td_block_template_16 widget widget_nav_menu"><h4 class="td-block-title"><span>Subscribe</span></h4><div class="menu-footer-subscribe-links-container"><ul id="menu-footer-subscribe-links" class="menu"><li id="menu-item-510636" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-510636"><a href="https://www.caymancompass.com/subscribe/">Subscribe to the Compass All-Access Pass</a></li><li id="menu-item-510641" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-510641"><a href="https://www.caymancompass.com/subscribe/daily-newsletter/">Subscribe to the Daily Newsletter</a></li><li id="menu-item-510638" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-510638"><a href="https://www.caymancompass.com/subscribe/employment-newsletter/">Subscribe to the Employment Newsletter</a></li><li id="menu-item-510637" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-510637"><a href="https://www.caymancompass.com/subscribe/cayman-real-estate-newsletter/">Subscribe to the Cayman Real Estate Newsletter</a></li><li id="menu-item-510639" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-510639"><a href="https://www.caymancompass.com/subscribe/financial-newsletter/">Subscribe to the Financial Newsletter</a></li></ul></div></aside><aside class="widget_text td_block_template_16 widget widget_custom_html"><div class="textwidget custom-html-widget"><div style="display: table;"><div class="footer-payment-logos" style="position:relative; display: inline;"><img class="alignnone size-full wp-image-482000" src="https://www.caymancompass.com/wp-content/uploads/2020/06/american_express.png" alt="" style="margin-top:10px;" width="46" height="24"> <img class="alignnone size-full wp-image-480084" src="https://www.caymancompass.com/wp-content/uploads/2020/06/visa.png" alt="" style="margin-top:10px;" width="46" height="24"> <img class="size-full wp-image-480085" src="https://www.caymancompass.com/wp-content/uploads/2020/06/mastercard.png" alt="" width="46" height="24"></div><div class="footer-payment-links-text" style="position:relative; display: inline;"> <span style="font-size: 14px; line-height:14px; font-family: Gliko-Modern-S-Regular !important; position: relative;"><br />Pay securely with your Credit Card. <a href="https://www.caymancompass.com/refund-policy/"><br />Click here to view our Refund Policy</a>.</span></div></div></div></aside></div></div></div><div class="td-footer-bottom-full"><div class="td-container"><div class="td-pb-row"><div class="td-pb-span3"><aside class="footer-logo-wrap"><a href="https://www.caymancompass.com/"><img class="td-retina-data" src="https://www.caymancompass.com/wp-content/uploads/2019/10/CaymanCompassLogoWhiteNew140x48.png" data-retina="https://www.caymancompass.com/wp-content/uploads/2019/10/CaymanCompassLogoWhiteNew280x96.png" alt="Cayman Compass" title="The most trusted news source in the Cayman Islands" width="140" /></a></aside></div><div class="td-pb-span5"><aside class="footer-text-wrap"><div class="block-title"><span>ABOUT US</span></div>Cayman Compass is Cayman Islands' most trusted news source.</aside></div><div class="td-pb-span4"><aside class="footer-social-wrap td-social-style-2"><div class="block-title"><span>FOLLOW US</span></div> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.facebook.com/caycompass/" title="Facebook"> <i class="td-icon-font td-icon-facebook"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.instagram.com/cayman_compass/" title="Instagram"> <i class="td-icon-font td-icon-instagram"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://twitter.com/cayCompass" title="Twitter"> <i class="td-icon-font td-icon-twitter"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.youtube.com/user/caymancompas" title="Youtube"> <i class="td-icon-font td-icon-youtube"></i> </a> </span></aside></div></div></div></div></div><div class="td-sub-footer-container td-container-wrap td_stretch_container"><div class="td-container"><div class="td-pb-row"><div class="td-pb-span td-sub-footer-menu"><div class="menu-sub-footer-menu-container"><ul id="menu-sub-footer-menu" class="td-subfooter-menu"><li id="menu-item-492593" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-492593"><a href="https://www.caymancompass.com/legal/">Legal</a></li><li id="menu-item-316352" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-316352"><a href="https://www.caymancompass.com/faq/">Help &#038; FAQ</a></li><li id="menu-item-480188" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-480188"><a href="https://www.caymancompass.com/contact/">Contact</a></li></ul></div></div><div class="td-pb-span td-sub-footer-copy"> &copy; Copyright Cayman Compass Ltd.</div></div></div></div></div></div> <style type="text/css" media="screen">/* custom css theme panel */
/* FOOTER LINKS FONT OVERRIDE */

.td-footer-wrapper .widget_nav_menu li {
    font-size: 14px;
    font-family: Gliko-Modern-S-Regular !important;
    line-height: 20px;
}

/* WOOCOMMERCE LIGHTBOX BEHIND HEADER */

.pswp {
z-index: 9999;
}
.woocommerce .product .woocommerce-tabs .panel {
    margin-top: 2em !important;
}


/*  PULL QUOTE OVERRIDE  */
.post .td_pull_quote p, .page .td_pull_quote p, .post .wp-block-pullquote blockquote p, .page .wp-block-pullquote blockquote p {
    font-family: Gliko-Modern-S-Bold-Italic;
    font-size: 21px !important;
    line-height: 30px !important;
}</style> <script type="text/javascript">(function () {
			var c = document.body.className;
			c = c.replace(/woocommerce-no-js/, 'woocommerce-js');
			document.body.className = c;
		})()</script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/themes/newspaper-child/assets/js/dist/bundle.js?ver=c60ff2a1e2befbcc8883d8207bfec0bd40ac7c62' id='compass_front_js-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/adbutler/includes/../js/adbutler_hb_init.js?ver=1.28' id='adbutler_hb_init-js'></script> <script type='text/javascript' id='adbutler_hb_init-js-after'>AdButlerHB.timeout = 700;</script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/adbutler/includes/../js/adbutler_hb_final.js?ver=1.28' id='adbutler_hb_final-js'></script> <script type='text/javascript' id='cookie-consent-js-extra'>var ctcc_vars = {"expiry":"90","method":"","version":"1"};</script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/uk-cookie-consent/assets/js/uk-cookie-consent-js.js?ver=2.3.0' id='cookie-consent-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/woocommerce/assets/js/jquery-blockui/jquery.blockUI.min.js?ver=2.70' id='jquery-blockui-js'></script> <script type='text/javascript' id='wc-add-to-cart-js-extra'>var wc_add_to_cart_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","i18n_view_cart":"View cart","cart_url":"https:\/\/www.caymancompass.com\/cart\/","is_cart":"","cart_redirect_after_add":"no"};</script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/woocommerce/assets/js/frontend/add-to-cart.min.js?ver=4.9.2' id='wc-add-to-cart-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/woocommerce/assets/js/js-cookie/js.cookie.min.js?ver=2.1.4' id='js-cookie-js'></script> <script type='text/javascript' id='woocommerce-js-extra'>var woocommerce_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%"};</script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/woocommerce/assets/js/frontend/woocommerce.min.js?ver=4.9.2' id='woocommerce-js'></script> <script type='text/javascript' id='wc-cart-fragments-js-extra'>var wc_cart_fragments_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","cart_hash_key":"wc_cart_hash_4437ba34d6b5d70623e49270760f1a5e","fragment_name":"wc_fragments_4437ba34d6b5d70623e49270760f1a5e","request_timeout":"5000"};</script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/woocommerce/assets/js/frontend/cart-fragments.min.js?ver=4.9.2' id='wc-cart-fragments-js'></script> <script type='text/javascript' id='cffscripts-js-extra'>var cffOptions = {"placeholder":"https:\/\/www.caymancompass.com\/wp-content\/plugins\/custom-facebook-feed-pro\/assets\/img\/placeholder.png","resized_url":"https:\/\/www.caymancompass.com\/wp-content\/uploads\/sb-facebook-feed-images\/"};</script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/custom-facebook-feed-pro/assets/js/cff-scripts.js?ver=3.19.5' id='cffscripts-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-includes/js/underscore.min.js?ver=1.8.3' id='underscore-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/td-cloud-library/assets/js/js_posts_autoload.min.js?ver=a50385a2d79d6600973a7e697f735a0b' id='tdb_js_posts_autoload-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js?ver=10.3.9.1' id='td-site-min-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-includes/js/comment-reply.min.js?ver=01c406beee79eb478b26e999eb5427ea' id='comment-reply-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=a50385a2d79d6600973a7e697f735a0b' id='tdb_js_files_for_front-js'></script> <script type='text/javascript' id='woomc-frontend-js-extra'>var woomc = {"currentURL":"https:\/\/www.caymancompass.com\/2021\/07\/27\/cita-expanded-vaccine-list-a-small-step-but-not-enough\/","currency":"KYD","cookieSettings":{"name":"woocommerce_multicurrency_forced_currency","expires":31536000},"console_log":"N","settings":{"woocommerce_default_customer_address":"***"}};</script> <script type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/woocommerce-multicurrency/src/WOOMC/Frontend/dist/frontend.js?ver=2.9.3' id='woomc-frontend-js'></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-includes/js/wp-embed.min.js?ver=01c406beee79eb478b26e999eb5427ea' id='wp-embed-js'></script> <script data-cfasync="false" type='text/javascript' data-parsely-site="caymancompass.com" src='https://cdn.parsely.com/keys/caymancompass.com/p.js?ver=2.5.0' id="parsely-cfg"></script> <script type='text/javascript' src='https://www.caymancompass.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=7.4.4' id='wp-polyfill-js'></script> <script type='text/javascript' id='wp-polyfill-js-after'>( 'fetch' in window ) || document.write( '<script src="https://www.caymancompass.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://www.caymancompass.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script src="https://www.caymancompass.com/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="https://www.caymancompass.com/wp-includes/js/dist/vendor/wp-polyfill-url.min.js?ver=3.6.4"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://www.caymancompass.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://www.caymancompass.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );</script> <script type='text/javascript' id='wp-parsely-api-js-extra'>var wpParsely = {"apikey":"caymancompass.com"};</script> <script data-cfasync="false" type='text/javascript' src='https://www.caymancompass.com/wp-content/plugins/wp-parsely/build/init-api.js?ver=2.5.0' id='wp-parsely-api-js'></script>  <script></script> <script type="text/javascript">jQuery(document).ready(function($){
												if(!catapultReadCookie("catAccCookies")){ // If the cookie has not been set then show the bar
							$("html").addClass("has-cookie-bar");
							$("html").addClass("cookie-bar-bottom-bar");
							$("html").addClass("cookie-bar-bar");
													}
													$(window).scroll(function(){
								var scroll = $(window).scrollTop();
								if ( scroll > 700 ) {
									ctccCloseNotification();
								}
							});	
																	});</script> <div id="catapult-cookie-bar" class=""><div class="ctcc-inner "><span class="ctcc-left-side">This site uses cookies. By using this site, you agree to our policies. <a class="ctcc-more-info-link" tabindex=0 target="_blank" href="https://www.caymancompass.com/privacy-policy/">Find out more.</a></span><span class="ctcc-right-side"><button id="catapultCookie" tabindex=0 onclick="catapultAcceptCookies();">CLOSE</button></span></div></div><script type="text/javascript">(function(){window['__CF$cv$params']={r:'675a13496ae15dda',m:'56eabbc7542285e93082fa86ea68b77798c41e96-1627433028-1800-ASb8jMnoTDgQpFTDfgYBQVIM9Eh1tekaqTu92hnZG/jE3qO99e9xQypVaytT/WmrCS9lhPEFUpkAM7GSkiMGrfZr3hGspnJzwY9118q5ueEXJb5zYk8hhPAmH/vMPvXCMHOXlar3NRoHnGnmV+fEay8GQMZs8qyIi3UK2+Zw8vAYWacWvaRkfRoB5RO/pS9X08j57xrkXtTtdBpcZNi8jR4=',s:[0x30026d95b8,0x982d9765f6],}})();</script><script defer src="https://static.cloudflareinsights.com/beacon.min.js" data-cf-beacon='{"rayId":"675a13496ae15dda","token":"2c131ff394e34e32a2d241d3f8019e28","version":"2021.7.0","si":10}'></script>
</body></html>
<!-- Dynamic page generated in 1.113 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2021-07-27 19:28:50 -->

<!-- Compression = gzip -->